totem-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.40.0
  5. %define _gtk_ver 3.12.0
  6. %define _gnomeicon_ver 3.12.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.6.0
  9. %define _gst_ver 1.2.0
  10. %define _gstpb_ver 1.2.0
  11. %define _gstpg_ver 1.2.0
  12. %define _gstpbad_ver 1.2.0
  13. %define _xulrunner_ver 1.9
  14. %define _nautilus_ver 3.12.0
  15. %define _shared_mime_info_ver 0.17
  16. %define _unique_ver 1.0
  17. %define _totem_pl_parser_ver 3.4.4
  18. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  19. %define mozplug_dir %{_libdir}/mozilla/plugins
  20. Summary: Movie player for GNOME 3
  21. Summary(ja): GNOME3 用動画プレイヤー
  22. Name: totem
  23. Version: 3.12.1
  24. Release: 1%{?_dist_release}
  25. License: GPL
  26. Group: Applications/Multimedia
  27. URL: http://www.gnome.org/projects/totem/
  28. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.xz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Takemikaduchi
  33. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: dbus-devel >= %{_dbus_ver}
  36. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  37. BuildRequires: gettext
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: yelp-tools
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: grilo-devel
  43. BuildRequires: bluez-libs-devel >= 4.15
  44. BuildRequires: lirc
  45. BuildRequires: unique-devel >= %{_unique_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pylint
  48. BuildRequires: pygobject3-devel
  49. BuildRequires: libpeas-devel
  50. BuildRequires: libXtst-devel
  51. BuildRequires: gsettings-desktop-schemas-devel
  52. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  53. BuildRequires: vala
  54. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  55. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  56. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  57. BuildRequires: gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
  58. BuildRequires: clutter-gtk-devel
  59. BuildRequires: clutter-gst-devel
  60. BuildRequires: libmx-devel
  61. %if %{build_plugin}
  62. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  63. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  64. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  65. %endif
  66. Requires: gstreamer1 >= %{_gst_ver}
  67. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  68. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  69. Requires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  70. Requires: iso-codes
  71. Obsoletes: nautilus-media
  72. Obsoletes: %{name}-gstreamer < 2.30.1-2
  73. Obsoletes: %{name}-xine < 2.30.1-2
  74. Obsoletes: %{name}-common < 2.30.1-3
  75. Provides: nautilus-media
  76. Provides: %{name}-common = %{version}-%{release}
  77. Requires(post): ldconfig, desktop-file-utils
  78. Requires(postun): ldconfig, desktop-file-utils
  79. %description
  80. Totem is simple movie player for the Gnome desktop. It features a
  81. simple playlist, a full-screen mode, seek and volume controls, as well as
  82. a pretty complete keyboard navigation.
  83. %if %{build_plugin}
  84. %package mozilla
  85. Summary: Totem movie plugin for Mozilla
  86. Summary(ja): Mozilla 用 Totem 動画プラグイン
  87. Group: Applications/Internet
  88. Requires: %{name} = %{version}-%{release}
  89. Obsoletes: %{name}-mozilla-common
  90. Obsoletes: %{name}-mozilla-gstreamer
  91. Obsoletes: %{name}-mozilla-xine
  92. %description mozilla
  93. Totem is simple movie player for the Gnome desktop. It features a
  94. simple playlist, a full-screen mode, seek and volume controls, as well as
  95. a pretty complete keyboard navigation.
  96. This package contains a Totem video plugin for Mozilla. It allows Totem
  97. movie player to be embedded into a web browser.
  98. %endif
  99. %package devel
  100. Summary: Plugin writer's documentation for totem
  101. Group: Development/Libraries
  102. Requires: %{name} = %{version}-%{release}
  103. %description devel
  104. The %{name}-devel package contains API documentation for
  105. developing developing plugins for %{name}.
  106. %prep
  107. %setup -q
  108. %build
  109. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  110. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  111. %configure \
  112. --enable-python \
  113. --enable-vala \
  114. --enable-nautilus \
  115. --enable-gmp-plugin \
  116. --enable-narrowspace-plugin \
  117. --enable-mully-plugin \
  118. --disable-vegas-plugin \
  119. %if %{build_plugin}
  120. --enable-browser-plugins
  121. %else
  122. --disable-browser-plugins
  123. %endif
  124. make %{?_smp_mflags}
  125. %install
  126. rm -rf $RPM_BUILD_ROOT
  127. make install DESTDIR=$RPM_BUILD_ROOT
  128. # remove unneeded files
  129. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  130. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  131. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  132. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  133. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  134. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  135. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  136. # remove unused file
  137. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  138. %find_lang %{name} --with-gnome
  139. # save space by linking identical images in translated docs
  140. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  141. for f in $helpdir/C/figures/*.png; do
  142. b="$(basename $f)"
  143. for d in $helpdir/*; do
  144. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  145. g="$d/figures/$b"
  146. if [ -f "$g" ]; then
  147. if cmp -s $f $g; then
  148. rm "$g"; ln -s "../../C/figures/$b" "$g"
  149. fi
  150. fi
  151. fi
  152. done
  153. done
  154. %clean
  155. %__rm -rf %{buildroot}
  156. %post
  157. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  158. touch %{_datadir}/icons/hicolor
  159. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  160. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  161. fi
  162. %postun
  163. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  164. touch %{_datadir}/icons/hicolor
  165. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  166. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  167. fi
  168. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  169. %posttrans
  170. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  171. %files -f %{name}.lang
  172. %defattr(-,root,root,-)
  173. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  174. %{_bindir}/totem
  175. %{_bindir}/totem-audio-preview
  176. %{_bindir}/totem-video-thumbnailer
  177. %{_datadir}/GConf/gsettings/opensubtitles.convert
  178. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  179. %{_datadir}/GConf/gsettings/totem.convert
  180. %{_datadir}/appdata/%{name}.appdata.xml
  181. %{_datadir}/applications/%{name}.desktop
  182. %{_datadir}/glib-2.0/schemas/*.xml
  183. %{_datadir}/icons/*/*/*/*
  184. %{_datadir}/thumbnailers/totem.thumbnailer
  185. %{_datadir}/%{name}
  186. %{_datadir}/gtk-doc/html/totem
  187. %{_libdir}/libtotem.so.*
  188. %{_libdir}/girepository-1.0/*.typelib
  189. %dir %{_libdir}/totem
  190. %dir %{_libdir}/totem/plugins
  191. %{_libdir}/totem/plugins/apple-trailers/
  192. %{_libdir}/totem/plugins/autoload-subtitles
  193. %{_libdir}/totem/plugins/brasero-disc-recorder
  194. %{_libdir}/totem/plugins/chapters
  195. %{_libdir}/totem/plugins/dbus
  196. %{_libdir}/totem/plugins/gromit
  197. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  198. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  199. %{_libdir}/totem/plugins/lirc
  200. %{_libdir}/totem/plugins/media-player-keys
  201. %{_libdir}/totem/plugins/ontop
  202. %{_libdir}/totem/plugins/opensubtitles
  203. %{_libdir}/totem/plugins/properties
  204. %{_libdir}/totem/plugins/pythonconsole
  205. %{_libdir}/totem/plugins/recent
  206. %{_libdir}/totem/plugins/rotation
  207. %{_libdir}/totem/plugins/screensaver
  208. %{_libdir}/totem/plugins/screenshot
  209. %{_libdir}/totem/plugins/skipto
  210. %{_libdir}/totem/plugins/save-file/libsave-file.so
  211. %{_libdir}/totem/plugins/save-file/save-file.plugin
  212. %{_libdir}/totem/plugins/vimeo
  213. %if %{build_plugin}
  214. %{_libdir}/nautilus/extensions-3.0/*.so*
  215. %endif
  216. %{_libexecdir}/%{name}/totem-bugreport.py
  217. %{_mandir}/man1/*
  218. %if %{build_plugin}
  219. %files mozilla
  220. %defattr(-,root,root,-)
  221. %{mozplug_dir}/*
  222. %{_libexecdir}/totem-plugin-viewer
  223. %endif
  224. %files devel
  225. %defattr(-, root, root,-)
  226. %{_includedir}/totem
  227. %{_libdir}/libtotem.so
  228. %{_libdir}/pkgconfig/totem.pc
  229. %{_datadir}/gir-1.0/Totem-1.0.gir
  230. %{_datadir}/gtk-doc/html/totem
  231. %changelog
  232. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  233. - new upstream release
  234. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  235. - new upstream release
  236. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  237. - rebuild with VineSeed environment
  238. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  239. - new upstream release
  240. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  241. - new upstream release
  242. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  243. - new upstream release
  244. - add BuildRequires: yelp-tools, vala
  245. - change configure option (--enable-vala)
  246. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  247. - new upstream release
  248. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  249. - new upstream release
  250. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  251. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  252. - new upstream release
  253. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  254. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  255. - new upstream release
  256. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  257. - add configure option (--disable-vegas-plugin)
  258. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  259. - new upstream release
  260. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  261. - new upstream release
  262. - add BuildRequires: pylint
  263. - remove BuildRequires: libgdata-devel
  264. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  265. - new upstream release
  266. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  267. - new upstream release
  268. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  269. - new upstream release
  270. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  271. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  272. - new upstream release
  273. - change BuildRequires: gtk3-devel instead of gtk2-devel
  274. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  275. clutter-gst-devel, libmx-devel
  276. - change configure option (--disable-vala)
  277. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  278. - new upstream release
  279. - fix %files
  280. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  281. - new upstream release
  282. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  283. - clean up spec file
  284. - remove totem-common and merged to totem main package.
  285. - add Obsoletes: totem-common
  286. - remove unneeded BR: and R:
  287. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  288. - libmusicbrainz, alternatives
  289. - remove explicit dependency
  290. - gtk2, glib2, dbus
  291. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  292. - add R: gstreamer-plugins-good
  293. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  294. - rebuild with libgdata (add youtube plugin)
  295. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  296. - add Obsolete: totem-gstreamer, totem-xine)
  297. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  298. - new upstream release
  299. - chagnge _gst_ver from 0.10.19 to 0.10.29
  300. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  301. - new upstream release
  302. - drop totem-tracker package
  303. - add BuildRequires: unique-devel
  304. - remove BuildRequires: hal-devel
  305. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  306. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  307. - remove unneeded autoreconf
  308. - add BR: lirc
  309. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  310. - new upstream release
  311. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  312. - remove bemused plugin
  313. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  314. - new upstream release
  315. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  316. - added tracker video search sub-package
  317. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  318. - new upstream release
  319. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  320. - new upstream release
  321. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  322. - remove libxine dependency from totem-common
  323. - build xine backend with minimum dependency
  324. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  325. - add BR: bluez-libs-devel >= 4.15
  326. - fix typo in %%postun xine
  327. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  328. - rebuild with bluez-libs-devel-4.15
  329. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  330. - new upstream release
  331. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  332. - new upstream release
  333. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  334. - new upstream release
  335. - add patch1 to build with xulrunner-1.9
  336. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  337. - new upstream release
  338. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  339. - new upstream release
  340. - disabled devel package (replaced by totem-pl-parser-devel)
  341. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  342. - new upstream release
  343. - update version macros
  344. - enable browser plugins on x86_64
  345. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  346. - new upstream release
  347. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  348. - upstream release
  349. - drop obsolete ja.po.patch (patch0)
  350. - revert change of 1.4.4-0vl2
  351. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  352. - upstream release
  353. - enable browser plugins (exclude x86_64 arch)
  354. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  355. - upstream release
  356. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  357. - update configure options
  358. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  359. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  360. - fix mistranslation (patch0)
  361. - add icon symlink
  362. - add BuildRequires: gstreamer-plugins-good
  363. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  364. - upstream release
  365. - update %%_glib_ver, %%_xine_ver
  366. - add BuildRequires: hal
  367. - update %%configure options
  368. - update %%files
  369. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  370. - upstream release
  371. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  372. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  373. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  374. - upstream release
  375. - drop obsolete patch0
  376. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  377. - upstream release
  378. - add patch0 to build with intltool-0.35
  379. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  380. - upstream release
  381. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  382. - upstream release
  383. - update alternatives entry
  384. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  385. - upstream release
  386. - drop fix-sort-function.patch (was merged to upstream, #331426)
  387. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  388. - rebuild with gnome-2.14rc
  389. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  390. - upstream release
  391. - add macros
  392. - _gtk_ver, _glib_ver
  393. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  394. - _dbus_ver
  395. - _gst_ver, gstpb_ver, _xine_ver
  396. - add fix-sort-function.patch to build with glib < 2.9.1
  397. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  398. - upstream release
  399. - add BuildRequires:
  400. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  401. - gnome-vfs2-devel >= 2.9.92
  402. - dbus-devel >= 0.35
  403. - use gstreamer-0.10 as backend for totem-gstreamer
  404. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  405. - use gstreamer08 instead of gstreamer
  406. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  407. - upstream release
  408. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  409. - fix missing links
  410. - update file list
  411. - update update-alternatives scripts
  412. - fix totem-gstreamer's %%postun script
  413. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  414. - upstream release
  415. - add BuildRequires: iso-codes, libmusicbrainz-devel
  416. - add Requires: iso-codes, libmusicbrains to -common package
  417. - remove BuildRequires: nautilus-cd-burner
  418. - remove Requires: nautilus-cd-burner from -common package
  419. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  420. - totem-gstreamer obsoletes nautilus-media
  421. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  422. - upstream release
  423. - add Requires(post,postun): alternatives for gstreamer,xine
  424. - add Requires(postun,triggers): alternatives for common
  425. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  426. - upstream release
  427. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  428. - build xine backend
  429. - move common files to common package
  430. - move GStreamer related files to gstreamer package
  431. - install xine related files to xine package
  432. - fix scripts
  433. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  434. - upstream release
  435. - update URL
  436. - move *.{a,la} to devel package
  437. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  438. - fix %%{post,preun} script (video-thumbnail.schemas)
  439. - sync with Fedora Core's 1.0.1-1
  440. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  441. - Update to upstream version 1.0.1
  442. - Break out devel package
  443. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  444. - add %%{post,pre}un script
  445. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  446. - initial build for Vine Linux
  447. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  448. - fix %%post
  449. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  450. - Obsolete nautilus-media
  451. - Install property page and thumbnailer
  452. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  453. - Update to 0.101
  454. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  455. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  456. missing menu entry (144088)
  457. - Remove workaround for desktop file being misinstalled, fixed
  458. by above patch
  459. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  460. - New upstream version 0.100
  461. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  462. - update to 0.99.22
  463. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  464. - Add patch to remove removed items from package from help
  465. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  466. - New upstream 0.99.19
  467. - Fixes crasher with CD playback (see NEWS)
  468. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  469. - Call update-desktop-database in post
  470. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  471. - update to 0.99.18
  472. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  473. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>