ldns-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. %{?!with_python: %global with_python 1}
  2. %if %{with_python}
  3. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. %endif
  6. Summary: Lowlevel DNS(SEC) library with API
  7. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  8. Name: ldns
  9. Version: 1.6.4
  10. Release: 2%{?_dist_release}
  11. License: BSD
  12. Url: http://www.nlnetlabs.nl/%{name}/
  13. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  14. Group: System Environment/Libraries
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  17. BuildRequires: perl, libpcap-devel, openssl-devel
  18. Requires: libpcap, openssl
  19. Patch1: ldns-installfix-r3167.patch
  20. Patch2: ldns-rpathfix.patch
  21. Distribution: Vine Linux
  22. Vendor: Project Vine
  23. Packager: iwaim
  24. %if %{with_python}
  25. BuildRequires: python-devel, swig
  26. %endif
  27. %description
  28. ldns is a library with the aim to simplify DNS programing in C. All
  29. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  30. level API which allows a programmer to (for instance) create or sign
  31. packets.
  32. %package devel
  33. Summary: Development package that includes the ldns header files
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The devel package contains the ldns library and the include files
  38. %if %{with_python}
  39. %package python
  40. Summary: Python extensions for ldns
  41. Group: Applications/System
  42. Requires: %{name} = %{version}-%{release}
  43. %description python
  44. Python extensions for ldns
  45. %endif
  46. %prep
  47. %setup -q
  48. %patch1
  49. %patch2
  50. # To built svn snapshots
  51. rm config.guess config.sub ltmain.sh
  52. aclocal
  53. libtoolize -c --install
  54. autoreconf --install
  55. %build
  56. %configure --disable-rpath --disable-static --with-sha2 \
  57. %if %{with_python}
  58. --with-pyldns
  59. %endif
  60. (cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  61. (cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  62. make %{?_smp_mflags}
  63. ( cd drill ; make %{?_smp_mflags} )
  64. ( cd examples ; make %{?_smp_mflags} )
  65. make %{?_smp_mflags} doc
  66. %install
  67. rm -rf %{buildroot}
  68. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  69. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  70. %if %{with_python}
  71. # remove execute perms from python files
  72. chmod a-x %{buildroot}%{python_sitelib}/*py
  73. %endif
  74. # don't package building script in doc
  75. rm doc/doxyparse.pl
  76. #remove doc stubs
  77. rm -rf doc/.svn
  78. #remove double set of man pages
  79. rm -rf doc/man
  80. # remove .la files
  81. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
  82. (cd drill ; make DESTDIR=%{buildroot} install)
  83. (cd examples; make DESTDIR=%{buildroot} install)
  84. %clean
  85. rm -rf %{buildroot}
  86. %files
  87. %defattr(-,root,root)
  88. %{_libdir}/libldns*so.*
  89. %{_bindir}/drill
  90. %{_bindir}/ldnsd
  91. #%{_bindir}/ldns-*
  92. %{_bindir}/ldns-chaos
  93. %{_bindir}/ldns-compare-zones
  94. %{_bindir}/ldns-[d-z]*
  95. %doc README LICENSE
  96. %{_mandir}/*/*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %{_libdir}/libldns*so
  100. %{_bindir}/ldns-config
  101. %dir %{_includedir}/ldns
  102. %{_includedir}/ldns/*.h
  103. %doc doc Changelog README
  104. %if %{with_python}
  105. %files python
  106. %defattr(-,root,root)
  107. %{python_sitelib}/*
  108. %endif
  109. %post -p /sbin/ldconfig
  110. %postun -p /sbin/ldconfig
  111. %changelog
  112. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  113. - rebuild with libpcap 1.1.1 on VineSeed
  114. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  115. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  116. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  117. - Fix missing _ldns.so causing ldns-python to not work
  118. - Patch for installing ldns-python files
  119. - Patch for rpath in ldns-python
  120. - Don't install .a file for ldns-python
  121. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  122. - Upgraded to 1.6.4.
  123. - Added ldns-python sub package
  124. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  125. - Upgraded to 1.6.3, which has minor bugfixes
  126. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  127. - Upgraded to 1.6.2. This fixes various bugs.
  128. (upstream released mostly to default with sha2 for the imminent
  129. signed root, but we already enabled that in our builds)
  130. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  131. - rebuilt with new openssl
  132. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  133. - Added openssl dependancy back in, since we get more functionality
  134. when using openssl. Especially in 'drill'.
  135. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  136. - Updated to 1.6.1
  137. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  139. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  140. - Fixed the ssl patch so it can now compile --without-ssl
  141. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  142. - Added patch to compile with --without-ssl
  143. - Removed openssl dependancies
  144. - Recompiled with --without-ssl
  145. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  146. - Updated to 1.6.0
  147. - (did not yet compile with --without-ssl due to compile failures)
  148. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  149. - Updated to 1.6.0
  150. - Compile without openssl
  151. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  152. - Memory management bug when generating a sha256 key, see:
  153. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  154. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  156. * Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  157. - Updated to new version, 1.5.0 had a bug preventing
  158. zone signing.
  159. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  160. - Updated to new version
  161. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  162. - fixed configure flags
  163. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  164. - rebuild with new openssl
  165. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  166. - Updated to 1.4.0
  167. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  168. - enable SHA2 functionality
  169. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  170. - re-tag (don't do builds while renaming local repo dirs)
  171. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  172. - Updated to latest release
  173. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  174. - Autorebuild for GCC 4.3
  175. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  176. - Rebuild for new libcrypto
  177. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  178. - Upgraded to 1.2.2. Removed no longer needed race workaround
  179. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  180. - Try to fix racing ln -s statements in parallel builds
  181. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  182. - Added patch for ldns-read-zone that does not put @. in RRDATA
  183. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  184. - Use install -p to work around multilib conflicts for .h files
  185. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  186. - Updated to 1.2.1
  187. - Removed patches that got moved into upstream
  188. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  189. - Patch for ldns-key2ds to write to stdout
  190. - Again remove extra set of man pages from doc
  191. - own /usr/include/ldns (bug 233858)
  192. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  193. - Added sha256 DS record patch to ldns-key2ds
  194. - Minor tweaks for proper doc/man page installation.
  195. - Workaround for parallel builds
  196. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  197. - Own the /usr/include/ldns directory (bug #233858)
  198. - Removed obsoleted patch
  199. - Remove files form previous libtool run accidentally packages by upstream
  200. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  201. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  202. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  203. - Fixed changelog typo in date
  204. - Rebuild requested for PT_GNU_HASH support from gcc
  205. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  206. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  207. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  208. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  209. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  210. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  211. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  212. * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  213. - added a make clean for 2.3.3 since .o files were left behind upstream,
  214. causing failure on ppc platform
  215. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  216. - minor cleanups
  217. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  218. - reworked for svn version
  219. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  220. - Initial version