python-imaging-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. %define pysite %{_libdir}/python%{pyver}/site-packages
  3. %define pyinc %{_includedir}/python%{pyver}
  4. Summary: The Python Imaging Library
  5. Summary(ja): Python イメージ処理ライブラリ
  6. Name: python-imaging
  7. Version: 1.1.6
  8. Release: 3%{?_dist_release}
  9. License: Distributable
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. Group: Development/Languages
  13. URL: http://www.pythonware.com/products/pil
  14. Source0: http://effbot.org/downloads/Imaging-%{version}.tar.gz
  15. Patch0: Imaging-1.1.5-setup.lib64.patch
  16. BuildRequires: python-devel >= 2.6
  17. BuildRequires: libjpeg-devel libpng-devel zlib-devel freetype2-devel
  18. BuildRequires: xorg-x11-devel
  19. Requires: python >= 2.6
  20. Requires: libjpeg >= 6a
  21. Requires: libpng >= 1.0.12
  22. Requires: zlib >= 1.1.4
  23. Requires: freetype2 >= 2.1.3
  24. Provides: Imaging, python-PIL
  25. Obsoletes: Imaging < %{version}
  26. Obsoletes: python-PIL < %{version}
  27. Obsoletes: python-Imaging <= %{version}
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. %description
  30. The Python Imaging Library (PIL) adds image processing capabilities
  31. to your Python environment. This library provides extensive file
  32. format support, an efficient internal representation, and fairly
  33. powerful image processing capabilities.
  34. %description -l ja
  35. Python Imaging Library (PIL) は Python 環境にイメージ処理能力を加えます.
  36. このライブラリには広範なファイル型式への対応, 効果的な内部表現, そして
  37. 真にパワフルなイメージ処理能力が備わっています.
  38. %prep
  39. %setup -q -n Imaging-%{version}
  40. %ifarch x86_64
  41. %patch0 -p1 -b .lib64~
  42. %endif
  43. %build
  44. python setup.py build_ext -i
  45. python selftest.py
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. #python setup.py install --root=$RPM_BUILD_ROOT
  49. mkdir -p $RPM_BUILD_ROOT%{pysite}/PIL
  50. mkdir -p $RPM_BUILD_ROOT%{pysite}/Sane
  51. cp PIL.pth $RPM_BUILD_ROOT%{pysite}/
  52. cp PIL/* $RPM_BUILD_ROOT%{pysite}/PIL/
  53. cp Sane/*[^\.c$] $RPM_BUILD_ROOT%{pysite}/Sane/
  54. mkdir -p $RPM_BUILD_ROOT%{pyinc}/PIL
  55. cp -p libImaging/*.h $RPM_BUILD_ROOT%{pyinc}/PIL/
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %files
  59. %defattr(-, root, root)
  60. %doc BUILDME CHANGES CONTENTS README
  61. %doc Docs
  62. %{pysite}/*
  63. %{pyinc}/*
  64. %changelog
  65. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-3
  66. - rebuild for python-2.6
  67. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-2vl5
  68. - rebuilt with python-2.5.2
  69. * Sat Jun 14 2008 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-1vl5
  70. - applied new versioning policy and spec in utf-8
  71. - added BuildRequires: xorg-x11-devel
  72. - fixed typo at Distribution
  73. * Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl4
  74. - fixed prereq, buildrequires pkgs
  75. * Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.6-0vl2
  76. - updated Imaging to 1.1.6
  77. - added BuildRequires: XOrg-devel zlib-devel libjpeg-devel libpng-devel freetype2-devel
  78. * Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl5
  79. - added Imaging-1.1.5-setup.lib64.patch
  80. - rebuilt for x86_64 architecture support
  81. * Wed May 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> python-imaging-1.1.5-0vl4
  82. - changed Group:
  83. * Fri Oct 07 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl3
  84. - rebuilt
  85. * Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> python-imaging-1.1.5-0vl2
  86. - changed package name 'python-Imaging' to 'python-imaging'
  87. * Fri May 20 2005 Shu KONNO <owa@bg.wakwak.com> python-Imaging-1.1.5-0vl1
  88. - changed package name 'Imaging' to 'python-Imaging'
  89. - updated Python Imaging Library (PIL) to 1.1.5
  90. - rebuilt with python-2.4
  91. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 1.1.3-0vl1
  92. - updated 1.1.3
  93. * Thu Jul 26 2001 Satoshi MACHINO <machino@vinelinux.org> 1.1.2-0vl1
  94. - updated 1.1.2
  95. * Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  96. - Imaging-1.1-0vl1
  97. - build on VineSeed
  98. * Sun Mar 7 1999 MATSUMOTO Shoji <vine@flatout.org>
  99. - make spec