tracker-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. Summary: An object database, tag/metadata database, search tool and indexer
  2. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  3. Name: tracker
  4. Version: 0.8.16
  5. Release: 3%{?_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. URL: http://www.gnome.org/projects/tracker/
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
  10. Patch0: tracker-ldfind.patch
  11. Patch1: tracker-0.8.16-poppler-0.15.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: glib2-devel >= 2.24.0
  14. BuildRequires: gtk2-devel >= 2.20.0
  15. BuildRequires: gnome-panel-devel
  16. BuildRequires: gmime-devel >= 2.4
  17. BuildRequires: poppler-devel
  18. BuildRequires: gettext
  19. BuildRequires: file
  20. BuildRequires: gnome-desktop-devel, gamin-devel
  21. BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
  22. BuildRequires: gstreamer-devel
  23. BuildRequires: desktop-file-utils, intltool
  24. BuildRequires: raptor-devel >= 1.4.18
  25. BuildRequires: sqlite3-devel
  26. BuildRequires: dbus-devel >= 1.0
  27. BuildRequires: dbus-glib-devel >= 0.78
  28. BuildRequires: libgnome-devel >= 2.13.2
  29. BuildRequires: libgnomeui-devel >= 2.13.7
  30. BuildRequires: libSM-devel
  31. BuildRequires: libnotify-devel >= 0.4.3
  32. BuildRequires: libuuid-devel
  33. BuildRequires: vala-devel
  34. BuildRequires: libgee-devel
  35. BuildRequires: upower-devel
  36. BuildRequires: gnome-applets
  37. BuildRequires: libgee-devel >= 0.3
  38. BuildRequires: nautilus-devel
  39. ## BuildRequires: autoconf, automake
  40. %description
  41. Tracker is a powerful desktop-neutral first class object database,
  42. tag/metadata database, search tool and indexer.
  43. It consists of a common object database that allows entities to have an
  44. almost infinte number of properties, metadata (both embedded/harvested as
  45. well as user definable), a comprehensive database of keywords/tags and
  46. links to other entities.
  47. It provides additional features for file based objects including context
  48. linking and audit trails for a file object.
  49. It has the ability to index, store, harvest metadata. retrieve and search
  50. all types of files and other first class objects
  51. %package devel
  52. Summary: Headers for developing programs that will use %{name}
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: pkgconfig
  56. Requires: dbus-glib-devel
  57. %description devel
  58. This package contains the static libraries and header files needed for
  59. developing with tracker
  60. %package search-tool
  61. Summary: Tracker search tool(s)
  62. Group: User Interface/Desktops
  63. Requires: %{name} = %{version}-%{release}
  64. %description search-tool
  65. Graphical frontend to tracker search facilities. This has dependencies on
  66. GNOME libraries
  67. %prep
  68. %setup -q
  69. %patch1 -p1 -b .poppler
  70. # remove shebangs from the python files as none should be executable scripts
  71. ## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
  72. %build
  73. ## libtoolize --force --copy
  74. ## intltoolize --copy --force
  75. ## autoreconf -i -f
  76. %configure --disable-static \
  77. --enable-video-extractor=external \
  78. --enable-tracker-search-tool=yes \
  79. --enable-tracker-search-bar=yes
  80. # Disable rpath
  81. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  82. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  83. make %{?_smp_mflags}
  84. %install
  85. rm -rf %{buildroot}
  86. make DESTDIR=%{buildroot} install
  87. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  88. echo "%{_libdir}/tracker-0.8" \
  89. > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  90. desktop-file-install --delete-original \
  91. --vendor="" \
  92. --dir=%{buildroot}%{_datadir}/applications \
  93. %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
  94. rm -rf %{buildroot}%{_libdir}/*.{a,la}
  95. rm -f %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
  96. rm -rf %{buildroot}%{_datadir}/tracker-tests
  97. %find_lang %{name}
  98. %clean
  99. rm -rf %{buildroot}
  100. %post
  101. /sbin/ldconfig
  102. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  103. %posttrans
  104. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  105. %postun
  106. /sbin/ldconfig
  107. if [ $1 -eq 0 ] ; then
  108. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  109. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  110. fi
  111. %files -f %{name}.lang
  112. %defattr(-, root, root, -)
  113. %doc AUTHORS ChangeLog COPYING NEWS README
  114. ### %doc %{_datadir}/gtk-doc/html/libtracker-common/
  115. ### %doc %{_datadir}/gtk-doc/html/libtracker-module/
  116. %{_bindir}/tracker*
  117. %exclude %{_bindir}/tracker-search-tool
  118. %exclude %{_bindir}/tracker-preferences
  119. ### %exclude %{_bindir}/tracker-applet
  120. %{_libexecdir}/tracker*
  121. %{_libdir}/*.so.*
  122. %{_libdir}/tracker-0.8/
  123. %{_datadir}/tracker/
  124. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  125. %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  126. %{_sysconfdir}/xdg/autostart/tracker*.desktop
  127. %{_mandir}/*/tracker*.gz
  128. %exclude %{_mandir}/man1/tracker-search-bar.1.gz
  129. %exclude %{_mandir}/man1/tracker-preferences.1.gz
  130. %exclude %{_mandir}/man1/tracker-search-tool.1.gz
  131. %files devel
  132. %defattr(-, root, root, -)
  133. %{_includedir}/tracker-0.8/
  134. ### %{_includedir}/libtracker-gtk/*
  135. %{_libdir}/*.so
  136. %{_libdir}/pkgconfig/*.pc
  137. %{_datadir}/vala/vapi/tracker*.vapi
  138. %{_datadir}/vala/vapi/tracker*.deps
  139. %files search-tool
  140. %defattr(-, root, root, -)
  141. %{_bindir}/tracker-search-tool
  142. %{_bindir}/tracker-preferences
  143. %{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
  144. %{_libdir}/nautilus/extensions-2.0/*.so
  145. %{_datadir}/icons/*/*/apps/tracker.*
  146. %{_datadir}/applications/*.desktop
  147. %{_mandir}/man1/tracker-search-bar.1.gz
  148. %{_mandir}/man1/tracker-preferences.1.gz
  149. %{_mandir}/man1/tracker-search-tool.1.gz
  150. %changelog
  151. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
  152. - rebuilt with poppler-0.16.3
  153. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
  154. - rebuild with poppler-0.14.2
  155. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
  156. - new upstream release
  157. - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
  158. - add configure option (--enable-tracker-search-bar)
  159. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  160. - new upstream release
  161. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  162. - new upstream release
  163. - fix URL of Source0
  164. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  165. - new upstream release
  166. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  167. - new upstream release
  168. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  169. - new upstream release
  170. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  171. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  172. - new upstream release
  173. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  174. - new upstream release
  175. - add BuildRequires: upower-devel, gnome-applets
  176. - change BuildRequires: dbus-glib -> dbus-glib-devel
  177. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  178. - new upstream release
  179. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  180. - fix BuildRequires: gmime-devel >= 2.4
  181. - add configure option (--enable-tracker-search-tool)
  182. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  183. - new upstream release
  184. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  185. - rebuild with poppler-0.10.2
  186. - spec in UTF-8
  187. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  188. - new upstream release
  189. - update Patch1
  190. - drop Patch10 (no more necessary)
  191. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  192. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  193. - apply new versioning policy
  194. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  195. - new upstream release
  196. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  197. - add Patch10 to fix selecting video-extractor
  198. - use external video extractor(totem) instead of gstreamer/xine
  199. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  200. - initial build for Vine Linux
  201. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  202. - Ship both autostart desktop files in the main package (BZ #233323)
  203. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  204. - Package the deskbar plugin properly (BZ #228308)
  205. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  206. - Split out tracker-search-tool sub-packages, for the GUI facility
  207. - Add proper requires for the -devel subpackage
  208. - Deal with the rpmlint complaints on rpath
  209. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  210. - Update to 0.5.4
  211. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  212. - Update to 0.5.3
  213. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  214. - Apply patch on Makefile.am instead of Makefile.in
  215. - Add libtool to BR
  216. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  217. - Update to 0.5.2
  218. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  219. - Update to new version
  220. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  221. - Have the devel subpackage require pkgconfig
  222. - Make the description field not have more than 76 characters on a line
  223. - Fix up the RPM group
  224. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  225. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  226. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  227. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  228. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  229. - Add autostart desktop file.
  230. - Edit the package description as suggested in review
  231. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  232. - More cleaups to the spec file.
  233. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  234. - Add needed BRs
  235. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  236. - Initial packaging for Fedora Extras