Field3D-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. Name: Field3D
  2. Version: 1.7.3
  3. Release: 4%{?_dist_release}
  4. Summary: Library for storing voxel data
  5. Summary(ja): ボクセルデータを蓄積するためのライブラリ
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://sites.google.com/site/field3d/
  11. # https://github.com/imageworks/Field3D/archive/v1.6.2.tar.gz
  12. Source0: https://github.com/imageworks/Field3D/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake doxygen
  15. BuildRequires: hdf5-devel
  16. BuildRequires: ilmbase-devel
  17. BuildRequires: libboost-devel
  18. BuildRequires: libboost-atomic
  19. BuildRequires: libboost-chrono
  20. BuildRequires: libboost-date-time
  21. BuildRequires: libboost-program-options
  22. BuildRequires: libboost-regex
  23. BuildRequires: libboost-system
  24. BuildRequires: libboost-thread
  25. BuildRequires: zlib-devel
  26. Requires: hdf5
  27. %description
  28. Field3D is an open source library for storing voxel data. It provides C++
  29. classes that handle in-memory storage and a file format based on HDF5 that
  30. allows the C++ objects to be written to and read from disk.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: programming
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. Development headers and documentation for %{name}.
  38. # Need devel-docs subpackage.
  39. %debug_package
  40. %prep
  41. %setup -q
  42. # for OpenEXR (IlmBase) >= 2.4.0
  43. SFX=`pkg-config --variable=libsuffix IlmBase`
  44. sed -i \
  45. -e "s/ Iex / Iex$SFX /" \
  46. -e "s/ Half / Half$SFX /" \
  47. -e "s/ IlmThread / IlmThread$SFX /" \
  48. -e "s/ Imath/ Imath$SFX/" \
  49. CMakeLists.txt
  50. %build
  51. export CFLAGS="%{?optflags} -DH5_USE_110_API=1"
  52. export CXXFLAGS="%{?optflags} -DH5_USE_110_API=1"
  53. %cmake -DINSTALL_DOCS=OFF
  54. %cmake_build
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. %cmake_install
  58. install -D -m 0644 man/f3dinfo.1 $RPM_BUILD_ROOT%{_mandir}/man1/f3dinfo.1
  59. %check
  60. %ctest
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %license COPYING
  65. %doc CHANGES README
  66. %{_bindir}/f3dinfo
  67. %{_libdir}/libField3D.so.*
  68. %{_mandir}/man1/f3dinfo.1.gz
  69. %files devel
  70. %doc docs/html/
  71. %{_includedir}/Field3D/
  72. %{_libdir}/libField3D.so
  73. %changelog
  74. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-4
  75. - rebuilt with icu69.
  76. - dropped ldconfig scriptlets.
  77. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-3
  78. - rebuilt with libboost-1.75.0.
  79. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-2
  80. - rebuilt with OpenEXR-2.5.3 and hdf5-1.12.0.
  81. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.3-1
  82. - new upstream release.
  83. - built with boost-1.72.0.
  84. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.2-2
  85. - rebuilt with ilmbase-2.4.0.
  86. * Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> - 1.7.2-1
  87. - update to 1.7.2
  88. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-4
  89. - rebuild with hdf5-1.8.20
  90. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.2-3
  91. - rebuild with libboost-1.66.0
  92. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-2
  93. - rebuild with gcc-5.4.0
  94. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.2-1
  95. - new upstream release
  96. - add BuildRequires: libboost-{atomic,chrono,date-time}
  97. * Fri Jan 30 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.3-2
  98. - added Group tag
  99. - added %%clean section
  100. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.3-1
  101. - initial build for Vine Linux
  102. * Wed Jan 07 2015 Orion Poplawski <orion@cora.nwra.com> - 1.4.3-3
  103. - Rebuild for hdf5 1.8.4
  104. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.3-2
  105. - rebuild (ilmbase), add matching/missing popd's
  106. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.3-1
  107. - Update to latest upstream release.
  108. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-19
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  110. * Tue Jun 10 2014 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-18
  111. - Rebuild for hdf 1.8.13
  112. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-17
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  114. * Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 1.3.2-16
  115. - Rebuild for boost 1.55.0
  116. * Fri Dec 27 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-15
  117. - Rebuild for hdf5 1.8.12
  118. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-14
  119. - rebuild (ilmbase)
  120. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.3.2-13
  121. - rebuild (ilmbase)
  122. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-12
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  124. * Sat Jul 27 2013 pmachata@redhat.com - 1.3.2-11
  125. - Rebuild for boost 1.54.0
  126. * Thu May 16 2013 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-10
  127. - Rebuild for hdf5 1.8.11
  128. * Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-9
  129. - Rebuild for Boost-1.53.0
  130. * Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.3.2-8
  131. - Rebuild for Boost-1.53.0
  132. * Mon Dec 3 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-7
  133. - Rebuild for hdf5 1.8.10
  134. * Wed Aug 8 2012 David Malcolm <dmalcolm@redhat.com> - 1.3.2-6
  135. - rebuild against boost-1.50
  136. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-4
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  138. * Tue May 15 2012 Orion Poplawski <orion@cora.nwra.com> - 1.3.2-3
  139. - Rebuild for hdf5 1.8.9
  140. - Explicitly require the version of hdf5 built with
  141. * Fri Mar 23 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-2
  142. - Bump EVR for oops with F17 package to make sure rawhide package is newer.
  143. * Tue Feb 28 2012 Richard Shaw <hobbes1069@gmail.com> - 1.3.2-1
  144. - Update to latest release.
  145. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-4
  146. - Rebuilt for c++ ABI breakage
  147. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-3
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  149. * Mon Jan 09 2012 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-2
  150. - Fixed building under GCC 4.7.0.
  151. * Sat Nov 12 2011 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  152. - Initial release.