HelixPlayer-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. Summary: Open source media player based on the Helix framework
  2. Summary(ja): Helix フレームワークに基づくメディアプレイヤー
  3. Name: HelixPlayer
  4. Version: 1.0.7
  5. Release: 6vl1
  6. Group: Applications/Multimedia
  7. License: RPSL, GPL
  8. URL: https://player.helixcommunity.org/
  9. Source0: https://helixcommunity.org/download.php/1950/hxplay-1.0.7-source.tar.bz2
  10. Source1: HelixPlayer-buildrc
  11. Obsoletes: G2player, RealOne
  12. Provides: G2player, RealOne
  13. Patch0: %{name}-1.0.beta20040615-cvs-no-update.patch
  14. Patch1: %{name}-1.0.3-disable-asm.patch
  15. Patch2: hxplay-1.0.4-nptl.patch
  16. Patch3: %{name}-1.0.5-missing-header.patch
  17. Patch4: HelixPlayer-1.0.7-ogg.patch
  18. Patch5: HelixPlayer-1.0.7-CVE-2007-3410.patch
  19. BuildRequires: libtheora-devel >= 1.0-0.alpha3
  20. BuildRequires: libvorbis-devel
  21. BuildRequires: gtk2-devel python prelink
  22. BuildRequires: libogg-devel XOrg-devel
  23. BuildRequires: desktop-file-utils >= 0.9
  24. ExcludeArch: ppc64 x86_64 s390 s390x ia64
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. %description
  27. The Helix Player is an open-source media player built in the Helix
  28. Community for consumers. Built using GTK, it plays open source formats,
  29. like Ogg Vorbis and Theora using the powerful Helix DNA Client Media
  30. Engine.
  31. %description -l ja
  32. Helix Player は Helix Community で作成されたコンシューマ向けの
  33. オープンソースなメディアプレイヤーです.GTKを利用して作成されており,強力な
  34. Helix DNA Client Media Engine を利用して Ogg Vorbis や Theora などの
  35. オープンソースフォーマットのファイルを演奏/閲覧することが可能です.
  36. %package plugin
  37. Summary: HelixPlayer's webbrowser plugin
  38. Group: Applications/Multimedia
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: %{_libdir}/mozilla/plugins
  41. %description plugin
  42. This plugin lets your webbrowser play multimedia content through
  43. HelixPlayer
  44. %prep
  45. %setup -q -n hxplay-%{version}
  46. %patch0 -p1 -b cvs-no-update
  47. %patch1 -p1 -b .disable-asm
  48. %patch2 -p1 -b .nptl
  49. %patch3 -p1 -b .missing-header
  50. %patch4 -p0 -b .ogg
  51. %patch5 -p1 -b .CVE-2007-3410
  52. %build
  53. # Change hxplay_gtk_release to whatever string is in the Makefile
  54. BUILDRC=%{SOURCE1} BUILD_ROOT="`pwd`/build" \
  55. PATH="$PATH:$$BUILD_ROOT/bin" \
  56. python build/bin/build -v -t release -k -y \
  57. %{?_smp_mflags} -m hxplay_gtk_release \
  58. -p green -P helix-client-all-defines-free \
  59. player_all
  60. chmod -x build/*.txt
  61. %install
  62. rm -rf %{buildroot}
  63. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  64. cat > $RPM_BUILD_ROOT%{_bindir}/hxplay <<EOF
  65. #!/bin/sh
  66. HELIX_LIBS=%{_libdir}/helix
  67. export HELIX_LIBS
  68. exec %{_bindir}/hxplay.bin "\$@"
  69. EOF
  70. install -p -m 755 release/hxplay.bin %{buildroot}/%{_bindir}/
  71. chmod a+x %{buildroot}/%{_bindir}/*
  72. mkdir -p %{buildroot}/%{_libdir}/helix/common
  73. install -p -m 755 player/installer/archive/temp/common/*.so %{buildroot}/%{_libdir}/helix/common/
  74. mkdir -p %{buildroot}/%{_libdir}/helix/plugins
  75. install -p -m 755 player/installer/archive/temp/plugins/*.so %{buildroot}/%{_libdir}/helix/plugins/
  76. mkdir -p %{buildroot}/%{_libdir}/helix
  77. install -p -m 644 player/installer/archive/temp/LICENSE %{buildroot}/%{_libdir}/helix/
  78. install -p -m 644 player/installer/archive/temp/README %{buildroot}/%{_libdir}/helix/
  79. (cd %{buildroot}/%{_docdir}/%{name}-%{version} && ln -s %{_libdir/helix} .)
  80. mkdir -p %{buildroot}/%{_libdir}/helix/codecs
  81. install -p -m 755 player/installer/archive/temp/codecs/*.so %{buildroot}/%{_libdir}/helix/codecs/
  82. mkdir -p %{buildroot}/%{_libdir}/mozilla/plugins
  83. install -p -m 755 player/installer/archive/temp/mozilla/nphelix.so %{buildroot}/%{_libdir}/mozilla/plugins/
  84. install -p -m 644 player/installer/archive/temp/mozilla/nphelix.xpt %{buildroot}/%{_libdir}/mozilla/plugins
  85. mkdir -p %{buildroot}/%{_datadir}/application-registry/
  86. install -p -m 644 player/installer/common/hxplay.applications %{buildroot}/%{_datadir}/application-registry/
  87. # Desktop file
  88. mkdir -p %{buildroot}/%{_datadir}/applications/
  89. cp -p player/installer/common/hxplay.desktop player/installer/common/realplay.desktop
  90. desktop-file-install --vendor vine \
  91. --dir %{buildroot}%{_datadir}/applications \
  92. --add-category X-Fedora \
  93. player/installer/common/realplay.desktop
  94. mkdir -p %{buildroot}/%{_datadir}/mime-info/
  95. install -p -m 644 player/installer/common/hxplay.keys %{buildroot}/%{_datadir}/mime-info/
  96. install -p -m 644 player/installer/common/hxplay.mime %{buildroot}/%{_datadir}/mime-info/
  97. mkdir -p %{buildroot}/%{_libdir}/helix/share/hxplay
  98. (cd %{buildroot}/%{_libdir}/helix/share/ && ln -s %{_datadir}/icons/hicolor/48x48/apps/hxplay.png .)
  99. install -p -m 644 player/app/gtk/res/default/*.png %{buildroot}/%{_libdir}/helix/share/hxplay/
  100. install -p -m 644 player/app/gtk/res/hxplay/*.png %{buildroot}/%{_libdir}/helix/share/hxplay/
  101. for LANGUAGE in "de" "es" "fr" "it" "ja" "ko" "pt_BR" "zh_CN" "zh_TW"; do
  102. dir=%{buildroot}/%{_datadir}/locale/$LANGUAGE/LC_MESSAGES/
  103. mkdir -p $dir
  104. install -p -m 644 "player/installer/archive/temp/share/locale/$LANGUAGE/player.mo" "$dir/hxplay.mo"
  105. install -p -m 644 "player/installer/archive/temp/share/locale/$LANGUAGE/widget.mo" "$dir/libgtkhx.mo"
  106. done
  107. for SIZE in "16x16" "32x32" "48x48" "128x128" "192x192" ; do
  108. mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE
  109. mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE/apps
  110. mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$SIZE/mimetypes
  111. ICON=player/app/gtk/res/icons/hxplay/hxplay_${SIZE}.png
  112. if [ -f "$ICON" ] ; then
  113. mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/apps
  114. install -p -m 644 "$ICON" %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/apps/hxplay.png
  115. fi
  116. for MIME in \
  117. "application-ram" \
  118. "application-rpm" \
  119. "application-rm" \
  120. "audio-ra" \
  121. "video-rv" ; do
  122. ICON=player/app/gtk/res/icons/hxplay/mime-${MIME}_${SIZE}.png
  123. if [ -f "$ICON" ] ; then
  124. mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/mimetypes
  125. install -p -m 644 "$ICON" %{buildroot}/%{_datadir}/icons/hicolor/${SIZE}/mimetypes/hxplay-${MIME}.png
  126. fi
  127. done
  128. done
  129. # Hack to get rid of executable stack on shared object files
  130. execstack -c %{buildroot}/%{_libdir}/helix/codecs/colorcvt.so
  131. execstack -c %{buildroot}/%{_libdir}/helix/codecs/cvt1.so
  132. execstack -c %{buildroot}/%{_libdir}/helix/plugins/vidsite.so
  133. chmod -x %{buildroot}/%{_datadir}/application-registry/hxplay.applications
  134. chmod -x %{buildroot}/%{_datadir}/mime-info/hxplay.mime
  135. chmod -x %{buildroot}/%{_libdir}/helix/LICENSE
  136. chmod -x %{buildroot}/%{_datadir}/mime-info/hxplay.keys
  137. %{find_lang} hxplay
  138. %{find_lang} libgtkhx
  139. cat hxplay.lang > %{name}.lang
  140. cat libgtkhx.lang >> %{name}.lang
  141. %clean
  142. rm -rf $RPM_BUILD_ROOT
  143. %post
  144. update-desktop-database %{_datadir}/applications
  145. touch --no-create %{_datadir}/icons/hicolor || :
  146. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  147. %postun
  148. update-desktop-database %{_datadir}/applications
  149. touch --no-create %{_datadir}/icons/hicolor || :
  150. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  151. %files -f %{name}.lang
  152. %defattr(-,root,root)
  153. %doc build/*.txt
  154. %{_bindir}/hxplay*
  155. %{_libdir}/helix
  156. #{_libdir}/mozilla/plugins/*
  157. %{_datadir}/icons/hicolor/*
  158. %{_datadir}/mime-info/*
  159. %{_datadir}/applications/*.desktop
  160. %{_datadir}/application-registry/hxplay.applications
  161. #{_datadir}/locale/*/*
  162. %files plugin
  163. %defattr(-,root,root)
  164. %{_libdir}/mozilla/plugins/*
  165. %changelog
  166. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-6vl1
  167. - new upstream release
  168. * Thu Jun 28 2007 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-6
  169. - fix bug 245838 (CVE-2007-3410)
  170. * Fri Dec 08 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-5
  171. - add patch to make ogg/vorbis work (bug 218896)
  172. * Thu Sep 28 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-4
  173. - fixes from bug 201006 comment 20
  174. * Thu Sep 28 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-3
  175. - split the webbrowser plugin
  176. * Tue Sep 19 2006 Aurelien Bompard <abompard@fedoraproject.org> 1:1.0.7-2
  177. - added fixes from bug 201006 comment 2
  178. * Tue Nov 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1vl1
  179. - new upstream release
  180. * Tue Sep 27 2005 John (J5) Palmieri <johnp@redhat.com> - 1:1.0.6-1
  181. - Fix for CAN-2005-2710
  182. * Fri Jun 24 2005 Colin Walters <walters@redhat.com> 1:1.0.5-1
  183. - New patch HelixPlayer-1.0.5-missing-header.patch
  184. * Sun Jun 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-4vl1
  185. - new upstream release
  186. * Thu Mar 3 2005 Ray Strode <rstrode@redhat.com> 1:1.0.3-4
  187. - Update to 1.0.3 to fix 150098 and 150103.
  188. - Add some execshield foo to stop some execstack regressions
  189. - Add libogg-devel build req to tame compiler
  190. * Wed Jan 24 2005 Colin Walters <walters@redhat.com> 1:1.0.2-3
  191. - Remove EULA from License field (there is no EULA AFAICS), and
  192. add GPL
  193. * Wed Jan 05 2005 Colin Walters <walters@redhat.com> 1:1.0.2-2
  194. - Apply patch from ville.skytta@iki.fi to avoid
  195. owning /usr/lib/mozilla (144237)
  196. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> 1:1.0.2-1
  197. - New upstream version 1.0.2
  198. - Switch to hxplay_gtk_stable branch
  199. * Sat Oct 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-1vl1
  200. - new upstream release
  201. - Drop upstreamed HelixPlayer-1.0.beta20040615-mmx-clobber.patch
  202. - Drop HelixPlayer-1.0.beta20040615-desktop.patch per request
  203. - Switch to bingo-gold target
  204. - added Japanese summary and description
  205. * Thu Sep 9 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0.298-3vl2
  206. - fixed %files section (Thanks to IWAI Masaharu)
  207. - added GPL and RPSL files into %doc
  208. * Sun Sep 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0.298-3vl1
  209. - Build for Vine
  210. - changed version numberring
  211. * Mon Aug 23 2004 Colin Walters <walters@redhat.com> 1.0.gold-3
  212. - Install README and LICENSE
  213. * Fri Aug 06 2004 Colin Walters <walters@redhat.com> 1.0.gold-2
  214. - Put mozilla plugins in correct directory (#129305)
  215. * Mon Aug 02 2004 Colin Walters <walters@redhat.com> 1.0.gold-1
  216. - Update to gold
  217. - Use setup -n to set directory instead of repacking tarball
  218. - Switch bif target to bingo-gold-free
  219. * Thu Jul 29 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-6
  220. - Rework Summary a bit
  221. - Minor spec cleanups
  222. * Mon Jul 26 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-5
  223. - Add patch to port to GtkFileChooser
  224. - ExcludeArch ppc
  225. * Fri Jul 16 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-4
  226. - Restore MIME icon installation into hicolor directory
  227. * Fri Jul 16 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-3
  228. - Add patch to fix desktop file name
  229. - Set build failure color to "green" to exit on any error
  230. - Add smp_mflags variable for parallel building
  231. * Thu Jul 15 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-2
  232. - BR latest theora
  233. - More spec file bits
  234. - Install logo for real
  235. * Mon Jul 12 2004 Colin Walters <walters@redhat.com> 1.0.beta20040615-1
  236. - Some spec file cleanups
  237. * Mon Jun 8 2004 Ryan Gammon <rgammon@real.com>
  238. - Adding /usr/share/pixmap, document icons
  239. * Mon Jun 7 2004 Nicholas Hart <nhart@real.com>
  240. - added .mime/.keys/.applications files
  241. * Wed May 5 2004 Ryan Gammon <rggammon@helixcommunity.org>
  242. - Updating icons
  243. * Thu Jan 13 2004 Nicholas Hart <nhart@helixcommunity.org>
  244. - tweaked some paths to deal with tarball generated by player/installer/app
  245. - changed, reformatted some of the package info
  246. * Sat Dec 27 2003 Thomas Chung <tchung@linuxinstall.org> 0.2.0.0-20031224
  247. - First RPM build for Fedora Core 1