dconf-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245
  1. %bcond_with systemd
  2. # Basic Information
  3. Name: dconf
  4. Summary: dconf is a low-level configuration system.
  5. Summary(ja): dconfは、低レベル設定システムです。
  6. Version: 0.40.0
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: yasumichi
  12. License: LGPL
  13. %global shortver %(echo %{version} | cut -d . -f 1-2)
  14. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. # Dependency
  17. Requires: dbus
  18. BuildRequires: meson, ninja
  19. BuildRequires: glib2-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: dbus-devel
  22. BuildRequires: libxslt-devel
  23. BuildRequires: vala
  24. BuildRequires: docbook-style-xsl
  25. BuildRequires: bash-completion
  26. BuildRequires: gtk-doc
  27. %description
  28. dconf is a low-level configuration system. Its main purpose is to provide
  29. a backend to GSettings on platforms that don't already have configuration
  30. storage systems.
  31. %description -l ja
  32. dconfは、低レベル設定システムです。その主要な目的は、まだ設定保存システムを
  33. 有していないプラットフォーム上にGSettingsのバックエンドを提供することです。
  34. %package devel
  35. Summary: Headers for developing programs that will use %{name}
  36. Summary(ja): %{name} の開発用ファイル
  37. Group: programming
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: glib2-devel
  40. Requires: libxml2-devel
  41. Requires: dbus-devel
  42. %description devel
  43. This package contains the headers that programmers will need to develop
  44. applications which will use %{name}.
  45. %package docs
  46. Summary: Documentation for %{name}
  47. Summary(ja): %{name} 用のドキュメント
  48. Group: documentation
  49. BuildArch: noarch
  50. %description docs
  51. This package contains documentation for %{name}.
  52. %package vala
  53. Summary: Vala bindings for %{name}
  54. Summary(ja): %{name} の Vala バインディング
  55. Group: programming
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: vala
  58. %description vala
  59. Vala bindings for %{name}.
  60. %debug_package
  61. %prep
  62. %setup -q
  63. %build
  64. %meson -Dgtk_doc=true
  65. %meson_build
  66. %install
  67. %{__rm} -rf %{buildroot}
  68. %meson_install
  69. %if ! %{with systemd}
  70. rm -rf %{buildroot}/usr/lib/systemd
  71. %endif
  72. mkdir -p %{buildroot}%{_sysconfdir}/dconf/profile
  73. cat << EOF > %{buildroot}%{_sysconfdir}/dconf/profile/user
  74. user-db:user
  75. system-db:local
  76. system-db:site
  77. system-db:distro
  78. EOF
  79. mkdir -p %{buildroot}%{_sysconfdir}/dconf/db/local.d/locks
  80. mkdir -p %{buildroot}%{_sysconfdir}/dconf/db/site.d/locks
  81. mkdir -p %{buildroot}%{_sysconfdir}/dconf/db/distro.d/locks
  82. %clean
  83. %{__rm} -rf %{buildroot}
  84. %posttrans
  85. dconf update ||:
  86. exit 0
  87. %if %{with systemd}
  88. %post
  89. %systemd_user_post dconf.service
  90. %preun
  91. %systemd_user_preun dconf.service
  92. %postun
  93. %systemd_user_postun_with_restart dconf.service
  94. %endif
  95. %files
  96. %defattr(-,root,root,-)
  97. %license COPYING
  98. %doc NEWS
  99. %dir %{_sysconfdir}/dconf
  100. %dir %{_sysconfdir}/dconf/db
  101. %dir %{_sysconfdir}/dconf/db/local.d
  102. %dir %{_sysconfdir}/dconf/db/local.d/locks
  103. %dir %{_sysconfdir}/dconf/db/site.d
  104. %dir %{_sysconfdir}/dconf/db/site.d/locks
  105. %dir %{_sysconfdir}/dconf/db/distro.d
  106. %dir %{_sysconfdir}/dconf/db/distro.d/locks
  107. %dir %{_sysconfdir}/dconf/profile
  108. %config(noreplace) %{_sysconfdir}/dconf/profile/user
  109. %{_bindir}/dconf
  110. %{_libdir}/gio/modules/libdconfsettings.so
  111. %{_libdir}/libdconf*.so.*
  112. %{_libexecdir}/dconf-service
  113. %dir %{_datadir}/bash-completion
  114. %dir %{_datadir}/bash-completion/completions
  115. %{_datadir}/bash-completion/completions/dconf
  116. %{_datadir}/dbus-1/services/ca.desrt.dconf.service
  117. %{_mandir}/man1/dconf.1.gz
  118. %{_mandir}/man1/dconf-service.1.gz
  119. %{_mandir}/man7/dconf.7.gz
  120. %if %{with systemd}
  121. %{_userunitdir}/*
  122. %endif
  123. %files devel
  124. %defattr(-,root,root,-)
  125. %{_includedir}/dconf/
  126. %{_libdir}/libdconf*.so
  127. %{_libdir}/pkgconfig/*.pc
  128. %files docs
  129. %defattr(-,root,root,-)
  130. %{_datadir}/gtk-doc/html/dconf/
  131. %files vala
  132. %defattr(-,root,root,-)
  133. %{_datadir}/vala/vapi/dconf.deps
  134. %{_datadir}/vala/vapi/dconf.vapi
  135. %changelog
  136. * Wed Apr 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.0-1
  137. - new upstream release.
  138. - dropped ldconfig scriptlets.
  139. - added /etc/dconf structures.
  140. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.36.0-1
  141. - new upstream release.
  142. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.0-1
  143. - new upstream release
  144. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  145. - new upstream release
  146. - remove dconf-editor subpackage
  147. - create %%{name}-docs,vala subpackages
  148. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  149. - new upstream release
  150. * Wed Jun 18 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.20.0-3
  151. - move some post/postun scripts to dconf-editor:
  152. - glib-compile-schemas, gtk-update-icon-cache, update-desktop-database
  153. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.20.0-2
  154. - split dconf-editor to subpackage.
  155. - drop libgee dependency(R,BR)
  156. - remove unneeded dependency(Requires)
  157. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.0-1
  158. - new upstream release
  159. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-2
  160. - rebuild with VineSeed environment
  161. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  162. - new upstream release
  163. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  164. - new upstream release
  165. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  166. - new upstream release
  167. - add BuildRequires: vala
  168. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  169. - new upstream release
  170. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  171. - new upstream release
  172. - add BuildRequires: libxslt-devel, docbook-style-xsl
  173. * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  174. - new upstream release
  175. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
  176. - new upstream release
  177. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  178. - new upstream release
  179. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
  180. - new upstream release
  181. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  182. - new upstream release
  183. - add BuildRequires: dbus-devel
  184. - change BuildRequires: gtk3-devel instead of gtk2-devel
  185. * Sun Oct 17 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.5.1-1
  186. - new package.