dejagnu-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. Summary: A front end for testing other programs.
  2. Summary(ja): 各種プログラムをテストするためのフロントエンド
  3. Name: dejagnu
  4. Epoch: 1
  5. Version: 1.6.3
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: shaolin
  11. License: GPLv2
  12. URL: https://www.gnu.org/software/dejagnu/
  13. Source: https://ftp.gnu.org/gnu/dejagnu/dejagnu-%{version}.tar.gz
  14. Requires: tcl >= 8.6, expect >= 5.21
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildArch: noarch
  17. BuildRequires: expect screen texinfo
  18. %description
  19. DejaGnu is an Expect/Tcl based framework for testing other programs.
  20. DejaGnu has several purposes: to make it easy to write tests for any
  21. program; to allow you to write tests which will be portable to any
  22. host or target where a program must be tested; and to standardize the
  23. output format of all tests (making it easier to integrate the testing
  24. into software development).
  25. %debug_package
  26. %prep
  27. %setup -q -n dejagnu-%{version}
  28. find . -name \*.rej -exec rm {} \;
  29. %build
  30. mkdir %{_vpath_builddir}
  31. pushd %{_vpath_builddir}
  32. %define _configure ../configure
  33. %configure -v
  34. popd
  35. %install
  36. rm -rf %{buildroot}
  37. pushd %{_vpath_builddir}
  38. %makeinstall
  39. rm -f %{buildroot}%{_infodir}/dir
  40. chmod a-x %{buildroot}/%{_datadir}/dejagnu/runtest.exp
  41. make DESTDIR=%{buildroot} install-man
  42. install -D -m 644 ../doc/dejagnu.info %{buildroot}/%{_infodir}/%{name}.info
  43. popd
  44. %check
  45. pushd %{_vpath_builddir}
  46. echo ============TESTING===============
  47. # Dejagnu test suite also has to test reporting to user. It needs a
  48. # terminal for that. That doesn't compute in mock. Work around it by
  49. # running the test under screen and communicating back to test runner
  50. # via temporary file. If you have better idea, we accept patches.
  51. TMP=`mktemp`
  52. export SCREENDIR=`mktemp -d`
  53. #screen -D -m sh -c '(make check RUNTESTFLAGS="RUNTEST=`pwd`/runtest"; echo $?) >> '$TMP
  54. screen -D -m sh -c '(make check; echo $?) >> '$TMP
  55. RESULT=`tail -n 1 $TMP`
  56. cat $TMP
  57. rm -f $TMP
  58. rm -rf $SCREENDIR
  59. echo ============END TESTING===========
  60. popd
  61. exit $RESULT
  62. %clean
  63. rm -rf %{buildroot}
  64. %post
  65. /sbin/install-info %{_infodir}/%{name}.info.gz --dir-file=%{_infodir}/dir ||:
  66. %preun
  67. if [ $1 = 0 ]; then
  68. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  69. fi
  70. %files
  71. %defattr(-,root,root)
  72. %license COPYING
  73. %doc NEWS README AUTHORS INSTALL ChangeLog doc/dejagnu.texi
  74. %{_bindir}/dejagnu
  75. %{_bindir}/runtest
  76. %{_datadir}/dejagnu
  77. %{_includedir}/dejagnu.h
  78. %{_mandir}/*/*
  79. %{_infodir}/*
  80. %changelog
  81. * Sat Jun 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1:1.6.3-1
  82. - new upstream release.
  83. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1:1.6.2-1
  84. - new upstream release.
  85. - dropped all patches.
  86. * Mon Jan 13 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:1.5.1-1
  87. - updated to 1.5.1; import patches from Fedora; spec cleanup
  88. * Sun May 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.4-2
  89. - rebuilt with current VineSeed
  90. - added BR: texinfo
  91. * Fri Sep 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.4-1
  92. - new versioning policy; spec in UTF-8
  93. - add Source2, Patch3 and Patch4 from Fedora 1.4.4-13
  94. * Tue Mar 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl3
  95. - rebuilt with gcc-4.1.x
  96. - imported Patch1 from FC 1.4.4-5
  97. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.4-0vl2
  98. - use License instead of Copyright
  99. * Tue Mar 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
  100. - updated to 1.4.4
  101. * Sun May 09 2004 Satoshi MACHINO <machino@vinelinux.org> 1.4.2-6vl2
  102. - moved %%{_libexecdir}/config.guess into %%{_datadir}/dejagnu
  103. - included overview docs
  104. - added BuildRequires
  105. * Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-6vl1
  106. - based on 1.4.2-6 from Rawhide and built for Vine Linux
  107. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  108. - automated rebuild
  109. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  110. - automated rebuild
  111. * Mon Apr 29 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-4
  112. - fix makefile style variable passing (#63984)
  113. * Thu Feb 28 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-3
  114. - rebuild
  115. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  116. - automated rebuild
  117. * Wed Nov 28 2001 Jakub Jelinek <jakub@redhat.com> 1.4.2-1
  118. - update to 1.4.2, mainly so that it can be built with gcc3+
  119. * Fri Sep 7 2001 Jakub Jelinek <jakub@redhat.com> 1.4.1-3
  120. - make it noarch again
  121. * Wed Aug 29 2001 Jakub Jelinek <jakub@redhat.com>
  122. - fix a typo (#52404)
  123. * Thu Jun 28 2001 Tim Powers <timp@redhat.com>
  124. - rebuilt for the distro
  125. * Tue Feb 27 2001 Tim Powers <timp@redhat.com>
  126. - minor modifications to the spec file. Built for Powertools.
  127. - added Epoch
  128. * Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org>
  129. - Fixed Requires line, and changed the URL to the new ftp site.
  130. * Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org>
  131. - updated to the latest snapshot
  132. - added doc files
  133. - added the site.exp config file
  134. * Mon Jul 12 1999 Tim Powers <timp@redhat.com>
  135. - updated to 19990628
  136. - updated patches as needed
  137. - added %defattr in files section
  138. * Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com>
  139. - add alpha expect patch (#989)
  140. - use %configure
  141. * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
  142. - Update to 19981215.
  143. * Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
  144. - Update to 1998-10-29.
  145. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  146. - Update to 1998-05-28.
  147. * Sun Feb 1 1998 Jeff Johnson <jbj@jbj.org>
  148. - Create.