fcgi-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. #define snap -SNAP-0910052249
  2. Summary: FastCGI development kit
  3. Summary(ja): FastCGI 開発キット
  4. Name: fcgi
  5. Version: 2.4.2
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. License: BSD
  9. URL: https://github.com/FastCGI-Archives/fcgi2
  10. Source0: https://github.com/FastCGI-Archives/fcgi2/archive/%{version}.tar.gz#/fcgi-%{version}%{?snap}.tar.gz
  11. Source1: fcgi-autogen.sh
  12. Patch0: fcgi-2.4.0-autotools.patch
  13. # Patch0 created with Source1 after patching Patch1 and Patch2
  14. #Patch1: fcgi-2.4.0-configure.in.patch
  15. #Patch2: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
  16. Patch3: fcgi-2.4.0-gcc44_fixes.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # for -perl
  19. BuildRequires: perl(ExtUtils::MakeMaker)
  20. # don't "provide" private Perl libs
  21. %global __provides_exclude_from %{perl_vendorarch}.*\\.so$
  22. %description
  23. FastCGI is a language independent, scalable, open extension to CGI that
  24. provides high performance without the limitations of server specific APIs.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Summary(ja): Development files for %{name}
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. %description devel
  31. The %{name}-devel package contains libraries and header files for
  32. developing applications that use %{name}.
  33. %package perl
  34. Summary: Perl bindings for %{name}
  35. Summary(ja): Perl bindings for %{name}
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  39. %description perl
  40. The %{name}-perl package contains the perl bindings for fcgi.
  41. %prep
  42. %setup -q -n "fcgi2-%{version}%{?snap}"
  43. #%patch0 -p1
  44. %patch3 -p1
  45. # remove DOS End Of Line Encoding
  46. sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
  47. # fix file permissions
  48. chmod a-x include/fcgios.h libfcgi/os_unix.c
  49. autoreconf -ivf
  50. %build
  51. %configure
  52. # does not build with parallel make flags
  53. make
  54. %install
  55. %{__rm} -rf %{buildroot}
  56. %{__mkdir_p} %{buildroot}
  57. make install DESTDIR=%{buildroot}
  58. %{__rm} -fv %{buildroot}/%{_libdir}/libfcgi{++,}.{l,}a
  59. install -p -m 0644 -D doc/cgi-fcgi.1 %{buildroot}/%{_mandir}/man1/cgi-fcgi.1
  60. for manpage in doc/*.3
  61. do
  62. install -p -m 0644 -D $manpage %{buildroot}%{_mandir}/man3/$(basename $manpage)
  63. done
  64. %{__rm} -f -- doc/*.1
  65. %{__rm} -f -- doc/*.3
  66. %post
  67. /sbin/ldconfig
  68. %postun
  69. /sbin/ldconfig
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %files
  73. %defattr(-,root,root,-)
  74. %{_bindir}/cgi-fcgi
  75. %{_libdir}/libfcgi.so.*
  76. %{_libdir}/libfcgi++.so.*
  77. %{_mandir}/man1/*
  78. %defattr(0644,root,root,0755)
  79. %license LICENSE.TERMS
  80. %doc README
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %{_includedir}/*
  84. %{_libdir}/libfcgi.so
  85. %{_libdir}/libfcgi++.so
  86. %{_libdir}/pkgconfig/*
  87. %{_mandir}/man3/*
  88. %defattr(0644,root,root,0755)
  89. %doc doc/
  90. %changelog
  91. * Sat Apr 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
  92. - new upstream release.
  93. - dropped Patch4: fixed in upstream.
  94. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 2.4.1-3
  95. - rebuild with gcc-5.4.0
  96. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-2
  97. - made to use internal dependency generator.
  98. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  99. - new upstream release.
  100. - removed perl binding (not used).
  101. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
  102. - build with perl 5.12.3
  103. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  104. - initial build for Vine Linux
  105. * Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
  106. - Stripping bad provides of private Perl extension libs
  107. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  109. * Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
  110. - Add missing #include <cstdio> to make it compile with gcc 4.4
  111. * Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
  112. - package up the perl bindings in their own subpackage
  113. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
  114. - Autorebuild for GCC 4.3
  115. * Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
  116. - bump release for rebuild
  117. * Wed Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
  118. - remove parallel make flags
  119. * Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
  120. - add some documentation
  121. - add mkdir ${RPM_BUILD_ROOT} to %%install
  122. - install man-pages
  123. * Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
  124. - Initial spec for fedora