gstreamer08-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. %define srcname gstreamer
  2. %define _glib2 2.4.7
  3. %define _libxml2 2.6.15
  4. ## exclude arches that don't work for now.
  5. #ExcludeArch: x86_64 ia64 alpha s390 s390x
  6. Name: gstreamer08
  7. Version: 0.8.12
  8. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  9. %define major 0.8
  10. Release: 2%{?_dist_release}
  11. Summary: GStreamer streaming media framework runtime.
  12. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  13. Group: System Environment/Libraries
  14. License: LGPL
  15. URL: http://gstreamer.net/
  16. Source:http://gstreamer.freedesktop.org/src/gstreamer/%{srcname}-%{version}.tar.bz2
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. # alpha
  19. Patch10: gstreamer-0.6.3-alpha-noWerror.patch
  20. %define po_package %{srcname}-%{major}
  21. Requires: glib2 >= %_glib2
  22. Requires: libxml2 >= %_libxml2
  23. Requires: popt > 1.6
  24. BuildRequires: glib2-devel >= %_glib2
  25. BuildRequires: libxml2-devel >= %_libxml2
  26. BuildRequires: bison
  27. BuildRequires: gtk-doc >= 1.1
  28. BuildRequires: zlib-devel
  29. BuildRequires: popt-devel > 1.6
  30. BuildRequires: flex
  31. BuildRequires: ghostscript
  32. Obsoletes: gstreamer-tools
  33. Conflicts: gstreamer < 0.9
  34. ### documentation requirements
  35. # documentaion build don't work well on 0.8.9
  36. # so, disabled following dependency
  37. #BuildRequires: openjade
  38. #BuildRequires: docbook-style-dsssl docbook-dtd31-sgml docbook-style-xsl
  39. #BuildRequires: docbook-utils
  40. #BuildRequires: transfig xfig
  41. %description
  42. GStreamer is a streaming-media framework, based on graphs of filters which
  43. operate on media data. Applications using this library can do anything
  44. from real-time sound processing to playing videos, and just about anything
  45. else media-related. Its plugin-based architecture means that new data
  46. types or processing capabilities can be added simply by installing new
  47. plugins.
  48. %package devel
  49. Summary: Libraries/include files for GStreamer streaming media framework.
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: glib2-devel >= %_glib2
  53. Requires: libxml2-devel >= %_libxml2
  54. %description devel
  55. GStreamer is a streaming-media framework, based on graphs of filters which
  56. operate on media data. Applications using this library can do anything
  57. from real-time sound processing to playing videos, and just about anything
  58. else media-related. Its plugin-based architecture means that new data
  59. types or processing capabilities can be added simply by installing new
  60. plugins.
  61. This package contains the libraries and includes files necessary to develop
  62. applications and plugins for GStreamer.
  63. %prep
  64. %setup -q -n %{srcname}-%{version}
  65. %ifarch alpha
  66. %patch10 -p1
  67. %endif
  68. %build
  69. %configure \
  70. --with-cachedir=%{_var}/cache/gstreamer-%{major} \
  71. --with-configdir=/etc/gstreamer \
  72. --disable-plugin-builddir \
  73. --disable-tests --disable-examples \
  74. --disable-docs-build \
  75. --disable-static \
  76. --with-html-dir=$RPM_BUILD_ROOT%{_datadir}/gtk-doc/html \
  77. --disable-debug
  78. make %{?_smp_mflags}
  79. %install
  80. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  81. %makeinstall
  82. mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
  83. /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.a
  84. /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
  85. /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  86. /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
  87. %find_lang %{po_package}
  88. # remove gst-* provided by newer gstreamer
  89. for i in complete compprep feedback inspect launch md5sum register typefind xmlinspect xmllaunch ; do
  90. %__rm -f %{buildroot}%{_bindir}/gst-$i
  91. done
  92. %clean
  93. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  94. %post
  95. /sbin/ldconfig
  96. env DISPLAY= %{_bindir}/gst-register-%{major} > /dev/null 2> /dev/null
  97. %postun -p /sbin/ldconfig
  98. %files -f %{po_package}.lang
  99. %defattr(-, root, root)
  100. %doc AUTHORS ChangeLog COPYING README NEWS
  101. %doc TODO ABOUT-NLS REQUIREMENTS DOCBUILDING
  102. %{_bindir}/*
  103. %dir %{_libdir}/gstreamer-%{major}
  104. %{_libdir}/gstreamer-%{major}/*.so*
  105. %{_libdir}/*.so.*
  106. %{_mandir}/man1/*
  107. %dir %{_var}/cache/gstreamer-%{major}
  108. %files devel
  109. %defattr(-, root, root)
  110. %dir %{_includedir}/%{srcname}-%{major}
  111. %{_includedir}/%{srcname}-%{major}/*
  112. #{_libdir}/*.a
  113. %{_libdir}/*.so
  114. %{_libdir}/pkgconfig/gstreamer*.pc
  115. %{_datadir}/aclocal/*.m4
  116. %changelog
  117. * Tue May 5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-2
  118. - removed lib*.a files
  119. - changed Group to System Environment/Libraries
  120. * Wed Sep 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-1
  121. - new upstream release
  122. - applied new versioning policy
  123. - spec in UTF-8
  124. * Fri Jan 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
  125. - fix typo
  126. - add Conflicts: gstreamer < 0.9
  127. * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
  128. - build for compatibility (gstreamer->gstreamer08)
  129. - remove %%{_bindir}/gst-* provided by newer gstreamer
  130. * Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
  131. - new upstream release
  132. * Thu May 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
  133. - new upstream release
  134. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
  135. - new upstream release
  136. - removed dependancy related to documentaion build
  137. * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
  138. - new upstream release
  139. * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
  140. - new upstream release
  141. * Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
  142. - update alpha-noWerror patch (Patch10)
  143. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
  144. - new upstream release
  145. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  146. - new upstream release
  147. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
  148. - new upstream release
  149. * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
  150. - build without -Werror on alpha (Patch10)
  151. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  152. - new upstream release
  153. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
  154. - merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
  155. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  156. - fix broken %files entries..
  157. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  158. - new upstream release
  159. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
  160. - build for Vine Linux
  161. * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
  162. - Add patch1 to fix C++ plugins on ia64
  163. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  164. - %post -p was wrong
  165. * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
  166. - explicitly add %{_libdir}/libgstreamer-{major}.so
  167. - explicitly add %{_libdir}/libgstcontrol-{major}.so
  168. * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
  169. - bump release
  170. * Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
  171. - move .so files out of -devel
  172. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  173. - new version 0.5.0
  174. - require docbook-style-xsl
  175. - add gstreamer-tools package too
  176. - New patch to use the right docbook prefix.
  177. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  178. - downgrade to a release candidate. Should work better on other arches
  179. - build without Werror
  180. * Mon Dec 9 2002 Jonathan Blandford <jrb@redhat.com>
  181. - update to new version. Remove ExcludeArch
  182. * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
  183. - excludearch some arches
  184. * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
  185. - import into CVS and build "officially"
  186. - use smp_mflags
  187. - temporarily disable docs build, doesn't seem to work
  188. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  189. - 0.4.2
  190. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  191. - 0.4.1
  192. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  193. - minor cleanups
  194. * Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
  195. - moved header location
  196. * Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
  197. - added popt
  198. - removed .la
  199. * Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
  200. - added release of gstreamer to req of gstreamer-devel
  201. - changed location of API docs to be in gtk-doc like other gtk-doc stuff
  202. - reordered SPEC file
  203. * Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
  204. - moved html docs to gtk-doc standard directory
  205. * Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
  206. - move version defines of glib2 and libxml2 to configure.ac
  207. - add BuildRequires for these two libs
  208. * Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
  209. - put html docs in canonical place, avoiding %doc erasure
  210. - added devhelp support, current install of it is hackish
  211. * Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
  212. - Added documentation to build
  213. * Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
  214. - added libgstbasicscheduler
  215. - renamed libgst to libgstreamer
  216. * Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
  217. - Added configdir parameter as it seems the configdir gets weird otherwise
  218. * Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
  219. - split off gstreamer-editor from core
  220. - removed gstreamer-gnome-apps
  221. * Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
  222. - Cleaned up the spec file for the gstreamer core/plug-ins split
  223. - Improve spec file
  224. * Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
  225. - Split of more plugins from the core and put them into their own modules
  226. - Includes colorspace, xfree and wav
  227. - Improved package Require lines
  228. - Added mp3encode (lame based) to the SPEC
  229. * Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
  230. - Thomas merged mpeg plugins into one
  231. * Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
  232. - More minor cleanups including some fixed descriptions from Andrew Mitchell
  233. * Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
  234. - Added logging to the make statement
  235. * Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
  236. - Updated in preparation for 0.3.0 release
  237. * Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
  238. - Updated for 0.2.1 release
  239. - Split out the GUI packages into their own RPM
  240. - added new plugins (FLAC, festival, quicktime etc.)
  241. * Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
  242. - Visualisation plugins bundled out togheter
  243. - Moved files sections up close to their respective descriptions
  244. * Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
  245. - Split the package into separate RPMS,
  246. putting most plugins out by themselves.
  247. * Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
  248. - Updated with change suggestions from Dennis Bjorklund
  249. * Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
  250. - updated to build -devel package as well
  251. * Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
  252. - first draft of spec file