gtkam-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223
  1. Summary: A GTK front-end for gPhoto2
  2. Name: gtkam
  3. %define gimpdir %(/bin/ls -d %{_libdir}/gimp/*/plug-ins 2> /dev/null | tail -n 1)
  4. %define gimpver %(echo %gimpdir | sed 's,^%{_libdir}/,,' | cut -d'/' -f2)
  5. %define icondir %{_datadir}/pixmaps
  6. Version: 0.1.14
  7. Release: 0vl2
  8. License: GPL
  9. Group: Applications/Graphics
  10. Source0: http://prdownloads.sourceforge.net/sourceforge/gphoto/%{name}-%{version}.tar.bz2
  11. %{?nosrc:NoSource: 0}
  12. Source1: gtkam.sh
  13. #Patch0: gtkam-0.1.12-fixsavefnames.patch.bz2
  14. #Patch1: gtkam-0.1.10-nodebugopt.patch.bz2
  15. #Patch2: gtkam-gimp2.patch.bz2
  16. #Patch3: gtkam-invalidxml.patch.bz2
  17. Patch4: gtkam-omf-install.patch.bz2
  18. URL: http://www.gphoto.org/proj/gtkam/
  19. ExcludeArch: s390 s390x
  20. Requires: gphoto2 >= 2.1.3
  21. BuildRequires: gphoto2-devel >= 2.1.3
  22. #BuildRequires: gdk-pixbuf-devel gimp-devel
  23. BuildRequires: gimp-devel
  24. BuildRequires: gtk2-devel libexif-devel libexif-gtk-devel
  25. Requires: gdk-pixbuf libexif-gtk
  26. BuildRequires: gettext
  27. BuildRequires: libbonobo-devel libbonoboui-devel libgnomeui-devel
  28. #BuildRequires: desktop-file-utils >= 0.2.92
  29. Prefix: %{_prefix}
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. %description
  32. The gtKam package provides a GTK-based front-end to gPhoto2. Install
  33. this package if you want to use a digital camera with Linux.
  34. %package gimp
  35. Summary: GIMP plug-in for digital camera access through gPhoto2
  36. Requires: %{name} = %{version}
  37. Requires: gimp >= %{gimpver}
  38. PreReq: fileutils gawk sh-utils
  39. Group: Applications/Graphics
  40. %description gimp
  41. A GIMP plug-in for direct digital camera access through gPhoto2.
  42. %prep
  43. rm -rf %{buildroot}
  44. %setup -q
  45. #%patch0 -p1
  46. #%patch1 -p1
  47. #patch2 -p1 -b .gimp2
  48. #%patch3 -p1 -b .invalidxml
  49. %patch4 -p1
  50. #%__cp configure configure.gimp2
  51. #sed -e "s/gimpui-1.3/gimpui-%{gimpver}/" configure.gimp2 > configure
  52. #sed -i -e "s,gimp/1.3/plug-ins,gimp/%{gimpver}/plug-ins," src/Makefile*
  53. %build
  54. %configure
  55. make
  56. %install
  57. %makeinstall imagesdir=%{buildroot}%{icondir}/gtkam
  58. mkdir -p %{buildroot}%{_libexecdir}
  59. cp src/gtkam-gimp %{buildroot}%{_libexecdir}
  60. mv %{buildroot}%{_bindir}/gtkam %{buildroot}%{_bindir}/gtkam.bin
  61. %__install -D -m 755 %{SOURCE1} %{buildroot}%{_bindir}/gtkam
  62. #gimp plugin
  63. #mkdir -p %{buildroot}%{gimpdir}
  64. #ln -sf %{_libexecdir}/gtkam-gimp %{buildroot}%{gimpdir}/gtkam
  65. # icon
  66. mkdir -p %{buildroot}%{icondir}
  67. %__cp gtkam.png %{buildroot}%{icondir}
  68. #echo "Icon=gtkam.png" >> %{buildroot}%{_datadir}/applications/gtkam.desktop
  69. #__mv %{buildroot}%{_datadir}/images/gtkam %{buildroot}%{icondir}
  70. %find_lang %{name}
  71. rm -rf %{buildroot}%{_prefix}/doc %{buildroot}%{_datadir}/doc %{buildroot}/var
  72. #[ "%{gimpver}" = "1.3" ] || rm -rf %{buildroot}%{_libdir}/gimp/1.3
  73. %clean
  74. rm -rf %{buildroot}
  75. %files -f %{name}.lang
  76. %defattr(-,root,root)
  77. %doc [A-LN-Z]*
  78. %config(missingok,noreplace) %{_datadir}/applications/*
  79. %{_bindir}/*
  80. %{_datadir}/gtkam
  81. %{_datadir}/gnome/help/gtkam
  82. %{_datadir}/omf/gtkam
  83. %{_mandir}/man1/*
  84. %{icondir}/*
  85. %files gimp
  86. %defattr(-,root,root)
  87. %{_libexecdir}/gtkam-gimp
  88. %{gimpdir}/*
  89. %changelog
  90. * Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.14-0vl2
  91. - rebuilt for VineSeed
  92. * Sun Mar 11 2007 Masaki Shinomiya <shino@pos.to> 0.1.14-0vl1
  93. - new upstream release
  94. - require libexif-gtk, group, desktop launcher
  95. * Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.13-0vl1
  96. - new upstream release
  97. - added BuildRequires: libexif-gtk-devel
  98. * Wed Feb 16 2005 Masaki Shinomiya <shino@pos.to> 0.1.12-0vl1
  99. - new upstream release, patches from Mandrake Linux
  100. - gimp plugin, desktop, icon, help, omf
  101. * Mon Nov 24 2003 KOBAYASHI R. taizo <tkoba@vinelinux.org> 0.1.10-0vl2
  102. - added source1 for ja_JP.UTF-8 wrapper
  103. * Tue Nov 11 2003 KOBAYASHI R. taizo <tkoba@vinelinux.org> 0.1.10-0vl1
  104. - source update
  105. - modified for Vine
  106. * Thu Sep 11 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-6.1
  107. - Rebuilt.
  108. * Thu Sep 11 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-6
  109. - Use %%{_libdir} etc throughout (bug #104204).
  110. * Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 0.1.7-5
  111. - Fix URL (bug #100907).
  112. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.1.7-4
  113. - rebuilt
  114. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 0.1.7-3
  115. - rebuilt
  116. * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 0.1.7-2
  117. - do not build on mainframe
  118. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 0.1.7-1
  119. - 0.1.7.
  120. - No longer need gtkam-gimp patch.
  121. - Don't install files not shipped.
  122. * Mon Aug 5 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-6
  123. - Don't require gimp-devel (bug #70754).
  124. - Don't ship empty NEWS file (bug #66086).
  125. * Mon Jul 22 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-5
  126. - Desktop file fixes (bug #69434).
  127. * Mon Jul 15 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-4
  128. - Use desktop-file-install.
  129. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.1.4-3
  130. - automated rebuild
  131. * Sun May 26 2002 Tim Powers <timp@redhat.com> 0.1.4-2
  132. - automated rebuild
  133. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 0.1.4-1
  134. - 0.1.4.
  135. - Update gimp patch.
  136. - No longer need linguas, gettext, ranlib patches.
  137. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 0.1.3-0.cvs20020225.2
  138. - The gimp subpackage requires /usr/bin/gimp-config in its %%post
  139. scriplet.
  140. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 0.1.3-0.cvs20020225.1
  141. - Adapted for Red Hat Linux. Tidied the spec file.
  142. - Made a desktop entry.
  143. - Fixed the gimp plug-in.
  144. * Mon Jan 28 2002 Till Kamppeter <till@mandrakesoft.com> 0.1-10mdk
  145. - Rebuilt for libusb 0.1.4.
  146. * Wed Jan 09 2002 David BAUDENS <baudens@mandrakesoft.com> 0.1-9mdk
  147. - Add %%defattr(-,root,root,-) for gtkam-gimp-plugin
  148. * Wed Jan 09 2002 David BAUDENS <baudens@mandrakesoft.com> 0.1-8mdk
  149. - Fix menu entry
  150. * Tue Dec 4 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-7mdk
  151. - Updated to the CVS snapshot from 04/12/2001.
  152. * Sat Dec 1 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-6mdk
  153. - Updated to the CVS of 01/12/2001.
  154. * Fri Nov 30 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-5mdk
  155. - Updated to the CVS of 30/11/2001.
  156. * Mon Oct 08 2001 Stefan van der Eijk <stefan@eijk.nu> 0.1-4mdk
  157. - BuildRequires: gettext-devel
  158. * Thu Sep 13 2001 Stefan van der Eijk <stefan@eijk.nu> 0.1-3mdk
  159. - fixed BuildRequires
  160. - Copyright --> License
  161. * Mon Aug 6 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-2mdk
  162. - Corrected the doc directory path again
  163. * Mon Aug 6 2001 Till Kamppeter <till@mandrakesoft.com> 0.1-1mdk
  164. - Moved to main
  165. - Corrected the doc directory
  166. - Added a menu entry
  167. - Updated from CVS
  168. * Mon Nov 27 2000 Lenny Cartier <lenny@mandrakesoft.com> 0.1-0.20001116mdk
  169. - new in contribs
  170. - macros
  171. - used srpm from rufus t firefly <rufus.t.firefly@linux-mandrake.com>
  172. - v0.1-0.20001116mdk (initial packaging from CVS)