gwenhywfar-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256
  1. Summary: A multi-platform helper library for other libraries
  2. Name: gwenhywfar
  3. Version: 5.6.0
  4. Release: 1%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv2+
  9. URL: https://www.aquamaniac.de/sites/aqbanking/index.php
  10. Source0: https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: openssl-devel
  13. BuildRequires: gnutls-devel
  14. BuildRequires: libgcrypt-devel
  15. BuildRequires: gettext
  16. %description
  17. This is Gwenhywfar, a multi-platform helper library for networking and
  18. security applications and libraries. It is heavily used by libchipcard
  19. and AqBanking/AqHBCI, the German online banking libraries.
  20. %package devel
  21. Summary: Gwenhywfar development kit
  22. Group: programming
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: %{name}-gui-cpp = %{version}-%{release}
  25. Requires: %{name}-gui-gtk3 = %{version}-%{release}
  26. Requires: %{name}-gui-qt5 = %{version}-%{release}
  27. Requires: pkgconfig
  28. %description devel
  29. This package contains gwenhywfar-config and header files for writing and
  30. compiling programs using Gwenhywfar.
  31. %package gui-cpp
  32. Summary: Gwenhywfar GUI framework for cpp
  33. Group: system
  34. Requires: %{name} = %{version}-%{release}
  35. %description gui-cpp
  36. This package contains the cpp gwenhywfar GUI backend.
  37. %package gui-gtk3
  38. Summary: Gwenhywfar GUI framework for GTK3
  39. Group: system
  40. BuildRequires: gtk3-devel
  41. Requires: %{name} = %{version}-%{release}
  42. Obsoletes: gui-gtk2
  43. %description gui-gtk3
  44. This package contains the gtk3 gwenhywfar GUI backend.
  45. %package gui-qt5
  46. Summary: Gwenhywfar GUI framework for Qt5
  47. Group: system
  48. BuildRequires: qt5-qtbase-devel
  49. Requires: %{name} = %{version}-%{release}
  50. Obsoletes: gui-qt4
  51. %description gui-qt5
  52. This package contains the qt5 gwenhywfar GUI backend.
  53. %debug_package
  54. %prep
  55. %setup -q
  56. autoreconf -iv
  57. %build
  58. # help configure find qt5 lrelease/lupdate
  59. export PATH=$PATH:%{_qt5_bindir}
  60. %configure \
  61. --disable-static \
  62. --enable-system-certs \
  63. --with-openssl-libs=%{_libdir} \
  64. --with-guis="gtk3 qt5" \
  65. --with-qt5-qmake=%{_bindir}/qmake-qt5 \
  66. --with-qt5-moc=%{_bindir}/moc-qt5 \
  67. --with-qt5-uic=%{_bindir}/uic-qt5
  68. # kill rpath
  69. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  70. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  71. make %{?_smp_mflags}
  72. %install
  73. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  74. make DESTDIR=$RPM_BUILD_ROOT install
  75. # use system ca-certificates
  76. rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  77. ln -sf %{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  78. $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  79. find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
  80. %find_lang %{name}
  81. %clean
  82. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %files -f %{name}.lang
  86. %defattr(-,root,root)
  87. %license COPYING
  88. %doc AUTHORS README ChangeLog
  89. %{_bindir}/gct-tool
  90. %{_libdir}/libgwenhywfar.so.*
  91. %{_libdir}/%{name}
  92. %dir %{_datadir}/%{name}
  93. %{_datadir}/%{name}/dialogs
  94. %{_datadir}/%{name}/typemaker2
  95. %exclude %{_datadir}/%{name}/typemaker*
  96. %{_datadir}/%{name}/ca-bundle.crt
  97. %files devel
  98. %defattr(-,root,root)
  99. %exclude %{_bindir}/gct-tool
  100. %{_bindir}/*
  101. %{_includedir}/gwenhywfar*
  102. %{_libdir}/*.so
  103. %{_libdir}/pkgconfig/*.pc
  104. %{_libdir}/cmake/*
  105. %{_datadir}/aclocal/gwenhywfar.m4
  106. %{_datadir}/%{name}/typemaker*
  107. %files gui-cpp
  108. %defattr(-,root,root)
  109. %{_libdir}/libgwengui-cpp.so.*
  110. %files gui-gtk3
  111. %defattr(-,root,root)
  112. %{_libdir}/libgwengui-gtk3.so.*
  113. %files gui-qt5
  114. %defattr(-,root,root)
  115. %{_libdir}/libgwengui-qt5.so.*
  116. %changelog
  117. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.6.0-1
  118. - new upstream release.
  119. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20.2-1
  120. - new upstream release.
  121. - switched guis to gtk3 and qt5.
  122. - added a subpackage "gui-cpp".
  123. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.3-2
  124. - rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
  125. * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.3-1
  126. - new upstream release
  127. - add BuildRequires: gtk2-devel, qt4-devel
  128. - create gui-gtk2, gui-qt4 subpackages (based on Fedora)
  129. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.3-3
  130. - rebuilt with openssl-1.0.0d
  131. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.3-2
  132. - rebuilt with rpm-4.8.1 for pkg-config
  133. * Sat Feb 13 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.11.3-1
  134. - new upstream release
  135. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0-1
  136. - new upstream release
  137. - built with gnutls-2.6.3
  138. * Sat Sep 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.1-1
  139. - new upstream release
  140. - applied new versioning policy
  141. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.2-0vl1
  142. - new upstream release
  143. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-2vl1
  144. - initial build for VineSeed
  145. * Wed Oct 10 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-2
  146. - fix build, rebuild for buildid
  147. * Fri Aug 3 2007 Bill Nottingham <notting@redhat.com>
  148. - tweak license tag
  149. * Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-1
  150. - update to 2.6.1
  151. * Mon Jun 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.0-1
  152. - update to 2.6.0
  153. * Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.5.4-1
  154. - update to 2.5.4
  155. * Thu Feb 22 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-7
  156. - build for Extras
  157. * Wed Jan 10 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-6
  158. - make gwen-public-ca.crt %%config(noreplace)
  159. * Tue Jan 9 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-5
  160. - spec tweaks
  161. * Thu Sep 7 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-4
  162. - rebuild for fixed debuginfo (#205501)
  163. * Tue Sep 5 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-3
  164. - fix multilib conflicts (#205213)
  165. * Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-2
  166. - rather than modifying the m4 file, make gwenhywfar-config use pkgconfig
  167. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.0-1.1
  168. - rebuild
  169. * Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-1
  170. - update to 2.3.0
  171. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.2
  172. - bump again for double-long bug on ppc(64)
  173. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.1
  174. - rebuilt for new gcc4.1 snapshot and glibc changes
  175. * Thu Dec 22 2005 Bill Nottingham <notting@redhat.com> 1.99.2-1
  176. - update to 1.99.2
  177. - use the pkgconfig file, not gwenhywfar-config
  178. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  179. - rebuilt
  180. * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> 1.7.2-3
  181. - rebuilt against new openssl
  182. * Wed Mar 2 2005 Bill Nottingham <notting@redhat.com> 1.7.2-2
  183. - rebuild against new openssl
  184. * Wed Feb 9 2005 Bill Nottingham <notting@redhat.com> 1.7.2-1
  185. - initial packaging, adopt upstream package