jsoncpp-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. Name: jsoncpp
  2. Version: 1.9.3
  3. Release: 1%{?_dist_release}
  4. Summary: JSON library implemented in C++
  5. Summary(ja): C++ で実装された JSON ライブラリ
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Public Domain or MIT
  10. URL: https://github.com/open-source-parsers/jsoncpp
  11. Source0: https://github.com/open-source-parsers/jsoncpp/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: cmake > 3.15.0
  14. BuildRequires: python3-devel
  15. BuildRequires: python3-rpm-macros
  16. %description
  17. %{name} is an implementation of a JSON (http://json.org) reader and writer in
  18. C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
  19. It is easy for humans to read and write. It is easy for machines to parse and
  20. generate.
  21. %package devel
  22. Summary: Development headers and library for %{name}
  23. Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. Obsoletes: %{name}-doc < 1.0.0
  27. %description devel
  28. This package contains the development headers and library for %{name}.
  29. %prep
  30. %autosetup -p1
  31. %build
  32. mkdir -p %{_target_platform}
  33. pushd %{_target_platform}
  34. %cmake -DBUILD_STATIC_LIBS=OFF \
  35. -DJSONCPP_WITH_WARNING_AS_ERROR=OFF \
  36. -DJSONCPP_WITH_PKGCONFIG_SUPPORT=ON \
  37. -DJSONCPP_WITH_CMAKE_PACKAGE=ON \
  38. -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF \
  39. -DPYTHON_EXECUTABLE="%{__python3}" \
  40. ..
  41. popd
  42. %make_build -C %{_target_platform}
  43. %check
  44. %make_build -C %{_target_platform} jsoncpp_check
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. %make_install -C %{_target_platform}
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %post -p /sbin/ldconfig
  51. %postun -p /sbin/ldconfig
  52. %files
  53. %license AUTHORS LICENSE
  54. %doc README*
  55. %{_libdir}/lib%{name}.so.*
  56. %files devel
  57. %doc doc/*.html
  58. %{_libdir}/lib%{name}.so
  59. %{_includedir}/json
  60. %{_libdir}/cmake/*
  61. %{_libdir}/pkgconfig/%{name}.pc
  62. %changelog
  63. * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.3-1
  64. - new upstream release.
  65. - dropped Patch0000: fixed in upstream.
  66. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
  67. - new upstream release.
  68. - dropped Source1.
  69. - dropped Patch0.
  70. - imported Patch0000 from rawhide.
  71. - dropped a sub-package "doc".
  72. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
  73. - rebuild with gcc-5.4.0
  74. * Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
  75. - Initial build for Vine Linux
  76. * Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
  77. - Allow int values to be converted to string (#1143774)
  78. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  80. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  82. * Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
  83. - https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
  84. patch to fix duplicated documentation
  85. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  87. * Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
  88. - Changed Summary
  89. - Added %%doc files to the doc package
  90. - Added python as an explicit BuildRequires
  91. * Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
  92. - Added documentation sub-package
  93. * Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
  94. - Added graphviz as a BuildRequire
  95. * Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
  96. - Install the corrected library
  97. * Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
  98. - Added libjsoncpp.so.0
  99. - Moved the shared lib build to the correct section
  100. * Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
  101. - Removed doc subpackage
  102. - Added .pc file
  103. - Fixed shared lib
  104. * Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
  105. - Removed static package
  106. - Preserving timestamp on installed files
  107. - Added guard grep to the sed expression
  108. - Removed duplicated doc files
  109. - Removed dependency on pkgconfig
  110. - Changed base package group
  111. * Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
  112. - Changed license field to Public Domain or MIT
  113. * Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
  114. - Creation of the spec file