lldb-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. Summary: Next generation high-performance debugger
  5. Summary(ja): 高性能デバッガー
  6. Name: lldb
  7. Version: 12.0.1
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: NCSA
  13. URL: https://llvm.org/
  14. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
  15. # patches
  16. Patch0: 0001-PATCH-lldb-Portable-asm-ptrace.h-include.patch
  17. Patch1: 0002-PATCH-lldb-Support-DWARF-5-DW_FORM_line_strp-used-by.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: binutils-devel
  20. BuildRequires: cmake
  21. BuildRequires: ninja
  22. BuildRequires: llvm-devel = %{version}
  23. BuildRequires: llvm-static = %{version}
  24. BuildRequires: clang-devel = %{version}
  25. BuildRequires: clang-tools-extra = %{version}
  26. BuildRequires: ncurses-devel
  27. BuildRequires: swig
  28. BuildRequires: libffi-devel >= 3.3
  29. BuildRequires: zlib-devel
  30. BuildRequires: libxml2-devel
  31. BuildRequires: libedit-devel
  32. BuildRequires: python3-devel
  33. Requires: python3-lldb = %{version}-%{release}
  34. %description
  35. LLDB is a next generation, high-performance debugger. It is built as a set
  36. of reusable components which highly leverage existing libraries in the
  37. larger LLVM Project, such as the Clang expression parser and LLVM
  38. disassembler.
  39. %package devel
  40. Summary: Header files for LLDB
  41. Summary(ja): LLDB のヘッダファイル
  42. Group: programming
  43. Requires: lldb = %{version}-%{release}
  44. %description devel
  45. This package contains header files for the LLDB debugger.
  46. %package -n python3-lldb
  47. Summary: Python3 module for LLDB
  48. Summary(ja): LLDB用Python3モジュール
  49. Group: programming
  50. BuildRequires: python3-devel
  51. Requires: python3-six
  52. Requires: lldb = %{version}-%{release}
  53. %description -n python3-lldb
  54. The package contains the LLDB Python3 module.
  55. %debug_package
  56. %prep
  57. %autosetup -p2 -n lldb-%{version}.src
  58. %build
  59. CFLAGS="%{optflags} -Wno-error=format-security"
  60. CXXFLAGS="%{optflags} -Wno-error=format-security"
  61. %cmake \
  62. -GNinja \
  63. -DCMAKE_BUILD_TYPE=Release \
  64. -DCMAKE_SKIP_RPATH:BOOL=ON \
  65. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  66. \
  67. -DLLDB_DISABLE_CURSES:BOOL=OFF \
  68. -DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
  69. -DLLDB_DISABLE_PYTHON:BOOL=OFF \
  70. %if 0%{?__isa_bits} == 64
  71. -DLLVM_LIBDIR_SUFFIX=64 \
  72. %else
  73. -DLLVM_LIBDIR_SUFFIX= \
  74. %endif
  75. \
  76. -DPYTHON_EXECUTABLE:STRING=%{__python3} \
  77. -DPYTHON_VERSION_MAJOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.major)") \
  78. -DPYTHON_VERSION_MINOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.minor)") \
  79. -DCLANG_LINK_CLANG_DYLIB=ON \
  80. -DLLVM_LIT_ARGS="-sv \
  81. --path %{_libdir}/llvm" \
  82. %{nil}
  83. %cmake_build
  84. %install
  85. rm -rf %{buildroot}
  86. %cmake_install
  87. # remove static libraries
  88. rm -fv %{buildroot}%{_libdir}/liblldb*.a
  89. # python: fix binary libraries location
  90. liblldb=$(basename $(readlink -e %{buildroot}%{_libdir}/liblldb.so))
  91. ln -vsf "../../../${liblldb}" %{buildroot}%{python3_sitearch}/lldb/_lldb.so
  92. # remove bundled six.py
  93. rm -f %{buildroot}%{python3_sitearch}/six.*
  94. %if %{with test}
  95. %check
  96. %endif
  97. %clean
  98. rm -rf %{buildroot}
  99. %files
  100. %defattr(-,root,root,-)
  101. #doc %{llvmdocdir lldb}/
  102. %{_bindir}/lldb*
  103. %{_libdir}/liblldb*.so.*
  104. %{_libdir}/liblldbIntelFeatures.so.*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_includedir}/lldb
  108. %{_libdir}/*.so
  109. %files -n python3-lldb
  110. %{python3_sitearch}/lldb
  111. %changelog
  112. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  113. - new upstream release.
  114. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  115. - devided lldb from llvm.
  116. - new upstream release.
  117. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  118. - enabled to build utils.
  119. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  120. - new upstream release.
  121. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  122. - new upstream release.
  123. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  124. - rebuilt with libffi-3.3.
  125. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  126. - new upstream release.
  127. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  128. - new upstream release.
  129. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  130. - dropped all patches.
  131. - switched build-system to ninja.
  132. - switched python to python3.
  133. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  134. - new upstream release.
  135. - added OpenMP.
  136. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  137. - fixed %%files.
  138. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  139. - new upstream release.
  140. - dropped Patch0, 4, 5, 100 and 200.
  141. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  142. - renamed a subpackage "llvm-libs".
  143. - added a subpackage "lld".
  144. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  145. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  146. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  147. - new upstream release.
  148. - dropped Patch1 and 2: fixed in upstream.
  149. - imported Patch0, 3-5, 100 and 200 from rawhide.
  150. - disabled Patch1002: no longer needed?
  151. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  152. - new upstream release.
  153. - switched to cmake.
  154. - disable ocaml binding as default.
  155. - updated Patch1000 and 1002.
  156. - disabled Patch1000 as default.
  157. - cleanup patches.
  158. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  159. - rebuild with gcc-5.4.0
  160. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  161. - new upstream release
  162. - added BR: ocaml-ctypes
  163. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  164. - new upstream release
  165. - dropt Patch 1, 201 and 1001
  166. - updated Patch 1000
  167. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  168. - updated to 3.5.1
  169. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  170. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  171. - obsoleted clang-doc
  172. - built with ocaml 4.02.1
  173. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  174. - fix <BTS:2832>
  175. - fix configure option "--with-c-include-dirs"
  176. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  177. - update Patch1001: clang-3.5.0-driver-lib64.patch
  178. - update Patch1002: clang-3.5.0-driver-vine.patch
  179. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  180. - update to 3.5.0
  181. - remove Patch11 (clang-hardfloat-hack.patch)
  182. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  183. - rebuild with libffi-3.0.13
  184. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  185. - update to 3.3
  186. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  187. - ld.gold (patch1000,1001)
  188. - add /%{_lib} to ld search path
  189. - add support *-vine-linux gcc (patch1002)
  190. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  191. - update to 3.1
  192. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  193. - updated to 3.0 release
  194. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  195. - added patch 2-4 to support -O4 link-time optimization
  196. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  197. - disable -fno-var-tracking-assignments on ppc
  198. (seems like gcc-4.4.5 still doesn't support this)
  199. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  200. - new upstream release
  201. - add BR: libffi-devel
  202. - add R: libffi-devel to -devel
  203. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  204. - initial build for Vine Linux
  205. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  206. - Update to final 2.7 release
  207. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  208. - Update to first 2.7 pre-release
  209. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  210. - Update to 2.6 pre-release2
  211. - -devel subpackage now virtually provides -static
  212. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  213. - Disable var tracking assignments on PPC
  214. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  215. - Don't adjust clang include dir; files there are noarch (bz#521893)
  216. - Enable clang unit tests
  217. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  218. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  219. - Package Clang's static analyzer tools
  220. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  221. - PIC is now enabled by default; explicitly disable on %%{ix86}
  222. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  223. - First 2.6 prerelease
  224. - Enable Clang front-end
  225. - Enable debuginfo generation
  226. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  227. - Disable assertions (needed by OpenGTL, bz#521261)
  228. - Align spec file with upstream build instructions
  229. - Enable unit tests
  230. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  231. - Only disable PIC on %%ix86; ppc actually needs it
  232. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  233. - Disable use of position-independent code on 32-bit platforms
  234. (buggy in LLVM <= 2.5)
  235. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  236. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  237. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  238. - Remove build scripts; they require the build directory to work
  239. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  240. - Update to 2.5
  241. - Package build scripts (bug #457881)
  242. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  243. - Patched build process for the OCaml binding
  244. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  245. - Update to 2.4
  246. - Package Ocaml binding
  247. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  248. - Add dependency on groff
  249. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  250. - LLVM 2.3
  251. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  252. - fix license tags
  253. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  254. - Fix compilation problems with gcc 4.3
  255. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  256. - Autorebuild for GCC 4.3
  257. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  258. - Fix review comments
  259. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  260. - Initial version