lua-rex-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. %define luaver %(pkg-config --variable=V lua || echo missing)
  2. %define lualibdir %{_libdir}/lua/%{luaver}
  3. Summary: Regular expression handling library for Lua
  4. Summary(ja): 正規表現を扱うための Lua ライブラリ
  5. Name: lua-rex
  6. Version: 2.9.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: MIT
  12. URL: http://rrthomas.github.io/lrexlib/
  13. %global altver %(echo %{version} | sed -e 's/\\./-/g')
  14. Source0: https://github.com/rrthomas/lrexlib/archive/rel-%{altver}.tar.gz
  15. Source1: Makefile
  16. Source2: common.mak
  17. Source3: defaults.mak
  18. Source4: rex_onig.mak
  19. Source5: rex_pcre.mak
  20. Source6: rex_posix.mak
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: oniguruma-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: lua
  25. BuildRequires: lua-devel
  26. BuildRequires: pkgconfig
  27. BuildRequires: unzip
  28. Requires: lua(abi) = %{luaver}
  29. Provides: lrexlib = %{version}
  30. %description
  31. Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
  32. and Oniguruma) to Lua.
  33. %prep
  34. %setup -q -n lrexlib-rel-%{altver}
  35. cp -f %{SOURCE1} ./
  36. cp -f %{SOURCE2} src/
  37. cp -f %{SOURCE3} src/
  38. cp -f %{SOURCE4} src/oniguruma/
  39. cp -f %{SOURCE5} src/pcre/
  40. cp -f %{SOURCE6} src/posix/
  41. %build
  42. make %{?_smp_mflags} LUA=lua LD=cc MYCFLAGS='%{optflags} -DVERSION=\"%{version}\" -fPIC %(pcre-config --cflags)' build
  43. %install
  44. rm -rf $RPM_BUILD_ROOT
  45. install -d $RPM_BUILD_ROOT%{lualibdir}
  46. cp -P */*/rex_{onig,pcre,posix}.so* $RPM_BUILD_ROOT%{lualibdir}
  47. %check
  48. make %{?_smp_mflags} LUA=lua test
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %{lualibdir}/*
  54. %license LICENSE
  55. %doc ChangeLog NEWS README doc
  56. %changelog
  57. * Fri Aug 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.1-1
  58. - new upstream release.
  59. * Sat Sep 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.0-1
  60. - new upstream release.
  61. - built with oniguruma-6.9.3.
  62. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-6
  63. - rebuild with pcre-8.31
  64. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.4.0-5
  65. - rebuilt with rpm-4.8.1-3
  66. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-4
  67. - rebuilt with gcc-4.4.3-3 on ppc
  68. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-3
  69. - rebuilt with rpm-4.8.0-3 (on ppc)
  70. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-2
  71. - added BR: unzip
  72. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  73. - initial build for Vine Linux
  74. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-5
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  76. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-4
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  78. * Tue Dec 23 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-3
  79. - Compile shared library as PIC
  80. * Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
  81. - Add doc directory to documentation
  82. - Allow parallel make runs
  83. * Tue Dec 16 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-1
  84. - Initial packaging