openbox-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414
  1. Name: openbox
  2. Version: 3.6.1
  3. Release: 1%{?_dist_release}
  4. Summary: A highly configurable and standards-compliant X11 window manager
  5. Summary(ja): 高度に設定可能な標準準拠の X11 ウィンドウマネージャ
  6. Group: User Interface/Desktops
  7. License: GPLv2+
  8. URL: http://openbox.org/
  9. Source0: http://openbox.org/releases/%{name}-%{version}.tar.xz
  10. Source1: http://icculus.org/openbox/tools/setlayout.c
  11. Source2: xdg-menu
  12. Source3: menu.xml
  13. Source4: terminals.menu
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Requires: %{name}-libs = %{version}-%{release}
  16. BuildRequires: gettext
  17. BuildRequires: glib2-devel >= 2.14.0
  18. BuildRequires: desktop-file-utils
  19. BuildRequires: pango-devel
  20. BuildRequires: startup-notification-devel
  21. BuildRequires: imlib2-devel
  22. BuildRequires: librsvg2-devel
  23. BuildRequires: libxml2-devel >= 2.6.0
  24. BuildRequires: libSM-devel
  25. BuildRequires: libXau-devel
  26. BuildRequires: libXcursor-devel
  27. BuildRequires: libXfixes-devel
  28. BuildRequires: libXt-devel
  29. BuildRequires: libXrandr-devel
  30. BuildRequires: libXinerama-devel
  31. # The xdg-menu dynamic pipe menu requires the gmenu Python module
  32. Requires: gnome-menus
  33. Requires: pyxdg
  34. %description
  35. Openbox is a window manager designed explicity for standards-compliance and
  36. speed. It is fast, lightweight, and heavily configurable (using XML for its
  37. configuration data). It has many features that make it unique among window
  38. managers: window resistance, chainable key bindings, customizable mouse
  39. actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
  40. For a full list of the FreeDesktop.org standards with which it is compliant,
  41. please see the COMPLIANCE file in the included documentation of this package.
  42. For a graphical configuration editor, you'll need to install the obconf
  43. package. For a graphical menu editor, you'll need to install the obmenu
  44. package.
  45. %package devel
  46. Summary: Development files for %{name}
  47. Summary(ja): %{name} の開発ファイル
  48. Group: Development/Libraries
  49. Requires: %{name}-libs = %{version}-%{release}
  50. Requires: pkgconfig
  51. Requires: pango-devel
  52. Requires: libxml2-devel
  53. Requires: glib2-devel
  54. %description devel
  55. The %{name}-devel package contains libraries and header files for
  56. developing applications that use %{name}.
  57. %package libs
  58. Summary: Shared libraries for %{name}
  59. Summary: %{name} の共有ライブラリ
  60. Group: System Environment/Libraries
  61. %description libs
  62. The %{name}-libs package contains shared libraries used by %{name}.
  63. %prep
  64. %setup -q
  65. autoreconf
  66. %build
  67. %configure \
  68. --disable-static
  69. ## Fix RPATH hardcoding.
  70. sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
  71. sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
  72. make %{?_smp_mflags}
  73. gcc %{optflags} -o setlayout %{SOURCE1} -lX11
  74. %install
  75. rm -rf %{buildroot}
  76. make install DESTDIR=%{buildroot}
  77. mkdir -m 644 %{buildroot}%{_datadir}/%{name}
  78. install setlayout %{buildroot}%{_bindir}
  79. install -p %{SOURCE2} %{buildroot}%{_libexecdir}/openbox-xdg-menu
  80. sed 's|_LIBEXECDIR_|%{_libexecdir}|g' < %{SOURCE3} \
  81. > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
  82. install -m644 -p %{SOURCE4} \
  83. %{buildroot}%{_sysconfdir}/xdg/%{name}/terminals.menu
  84. # 'make install' misses these two, so we install them manually
  85. install -m644 -D data/gnome-session/openbox-gnome.session \
  86. %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome.session
  87. install -m644 -D data/gnome-session/openbox-gnome-fallback.session \
  88. %{buildroot}%{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
  89. %find_lang %{name}
  90. rm -f %{buildroot}%{_libdir}/*.la
  91. rm -rf %{buildroot}%{_datadir}/doc/%{name}
  92. %clean
  93. rm -rf %{buildroot}
  94. %files -f %{name}.lang
  95. %defattr(-,root,root,-)
  96. %doc AUTHORS CHANGELOG COMPLIANCE COPYING README
  97. %doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
  98. %dir %{_sysconfdir}/xdg/%{name}/
  99. %config(noreplace) %{_sysconfdir}/xdg/%{name}/*
  100. %{_bindir}/gnome-panel-control
  101. %{_bindir}/gdm-control
  102. %{_bindir}/%{name}*
  103. %{_bindir}/obxprop
  104. %{_bindir}/setlayout
  105. %{_datadir}/applications/*%{name}.desktop
  106. %{_datadir}/%{name}
  107. %{_datadir}/themes/*/
  108. %{_datadir}/pixmaps/%{name}.png
  109. %{_datadir}/gnome/wm-properties/
  110. %{_datadir}/gnome-session/sessions/openbox-gnome.session
  111. %{_datadir}/gnome-session/sessions/openbox-gnome-fallback.session
  112. %{_datadir}/xsessions/%{name}*.desktop
  113. %{_libexecdir}/openbox-*
  114. %{_mandir}/man1/*
  115. %files libs
  116. %{_libdir}/libobrender.so.*
  117. %{_libdir}/libobt.so.*
  118. %files devel
  119. %{_includedir}/%{name}/
  120. %{_libdir}/libobrender.so
  121. %{_libdir}/libobt.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %post libs -p /sbin/ldconfig
  124. %postun libs -p /sbin/ldconfig
  125. %changelog
  126. * Sun Nov 15 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.6.1-1
  127. - new upstream release
  128. - changet source archive type gz to xz
  129. - fixed Source3
  130. - deleted unused menu
  131. - cleaned up spec
  132. - renumbered %%{Source} files
  133. * Fri Jul 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.5.2-2
  134. - fix file list (libs,devel)
  135. - remove .so from -libs
  136. - remove .so.* from -devel
  137. * Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.2-1
  138. - new upstream release
  139. - replaced Source2 to newer from Fedora rawhide
  140. - added BuildRequires: imlib2-devel, librsvg2-devel
  141. * Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-4
  142. - added Patch3,4,5 from Debian sid
  143. * Sun Apr 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-3
  144. - replaced Source2 to newer from Fedora rawhide
  145. * Sat Feb 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-2
  146. - replaced Source2 to newer from Fedora rawhide
  147. - added Patch2 from Debian sid to fix load xml files
  148. * Fri Aug 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.5.0-1
  149. - new upstream release
  150. - dropt Patch0,7,10,11
  151. - renumbered patches
  152. - added Source5 from Fedora development
  153. - improved Source3
  154. - run autoreconf in %%prep
  155. * Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
  156. - dropt Patch1,3
  157. - added patch11 from Debian
  158. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
  159. - rebuilt with rpm-4.8.1 for pkg-config
  160. - BuildRequires: libXau-devel
  161. * Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
  162. - new upstream release
  163. - added Requires: pyxdg
  164. * Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
  165. - new upstream release
  166. - changed URL and Source0
  167. - dropt Patch6
  168. - added BuildRequires: libXfixes-devel, libSM-devel
  169. - changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
  170. * Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
  171. - new upstream release
  172. - added Patch10 from Fedora
  173. - added summary(ja) in -devel and -libs
  174. * Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
  175. - new upstream release
  176. - dropt Patch8
  177. - Patch9 from Fedora
  178. * Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
  179. - new upstream release
  180. - dropt patch2
  181. - replaced and renamed Patch0 from Fedora
  182. * Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
  183. - new upstream release
  184. - dropt patch4,5
  185. - added Patch8 from Fedora
  186. - added Requires: gnome-menus
  187. * Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
  188. - improved Source3
  189. - enabled administration menu (disabled preference menu because included)
  190. - added Patch6 from Mandriva
  191. - added Patch7 from Fedora
  192. - replaced Source1 from Fedora
  193. * Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
  194. - updated Source4
  195. - added Patch4,5 from Debian
  196. * Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
  197. - changed openbox-libs Group: System Environment/Libraries
  198. - spec in UTF-8
  199. * Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
  200. - initial build for VineSeed
  201. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  203. * Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
  204. - Restore gnome session script (#474143)
  205. - Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
  206. * Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
  207. - Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
  208. - Add application desktop file to allow starting openbox in gnome-session
  209. when configured in gconf
  210. * Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
  211. - Don't use --choose-session option in gnome session script
  212. * Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
  213. - Remove field codes from commands in xdg-menu (#452403)
  214. - Add support for launching applications in xterm to xdg-menu
  215. * Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
  216. - Clean up properties after gdm in session scripts (#444135)
  217. - Add license to xdg-menu script
  218. * Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
  219. - Drop numdesks patch (#444135)
  220. * Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
  221. - Update to 3.4.7.2
  222. - Use gnome menus by default (Luke Macken) (#443548)
  223. - Force setting number of desktops (#444135)
  224. * Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
  225. - Update to 3.4.7.1
  226. - Don't require /usr/share/themes
  227. * Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
  228. - Update to 3.4.6.1
  229. * Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
  230. - Update to 3.4.6
  231. * Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
  232. - Update to 3.4.5
  233. * Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
  234. - Rebuild
  235. * Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
  236. - Update to 3.4.4
  237. - Update license tag
  238. * Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
  239. - Update to 3.4.3
  240. - Package setlayout tool
  241. * Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
  242. - Update to 3.4.2
  243. * Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
  244. - Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
  245. in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
  246. Lichvar for the bug report.)
  247. * Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
  248. - Split shared libraries into a -libs subpackage to properly handle multilib
  249. setups. (This precludes the further need to %%ghost the byte-compiled
  250. themeupdate scripts which was introduced in the previous release.)
  251. - Fix handling of the startup_notification build conditional. It will actually
  252. work properly now. :)
  253. - Remove the hardcoded RPATH using some sed invocations from the packaging
  254. guidelines.
  255. * Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
  256. - %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
  257. (bug #228379).
  258. * Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
  259. - Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
  260. by gnome-session in Rawhide and we should not have ownership conflicts with
  261. Core packages.
  262. * Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
  263. - Rebuild to pick up unwind info generation fixes in new GCC
  264. * Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
  265. - Allow building with startup-notification as an rpmbuild option (though it is
  266. disabled by default as recommended by upstream).
  267. * Sat Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
  268. - Update to new 3.3.1 from upstream
  269. * Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
  270. - Mass FC6 rebuild
  271. * Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
  272. - Bump release to fix sources tagging issue
  273. * Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
  274. - Update to 3.3 final release from upstream
  275. - Remove the slew of versioning macros, as it's overkill for this and just adds
  276. unneeded complexity to the spec.
  277. * Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
  278. - Add missing BuildRequires: libXxf86vm-devel
  279. * Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
  280. - Unconditionalize the BuildRequires for modular X.org, since it's branched
  281. for a specific Fedora release.
  282. * Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
  283. - Own the %%{_datadir}/gnome/wm-properties directory (#195292)
  284. * Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
  285. - Add %%{_datadir}/themes to Requires (#195292)
  286. * Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
  287. - Own all created theme directories (#195292)
  288. - Fix previous review bug IDs in this %%changelog to point to the recreated
  289. review bug (due to recent bugzilla outage)
  290. * Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
  291. - Don't default to an executable xsession script (#195292)
  292. * Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
  293. - Fix versioning to conform to the Extras packaging guidelines
  294. * Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
  295. - Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
  296. login screen (#195292)
  297. * Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
  298. - Unorphan, rewriting nearly all of the spec file
  299. - Update to upstream 3.3 RC2
  300. * Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
  301. - Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
  302. - Need to conflict with fluxbox (#422 / #440)
  303. * Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
  304. - Need to own /usr/share/apps/switchdesk (#422)
  305. * Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
  306. - More spec revisions (#422); change make and preserve timestamps
  307. * Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
  308. - Minor spec revisions (#422); add epoch and versions to changelogs
  309. * Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
  310. - Add switchdesk support
  311. - Add display manager support
  312. - Fix NLS build on Cambridge
  313. - Fedora'ize the spec
  314. * Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
  315. - Rev to 2.3.1 release
  316. - Make go with GCC 3.3
  317. * Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
  318. - Package of 2.3.0 release