php-pear-Mail-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. %{!?__pear: %{expand: %%global __pear %{_bindir}/pear5}}
  2. %global pear_name Mail
  3. Name: php-pear-Mail
  4. Version: 1.2.0
  5. Release: 4%{?_dist_release}
  6. Summary: Class that provides multiple interfaces for sending emails
  7. Group: Development/Libraries
  8. License: BSD
  9. URL: http://pear.php.net/package/Mail
  10. Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
  11. Source2: xml2changelog
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildArch: noarch
  14. BuildRequires: php-pear(PEAR) >= 1.5.6
  15. Requires: php-pear(PEAR) >= 1.5.6
  16. Requires: php-pear(Net_SMTP) >= 1.4.1
  17. Requires(post): %{__pear}
  18. Requires(postun): %{__pear}
  19. Provides: php-pear(%{pear_name}) = %{version}
  20. %description
  21. PEAR's Mail package defines an interface for implementing mailers under the
  22. PEAR hierarchy. It also provides supporting functions useful to multiple
  23. mailer backends. Currently supported backends include: PHP's native
  24. mail() function, sendmail, and SMTP. This package also provides a RFC822
  25. email address list validation utility class.
  26. %prep
  27. %setup -q -c
  28. # Package is V2
  29. %{_bindir}/php -n %{SOURCE2} package.xml >CHANGELOG
  30. mv package.xml %{pear_name}-%{version}/%{name}.xml
  31. %build
  32. cd %{pear_name}-%{version}
  33. # Empty build section, most likely nothing required.
  34. %install
  35. rm -rf %{buildroot}
  36. cd %{pear_name}-%{version}
  37. %{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
  38. # Clean up unnecessary files
  39. rm -rf %{buildroot}%{pear_phpdir}/.??*
  40. # Install XML package description
  41. mkdir -p %{buildroot}%{pear_xmldir}
  42. install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
  43. %clean
  44. rm -rf %{buildroot}
  45. %post
  46. %{__pear} install --nodeps --soft --force --register-only \
  47. %{pear_xmldir}/%{name}.xml >/dev/null || :
  48. %postun
  49. if [ $1 -eq 0 ] ; then
  50. %{__pear} uninstall --nodeps --ignore-errors --register-only \
  51. %{pear_name} >/dev/null || :
  52. fi
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc CHANGELOG
  56. %{pear_phpdir}/Mail.php
  57. %{pear_phpdir}/Mail
  58. %{pear_testdir}/Mail
  59. %{pear_xmldir}/%{name}.xml
  60. %changelog
  61. * Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.0-4
  62. - initial build for Vine Linux
  63. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  65. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  67. * Mon Mar 1 2010 Remi Collet <Fedora@FamilleCollet.com> 1.2.0-1
  68. - update to 1.2.0
  69. - license is now BSD
  70. * Fri Nov 27 2009 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-5
  71. - Fix CVE-2009-4023 (#540842)
  72. - rename Mail.xml to php-pear-Mail.xml
  73. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.14-4
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  75. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.14-3
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  77. * Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-2
  78. - Fix License
  79. * Thu Oct 12 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-1
  80. - update to 1.1.14
  81. * Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.13-1
  82. - regenerate SPEC with pear make-rpm-spec
  83. - remove PEAR from sumnary
  84. - update to 1.1.13
  85. - add generated CHANGELOG %%doc
  86. * Fri Sep 08 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-8
  87. - last template.spec
  88. * Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-7
  89. - new and simpler %%prep and %%install
  90. * Mon Aug 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-6
  91. - FE6 rebuild
  92. * Sat Jul 22 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-5
  93. - remove "rm pearrc"
  94. - secure scriplet with || :
  95. - install Licence in prep
  96. - use new macros from /etc/rpm/macros.pear
  97. * Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-4
  98. - Require pear >= 1:1.4.9
  99. - Requires(hint): php-pear(Net_SMTP) >= 1.1.0 (only comment actually)
  100. - bundle the v3.01 PHP LICENSE file
  101. - use --packagingroot (instead of -R)
  102. - check from install to check (as in php-pear)
  103. * Sun May 14 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-3
  104. - License : PHP -> PHP License
  105. * Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-2
  106. - new spec for extras
  107. - use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
  108. * Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-1
  109. - spec for extras
  110. * Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.1.10-1.fc{3,4,5}.remi
  111. - update to 1.1.10
  112. * Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.1.9-2.fc{3,4,5}.remi
  113. - change /var/lib/pear to %%{_libdir}/php/pear for XML (as in extras for FC5)
  114. - spec cleanning
  115. * Sat Jan 7 2006 Remi Collet <remi.collet@univ-reims.fr> 1.1.9-1.fc{3,4}.remi
  116. - initial RPM