ruby-gnome2-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495
  1. %define ruby /usr/bin/ruby
  2. %define rbindir %(%{ruby} -r rbconfig -e 'print RbConfig::CONFIG["bindir"]')
  3. %define rlibdir %(%{ruby} -r rbconfig -e 'print RbConfig::CONFIG["rubylibdir"]')
  4. %define rarchdir %(%{ruby} -r rbconfig -e 'print RbConfig::CONFIG["archdir"]')
  5. Summary: language bindings for GNOME2 and GNOME3 for use with Ruby
  6. Summary(ja): Ruby から GNOME2 及び GNOME3 を使う為のライブラリ
  7. Name: ruby-gnome2
  8. Version: 2.2.5
  9. Release: 3%{?_dist_release}
  10. Group: Development/Libraries
  11. License: GPL
  12. URL: http://ruby-gnome2.sourceforge.jp/
  13. Source0: http://sourceforge.net/projects/%{name}/files/%{name}/%{name}-%{version}/%{name}-all-%{version}.tar.gz
  14. Requires: ruby-gtk2 = %{version}-%{release}
  15. Requires: ruby-gtk3 = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: ruby-devel
  18. BuildRequires: ruby-pkg-config
  19. BuildRequires: rcairo-devel >= 1.8.0
  20. BuildRequires: glib2-devel
  21. BuildRequires: pango-devel
  22. BuildRequires: atk-devel
  23. BuildRequires: gtk2-devel
  24. BuildRequires: gtk3-devel >= 3.4.2
  25. BuildRequires: gobject-introspection-devel >= 1.32.1
  26. BuildRequires: gtksourceview2-devel >= 2.0.0
  27. BuildRequires: gtksourceview3-devel >= 3.4.2
  28. BuildRequires: librsvg2-devel >= 2.8.0
  29. BuildRequires: gstreamer1-devel
  30. BuildRequires: gstreamer1-plugins-base-devel
  31. BuildRequires: vte-devel >= 0.12.1
  32. BuildRequires: vte290-devel >= 0.32.2
  33. BuildRequires: poppler-devel >= 0.14.2
  34. BuildRequires: sed
  35. Obsoletes: ruby-gtkglext < 2.0.0
  36. Obsoletes: ruby-gtkmozembed < 2.0.0
  37. Obsoletes: ruby-glade2 < 2.0.0
  38. Obsoletes: ruby-goocanvas < 2.2.5
  39. %description
  40. This is a set of bindings for the GNOME-2.x and GNOME-3.x libraries to
  41. use from Ruby 2.2.x.
  42. %package -n ruby-gtk2
  43. Summary: language bindings for GTK+2 for use with Ruby
  44. Summary(ja): Ruby から GTK+2 を使う為のライブラリ
  45. Group: Development/Libraries
  46. Requires: ruby
  47. Requires: rcairo >= 1.12.0
  48. %description -n ruby-gtk2
  49. This package is a ruby bindings for gtk2.
  50. This package contains follow bindings.
  51. * Ruby/GLib2: Ruby binding of GLib-2.x.
  52. * Ruby/GIO2: Ruby binding of gio-2.0.x.
  53. * Ruby/ATK: Ruby binding of ATK-1.0.x or later.
  54. * Ruby/Pango: Ruby binding of pango-1.x.
  55. * Ruby/GdkPixbuf2: Ruby binding of GdkPixbuf-2.x.
  56. * Ruby/GTK2: Ruby binding of GTK+-2.0.x.
  57. * Ruby/GObjectIntrospection: Ruby binding of GObject Introspect.
  58. * Ruby/CairoGObject: Ruby binding of cairo-gobject.
  59. %package -n ruby-gtk3
  60. Summary: language bindings for GTK+2 for use with Ruby
  61. Summary(ja): Ruby から GTK+2 を使う為のライブラリ
  62. Group: Development/Libraries
  63. Requires: ruby
  64. Requires: ruby-gtk2
  65. %description -n ruby-gtk3
  66. This package is a ruby bindings for gtk3.
  67. This package contains follow bindings.
  68. * Ruby/GDK3: Ruby binding of GDK 3.
  69. * Ruby/GTK3: Ruby binding of GTK 3.
  70. %package -n %{name}-devel
  71. Summary: The header files for the ruby-gnome2.
  72. Summary(ja): ruby-gnome2 用のヘッダーファイル群
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. %description -n %{name}-devel
  76. %{name}-devel provides the header files for the %{name}.
  77. %package -n ruby-gstreamer
  78. Summary: Ruby binding of GStreamer
  79. Group: Development/Libraries
  80. Requires: ruby-gtk3 = %{version}-%{release}
  81. %description -n ruby-gstreamer
  82. Ruby/GStreamer is a Ruby binding for GStreamer
  83. %package -n ruby-gtksourceview2
  84. Summary: Ruby binding of gtksourceview-2.x
  85. Summary(ja): Ruby の gtksourceview-2.x バインディング
  86. Group: Development/Libraries
  87. Requires: ruby-gtk2 = %{version}-%{release}
  88. %description -n ruby-gtksourceview2
  89. Ruby/GtkSourceView2 is a Ruby binding of gtksourceview-2.x.
  90. %package -n ruby-gtksourceview3
  91. Summary: Ruby binding of gtksourceview-3.x
  92. Summary(ja): Ruby の gtksourceview-3.x バインディング
  93. Group: Development/Libraries
  94. Requires: ruby-gtk3 = %{version}-%{release}
  95. %description -n ruby-gtksourceview3
  96. Ruby/GtkSourceView3 is a Ruby binding of gtksourceview-3.x.
  97. %package -n ruby-poppler
  98. Summary: bindings for poppler for use with Ruby
  99. Summary(ja): Ruby から poppler を使う為のライブラリ
  100. Group: Development/Libraries
  101. License: LGPL
  102. Requires: ruby-gtk2 = %{version}-%{release}
  103. %description -n ruby-poppler
  104. Ruby/Poppler is a Ruby binding of poppler-glib.
  105. %package -n ruby-vte
  106. Summary: bindings for vte for use with Ruby
  107. Summary(ja): Ruby から vte を使う為のライブラリ
  108. Group: Development/Libraries
  109. License: LGPL
  110. Requires: ruby-gtk2 = %{version}-%{release}
  111. %description -n ruby-vte
  112. Ruby/VTE is a Ruby binding of VTE.
  113. %package -n ruby-vte3
  114. Summary: bindings for vte3 for use with Ruby
  115. Summary(ja): Ruby から vte3 を使う為のライブラリ
  116. Group: Development/Libraries
  117. License: LGPL
  118. Requires: ruby-gtk3 = %{version}-%{release}
  119. %description -n ruby-vte3
  120. Ruby/VTE3 is a Ruby binding of VTE3.
  121. %package -n ruby-rsvg2
  122. Summary: Ruby binding of librsvg2
  123. Summary(ja): Ruby の rsvg-2.x バインディング
  124. Group: Development/Libraries
  125. Requires: ruby-gtk2 = %{version}-%{release}
  126. %description -n ruby-rsvg2
  127. Ruby/RSVG is a Ruby binding of librsvg2.
  128. %prep
  129. %setup -q -n %{name}-all-%{version}
  130. for file in `find . -regex '.*/sample/.*\.rb'`
  131. do
  132. sed -e 's/^#! *\/usr\/local\/bin\/ruby/#!\/usr\/bin\/env ruby/' < $file > $file.mod
  133. mv $file.mod $file
  134. done
  135. %build
  136. %{ruby} extconf.rb --with-opt-include=%{rarchdir}
  137. make
  138. %install
  139. rm -rf $RPM_BUILD_ROOT
  140. make DESTDIR=$RPM_BUILD_ROOT \
  141. sitearchdir=$RPM_BUILD_ROOT%{rarchdir} \
  142. sitelibdir=$RPM_BUILD_ROOT%{rlibdir} install
  143. %clean
  144. rm -rf $RPM_BUILD_ROOT
  145. %files
  146. %defattr(-,root,root)
  147. %doc AUTHORS COPYING.LIB NEWS README
  148. %{rlibdir}/gnome2/
  149. %{rlibdir}/gnome2-raketask.rb
  150. %{rlibdir}/mkmf-gnome2.rb
  151. %files -n %{name}-devel
  152. %defattr(-,root,root)
  153. %{rarchdir}/*.h
  154. %files -n ruby-gtk2
  155. %defattr(-,root,root)
  156. %doc glib2/COPYING.LIB glib2/README glib2/sample
  157. %doc gdk_pixbuf2/COPYING.LIB gdk_pixbuf2/README gdk_pixbuf2/sample
  158. %doc gio2/COPYING.LIB gio2/README gio2/sample
  159. %doc gobject-introspection/COPYING.LIB
  160. %doc gobject-introspection/README gobject-introspection/sample
  161. %doc gtk2/COPYING.LIB gtk2/README gtk2/sample
  162. %doc pango/COPYING.LIB pango/README pango/sample
  163. %{rlibdir}/atk.rb
  164. %{rlibdir}/cairo-gobject.rb
  165. %{rlibdir}/gdk_pixbuf2.rb
  166. %{rlibdir}/glib2.rb
  167. %{rlibdir}/glib2/
  168. %{rlibdir}/gio2.rb
  169. %{rlibdir}/gio2/
  170. %{rlibdir}/glib-mkenums.rb
  171. %{rlibdir}/gobject-introspection/
  172. %{rlibdir}/gobject-introspection.rb
  173. %{rlibdir}/gtk2/
  174. %{rlibdir}/gtk2.rb
  175. %{rlibdir}/pango.rb
  176. %{rarchdir}/atk.so
  177. %{rarchdir}/cairo_gobject.so
  178. %{rarchdir}/gdk_pixbuf2.so
  179. %{rarchdir}/glib2.so
  180. %{rarchdir}/gio2.so
  181. %{rarchdir}/gobject_introspection.so
  182. %{rarchdir}/gtk2.so
  183. %{rarchdir}/pango.so
  184. %files -n ruby-gtk3
  185. %defattr(-,root,root)
  186. %doc gtk3/COPYING.LIB gtk3/README gtk3/sample
  187. %{rlibdir}/gtk3/
  188. %{rlibdir}/gtk3.rb
  189. %{rarchdir}/gtk3.so
  190. %files -n ruby-gstreamer
  191. %defattr(-,root,root,-)
  192. %doc gstreamer/COPYING.LIB gstreamer/sample
  193. %{rlibdir}/gst/
  194. %{rlibdir}/gst.rb
  195. %{rlibdir}/gstreamer.rb
  196. %{rarchdir}/gstreamer.so
  197. %files -n ruby-gtksourceview2
  198. %defattr(-,root,root,-)
  199. %doc gtksourceview2/COPYING.LIB gtksourceview2/README gtksourceview2/sample
  200. %{rlibdir}/gtksourceview2.rb
  201. %{rarchdir}/gtksourceview2.so
  202. %files -n ruby-gtksourceview3
  203. %defattr(-,root,root,-)
  204. %doc gtksourceview3/COPYING.LIB gtksourceview3/README gtksourceview3/sample
  205. %{rlibdir}/gtksourceview3.rb
  206. %{rlibdir}/gtksourceview3/
  207. %{rarchdir}/gtksourceview3.so
  208. %files -n ruby-poppler
  209. %defattr(-,root,root)
  210. %doc poppler/COPYING.LIB poppler/README poppler/sample
  211. %{rlibdir}/poppler.rb
  212. %{rarchdir}/poppler.so
  213. %files -n ruby-vte
  214. %defattr(-,root,root)
  215. %doc vte/COPYING.LIB vte/README vte/sample
  216. %{rlibdir}/vte.rb
  217. %{rlibdir}/vte/
  218. %{rarchdir}/vte.so
  219. %files -n ruby-vte3
  220. %defattr(-,root,root)
  221. %doc vte3/COPYING.LIB vte3/README vte3/sample
  222. %{rlibdir}/vte3.rb
  223. %{rlibdir}/vte3/
  224. %{rarchdir}/vte3.so
  225. %files -n ruby-rsvg2
  226. %defattr(-,root,root)
  227. %doc rsvg2/COPYING.LIB rsvg2/README rsvg2/sample
  228. %{rlibdir}/rsvg2.rb
  229. %{rarchdir}/rsvg2.so
  230. %changelog
  231. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.5-3
  232. - rebuild with poppler-0.37.0
  233. * Fri Sep 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.5-2
  234. - rebuild with ruby-2.2.3
  235. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.5-1
  236. - new upstream release
  237. - change BuildRequires: vte290-devel instead of vte3-devel
  238. - remove %%{name}-goocanvas subpackage
  239. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-3
  240. - rebuild with poppler-0.26.2
  241. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-2
  242. - rebuild with poppler-0.24.5
  243. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.0-1
  244. - new upstream release
  245. * Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-3
  246. - rebuild with ruby-2.0.0.353
  247. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-2
  248. - rebuild with poppler-0.24.2
  249. * Sat Sep 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-1
  250. - new upstream release
  251. - fix BR
  252. - remove old patches
  253. - remove ruby-gtkglext, ruby-gtkmozembed, ruby-glade2 subpackages
  254. - add ruby-gtk3, ruby-gtksourceview3, ruby-vte3, ruby-rsvg2 subpackages
  255. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19.3-3
  256. - rebuilt with poppler-0.16.3
  257. - added Patch15
  258. - added BuildRequires: goocanvas-devel
  259. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.19.3-2
  260. - rebuild with poppler-0.14.2
  261. - add BuildRequires: ruby
  262. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  263. - fix %files (add pkgconfig files)
  264. * Fri Mar 19 2010 IWAI, Masaharu <iwai@alib.jp> 0.19.3-1
  265. - new upstream release
  266. - drop gtkmozembed.patch (Patch15): upstream fixed
  267. - add BuildRequires:
  268. - gtksourceview-devel >= 1.0.1
  269. - gstreamer-plugins-base-devel
  270. - mesa-libGLU-devel
  271. - libXmu-devel
  272. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.0-1
  273. - new upstream release
  274. - build with xulrunner-1.9.1
  275. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.18.1-2
  276. - rebuild with poppler-0.10.2
  277. * Sat Nov 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.1-1vl5
  278. - new upstream release
  279. - changed Group to Development/Libraries
  280. * Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.0-1vl5
  281. - applied new versioning policy
  282. - spec in UTF-8
  283. - new upstream release
  284. - added Patch14 from Fedora for building with xulrunner
  285. * Fri Dec 28 2007 Alex Lancaster <alexlan@fedoraproject.org> 0.16.0-21
  286. - Add xulrunner patch from bugzilla #402591
  287. - Rebuild against gecko-lib 1.9 (xulrunner)
  288. - dropped Patch20-23
  289. - new ruby-gstreaner, ruby-gtksourceview2 subpackage
  290. * Fri Aug 31 2007 Shu KONNO <owa@bg.wakwak.com> 0.16.0-0vl3
  291. - add Patch20: ruby-gnome2-all-0.16.0-rbglib_unicode.patch
  292. - add Patch21: ruby-gnome2-all-0.16.0-rbglib_maincontext.patch
  293. - add Patch22: ruby-gnome2-all-0.16.0-rbgobj_boxed.patch
  294. - add Patch23: ruby-gnome2-all-0.16.0-rbgtktreeiter.patch
  295. - set iffox is true if x86_64
  296. * Sun Jun 25 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.16.0-0vl2
  297. - upstream release
  298. - add BuildRequires: poppler-devel, vte-devel
  299. - add new packages: ruby-poppler, ruby-vte
  300. - add Obsoletes: ruby-libgda (no longer supported)
  301. - drop Patch10
  302. - add Requires: mozilla to ruby-gtkmozembed
  303. * Tue May 16 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.1-0vl5
  304. - rebuild with Ruby-1.8.4
  305. * Sat Apr 1 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.1-0vl4
  306. - rebuild with GNOME-2.14
  307. - change BuildRequires: from gstreamer-devel to gstreamer08-devel
  308. - change BuildRequires: from firefox-devel to mozilla-devel
  309. (Patch 10 is kept in package)
  310. * Sat Feb 25 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.1-0vl3
  311. - add Requires: ruby-gtk2 to ruby-gtkmozembed
  312. - add Requires: ruby-gnome2 to ruby-libglade2
  313. * Tue Feb 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.1-0vl2
  314. - added Patch10 (use firefox-devel instead of mozilla-devel)
  315. * Sat Feb 18 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.1-0vl1
  316. - upstream release
  317. - temporally remove ruby-libgda
  318. (libgda binding is not available with libgda-1.9.100-0vl1)
  319. * Sun Oct 30 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.0-0vl2
  320. - fix typo in Summary: of ruby-gtk2
  321. - add Requires: rcairo for ruby-gtk2
  322. - add BuildRequires: rcairo-devel to support rcairo
  323. * Sun Oct 23 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.14.0-0vl1
  324. - upstream release
  325. - add BuildRequires: mozilla-devel to build ruby-gtkmozembed
  326. * Sun Sep 4 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.13.0-0vl1
  327. - upstream release
  328. - change BuildRequires: kernel-headers to glibc-kernheaders
  329. * Mon May 9 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.12.0-0vl2
  330. - add gtkglext and libgda modules as independent VineSeedPlus package
  331. * Fri May 6 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.12.0-0vl1
  332. - catch up to upstream release
  333. - replace Patch10 with eqivalent C-shell script
  334. - replace BuildRequires
  335. - add new modules to ruby-gnome2
  336. - remove gtkglext modules (currently in VineSeedPlus)
  337. * Fri Nov 12 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.1-0vl3
  338. - rebuilt with newest gnome in VineSeed
  339. * Sun Sep 26 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.1-0vl2
  340. - remove ruby-libglade2's ruby-gnome2 dependency
  341. - temporarily removed libgda module (libgda is in VineSeedPlus)
  342. * Fri Mar 26 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 0.9.1-0vl1
  343. - updated to newest upstream release
  344. - add ruby-gnome2-0.9.1-vine.patch for remove /usr/local/bin/ruby
  345. - add atk to ruby-gtk2 and libgda and gtkglext to ruby-gnome2
  346. - remove sentence for Imlib from description
  347. * Sun Dec 07 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 0.8.1-0vl1
  348. - updated to newest upstream releas
  349. - added to kernel-headers and libgnomeui-devel in BuildPrereq
  350. - new subpackage ruby-gnome2-devel for header files
  351. * Fri Oct 10 2003 Satoshi MACHINO <machino@vinelinux.org> 0.7.0-0vl2
  352. - added to gstreamer-devel in BuildPrereq
  353. * Thu Oct 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.7.0-0vl1
  354. - updated to newest upstream release
  355. * Mon May 26 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.4.0-0vl6
  356. - add html_stream_close
  357. * Sun May 25 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.4.0-0vl5
  358. - fixed lack of HtmlStrem's free.
  359. * Sun May 25 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.4.0-0vl4
  360. - add html_stream_write.
  361. * Sun May 25 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.4.0-0vl3
  362. - add libgtkhtml2
  363. * Mon May 12 2003 kazuhisa TAKEI <takei@vinelinux.org> 0.4.0vl2
  364. - rebuild for new gtk2,gnome2
  365. * Fri Apr 11 2003 Kazuhisa TAKEI <takei@linux.or.jp> 0.4.0-0vl1
  366. - new upstream version
  367. * Wed Jan 1 2003 Kazuhisa TAKEI <takei@linux.or.jp> 0.2-0vl1
  368. - initial package for ruby-gnome2 based on ruby-gnme package.
  369. * Sat Sep 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.30-0vl1
  370. - updated to new upstream release
  371. - ruby-libgrade requires ruby-gnome
  372. * Fri Aug 02 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.29-0vl2
  373. - increased release number to avoid confusion between VinePlus and VineSeedPlus
  374. - put ruby-classbrowser-{%{gtk},gnome} to %%{_bindir}
  375. * Mon Jul 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.29-0vl1
  376. - updated to 0.29 upstream release
  377. - Patch0 removed
  378. - added forgottten %%clean section
  379. * Mon Jun 03 2002 Satoshi MACHINO <machino@vinelinux.org> 0.28-0vl1
  380. - updated ruby-gnome-0.28
  381. - dropped ruby-gnome-itemfactory.patch
  382. -- merged upstream
  383. - added ruby-gnome-0.28-extconf.patch
  384. -- To install gnome.rb
  385. * Wed May 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.27-0vl1
  386. - tons of changes since 0.27-0vl0 :)
  387. - now ruby-gtk and ruby-libglade are separated subpackages
  388. - files installed to rlibdir, NOT sitedir
  389. - added Obsoletes: gnome-ruby < %%{version}
  390. * Fri Apr 12 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  391. - First package.