smart-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509
  1. %bcond_with ksmarttray
  2. %bcond_without smart_update
  3. Summary: Smart Package Manager
  4. Summary(ja): Smart パッケージマネージャ
  5. Name: smart
  6. Version: 1.4.1
  7. Release: 1%{?_dist_release}
  8. Group: Applications/Administration
  9. License: GPLv2+
  10. URL: http://smartpm.org
  11. Source0: http://labix.org/download/smart/%{name}-%{version}.tar.bz2
  12. #Source1: smart-vine-distro.py
  13. Source2: smart.console
  14. Source4: smart-package-manager.desktop
  15. #Source6: smart-newer.py
  16. BuildRequires: desktop-file-utils
  17. BuildRequires: python-devel
  18. BuildRequires: rpm-python
  19. Requires: rpm-python
  20. Requires: usermode
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: daisuke
  25. %description
  26. Smart Package Manager is a next generation package handling tool.
  27. %package gui
  28. Summary: Smart GTK user interface
  29. Summary(ja): Smart GTK ユーザインタフェース
  30. Group: Applications/Administration
  31. Requires(post): desktop-file-utils
  32. Requires(postun): desktop-file-utils
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: pygtk2
  35. %description gui
  36. Smart GTK user interface.
  37. %if %{with smart_update}
  38. %package update
  39. Summary: Allows execution of 'smart update' by normal users (suid)
  40. Summary(ja): 'smart update' をユーザ権限で実行できるようにする (suid)
  41. Group: Applications/Administration
  42. Requires: %{name} = %{version}-%{release}
  43. %description update
  44. Allows execution of 'smart update' by normal users through a
  45. special suid command.
  46. %endif
  47. %if %{with ksmarttray}
  48. %package -n ksmarttray
  49. Summary: KDE tray program for watching updates with Smart Package Manager
  50. Group: Applications/Administration
  51. Requires(post): desktop-file-utils
  52. Requires(postun): desktop-file-utils
  53. Requires: %{name}-update = %{version}-%{release}
  54. BuildRequires: kdelibs-devel
  55. BuildRequires: popt
  56. BuildRequires: rpm-devel
  57. %description -n ksmarttray
  58. KDE tray program for watching updates with Smart Package Manager.
  59. %endif
  60. %prep
  61. %setup -q
  62. %build
  63. %__make
  64. %if %{with ksmarttray}
  65. pushd contrib/ksmarttray
  66. make -f admin/Makefile.common
  67. %configure_kde3
  68. %__make
  69. popd
  70. %endif
  71. %if %{with smart_update}
  72. pushd contrib/smart-update
  73. %__make
  74. popd
  75. %endif
  76. %install
  77. rm -fr %{buildroot}
  78. %__make DESTDIR=%{buildroot} install
  79. install -m644 %{SOURCE2} -D %{buildroot}%{_sysconfdir}/security/console.apps/smart-root
  80. ln -sf consolehelper %{buildroot}%{_bindir}/smart-root
  81. mkdir -p %{buildroot}%{_sysconfdir}/pam.d
  82. cat > %{buildroot}%{_sysconfdir}/pam.d/smart-root <<EOF
  83. #%PAM-1.0
  84. auth include config-util
  85. account include config-util
  86. session include config-util
  87. EOF
  88. mkdir -p %{buildroot}%{_datadir}/applications
  89. desktop-file-install \
  90. --dir %{buildroot}%{_datadir}/applications \
  91. %{SOURCE4}
  92. install -m644 smart/interfaces/images/smart.png -D %{buildroot}%{_datadir}/pixmaps/smart-package-manager.png
  93. mkdir -p %{buildroot}%{_localstatedir}/lib/smart/channels
  94. #install -m644 %{SOURCE6} -D %{buildroot}%{py_sitelib}/%{name}/commands/newer.py
  95. %if %{with smart_update}
  96. install -m755 contrib/smart-update/smart-update -D %{buildroot}%{_bindir}/smart-update
  97. %endif
  98. %if %{with ksmarttray}
  99. pushd contrib/ksmarttray
  100. %makeinstall_std
  101. popd
  102. install -m755 contrib/servicemenus/kde_add_smart_channel.sh -D %{buildroot}%{_kde3_bindir}/kde_add_smart_channel.sh
  103. mkdir -p %{buildroot}%{_kde3_datadir}/apps/konqueror/servicemenus
  104. desktop-file-install \
  105. --dir %{buildroot}%{_kde3_datadir}/apps/konqueror/servicemenus \
  106. contrib/servicemenus/add_smart_channel.desktop
  107. # XDG menu entry
  108. mkdir -p %{buildroot}%{_kde3_datadir}/applications/
  109. cat > ksmarttray.desktop << EOF
  110. [Desktop Entry]
  111. Name=KSmartTray
  112. Comment=KDE Tray widget for updating RPM files
  113. Exec=%{_kde3_bindir}/ksmarttray %%F
  114. Icon=smart-package-manager
  115. Type=Application
  116. Categories=Qt;KDE;Settings;PackageManager;
  117. EOF
  118. %{_bindir}/desktop-file-install \
  119. --dir %{buildroot}%{_kde3_datadir}/applications \
  120. ksmarttray.desktop
  121. %endif
  122. %find_lang %{name}
  123. %clean
  124. rm -rf %{buildroot}
  125. %files -f %{name}.lang
  126. %defattr(0644,root,root,0755)
  127. %doc HACKING README TODO IDEAS doc/*.css doc/*.html
  128. %config(noreplace) %{_sysconfdir}/security/console.apps/smart-root
  129. %config(noreplace) %{_sysconfdir}/pam.d/smart-root
  130. %attr(0755,root,root)%{_bindir}/%{name}
  131. %attr(0755,root,root)%{_bindir}/%{name}-root
  132. %dir %{python_sitearch}/smart
  133. %{python_sitearch}/smart/*
  134. %{python_sitearch}/*.egg-info
  135. %exclude %{python_sitearch}/smart/interfaces/gtk
  136. %dir %{_localstatedir}/lib/smart/channels
  137. %{_mandir}/*/*
  138. %files gui
  139. %defattr(0644,root,root,0755)
  140. %{_datadir}/applications/smart-package-manager.desktop
  141. %{_datadir}/pixmaps/smart-package-manager.png
  142. %{python_sitearch}/smart/interfaces/gtk
  143. %if %{with smart_update}
  144. %files update
  145. %attr(4755,root,root) %{_bindir}/smart-update
  146. %endif
  147. %if %{with ksmarttray}
  148. %files -n ksmarttray
  149. %defattr(-,root,root)
  150. %{_kde3_bindir}/ksmarttray
  151. %{_kde3_bindir}/kde_add_smart_channel.sh
  152. %{_kde3_datadir}/apps/ksmarttray
  153. %{_kde3_datadir}/applications/ksmarttray.desktop
  154. %{_kde3_datadir}/apps/konqueror/servicemenus/add_smart_channel.desktop
  155. %{_kde3_iconsdir}/hicolor/48x48/apps/ksmarttray.png
  156. %endif
  157. %changelog
  158. * Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  159. - initial build for Vine Linux
  160. * Fri Jan 28 2011 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.4-1.r951.1mdv2011.0
  161. + Revision: 633562
  162. - implement distepoch support
  163. * Fri Oct 29 2010 Michael Scherer <misc@mandriva.org> 1:1.4-1.r949.2mdv2011.0
  164. + Revision: 590080
  165. - rebuild for python 2.7
  166. * Sat Oct 02 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.4-1.r949.1mdv2011.0
  167. + Revision: 582426
  168. - New release: 1.4 (merging in latest code from trunk)
  169. * Thu Apr 22 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.3.1-0.r948.1mdv2010.1
  170. + Revision: 537821
  171. - update to revision 948:
  172. o fix loading of old cache lacking new channel attribute (fixes #58144)
  173. o revert an accidental change that were commited in r942
  174. - remove scriptlets for < 2009.0 releases
  175. - update to revision 946 to fix a build failure and a couple of test failures
  176. - new bzr snapshot:
  177. o fixes gtk gui breakage with channel updating
  178. o merges latest code from trunk & unity branch
  179. * Sat Feb 27 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.3-1mdv2010.1
  180. + Revision: 512282
  181. - new release: 1.3 (synced mandriva branch with trunk)
  182. - use %%setup_compile_flags macro
  183. * Sun Sep 27 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-10mdv2010.0
  184. + Revision: 449900
  185. - make multilib behaviour optionable and also apply the behaviour to package
  186. upgrades as well (updates P501)
  187. - move distro.py to standard location as it no longer contains any arch specific
  188. stuff...
  189. - fix slow pycurl fetcher without breaking others..
  190. - fix huge slowdown limiting download speed to ~160K/sec when using pycurl
  191. - for a dependency which only two packages of same version and different arch
  192. satisfies, automatically pick the one with best arch score. This will ie.
  193. make smart able to automatically pick 'lib64foo-devel' to satisfy 'foo-devel'
  194. in cases where both 'libfoo-devel' & 'lib64foo-devel' provides it. (P501)
  195. - restore old revision after accidental removal of directory
  196. - fixes and updates from smart mandriva branch (P500):
  197. o really fix handling of hdlist.cz to make it actually work again
  198. o make sure that mirror picked by urpmisync plugin may actually be used
  199. o add XZHandler for handling xz compressed files
  200. * Tue Jun 02 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-8mdv2010.0
  201. + Revision: 382279
  202. - add a buildconflicts on python-curl to prevent it's different output breaking test suite
  203. - update to new tarball generated from my branch:
  204. o fix handling of restricted channels (fixes #51249)
  205. o fix handling of cdrom (fixes #51247)
  206. o fix baseurl so that downloading will work again (fixes #50460)
  207. o print warning if errors resulting in urpmisync being disabled occurs
  208. * Mon May 25 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-7mdv2010.0
  209. + Revision: 379714
  210. - disable ksmarttray for >= 2010.0
  211. - * make urpmisync more sturdy, remove channels when disabled and fallback to
  212. disabled if exceptions occurs (P505)
  213. - fix decompression of hdlist.cz (P504)
  214. * Sat Apr 25 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-6mdv2010.0
  215. + Revision: 369038
  216. - skip global options urpmi.cfg for urpmichannelsync (fixes #48509,8)
  217. - fix dealing with urpmi medias containing dots in the name (P502)
  218. * Tue Mar 10 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-5mdv2009.1
  219. + Revision: 353349
  220. - make urpmichannelsync channels default to 0 for priority to keep consistent
  221. priority of packages based on their version only which is what one usually wants..
  222. - be sure to move hdlist if present as well updates (P0)
  223. * Mon Mar 09 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-4mdv2009.1
  224. + Revision: 353328
  225. - reuse existing urpmi metadata when forcing migration to new layout and remove
  226. any old leftovers (P0)
  227. * Sat Mar 07 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-3mdv2009.1
  228. + Revision: 350674
  229. - add python-rpm to buildrequires (required by test suite)
  230. - add %%check section with test suite running to prevent more silly mistakes..:p
  231. - gah, previous commit/release missed the actually updated tarball, update it
  232. from my branch again with more fixes:
  233. o in situations where /var/lib/media/<medianame>/ doesn't exist, create it,
  234. will force urpmi to migrate to new layout from old with
  235. /var/lib/media/synthesis.hdlist.<medianame>.cz etc. as well.
  236. o fix broken urpmichannelsync test
  237. o fix locale issue which would break the test suite
  238. o fix issue where dpkg installed, but not used would break smart
  239. * Fri Mar 06 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-2mdv2009.1
  240. + Revision: 349658
  241. - fix mess with unresolved conflicts which made it in to the branch by accident:(
  242. * Thu Mar 05 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-1mdv2009.1
  243. + Revision: 349177
  244. - update to new version based on my branch:
  245. o merging in new 1.2 stable release from trunk
  246. o merge in several of afb's bugfix and relevant feature branches which hasn't
  247. made their way to trunk yet
  248. o improve urpmichannelsync plugin making it a bit more robust
  249. o merge all of our appropriate patches and throw away those who's not
  250. o switch to xz compression for tarball
  251. fix up after previous vandalism commit:
  252. o revert back to my mandriva branch
  253. o fix reckless usage of epoch tag which broke dependencies on subpackages
  254. o fix #48265 properly
  255. * Thu Feb 26 2009 Helio Chissini de Castro <helio@mandriva.com> 1:1.1-3mdv2009.1
  256. + Revision: 345173
  257. - Fixing bug https://qa.mandriva.com/show_bug.cgi?id=48265 with a easy solution, using the real upstream package.
  258. In near future, we should accept only upstream tarballs, instead of use unfinished obscure branchs
  259. * Thu Dec 25 2008 Funda Wang <fwang@mandriva.org> 1.1.1-2mdv2009.1
  260. + Revision: 318616
  261. - fix patch
  262. - rediff signature patch
  263. - rediff channel patch
  264. - rebuild for new python
  265. * Wed Nov 05 2008 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.1.1-1mdv2009.1
  266. + Revision: 300004
  267. - workaround nagging about missing files during build of ksmarttray
  268. - perform some spec cleanups and cosmetics to follow "regular" Mandriva style
  269. - update from my own branch based on 1.1.1:
  270. o adds urpimsync plugin to natively supporting use of local urpmi
  271. configuration and data (replaces existing distro.py and obsoletes
  272. urpmi2smart)
  273. o adds basic mirrorlist support
  274. - make dependency on python-liblzma versioned
  275. * Mon Sep 15 2008 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.1-1mdv2009.0
  276. + Revision: 285039
  277. - since last one never got through, bump release down back to 1
  278. - bump release
  279. - cool down on overeager macro usage for %%{name}
  280. - change conflicts on python-curl to suggests
  281. - add dependency on python-liblzma since we need it for info.xml.lzma
  282. - add support for info.xml metadata and fix crash with curl (P200, from my own branch:)
  283. - fix string splitting in urpmi2smart that got broken due to a second ':' showing
  284. up in new mirrorurl variable
  285. - new release
  286. - remove conflict on python-curl, new version of python-curl works without
  287. segfaulting :)
  288. - always pass -pX argument to %%patchX
  289. * Fri Aug 15 2008 Nicolas Lécureuil <nlecureuil@mandriva.com> 1.0-1mdv2009.0
  290. + Revision: 272233
  291. - Update to Smart 1.0
  292. Remove patches 0, 2,6 ,11 ( Merged upstream )
  293. Added comment about patch 13 ( i do not know if this is still needed to use it )
  294. * Fri Aug 08 2008 Thierry Vignaud <tv@mandriva.org> 0.52-7mdv2009.0
  295. + Revision: 269254
  296. - rebuild early 2009.0 package (before pixel changes)
  297. + Pixel <pixel@mandriva.com>
  298. - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
  299. - ensure comment does not appear in ksmarttray's %%postun
  300. * Sat Jun 07 2008 Funda Wang <fwang@mandriva.org> 0.52-6mdv2009.0
  301. + Revision: 216583
  302. - use media_info and synthesis by default
  303. - move kde3 stuff to /opt
  304. + Pixel <pixel@mandriva.com>
  305. - adapt to %%_localstatedir now being /var instead of /var/lib (#22312)
  306. * Thu Jan 31 2008 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-5mdv2008.1
  307. + Revision: 160889
  308. - fix smart widht when running in terminal, patch 105
  309. + Olivier Blin <oblin@mandriva.com>
  310. - restore BuildRoot
  311. + Thierry Vignaud <tv@mandriva.org>
  312. - kill re-definition of %%buildroot on Pixel's request
  313. * Mon Dec 17 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-4mdv2008.1
  314. + Revision: 121130
  315. - use SUSE patches
  316. - drop patches 100-102
  317. - rebuild for new rpm
  318. - new license policy
  319. - do not package LICENSE file
  320. * Mon Oct 22 2007 David Walluck <walluck@mandriva.org> 0.52-3mdv2008.1
  321. + Revision: 101073
  322. - always include ksmarttray patches in src.rpm
  323. - always apply ksmarttray patches regardless of whether we are building it
  324. * Thu Oct 18 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-2mdv2008.1
  325. + Revision: 99836
  326. - drop patch 9 (merged in one SUSE patch)
  327. - add three SUSE patches (x86_64 support)
  328. * Tue Oct 09 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-1mdv2008.1
  329. + Revision: 96573
  330. - remove patch 2 as it has been applied upstream
  331. - new version
  332. - *.pyc files should be shipped
  333. * Thu Sep 27 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-17mdv2008.0
  334. + Revision: 93301
  335. - do not hardcode libdir
  336. - conflicts python-curl as it crashesh smart while updating channels
  337. - do not ship *.pyc files
  338. - add full url for source0
  339. - enable ksmarttray (somehow i just disabled it ;)
  340. - use smart's makefile
  341. - fix mixture of tabs and spaces
  342. - do not use vendor in desktop files
  343. - move patch 12 to ksmarttray section
  344. - suggests python-curl
  345. * Sat Sep 15 2007 David Walluck <walluck@mandriva.org> 0.51-16mdv2008.0
  346. + Revision: 85891
  347. - require smart = %%{version}-%%{release} from subpackages so we don't get breakage
  348. * Sat Sep 15 2007 David Walluck <walluck@mandriva.org> 0.51-15mdv2008.0
  349. + Revision: 85877
  350. - fix conflicts with gui subpackage
  351. * Fri Sep 14 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-14mdv2008.0
  352. + Revision: 85627
  353. - check rpm signatures and add default pgp keyserver
  354. provide patch 14, which prevents segfaults on slower connections
  355. provide patch 15, which add support for fail on curl authentification error
  356. provide patch 16, which add Hide-Unlocked option in View menu
  357. provide patch 17, which should haven't slowndown on curl downloading
  358. set requires on python-curl, especially useful for people using proxies
  359. * Thu Sep 13 2007 Thierry Vignaud <tv@mandriva.org> 0.51-13mdv2008.0
  360. + Revision: 85237
  361. - bump conflicts in order to fix upgrade (#33465)
  362. * Thu Sep 13 2007 David Walluck <walluck@mandriva.org> 0.51-12mdv2008.0
  363. + Revision: 84932
  364. - bump release
  365. - remove executable bit from smart-package-manager.desktop
  366. - document some outstanding issues
  367. * Thu Sep 13 2007 David Walluck <walluck@mandriva.org> 0.51-10mdv2008.0
  368. + Revision: 84913
  369. - partial fix for upstream ksmarttray update bug
  370. - fix for bug #28782 (detectsys)
  371. * Sun Sep 09 2007 David Walluck <walluck@mandriva.org> 0.51-9mdv2008.0
  372. + Revision: 83949
  373. - include modified urpmi2smart.py script
  374. - replace references to i568 with i586 in distro.i586
  375. - always include distro.i586 as a source regardless of arch and update at install time
  376. - use %%bcond_without macros for spec options
  377. - add patch to fix downloading over scp
  378. - use desktop-file-install and make sure .desktop files validate
  379. - show ksmarttray in menus
  380. + Tomasz Pawel Gajc <tpg@mandriva.org>
  381. - update channel list
  382. remove JPackage because it is dead
  383. add non-free channel
  384. provide separate channel list for i586 and x86_64
  385. * Mon Sep 03 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-6mdv2008.0
  386. + Revision: 78579
  387. - use script fo find translations
  388. - remove options for older mdv release
  389. - drop exclude for some files
  390. - ksmarttray will be shown only in KDE menus
  391. * Wed Aug 29 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-5mdv2008.0
  392. + Revision: 74263
  393. - remove doubled/unneeded buildrequires
  394. - do not use %%{_sourcedir}
  395. - remove %%ifarch, rely on libsuffix for configure script
  396. - small cleans in a spec file
  397. - drop source 5 (smart has french translation already)
  398. - provide patch 8 (fixes gui)
  399. - provide patch 9 (speed up listing packages in channels)
  400. - provide patch 5 (should speed up gui responsiveness)
  401. * Tue Aug 28 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-4mdv2008.0
  402. + Revision: 72632
  403. - fix build on x86_64
  404. - provides smart newer, a command which shows packages that have available upgrades
  405. - add ksmarttray's konqueror service menus
  406. - add scriplets
  407. - provide patch 4, which adds handling of rpm gpg signatures
  408. - provide patch 3 (mirrors for channels)
  409. - provide patch 2 (should speed up cache loading)
  410. - provide patch 7 (ksmarttray can start smart-gui now)
  411. * Fri Aug 10 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-3mdv2008.0
  412. + Revision: 61015
  413. - provide patch 6 (enable build of ksmarttray)
  414. - drop X-MandrivaLinux from desktop file
  415. * Mon Jun 11 2007 Olivier Thauvin <nanardon@mandriva.org> 0.51-2mdv2008.0
  416. + Revision: 37984
  417. - rebuild for rpm
  418. * Mon May 21 2007 Andreas Hasenack <andreas@mandriva.com> 0.51-1mdv2008.0
  419. + Revision: 29383
  420. - updated to version 0.51
  421. - removed patches that were already included
  422. * Wed May 02 2007 Funda Wang <fwang@mandriva.org> 0.50-5mdv2008.0
  423. + Revision: 20377
  424. - Move translations into main package, because vt under x11 may need
  425. translations.