python-lxml-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106
  1. %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
  2. %{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  3. %define _lxml lxml
  4. Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
  5. Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
  6. Name: python-%{_lxml}
  7. Group: Development/Libraries
  8. Version: 3.8.0
  9. Release: 1%{?_dist_release}
  10. License: BSD
  11. URL: http://codespeak.net/lxml
  12. #URL: http://pypi.python.org/pypi/lxml
  13. Source: http://pypi.python.org/packages/source/l/%{_lxml}/%{_lxml}-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. BuildRequires: libxml2-devel >= 2.6.21
  18. BuildRequires: libxslt-devel >= 1.1.15
  19. BuildRequires: python-devel >= 2.3
  20. BuildRequires: python3-devel
  21. BuildRequires: python-pyrex
  22. %description
  23. lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries. It is
  24. unique in that it combines the speed and feature completeness of these
  25. libraries with the simplicity of a native Python API, mostly compatible but
  26. superior to the well-known ElementTree_ API. See the introduction_ for more
  27. information about background and goals.
  28. %package -n python3-lxml
  29. Summary: lxml is a Pythonic binding for the libxml2 and libxslt libraries
  30. Summary(ja): lxml は libxml2 と libxslt の Python バインディングです
  31. Group: Development/Libraries
  32. %description -n python3-lxml
  33. lxml is a Pythonic binding for the libxml2_ and libxslt_ libraries. It is
  34. unique in that it combines the speed and feature completeness of these
  35. libraries with the simplicity of a native Python API, mostly compatible but
  36. superior to the well-known ElementTree_ API. See the introduction_ for more
  37. information about background and goals.
  38. %prep
  39. %setup -q -T -c -n %{_lxml}-%{version}
  40. tar xvf %{SOURCE0}
  41. mv %{_lxml}-%{version} py2
  42. cp -a py2 py3
  43. %build
  44. pushd py2
  45. %{__python} setup.py build
  46. popd
  47. pushd py3
  48. python3 setup.py build
  49. popd
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. pushd py2
  53. %{__python} setup.py install --root=$RPM_BUILD_ROOT
  54. popd
  55. pushd py3
  56. python3 setup.py install --root=$RPM_BUILD_ROOT
  57. popd
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %files
  61. %defattr(-,root,root)
  62. %doc py2/CHANGES.txt py2/CREDITS.txt py2/LICENSES.txt py2/README.* py2/TODO.txt
  63. %doc py2/doc
  64. %{python_sitearch}/%{_lxml}
  65. %{python_sitearch}/%{_lxml}-*-info
  66. %files -n python3-lxml
  67. %defattr(-,root,root)
  68. %doc py3/CHANGES.txt py3/CREDITS.txt py3/LICENSES.txt py3/README.* py3/TODO.txt
  69. %doc py3/doc
  70. %{python3_sitearch}/%{_lxml}
  71. %{python3_sitearch}/%{_lxml}-*-info
  72. %changelog
  73. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.0-1
  74. - new upstream release.
  75. - added python3 support.
  76. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-4
  77. - rebuild with VineSeed environment
  78. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.6-3
  79. - rebuild with python-2.7.2
  80. * Wed Mar 10 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 2.2.6-2
  81. - change required version of libxml2-devel for Vine Plus/5
  82. (2.7.2 or later is recomended, but works with 2.6.21 or later)
  83. * Sun Mar 07 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.6-1
  84. - initial build for vine linux