libxcrypt-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584
  1. %bcond_with fipstest
  2. %if 0%{?__isa_bits} == 64
  3. %bcond_without check
  4. %else
  5. %bcond_with check
  6. %endif
  7. Name: libxcrypt
  8. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  9. Version: 4.4.24
  10. Release: 1%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # For explicit license breakdown, see the
  15. # LICENSING file in the source tarball.
  16. License: LGPLv2+ and BSD and Public Domain
  17. URL: https://github.com/besser82/%{name}
  18. Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
  19. # Patch 0000 - 2999: Backported patches from upstream.
  20. # Patch 3000 - 5999: Backported patches from pull requests.
  21. # Patch 6000 - 9999: Downstream patches.
  22. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  23. # Build with new api?
  24. %bcond_without new_api
  25. # Build the compat package?
  26. %bcond_without compat_pkg
  27. # Shared object version of libcrypt.
  28. %if %{with new_api}
  29. %global soc 2
  30. %global sol 0
  31. %global sof 0
  32. %global sov %{soc}.%{sol}.%{sof}
  33. %if %{with compat_pkg}
  34. %global csoc 1
  35. %global csol 1
  36. %global csof 0
  37. %global csov %{csoc}.%{csol}.%{csof}
  38. %endif
  39. %else
  40. %global soc 1
  41. %global sol 1
  42. %global sof 0
  43. %global sov %{soc}.%{sol}.%{sof}
  44. %endif
  45. # Hash methods and API supported by libcrypt.
  46. # NEVER EVER touch this, if you do NOT know what you are doing!
  47. %if %{with new_api}
  48. %global hash_methods all
  49. %global obsolete_api no
  50. %if %{with compat_pkg}
  51. %global compat_methods glibc
  52. %global compat_api glibc
  53. %endif
  54. %else
  55. %global hash_methods all
  56. %global obsolete_api glibc
  57. %endif
  58. # Needed for the distribution README file.
  59. %global distname .vine
  60. # Needed for out-of-tree builds.
  61. %global _configure ../"configure"
  62. # Common configure options.
  63. %global common_configure_options \\\
  64. --libdir=/%{_lib} \\\
  65. --disable-failure-tokens \\\
  66. --disable-silent-rules \\\
  67. --enable-shared \\\
  68. --enable-static \\\
  69. --disable-valgrind \\\
  70. --srcdir=.. \\\
  71. --with-pkgconfigdir=%{_libdir}/pkgconfig
  72. %if %{with fipstest}
  73. # Add generation of HMAC checksums of the final stripped
  74. # binaries. %%define with lazy globbing is used here
  75. # intentionally, because using %%global does not work.
  76. BuildRequires: fipscheck
  77. %define __spec_install_post \
  78. %{?__debug_package:%{__debug_install_post}} \
  79. %{__arch_install_post} \
  80. %{__os_install_post} \
  81. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.a \
  82. %{__ln_s} .libcrypt.a.hmac \\\
  83. %{buildroot}/%{_lib}/.libxcrypt.a.hmac \
  84. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{sov} \
  85. %{__ln_s} .libcrypt.so.%{sov}.hmac \\\
  86. %{buildroot}/%{_lib}/.libcrypt.so.%{soc}.hmac \
  87. if [[ %{with new_api} == 1 && %{with compat_pkg} == 1 ]]; then \
  88. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{csov} \
  89. %{__ln_s} .libcrypt.so.%{csov}.hmac \\\
  90. %{buildroot}/%{_lib}/.libcrypt.so.%{csoc}.hmac \
  91. fi \
  92. %{nil}
  93. %endif
  94. BuildRequires: libtool
  95. %if %{with check}
  96. BuildRequires: glibc-debuginfo
  97. %endif
  98. # We do not need to keep this forever.
  99. # We need a version of glibc, that doesn't build libcrypt anymore.
  100. Requires: glibc%{?_isa} >= 2.26.9000-46
  101. # libxcrypt >= 4.4.22 is not compatible with pam < 1.5.1-2
  102. Conflicts: pam < 1.5.1-2
  103. %if 0%{?fedora} >= 30
  104. Recommends: mkpasswd
  105. %endif
  106. %description
  107. libxcrypt is a modern library for one-way hashing of passwords. It
  108. supports a wide variety of both modern and historical hashing methods:
  109. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  110. %if %{with new_api}
  111. md5crypt, and descrypt.
  112. %else
  113. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  114. %endif
  115. It provides the traditional Unix crypt and crypt_r interfaces, as well
  116. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  117. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  118. libxcrypt is intended to be used by login(1), passwd(1), and other
  119. similar programs; that is, to hash a small number of passwords during
  120. an interactive authentication dialogue with a human. It is not suitable
  121. for use in bulk password-cracking applications, or in any other situation
  122. where speed is more important than careful handling of sensitive data.
  123. However, it is intended to be fast and lightweight enough for use in
  124. servers that must field thousands of login attempts per minute.
  125. %if %{with new_api}
  126. This version of the library does not provide the legacy API functions
  127. that have been provided by glibc's libcrypt.so.1.
  128. %endif
  129. %if %{with new_api} && %{with compat_pkg}
  130. %package compat
  131. Summary: Compatibility library providing legacy API functions
  132. Group: system
  133. Requires: %{name}%{?_isa} == %{version}-%{release}
  134. %description compat
  135. This package contains the library providing the compatibility API
  136. for applications that are linked against glibc's libxcrypt, or that
  137. are still using the unsafe and deprecated, encrypt, encrypt_r,
  138. setkey, setkey_r, and fcrypt functions, which are still required by
  139. recent versions of POSIX, the Single UNIX Specification, and various
  140. other standards.
  141. All existing binary executables linked against glibc's libcrypt should
  142. work unmodified with the library supplied by this package.
  143. %endif
  144. %package devel
  145. Summary: Development files for %{name}
  146. Group: programming
  147. Conflicts: man-pages < 4.15-3
  148. Requires: %{name}%{?_isa} == %{version}-%{release}
  149. Requires: glibc-devel%{?_isa}
  150. %description devel
  151. The %{name}-devel package contains libraries and header files for
  152. developing applications that use %{name}.
  153. %package static
  154. Summary: Static library for -static linking with %{name}
  155. Group: programming
  156. Requires: %{name}-devel%{?_isa} == %{version}-%{release}
  157. Requires: glibc-static%{?_isa}
  158. %description static
  159. This package contains the libxcrypt static library for -static
  160. linking.
  161. You don't need this, unless you link statically, which is highly
  162. discouraged.
  163. %package -n compat32-%{name}
  164. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  165. Group: system,legacy
  166. %description -n compat32-%{name}
  167. libxcrypt is a modern library for one-way hashing of passwords. It
  168. supports a wide variety of both modern and historical hashing methods:
  169. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  170. %if %{with new_api}
  171. md5crypt, and descrypt.
  172. %else
  173. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  174. %endif
  175. It provides the traditional Unix crypt and crypt_r interfaces, as well
  176. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  177. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  178. libxcrypt is intended to be used by login(1), passwd(1), and other
  179. similar programs; that is, to hash a small number of passwords during
  180. an interactive authentication dialogue with a human. It is not suitable
  181. for use in bulk password-cracking applications, or in any other situation
  182. where speed is more important than careful handling of sensitive data.
  183. However, it is intended to be fast and lightweight enough for use in
  184. servers that must field thousands of login attempts per minute.
  185. %if %{with new_api}
  186. This version of the library does not provide the legacy API functions
  187. that have been provided by glibc's libcrypt.so.1.
  188. %endif
  189. %package -n compat32-%{name}-devel
  190. Summary: Development files for cpmpat32-%{name}
  191. Group: programming,legacy
  192. Requires: %{name}-devel == %{version}-%{release}
  193. Requires: compat32-glibc-devel
  194. %description -n compat32-%{name}-devel
  195. The compat32-%{name}-devel package contains libraries and header files for
  196. developing applications that use compat32-%{name}.
  197. %debug_package
  198. %prep
  199. %autosetup -p 1
  200. ./autogen.sh
  201. %if %{with new_api}
  202. %{__cat} << EOF >> README%{distname}
  203. This version of the %{name} package ships the libcrypt.so.2
  204. library and does not provide the legacy API functions that have
  205. been provided by glibc's libcrypt.so.1. The removed functions
  206. by name are encrypt, encrypt_r, setkey, setkey_r, and fcrypt.
  207. %if %{with compat_pkg}
  208. If you are using a third-party application that links against
  209. those functions, or that is linked against glibc's libcrypt,
  210. you may need to install the %{name}-compat package manually.
  211. All existing binary executables linked against glibc's libcrypt
  212. should work unmodified with the libcrypt.so.1 library supplied
  213. by the %{name}-compat package.
  214. %endif
  215. EOF
  216. %endif
  217. %{__mkdir_p} %{_vpath_builddir}{,-compat}
  218. %build
  219. # Build the default system library.
  220. pushd %{_vpath_builddir}
  221. %configure \
  222. %{common_configure_options} \
  223. --enable-hashes=%{hash_methods} \
  224. --enable-obsolete-api=%{obsolete_api}
  225. %make_build
  226. popd
  227. %if %{with new_api} && %{with compat_pkg}
  228. # Build the compatibility library.
  229. pushd %{_vpath_builddir}-compat
  230. %configure \
  231. %{common_configure_options} \
  232. --enable-hashes=%{compat_methods} \
  233. --enable-obsolete-api=%{compat_api}
  234. %make_build
  235. popd
  236. %endif
  237. %install
  238. rm -rf %{buildroot}
  239. %if %{with new_api} && %{with compat_pkg}
  240. # Install the compatibility library.
  241. %make_install -C %{_vpath_builddir}-compat
  242. # Cleanup everything we do not need from the compatibility library.
  243. %{__rm} -fr %{buildroot}%{_bindir} \
  244. %{buildroot}%{_includedir} \
  245. %{buildroot}/%{_lib}/lib{,x}crypt.{a,so} \
  246. %{buildroot}%{_libdir}/pkgconfig \
  247. %{buildroot}%{_mandir} \
  248. %{buildroot}%{_sbindir}
  249. %endif
  250. # Install the default system library.
  251. %make_install -C %{_vpath_builddir}
  252. # Get rid of libtool crap.
  253. %{_bindir}/find %{buildroot} -name '*.la' -print -delete
  254. %if %{with check}
  255. %check
  256. build_dirs="%{_vpath_builddir}"
  257. %if %{with new_api} && %{with compat_pkg}
  258. build_dirs="${build_dirs} %{_vpath_builddir}-compat"
  259. %endif
  260. for dir in ${build_dirs}; do
  261. %make_build -C ${dir} check || \
  262. {
  263. rc=$?;
  264. echo "-----BEGIN TESTLOG: ${dir}-----";
  265. %{__cat} ${dir}/test-suite.log;
  266. echo "-----END TESTLOG: ${dir}-----";
  267. exit $rc;
  268. }
  269. done
  270. %endif
  271. %files
  272. %doc NEWS README* THANKS
  273. %license AUTHORS COPYING.LIB LICENSING
  274. %if %{with fipstest}
  275. /%{_lib}/.libcrypt.so.%{soc}.hmac
  276. /%{_lib}/.libcrypt.so.%{sov}.hmac
  277. %endif
  278. /%{_lib}/libcrypt.so.%{soc}
  279. /%{_lib}/libcrypt.so.%{sov}
  280. %{_mandir}/man5/crypt.5.*
  281. %if %{with new_api} && %{with compat_pkg}
  282. %files compat
  283. %if %{with fipstest}
  284. /%{_lib}/.libcrypt.so.%{csoc}.hmac
  285. /%{_lib}/.libcrypt.so.%{csov}.hmac
  286. %endif
  287. /%{_lib}/libcrypt.so.%{csoc}
  288. /%{_lib}/libcrypt.so.%{csov}
  289. %endif
  290. %files devel
  291. %doc ChangeLog TODO
  292. /%{_lib}/lib*crypt.so
  293. %{_includedir}/*crypt.h
  294. %{_libdir}/pkgconfig/libcrypt.pc
  295. %{_libdir}/pkgconfig/%{name}.pc
  296. %{_mandir}/man3/crypt*.3*
  297. %files static
  298. %if %{with fipstest}
  299. /%{_lib}/.lib*crypt.a.hmac
  300. %endif
  301. /%{_lib}/lib*crypt.a
  302. %if 0%{?build_compat32}
  303. %files -n compat32-%{name}
  304. %if %{with fipstest}
  305. /%{_lib}/.libcrypt.so.%{soc}.hmac
  306. /%{_lib}/.libcrypt.so.%{sov}.hmac
  307. %endif
  308. /%{_lib}/libcrypt.so.%{soc}
  309. /%{_lib}/libcrypt.so.%{sov}
  310. %files -n compat32-%{name}-devel
  311. /%{_lib}/lib*crypt.so
  312. %{_libdir}/pkgconfig/libcrypt.pc
  313. %{_libdir}/pkgconfig/%{name}.pc
  314. %endif
  315. %changelog
  316. * Thu Aug 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.24-1
  317. - new upstream release.
  318. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.19-1
  319. - new upstream release.
  320. - dropped ldconfig scriptlets.
  321. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.17-1
  322. - new upstream release.
  323. * Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.15-1
  324. - new upstream release.
  325. * Sat Jan 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.2-6
  326. - initial build for Vine Linux.
  327. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-5
  328. - Build the compat package with glibc hashing methods only
  329. - Add an option to disable the compat-package for future use
  330. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-4
  331. - Bump SO-name for Fedora >= 30 and enable compat package (#1666033)
  332. - Add distribution README file
  333. - Update description of the compat package
  334. - Conditionally remove non-built hashing methods from description
  335. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-3
  336. - Remove architecture bits from Recommends
  337. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-2
  338. - Update summary
  339. * Sat Dec 22 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-1
  340. - New upstream release
  341. * Thu Dec 06 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.1-1
  342. - New upstream release
  343. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-5
  344. - Sync -fno-plt patch with upstream commit
  345. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-4
  346. - Backport upstream commit to fix a memory leak from a static pointer
  347. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-3
  348. - Backport upstream PR to build with -fno-plt optimization
  349. * Mon Nov 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-2
  350. - Backport upstream commit to use a safer strcpy for the NT method
  351. - Backport upstream generating base64 encoded output for NT gensalt
  352. - Backport upstream commit to require less rbytes for NT gensalt
  353. - Backport upstream commit to test incremental hmac-sha256 computation
  354. - Add Recommends: mkpasswd for Fedora >= 30
  355. * Tue Nov 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-1
  356. - New upstream release
  357. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.4-1
  358. - New upstream release
  359. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-4
  360. - Bump release for proper obsoletion of former common sub-package
  361. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-3
  362. - Add two upstream patches with minor fixes
  363. - Add HMAC checksum file for the static library
  364. - Drop the common sub-package
  365. - Some spec-file optimizations
  366. * Tue Nov 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-2
  367. - Add a patch to define crypt_gensalt_r as macro, so applications
  368. link the identical crypt_gensalt_rn directly
  369. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-1
  370. - New upstream release
  371. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.2-1
  372. - New upstream release
  373. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-2
  374. - Backport two patches from upstream fixing the gensalt function for
  375. NT to properly terminate its returned output
  376. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-1
  377. - New upstream release
  378. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.0-1
  379. - New upstream release
  380. * Fri Oct 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.3-1
  381. - New upstream release
  382. * Thu Oct 25 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-2
  383. - Add patch updating to recent development version
  384. - Run valgrind-memcheck
  385. - Use bootstrap script
  386. * Thu Oct 18 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-1
  387. - New upstream release
  388. * Mon Oct 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-3
  389. - Drop compat-devel package
  390. - Set configure options from globals
  391. * Sun Sep 30 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-2
  392. - Build out-of-tree
  393. - Split off noarch-bits into common sub-package
  394. - Update %%description
  395. - Prepare to remove legacy API from library and to provide a compatibilty
  396. package for the legacy API
  397. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-1
  398. - New upstream release
  399. - Add new manpages
  400. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.0-1
  401. - New upstream release
  402. * Fri Aug 24 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.2-1
  403. - New upstream release
  404. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-4
  405. - Move *.3 manpages to devel subpackage (#1613762)
  406. - Add needed Conflicts: man-pages < 4.15-3
  407. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-3
  408. - Make crypt{,_r} return NULL on failure (#1611784)
  409. * Sat Aug 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-2
  410. - Add manpages for crypt{,_r,_ra}.3 (#1610307)
  411. * Wed Aug 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-1
  412. - New upstream release
  413. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
  414. - New upstream release
  415. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
  416. - Make testsuite fail on error again
  417. - Update patch0 with more upstream fixes
  418. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-5
  419. - Add patch to update to recent development branch
  420. - Re-enable SUNMD5 support as it is BSD licensed now
  421. - Build compatibility symbols for glibc only
  422. - Skip failing testsuite once
  423. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
  424. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  425. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-3
  426. - Remove CDDL from license list (#1592445)
  427. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-2
  428. - Remove SUNMD5 support (#1592445)
  429. * Wed May 16 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-1
  430. - New upstream release
  431. * Sat Feb 17 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-5
  432. - Switch to %%ldconfig_scriptlets
  433. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-4
  434. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  435. * Thu Feb 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-3
  436. - Add patch to fix unintialize value in badsalt test
  437. * Wed Jan 31 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-2
  438. - Add patch to fix bcrypt test with GCC8
  439. * Sat Jan 27 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-1
  440. - New upstream release
  441. * Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-0.204.20180120git3436e7b
  442. - Fix Obsoletes
  443. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.203.20180120git3436e7b
  444. - Update to new snapshot fixing cast-align
  445. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.202.20180120gitde99d27
  446. - Update to new snapshot (rhbz#1536752)
  447. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.201.20171109git15447aa
  448. - Use archful Obsoletes for libcrypt
  449. - Add versioned Requires on glibc packages not shipping libcrypt
  450. - Add comments about the packaging logic for replacing former libcrypt
  451. * Fri Jan 12 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.200.20171109git15447aa
  452. - Initial import (rhbz#1532794)
  453. - Add Obsoletes/Provides for libcrypt
  454. * Wed Jan 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.101.20171109git15447aa
  455. - Fix style of %%git_{rel,ver}
  456. * Tue Jan 09 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.100.git20171109.15447aa
  457. - Initial rpm release (rhbz#1532794)
  458. - Start revision at 0.100 to superseed builds from COPR