texlive-collection-texinfo-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
  3. ## tlpdb2rpmspec collection-texinfo
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %bcond_with firstbuild
  8. %define tex_destdir %{_datadir}
  9. %define texmf %{tex_destdir}/texmf
  10. %define texlive_src %{tex_destdir}/texlive-sources
  11. %define build_tex_destdir %{buildroot}%{tex_destdir}
  12. %define build_texmf %{buildroot}%{texmf}
  13. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  14. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  15. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  16. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  17. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  18. %define vartexfonts %{_var}/lib/texmf/fonts
  19. Summary: TeX Live: GNU Texinfo
  20. Summary(ja): TeX Live: GNU Texinfo
  21. Name: texlive-collection-texinfo
  22. Version: 2011
  23. Release: 1%{?_dist_release}
  24. License: GPL+
  25. Group: Applications/Publishing
  26. URL:http://www.tug.org/texlive/
  27. Requires: texlive = %{version}
  28. Requires: texlive-collection-basic = %{version}
  29. Requires(post): texlive = %{version}
  30. Requires(postun): texlive = %{version}
  31. BuildRequires: texlive-sources = %{version}
  32. BuildArch: noarch
  33. Buildroot: %{_tmppath}/%{name}-%{version}-root
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: munepi
  37. %description
  38. The TeX Live software distribution offers a complete TeX system for a
  39. variety of Unix, Macintosh, Windows and other platforms. It
  40. encompasses programs for editing, typesetting, previewing and printing
  41. of TeX documents in many different languages, and a large collection
  42. of TeX macros and font libraries.
  43. The distribution includes extensive general documentation about TeX,
  44. as well as the documentation for the included software packages.
  45. This package is a collection of GNU Texinfo:
  46. TeX macros for the GNU Texinfo documentation system. The
  47. programs and documentation are no longer distributed with TeX
  48. Live; get the original Texinfo package for your system.
  49. This package contains the following CTAN packages:
  50. texinfo: Texinfo documentation system.
  51. %description -l ja
  52. TeX Live ソフトウェアディストリビューションは、
  53. さまざまな Unix, Macintosh, Windows、および
  54. 他のプラットホームに対して完全な TeX システムを提供します。
  55. 多くの異なった言語を含む TeX ドキュメントの
  56. 編集、組版、閲覧、印刷するためのプログラム、
  57. そして、TeX マクロやフォントライブラリの大きなコレクションを
  58. 同梱しています。
  59. このディストリビューションは
  60. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  61. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  62. このパッケージは以下のようなパッケージ集です。
  63. GNU Texinfo:
  64. TeX macros for the GNU Texinfo documentation system. The
  65. programs and documentation are no longer distributed with TeX
  66. Live; get the original Texinfo package for your system.
  67. このパッケージは以下の CTAN パッケージを含んでいます:
  68. texinfo: Texinfo documentation system.
  69. %prep
  70. %build
  71. %install
  72. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  73. PREF=%{buildroot}%{tex_destdir}
  74. manifest=(
  75. texmf-dist/tex/texinfo/texinfo.ini
  76. texmf-dist/tex/texinfo/texinfo.tex
  77. texmf-dist/tex/texinfo/txi-cs.tex
  78. texmf-dist/tex/texinfo/txi-de.tex
  79. texmf-dist/tex/texinfo/txi-en.tex
  80. texmf-dist/tex/texinfo/txi-es.tex
  81. texmf-dist/tex/texinfo/txi-fr.tex
  82. texmf-dist/tex/texinfo/txi-it.tex
  83. texmf-dist/tex/texinfo/txi-nb.tex
  84. texmf-dist/tex/texinfo/txi-nl.tex
  85. texmf-dist/tex/texinfo/txi-nn.tex
  86. texmf-dist/tex/texinfo/txi-pl.tex
  87. texmf-dist/tex/texinfo/txi-pt.tex
  88. texmf-dist/tex/texinfo/txi-ru.tex
  89. texmf-dist/tex/texinfo/txi-sr.tex
  90. texmf-dist/tex/texinfo/txi-tr.tex
  91. texmf-dist/tex/texinfo/txi-uk.tex
  92. )
  93. %__mkdir_p ${PREF}/texmf-dist
  94. for i in "${manifest[@]}"; do
  95. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  96. done
  97. ## make symlinks of core script utils
  98. mk_symlinks=(
  99. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  100. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  101. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  102. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  103. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  104. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  105. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  106. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  107. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  108. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  109. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  110. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  111. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  112. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  113. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  114. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  115. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  116. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  117. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  118. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  119. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  120. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  121. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  122. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  123. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  124. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  125. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  126. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  127. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  128. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  129. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  130. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  131. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  132. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  133. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  134. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  135. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  136. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  137. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  138. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  139. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  140. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  141. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  142. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  143. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  144. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  145. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  146. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  147. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  148. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  149. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  150. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  151. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  152. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  153. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  154. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  155. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  156. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  157. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  158. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  159. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  160. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  161. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  162. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  163. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  164. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  165. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  166. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  167. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  168. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  169. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  170. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  171. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  172. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  173. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  174. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  175. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  176. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  177. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  178. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  179. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  180. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  181. )
  182. %__mkdir_p %{buildroot}%{_bindir}
  183. pushd %{buildroot}%{_bindir}
  184. for i in "${mk_symlinks[@]}"; do
  185. tlc=$(echo $i | cut -f 1 -d",")
  186. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  187. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  188. [ "%{name}" = "$tlc" ] || continue
  189. [ -f $rlnk ] || exit 1
  190. %__ln_s $rlnk $lnk || exit 1
  191. done
  192. popd
  193. ## Files list
  194. find %{buildroot} -type f -or -type l | \
  195. %__sed -e "s|%{buildroot}||g" > filelist.full
  196. find %{buildroot}%{texmf}-dist -type d | \
  197. %__sed -e "s|^%{buildroot}|%dir |" \
  198. -e "s|$|/|" >> filelist.full
  199. %clean
  200. %__rm -rf %{buildroot}
  201. %post
  202. %{exec_texhash}
  203. exit 0
  204. %postun
  205. if [ "$1" = 0 ]; then
  206. %{exec_texhash}
  207. fi
  208. exit 0
  209. %files -f filelist.full
  210. %defattr(-,root,root,-)
  211. %changelog
  212. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  213. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-texinfo
  214. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  215. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-texinfo
  216. - make symlinks of core script utils (texlive-collection-binextra,
  217. texlive-collection-context, texlive-collection-fontutils,
  218. texlive-collection-langgreek, texlive-collection-langindic,
  219. texlive-collection-latex, texlive-collection-latexextra,
  220. texlive-collection-latexrecommended, texlive-collection-pictures,
  221. texlive-collection-pstricks, texlive-collection-science)
  222. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  223. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-texinfo
  224. - improved %%post
  225. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  226. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-texinfo
  227. - removed arch dependent binaries (texlive-collection-latexextra)
  228. - fixed perl path
  229. - improved updmap process in %%post and %%postun
  230. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  231. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-texinfo