thunderbird-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 13.0.1
  3. #%define tbversion %{tbmajor}.10
  4. %define tbversion %{tbmajor}
  5. %define tbrelease 1%{?_dist_release}
  6. # The tarball is pretty inconsistent with directory structure.
  7. # Sometimes there is a top level directory. That goes here.
  8. #
  9. # IMPORTANT: If there is no top level directory, this should be
  10. # set to the cwd, ie: '.'
  11. #%define tarballdir .
  12. %define tarballdir comm-release
  13. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  14. %define moz_objdir objdir-tb
  15. %define version_internal %{tbmajor}
  16. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  17. %define desktop_file_utils_version 0.6
  18. %define nspr_version 4.9
  19. %define nss_version 3.13.2
  20. %define cairo_version 1.6.0
  21. %define freetype_version 2.1.9
  22. %define sqlite_version 3.6.14
  23. %define libnotify_version 0.4
  24. %define build_vine7 0
  25. %define build_vine6 0
  26. %define build_vine5 0
  27. %if "%{?_dist_release}" >= "vl7"
  28. %define build_vine7 1
  29. %endif
  30. %if "%{?_dist_release}" == "vl6"
  31. %define build_vine6 1
  32. %endif
  33. %if "%{?_dist_release}" == "vl5"
  34. %define build_vine5 1
  35. %endif
  36. Summary: Thunderbird Community Edition, Mail/newsgroup client
  37. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  38. Name: thunderbird
  39. Version: %{tbversion}
  40. Release: %{tbrelease}
  41. URL: http://www.mozilla.org/projects/thunderbird/
  42. License: MPL
  43. Group: Applications/Internet
  44. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  45. Source1: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
  46. Source1010: mozconfig-thunderbird-vine5
  47. Source1020: mozconfig-thunderbird-vine6
  48. Source1030: mozconfig-thunderbird-vine7
  49. Source12: thunderbird-vine-default-prefs.js
  50. Source20: thunderbird.desktop
  51. Source21: thunderbird.vine.sh.in
  52. Source30: thunderbird-open-browser.sh
  53. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  54. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  55. Source42: thunderbird-unofficial-brandig-tb-ja-brand.properties
  56. Source43: thunderbird-unofficial-brandig-tb-ja-brand.dtd
  57. Source100: find-external-requires
  58. # locale sources
  59. #%define MOZ_BUILD_LOCALES "ja"
  60. # get from mercurial repository with command,
  61. # mkdir l10n
  62. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  63. #Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  64. # upstream patch
  65. # Fix for version issues
  66. Patch0: thunderbird-version.patch
  67. # customization patches
  68. Patch1: firefox-1.5-default-a4-paper.patch
  69. # https://bugzilla.mozilla.org/show_bug.cgi?id=736836
  70. Patch2: thunderbird-13.0-buildfix-nspr.patch
  71. # Linux specific
  72. Patch100: thunderbird-9.0-enable-addons.patch
  73. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  74. BuildRequires: pango-devel
  75. BuildRequires: cairo-devel >= %{cairo_version}
  76. %if %{build_vine7}
  77. BuildRequires: nspr-devel >= %{nspr_version}
  78. BuildRequires: nss-devel >= %{nss_version}
  79. BuildRequires: hunspell-devel
  80. %endif
  81. %if %{build_vine6}
  82. BuildRequires: hunspell-devel
  83. %endif
  84. BuildRequires: pixman-devel
  85. BuildRequires: libpng-devel
  86. %if %{build_vine5}
  87. BuildRequires: libjpeg-devel
  88. %else
  89. BuildRequires: libjpeg-turbo-devel
  90. %endif
  91. BuildRequires: gtk2-devel
  92. BuildRequires: zlib-devel, gzip, zip, unzip
  93. BuildRequires: libIDL-devel
  94. BuildRequires: freetype2-devel >= %{freetype_version}
  95. ## disabled libnotify support
  96. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  97. BuildRequires: libnotify-devel >= %{libnotify_version}
  98. BuildRequires: bzip2-devel
  99. BuildRequires: gnome-vfs2-devel
  100. BuildRequires: libgnome-devel
  101. BuildRequires: libgnomeui-devel
  102. BuildRequires: krb5-devel
  103. BuildRequires: pango-devel
  104. BuildRequires: libXt-devel
  105. BuildRequires: libXrender-devel
  106. # hunspell is in plus category for vine
  107. #BuildRequires: hunspell-devel
  108. BuildRequires: sqlite3-devel >= %{sqlite_version}
  109. BuildRequires: startup-notification-devel
  110. BuildRequires: desktop-file-utils
  111. BuildRequires: alsa-lib-devel
  112. BuildRequires: yasm
  113. Requires: sqlite3 >= %{sqlite_version}
  114. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  115. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  116. Obsoletes: MozillaThunderbird
  117. Provides: MozillaThunderbird = %{version}
  118. Vendor: Project Vine
  119. Distribution: Vine Linux
  120. Packager: daisuke, ryoichi, kazutaka
  121. AutoProv: 0
  122. %define _use_internal_dependency_generator 0
  123. %define __find_requires %{SOURCE100}
  124. %description
  125. Thunderbird is a standalone mail and newsgroup client.
  126. %description -l ja
  127. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  128. #===============================================================================
  129. %prep
  130. %setup -q %{name}-%{version} -c
  131. cd %{tarballdir}
  132. # Fix for version issue
  133. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  134. > version.patch
  135. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  136. cd mozilla
  137. %patch1 -p1 -b .default-a4
  138. %patch2 -p1 -b .buildfix-nspr
  139. cd -
  140. %{__rm} -f .mozconfig
  141. %if %{build_vine5}
  142. %{__cp} %{SOURCE1010} .mozconfig
  143. %endif
  144. %if %{build_vine6}
  145. %{__cp} %{SOURCE1020} .mozconfig
  146. %endif
  147. %if %{build_vine7}
  148. %{__cp} %{SOURCE1030} .mozconfig
  149. %endif
  150. # setup unofficial branding name
  151. %{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
  152. %{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
  153. %patch100 -p1 -b .addons
  154. #===============================================================================
  155. %build
  156. cd %{tarballdir}
  157. INTERNAL_GECKO=%{version_internal}
  158. MOZ_APP_DIR=%{mozappdir}
  159. %if %{build_vine7}
  160. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  161. %else
  162. %ifarch x86_64
  163. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  164. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
  165. %else
  166. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  167. %endif
  168. %endif
  169. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  170. export CFLAGS="$RPM_OPT_FLAGS"
  171. #export CFLAGS=""
  172. export CXXFLAGS="$CFLAGS"
  173. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  174. %ifarch ppc ppc64 s390 s390x
  175. %define moz_make_flags -j1
  176. %else
  177. %define moz_make_flags %{?_smp_mflags}
  178. %endif
  179. export PREFIX='%{_prefix}'
  180. export LIBDIR='%{_libdir}'
  181. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  182. export MAKE="gmake %{moz_make_flags}"
  183. %{__make} -f client.mk build
  184. ## build locales
  185. #LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  186. # sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  187. #for dir in $LOCALEDIRS
  188. #do
  189. # for lang in %{MOZ_BUILD_LOCALES} ; do
  190. # make -C $dir/locales AB_CD=$lang
  191. # done
  192. #done
  193. #===============================================================================
  194. %install
  195. %{__rm} -rf $RPM_BUILD_ROOT
  196. cd %{tarballdir}
  197. INTERNAL_GECKO=%{version_internal}
  198. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  199. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  200. cd %{moz_objdir}
  201. DESTDIR=$RPM_BUILD_ROOT make install
  202. # install unofficial icons
  203. cd -
  204. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
  205. %{__cp} mail/branding/aurora/mailicon16.png \
  206. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  207. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  208. %{__cp} mail/branding/aurora/mailicon16.png \
  209. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  210. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  211. %{__cp} mail/branding/aurora/mailicon22.png \
  212. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  213. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  214. %{__cp} mail/branding/aurora/mailicon24.png \
  215. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  216. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  217. %{__cp} mail/branding/aurora/mailicon32.png \
  218. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  219. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  220. %{__cp} mail/branding/aurora/mailicon48.png \
  221. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  222. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  223. %{__cp} mail/branding/aurora/mailicon256.png \
  224. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  225. desktop-file-install --vendor vine \
  226. --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
  227. # set up the thunderbird start script
  228. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  229. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  230. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  231. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  232. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  233. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  234. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  235. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  236. $RPM_BUILD_ROOT/vine-default-prefs
  237. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  238. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  239. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  240. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  241. # own mozilla plugin dir (#135050)
  242. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  243. # own extension directories
  244. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  245. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  246. # install locales
  247. #for lang in %{MOZ_BUILD_LOCALES} ; do
  248. # %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  249. #done
  250. # install ja.xpi to langpacks directory
  251. #%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  252. #unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  253. # also setup unofficial branding name
  254. #%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
  255. #%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
  256. # install ja.xpi to langpack file
  257. %{__mkdir_p} lang_tmp
  258. unzip %{SOURCE1} -d lang_tmp
  259. # also setup unofficial branding name
  260. %{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
  261. %{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
  262. %{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
  263. cd lang_tmp; \
  264. zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
  265. %clean
  266. %{__rm} -rf $RPM_BUILD_ROOT
  267. #===============================================================================
  268. %post
  269. update-desktop-database &> /dev/null || :
  270. touch --no-create %{_datadir}/icons/hicolor
  271. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  272. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  273. fi
  274. %postun
  275. update-desktop-database &> /dev/null || :
  276. touch --no-create %{_datadir}/icons/hicolor
  277. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  278. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  279. fi
  280. %files
  281. %defattr(-,root,root,-)
  282. %attr(755,root,root) %{_bindir}/thunderbird
  283. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  284. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  285. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  286. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  287. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  288. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  289. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  290. %{mozappdir}
  291. #%{_libdir}/mozilla
  292. %exclude %{_libdir}/%{name}-%{version_internal}/removed-files
  293. %exclude %{_datadir}/idl/%{name}-%{version_internal}
  294. %exclude %{_includedir}/%{name}-%{version_internal}
  295. %exclude %{_libdir}/%{name}-devel-%{version_internal}
  296. #===============================================================================
  297. %changelog
  298. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
  299. - new upstream release
  300. * Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
  301. - new upstream release
  302. - add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
  303. * Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
  304. - new upstream release
  305. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
  306. - new upstream release
  307. - update Source1030 (mozconfig-thunderbird-vine7)
  308. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
  309. - new upstream release
  310. - update Source1020 (mozconfig-thunderbird-vine6)
  311. * Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
  312. - new upstream release
  313. * Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
  314. - new upstream release
  315. * Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
  316. - new upstream release
  317. * Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
  318. - new upstream release
  319. - update Source1
  320. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
  321. - new upstream release
  322. - update Source1
  323. - add Source1030 (mozconfig-thunderbird-vine7)
  324. - add Patch100 (thunderbird-9.0-enable-addons.patch)
  325. * Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
  326. - fix %%version_internal
  327. * Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
  328. - new upstream release
  329. - update Source1
  330. * Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
  331. - new upstream release
  332. - update Source1,21,1010,1020
  333. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
  334. - rebuild with libnotify-0.7
  335. * Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
  336. - enable-install-strip
  337. * Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
  338. - new upstream release
  339. - drop obsolete patch and renumber patch26 to patch1
  340. - add BuildRequires: yasm
  341. - enable libnotify support
  342. - add --disable-updater and --disable-installer to mozconfig
  343. - use ja.xpi instead of l10n source
  344. - update Source21: add step to setup langpack plugin
  345. - update Source20: add japanese translation
  346. - add Source42 & Source43 for localized branding
  347. - add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
  348. for mozconfig-thunderbird-vine5
  349. * Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
  350. - new upstream release with security fix
  351. * Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
  352. - new upstream release with security fix
  353. * Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
  354. - new upstream release with security fix
  355. * Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
  356. - new upstream release with security fix
  357. - add patch5 to fix build failure
  358. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  359. - new upstream release
  360. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  361. - new upstream release with security fix
  362. - add Patch1030 to fix compilation error
  363. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  364. - change mozconfig (Source1030 & 1040): add --enable-jsd
  365. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  366. - new upstream release
  367. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  368. - new upstream release with security fix
  369. - add Patch0 from fedora development: fix version issue
  370. - remove BuildRequires: hunspell-devel
  371. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  372. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  373. - add BuildRequires: alsa-lib-devel
  374. - remove BuildRequires: libnotify-devel
  375. (workaround for known bug)
  376. - update mozconfig to add --disable-libnotify option
  377. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  378. - new upstream release
  379. - update spec entirely
  380. - import patches from fedora (Patch1, 2 & 4)
  381. - drop outdated patches (Patch22, 24)
  382. - update Sources:
  383. - mozconfig (Source1030 & Source1040)
  384. - default prefs.js (Source12)
  385. - unofficial branding (Source40 & Source41)
  386. - japanese translation (Source1000)
  387. - update Patch1000 (sjis-alias)
  388. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  389. - new upstream release
  390. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  391. - new upstream release
  392. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  393. - don't install official branding logos
  394. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  395. - add necessary icons in %%{tbdir}/chrome/icons/default
  396. - add Packager tag
  397. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  398. - new upstream release
  399. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  400. - new upstream release
  401. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  402. - new upstream release
  403. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  404. - new upstream release
  405. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  406. - rebuilt for VineSeed
  407. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  408. - new upstream release
  409. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  410. - new upstream release
  411. - built for Vine Linux 4.x
  412. - dropped Patch1020 (merged into upstream)
  413. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  414. - added Patch1020 for workaround gcc visibility hidden bugs
  415. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  416. - build with new environment/toolchain
  417. - add build options to build with external nss/nspr libraries
  418. ac_add_options --with-system-nspr
  419. ac_add_options --with-system-nss
  420. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  421. - new upstream release
  422. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  423. - new upstream release
  424. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  425. - new upstream release
  426. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  427. - new upstream release
  428. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  429. - new upstream release
  430. - merge changes from firefox
  431. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  432. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  433. - new upstream release
  434. - build en-US locale
  435. - merge changes from firefox
  436. - add upstream patches
  437. - disable pango rendering by default
  438. (workaround fix slow rendering in some page)
  439. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  440. - initial build for Vine Linux based on FC package
  441. - update to 1.5RC2
  442. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  443. - Fix issue with popup dialogs and other actions causing lockups
  444. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  445. - Update to 1.5 rc1
  446. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  447. - Update to 1.5 beta2
  448. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  449. - Update to 1.5 beta1
  450. - Bring the install phase of the spec file up to speed
  451. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  452. - Rebuild
  453. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  454. - Add patch to make file chooser dialog modal
  455. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  456. - Update to 1.0.6
  457. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  458. - 1.0.6 Release Candidate
  459. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  460. - Use system NSPR
  461. - Fix crash on 64bit platforms (#160330)
  462. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  463. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  464. references, fixing the "no fonts" problem.
  465. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  466. - Change the Exec line in the desktop file to `thunderbird`
  467. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  468. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  469. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  470. - Add temporary workaround to not create files in the user's $HOME (#149664)
  471. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  472. - Don't have downloads "disappear" when downloading to desktop (#139015)
  473. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  474. - Add upstream patch to fix bidi justification of pango
  475. - Add patch to fix launching of helper applications
  476. - Add patch to properly link against libgfxshared_s.a
  477. - Fix multilib conflicts
  478. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  479. - correct confusing PANGO vars in startup script
  480. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  481. - Thunderbird 1.0.2
  482. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  483. - Add patch to compile against new fortified glibc macros
  484. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  485. - Rebuild against GCC 4.0
  486. - Add execshield patches
  487. - Minor specfile cleanup
  488. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  489. - Rebuild
  490. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  491. - Add RPM version to useragent
  492. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  493. - Port over pango patches from firefox
  494. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  495. - Thunderbird 1.0
  496. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  497. - Fix advanced prefs
  498. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  499. - Make this run on s390(x) now for real
  500. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  501. - Update to 1.0 rc1
  502. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  503. - Add patches to build and run on s390(x)
  504. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  505. - Rebuild to fix file chooser
  506. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  507. - Update to 0.9
  508. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  509. - Prevent inlining of stack direction detection (#135255)
  510. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  511. - More file chooser fixes (same as in firefox)
  512. - Fix for upstream 28327.
  513. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  514. - Update the pango patch
  515. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  516. - Pull over patches from firefox build:
  517. - disable default application dialog
  518. - don't include software update since it doesn't work
  519. - make external app support work
  520. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  521. - Use pango for rendering
  522. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  523. - Fix for 64 bit crash at startup (b.m.o #256603)
  524. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  525. - Add patches to fix xremote (#135036)
  526. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  527. - Add patch to fix button focus issues (#133507)
  528. - Add patch for fix IMAP race issues (bmo #246439)
  529. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  530. - filter out library Provides: and internal Requires:
  531. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  532. - Backport the GTK+ File Chooser.
  533. - Add fix for JS math on x86_64 systems
  534. - Add pkgconfig patch
  535. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  536. - Update to 0.8.0
  537. - Remove enigmail
  538. - Update BuildRequires
  539. - Remove gcc34 and extension manager patches -- they are upstreamed.
  540. - Fix for gnome-vfs2 error at component registration
  541. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  542. - Build with --disable-xprint
  543. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  544. - remove all Xvfb-related hacks
  545. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  546. - actually apply psfonts
  547. - add mozilla gnome-uriloader patch to prevent build failure
  548. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  549. - rawhide import
  550. - apply NetBSD's freetype 2.1.8 patch
  551. - apply psfonts patch
  552. - remove BR on /usr/bin/ex, breaks beehive
  553. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  554. - oops, fix %%install
  555. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  556. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  557. - remove XUL.mfasl on startup, add Debian enigmail patches
  558. - add Xvfb hack for -install-global-extension
  559. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  560. - update to 0.7.2, just because it's there
  561. - update gcc-3.4 patch (Kaj Niemi)
  562. - add EM registration patch and remove instdir hack
  563. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  564. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  565. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  566. - update to 0.7.1
  567. - remove Enigmail
  568. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  569. - re-enable Enigmail 0.84.1
  570. - add gcc-3.4 patch (Kaj Niemi)
  571. - use official branding (with permission)
  572. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  573. - update to 0.7
  574. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  575. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  576. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  577. - temporary workaround for enigmail skin "modern" bug
  578. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  579. - update to Enigmail 0.84.0
  580. - update launch script
  581. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  582. - installation directory now versioned
  583. - allow root to run the program (for installing extensions)
  584. - remove unnecessary %%pre and %%post
  585. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  586. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  587. - include Enigmail, re-add release notes
  588. - delete %{_libdir}/thunderbird in %%pre
  589. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  590. - update to Thunderbird 0.6
  591. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  592. - update to Thunderbird 0.6 RC1
  593. - add new icon, remove release notes
  594. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  595. - update to latest CVS, update mozconfig and %%build accordingly
  596. - update to Enigmail 0.83.6
  597. - remove x-remote and x86_64 patches
  598. - build with -Os
  599. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  600. - update x-remote patch
  601. - more startup script fixes
  602. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  603. - startup script fixes, and a minor cleanup
  604. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  605. - Minor cleanups
  606. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  607. - minor improvements to open-browser.sh and startup script
  608. - update to latest version of Blizzard's x-remote patch
  609. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  610. - update open-browser.sh, startup script, and BuildRequires
  611. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  612. - update open-browser script, modify BuildRequires (Warren)
  613. - add Blizzard's x-remote patch
  614. - initial attempt at x-remote-enabled startup script
  615. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  616. - refuse to run with excessive privileges
  617. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  618. - add Mozilla x86_64 patch (Oliver Sontag)
  619. - Enigmail source filenames now include the version
  620. - modify BuildRoot
  621. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  622. - use the updated official tarball
  623. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  624. - fix %%prep script
  625. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  626. - update Enigmail to 0.83.3
  627. - use official source tarball (after removing the CRLFs)
  628. - package renamed to thunderbird
  629. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  630. - update to 0.5
  631. - check for lockfile before launching
  632. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  633. - update to latest cvs
  634. - update to Enigmail 0.83.2
  635. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  636. - update to Enigmail 0.83.1
  637. - removed Mozilla/Firebird script patching
  638. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  639. - add startup notification to .desktop file
  640. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  641. - open-browser.sh release 3
  642. - patch broken /usr/bin/mozilla script during install
  643. - dir ownership
  644. - XXX: Source fails build on x86_64... fix later
  645. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  646. - update to Enigmail 0.82.5
  647. - add Warren's open-browser.sh (#1113)
  648. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  649. - use Thunderbird's mozilla-xremote-client to launch browser
  650. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  651. - update to 0.4
  652. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  653. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  654. - update to 0.4rc2
  655. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  656. - update to 0.4rc1 and Enigmail 0.82.4
  657. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  658. - update to latest CVS and Enigmail 0.82.3
  659. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  660. - update to latest CVS (0.4a)
  661. - update Enigmail to 0.82.2
  662. - alter mozconfig for new build requirements
  663. - add missing BuildReq (#987)
  664. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  665. - update to 0.3
  666. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  667. - update to 0.3rc3
  668. - update Enigmail to 0.81.7
  669. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  670. - update to 0.3rc2
  671. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  672. - simplify startup script
  673. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  674. - add GPG support (Enigmail 0.81.6)
  675. - specfile fixes (#679)
  676. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  677. - update to 0.2
  678. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  679. - initial RPM
  680. (based on the fedora MozillaFirebird-0.6.1 specfile)