foomatic-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665
  1. %define dbver_rel 4.0
  2. %define dbver_snap 20090529
  3. %define enginever 4.0.1
  4. %define filtersver 4.0.1
  5. %define hpijsver 20090529
  6. Summary: Foomatic printer database.
  7. Name: foomatic
  8. Version: %{enginever}
  9. Release: 3%{?_dist_release}
  10. License: GPL
  11. Group: System Environment/Libraries
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: tomop, daisuke, machino
  15. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  16. Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
  17. Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
  18. Source3: http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-%{hpijsver}.tar.gz
  19. # Use libdir.
  20. Patch1: foomatic-filters-libdir.patch
  21. Patch2: foomatic-db-engine-libdir.patch
  22. # Handle non-UTF-8 encodings in imported PPD files.
  23. Patch15: foomatic-bad-utf8.patch
  24. Url: http://www.linuxprinting.org
  25. Requires: perl >= 5.10.0
  26. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  27. Requires: hpijs
  28. BuildRequires: perl >= 5.10.0
  29. BuildRequires: libxml2-devel
  30. BuildRequires: ghostscript-devel
  31. BuildRequires: autoconf, automake
  32. BuildRequires: mpage
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  34. Provides: perl(Foomatic::GrovePath)
  35. # For 'rm' and '/sbin/service' in post
  36. PreReq: fileutils initscripts
  37. Obsoletes: foomatic-db < 4.0.0
  38. Obsoletes: foomatic-ppd < 4.0.0
  39. Obsoletes: foomatic-ppd-gimp-print < 4.0.0
  40. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
  41. Obsoletes: foomatic-ppd-omni < 4.0.0
  42. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  43. Conflicts: ghostscript < 7.05
  44. %description
  45. Foomatic is a comprehensive, spooler-independent database of printers,
  46. printer drivers, and driver descriptions. It contains utilities to
  47. generate driver description files and printer queues for CUPS, LPD,
  48. LPRng, and PDQ using the database. There is also the possibility to
  49. read the PJL options out of PJL-capable laser printers and take them
  50. into account at the driver description file generation.
  51. There are spooler-independent command line interfaces to manipulate
  52. queues (foomatic-configure) and to print files/manipulate jobs
  53. (foomatic printjob).
  54. The site http://www.linuxprinting.org/ is based on this database.
  55. %prep
  56. %setup -q -c -a 1 -a 2 -a 3
  57. pushd foomatic-filters-%{filtersver}
  58. %patch1 -p1 -b .libdir
  59. popd
  60. pushd foomatic-db-engine-%{enginever}
  61. chmod a+x mkinstalldirs
  62. %patch2 -p1 -b .libdir
  63. %patch15 -p1
  64. popd
  65. pushd foomatic-db-hpijs-%{hpijsver}
  66. popd
  67. pushd foomatic-db-%{dbver_snap}
  68. cd db/source
  69. # For gutenprint printers, use gutenprint-ijs-simplified.5.2.
  70. perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
  71. # Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
  72. # Also foo2lava, foo2kyo, foo2xqx (bug #438319).
  73. for x in zjs oak hp qpdl lava kyo xqx
  74. do
  75. find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
  76. rm -f driver/foo2${x}.xml opt/foo2${x}-*
  77. done
  78. # Same for m2300w/m2400w
  79. find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
  80. rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
  81. # Same for all these.
  82. for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
  83. do
  84. find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
  85. rm -vf driver/${x}.xml opt/${x}-*
  86. done
  87. popd
  88. %build
  89. export LIB_CUPS=%{_libdir}/cups
  90. export CUPS_BACKENDS=%{_libdir}/cups/backend
  91. export CUPS_FILTERS=%{_libdir}/cups/filter
  92. export CUPS_PPDS=%{_datadir}/cups/model
  93. pushd foomatic-filters-%{filtersver}
  94. %configure
  95. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  96. INSTALLDIRS=vendor
  97. popd
  98. pushd foomatic-db-engine-%{enginever}
  99. %configure --disable-xmltest
  100. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  101. INSTALLDIRS=vendor defaults
  102. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  103. INSTALLDIRS=vendor
  104. popd
  105. pushd foomatic-db-%{dbver_snap}
  106. %configure
  107. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  108. INSTALLDIRS=vendor
  109. popd
  110. pushd foomatic-db-hpijs-%{hpijsver}
  111. %configure
  112. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  113. INSTALLDIRS=vendor
  114. popd
  115. %install
  116. rm -rf %{buildroot}
  117. pushd foomatic-filters-%{filtersver}
  118. eval `perl '-V:installvendorlib' '-V:installvendorarch'`
  119. mkdir -p %{buildroot}/$installvendorlib
  120. echo %{buildroot}
  121. make DESTDIR=%{buildroot} PREFIX=%{_prefix} \
  122. INSTALLDIRS=vendor \
  123. INSTALLVENDORLIB=$installvendorlib \
  124. INSTALLVENDORARCH=$installvendorarch \
  125. install-main install-cups
  126. popd
  127. pushd foomatic-db-engine-%{enginever}
  128. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  129. INSTALLDIRS=vendor \
  130. INSTALLVENDORLIB=$installvendorlib \
  131. INSTALLVENDORARCH=$installvendorarch \
  132. install
  133. popd
  134. pushd foomatic-db-%{dbver_snap}
  135. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  136. INSTALLDIRS=vendor \
  137. INSTALLVENDORLIB=$installvendorlib \
  138. INSTALLVENDORARCH=$installvendorarch \
  139. install
  140. popd
  141. pushd foomatic-db-hpijs-%{hpijsver}
  142. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  143. INSTALLDIRS=vendor \
  144. INSTALLVENDORLIB=$installvendorlib \
  145. INSTALLVENDORARCH=$installvendorarch \
  146. install
  147. popd
  148. # Remove ghostscript UPP drivers that are gone in 7.07
  149. rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
  150. # Remove drivers with no command line.
  151. pushd foomatic-db-engine-%{enginever}
  152. perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
  153. popd
  154. # Update any old-style printer IDs still left around.
  155. echo '#!/usr/bin/perl -pi' > convert-printerids.pl
  156. sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
  157. %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
  158. >> convert-printerids.pl
  159. chmod a+x convert-printerids.pl
  160. ./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
  161. find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
  162. # Use relative, not absolute, symlink for CUPS filter.
  163. ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
  164. mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
  165. mkdir -p %{buildroot}%{_var}/cache/foomatic
  166. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  167. # Remove things we don't ship.
  168. rm -rf %{buildroot}%{_libdir}/perl5/site_perl \
  169. %{buildroot}%{_libdir}/ppr \
  170. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
  171. find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
  172. %post
  173. /bin/rm -f /var/cache/foomatic/*
  174. # restart the print server if it is running now
  175. /sbin/service lpd condrestart >/dev/null 2>&1
  176. /sbin/service cups condrestart >/dev/null 2>&1
  177. exit 0
  178. %clean
  179. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  180. %files
  181. %defattr(-,root,root)
  182. %doc --parents */README */USAGE */ChangeLog
  183. %dir %{_sysconfdir}/foomatic
  184. %config(noreplace) %{_sysconfdir}/foomatic/filter.conf
  185. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  186. %{_bindir}/*
  187. %{_sbindir}/*
  188. %{perl_vendorlib}/Foomatic
  189. %{_libdir}/cups/backend/*
  190. %{_libdir}/cups/driver/*
  191. %{_libdir}/cups/filter/*
  192. %{_datadir}/foomatic
  193. %{_datadir}/cups/model/foomatic-db-ppds
  194. %{_mandir}/*/*
  195. %{_var}/cache/foomatic
  196. %changelog
  197. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  198. - rebuild with perl 5.12.3
  199. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  200. - add Requires: hpijs
  201. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  202. - new upstream release
  203. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  204. - new upstream release.
  205. - applied some patches from Fedora development.
  206. - remove subpackages.
  207. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  208. - applied new versioning policy
  209. - used rpm macros: %%perl_sitelib %%perl_sitearch
  210. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  211. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  212. - fixed permission of %%{_datadir}/foomatic/db
  213. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  214. - add BuildRequires: libxml2-devel, mpage, Omni
  215. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  216. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  217. - not create ppd-omni package if omni support is disabled
  218. * Tue Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  219. - updated foomatic-db to 20050411
  220. - updated foomatic-db-engine to 3.1-20050411
  221. - updated foomatic-db-hpijs to 1.5-20050411
  222. - updated foomatic-filters to 3.1-20050411
  223. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  224. - updated foomatic-db to 20050112
  225. - updated foomatic-db-engine to 3.1-20050112
  226. - updated foomatic-db-hpijs to 1.5-20050112
  227. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  228. - updated foomatic-db to 20041220
  229. - updated foomatic-db-hpijs to 1.5-20041220
  230. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  231. - updated foomatic-db to 20040919
  232. - updated foomatic-db-engine to 3.0.2
  233. - updated foomatic-db-hpijs to 1.5-20040919
  234. - updated foomatic-filters to 3.0.2
  235. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  236. - update foomatic-db to 20040526
  237. - update foomatic-db-hpijs to 1.5-20040526
  238. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  239. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  240. ppd-gimp-print-ijs
  241. - add Requires: to ppd-* subpackages.
  242. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  243. - new upstream version
  244. -- Omni-printers-0.9.1
  245. -- gimp-print-foomatic-db-4.2.6
  246. - foomatic.spec -> foomatic-vl.spec
  247. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  248. - new upstream version
  249. -- foomatic-filters-3.0.1
  250. -- foomatic-db-engine-3.0.1
  251. -- foomatic-db-20040219
  252. -- foomatic-db-hpijs-1.5-20040219
  253. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  254. - new upstream version
  255. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  256. -- defined filterver
  257. - dropped patch101
  258. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  259. - new upstream cvs version(foomatic-3.0.1rc2)
  260. -- foomatic-db-20040125
  261. -- foomatic-db-engine-3.0.1rc2
  262. -- foomatic-db-hpijs-1.5-20040125
  263. -- foomatic-filters-3.0.1rc2
  264. - added patch101
  265. -- tests diris null in foomatic-filters-3.0.1rc2
  266. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  267. - new upstream cvs version
  268. -- foomatic-db-20040123
  269. -- foomatic-db-engine-3.0-20040123
  270. -- foomatic-db-hpijs-1.5-20040123
  271. -- foomatic-filters-3.0-20040123
  272. - dropped old patches
  273. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  274. - built on perl-5.8.2
  275. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  276. - separated foomatic-db package included xml files
  277. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  278. - added description of ppd sub package
  279. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  280. - separated foomatic-ppd package included PPD files
  281. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  282. - new upstream version
  283. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  284. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  285. - dropped patches
  286. -- foomatic-filters-path.patch(patch0)
  287. -- foomatic-2.0.2-fontpath.patch(patch3)
  288. - updated patches
  289. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  290. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  291. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  292. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  293. - built on perl-5.8.1
  294. - fixed install section in spec file
  295. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  296. - fix some bugs of foomatic-filters.
  297. A
  298. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  299. - new upstream version
  300. -- rewrote spec file
  301. -- added some patches from rawhide(foomatic-3.0.0-5)
  302. - enable cups support
  303. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  304. - imported some patches from foomatic-2.0.2-18
  305. -- added foomatic-2.0.2-psc2210.patch
  306. -- added foomatic-2.0.2-duplex184.patch
  307. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  308. - imported foomatic-2.0.2-15
  309. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  310. - Update data-generators to CVS.
  311. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  312. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  313. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  314. - Pacify printers that don't understand duplex (bug #82385).
  315. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  316. - rebuilt
  317. * Thu Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  318. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  319. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  320. manufacturer and model anyway.
  321. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  322. - Set GS_FONTPATH in gs wrapper (bug #81410).
  323. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  324. - use internal dep generator.
  325. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  326. - Add several device IDs.
  327. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  328. - Update Omni printers to 0.7.2.
  329. - No longer need Omni badxml patch.
  330. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  331. - don't use rpms internal dep generator
  332. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  333. - Omni XML wasn't well-formed.
  334. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  335. - Update gimp-print data.
  336. - Add 'generic postscript' model.
  337. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  338. - Update Omni printers to 0.7.1.
  339. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  340. - Fix file manifest for perl modules.
  341. - Add autodetect information for HP DeskJet 990C.
  342. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  343. - 2.0.2.
  344. - No longer need 67973, 970c patches.
  345. - Remove cups-drivers-* packages (no longer needed).
  346. - Remove files not shipped. Ship filter.conf.
  347. - Conditionally restart cups.
  348. - Use libdir.
  349. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  350. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  351. - Fix autodetect information for HPDJ970C.
  352. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  353. - For gimp-print, use the Ghostscript stp driver in preference to the
  354. IJS interface.
  355. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  356. - Quieten scriptlets.
  357. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  358. - Fix autodetect information for HPLJ2100/2100M.
  359. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  360. - automated rebuild
  361. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  362. - Omni 0.7.0 printers.
  363. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  364. - Update to CVS.
  365. - Remove some more explicit perl dependencies that are picked up
  366. automatically.
  367. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  368. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  369. and that is picked up automatically.
  370. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  371. - Fix release number.
  372. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  373. (bug #63622).
  374. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  375. - automated rebuild
  376. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  377. - Remove ghostscript UPP drivers that are gone in 7.05.
  378. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  379. - Update to CVS.
  380. - Updated requirements.
  381. - Updated path and libdir patches.
  382. - Drop hpijs 1.0.2 patch.
  383. - foomatic-datafile has moved to %%{_bindir}.
  384. - Update gimp-print data to 4.2.1.
  385. - Update Omni printer data to 0.6.1.
  386. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  387. - Fix the hpijs option data too (bug #62587).
  388. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  389. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  390. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  391. - Update to CVS.
  392. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  393. - Update to CVS.
  394. - Patches no longer needed: conffile, sys, cachedir, fd0.
  395. - Adapted path patch.
  396. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  397. - Fix bug #58319.
  398. - Drop dbg patch.
  399. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  400. - Fix file lists.
  401. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  402. - Fix %post scriplet bug (bug #59942).
  403. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  404. - Rebuild in new environment.
  405. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  406. - Merge cups-drivers. No epoch needed.
  407. - Require perl-URI.
  408. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  409. - Cache fix.
  410. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  411. - Don't ship backup files.
  412. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  413. - Rebuild to pick up new perl installsitelib.
  414. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  415. - Fix a thinko in DB.pl.
  416. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  417. - Update to CVS.
  418. - No longer need the cachedir patch.
  419. - Fix config file path.
  420. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  421. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  422. - Update to CVS.
  423. - Patches no longer needed: prepend, fd3.
  424. - Use RPM_OPT_FLAGS.
  425. - Allow non-root users to use foomatic-datafile (bug #58956).
  426. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  427. - added Provides: perl(Foomatic::GrovePath)
  428. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  429. - Update to CVS.
  430. - Updated Omni printers to those in Omni 0.5.1.
  431. - Updated patches: prepend, fd3.
  432. - Patches no longer needed: utf8, lpdomatic.
  433. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  434. stp.xml file.
  435. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  436. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  437. - REALLY fix PCL fixup code (bug #55909, others).
  438. - PreReq fileutils, initscripts (bug #56984).
  439. - Fix prepends in lpdomatic (bug #57371).
  440. - Run foomatic-cleanupdrivers during install, to remove driver entries
  441. with no command line.
  442. - Put lpdomatic in /usr/sbin again.
  443. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  444. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  445. - re-imported from upstream to fix some perl fixup code on pcl printers.
  446. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  447. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  448. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  449. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  450. - respin to pull in latest foomatic database, fixes:
  451. - properly use the cache in relation to foomatic-combo-xml's output
  452. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  453. * Thu Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  454. - respin to pull in latest foomatic database, fixes:
  455. - droping half of a large job
  456. - -Mutf8 added to the upstream filters
  457. - miscelaneous printer db updates
  458. * Mon Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  459. - added Requires: fileutils for the 'rm' in post
  460. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  461. - /var/chache => /var/cache, doh!
  462. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  463. - fix %%post scriptlet
  464. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  465. - changed the patch to use the -Mutf8 command line option,
  466. - and to restart the printserver, after rebuilding the settings.
  467. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  468. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  469. - pragma. Without it, they break on _some_ of their options.
  470. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  471. - patched lpdomatic to prepend PostScript options in the _right_ place.
  472. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  473. - zap the foomatic cache on install
  474. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  475. - rolled to pull in latest information.
  476. - added Omni printers to the printer list.
  477. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  478. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  479. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  480. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  481. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  482. - upgraded to latest foomatic, we now have fast overview generation!
  483. - this means that there is no prebuilt overview file.
  484. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  485. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  486. - It is now fast enough that there is no real benifit to precompiling.
  487. - NOTE: this forces the package to stop being noarched.
  488. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  489. - fresh pull, maybe it fixes the build errors.
  490. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  491. - did a fresh database pull, which contains the old japanese printers as well.
  492. - removed japanese hack.
  493. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  494. - Add Japanese printer entry.
  495. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  496. - move the cache back to /var, sigh.
  497. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  498. - made foomatic pre-compute its db
  499. * Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  500. - imported from mandrake.
  501. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  502. - Added job listing/removal/manipulation and queue control to
  503. foomatic-printjob
  504. - Support for printing multiple copies with PDQ
  505. * Fri Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  506. - Included the cupsomatic filter script
  507. - When a queue is set up, default options can be set now
  508. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  509. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  510. - Many bugfixes in "foomatic-printjob".
  511. - "foomatic-configure" adds the Foomatic config file directory automatically
  512. to the search paths of PDQ.
  513. - Printing a help page under PDQ was broken.
  514. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  515. - BuildRequires: perl-devel
  516. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  517. - initial release.
  518. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  519. - Patch applied which flushes the memory cache regularly, otherwise
  520. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  521. installed.