strongswan-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787
  1. %bcond_with systemd
  2. %bcond_with fips2
  3. %bcond_without tss
  4. %global _unpackaged_files_terminate_build 1
  5. %global _hardened_build 0
  6. #%%define prerelease dr1
  7. Name: strongswan
  8. Version: 5.8.4
  9. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  10. Summary: An OpenSource IPsec-based VPN and TNC solution
  11. Summary(ja): オープンソースのIPsec VPN/TNCソリューション
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPLv2+
  15. URL: https://www.strongswan.org/
  16. Source0: https://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
  17. Source1: tmpfiles-strongswan.conf
  18. Source1000: strongswan.init
  19. Patch0: strongswan-5.8.4-runtime-dir.patch
  20. Patch1: strongswan-5.6.0-uintptr_t.patch
  21. Patch3: strongswan-5.6.2-CVE-2018-5388.patch
  22. # only needed for pre-release versions
  23. #BuildRequires: autoconf automake
  24. BuildRequires: gmp-devel
  25. BuildRequires: curl-devel
  26. BuildRequires: openldap-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: sqlite3-devel
  29. BuildRequires: gettext-devel
  30. BuildRequires: libxml2-devel
  31. BuildRequires: pam-devel
  32. BuildRequires: libgcrypt-devel
  33. BuildRequires: iptables-devel
  34. %if %{with tss}
  35. BuildRequires: trousers-devel
  36. BuildRequires: json-c-devel >= 0.14
  37. %endif
  38. %if "%{?_dist_release}" != "vl6"
  39. BuildRequires: NetworkManager-libnm-devel
  40. %endif
  41. %if %{with systemd}
  42. BuildRequires: systemd-devel
  43. Requires(post): systemd
  44. Requires(preun): systemd
  45. Requires(postun): systemd
  46. %else
  47. Requires(post): /sbin/chkconfig
  48. Requires(preun): /sbin/chkconfig
  49. Requires(postun): /sbin/chkconfig
  50. %endif
  51. %description
  52. The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
  53. exchange protocols in conjunction with the native NETKEY IPsec stack of the
  54. Linux kernel.
  55. %package libipsec
  56. Summary: Strongswan's libipsec backend
  57. %description libipsec
  58. The kernel-libipsec plugin provides an IPsec backend that works entirely
  59. in userland, using TUN devices and its own IPsec implementation libipsec.
  60. %package charon-nm
  61. Summary: NetworkManager plugin for Strongswan
  62. Requires: dbus
  63. Obsoletes: %{name}-NetworkManager < 0:5.0.4-5
  64. Conflicts: %{name}-NetworkManger < 0:5.0.4-5
  65. %description charon-nm
  66. NetworkManager plugin integrates a subset of Strongswan capabilities
  67. to NetworkManager.
  68. %if %{with tss}
  69. %package tnc-imcvs
  70. Summary: Trusted network connect (TNC)'s IMC/IMV functionality
  71. Requires: %{name} = %{version}
  72. %description tnc-imcvs
  73. This package provides Trusted Network Connect's (TNC) architecture support.
  74. It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
  75. exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
  76. and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
  77. attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
  78. modules can be used by any third party TNC Client/Server implementation
  79. possessing a standard IF-IMC/IMV interface. In addition, it implements
  80. PT-TLS to support TNC over TLS.
  81. %endif
  82. %debug_package
  83. %prep
  84. %setup -q -n %{name}-%{version}%{?prerelease}
  85. %patch0 -p1
  86. %patch1 -p1
  87. %patch3 -p1
  88. %build
  89. # only for snapshots
  90. #autoreconf
  91. # --with-ipsecdir moves internal commands to /usr/libexec/strongswan
  92. # --bindir moves 'pki' command to /usr/libexec/strongswan
  93. # See: http://wiki.strongswan.org/issues/552
  94. # too broken to enable: --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
  95. %configure --disable-static \
  96. --with-ipsec-script=strongswan \
  97. --sysconfdir=%{_sysconfdir}/strongswan \
  98. --with-ipsecdir=%{_libexecdir}/strongswan \
  99. --bindir=%{_libexecdir}/strongswan \
  100. --with-ipseclibdir=%{_libdir}/strongswan \
  101. %if %{with fips2}
  102. --with-fips-mode=2 \
  103. %endif
  104. %if "%{?_dist_release}" != "vl6"
  105. --enable-nm \
  106. %endif
  107. --enable-openssl \
  108. --enable-unity \
  109. --enable-ctr \
  110. --enable-ccm \
  111. --enable-gcm \
  112. --enable-chapoly \
  113. --enable-md4 \
  114. --enable-gcrypt \
  115. --enable-newhope \
  116. --enable-xauth-eap \
  117. --enable-xauth-pam \
  118. --enable-xauth-noauth \
  119. --enable-eap-identity \
  120. --enable-eap-md5 \
  121. --enable-eap-gtc \
  122. --enable-eap-tls \
  123. --enable-eap-ttls \
  124. --enable-eap-peap \
  125. --enable-eap-mschapv2 \
  126. --enable-eap-tnc \
  127. --enable-eap-sim \
  128. --enable-eap-sim-file \
  129. --enable-eap-aka \
  130. --enable-eap-aka-3gpp \
  131. --enable-eap-aka-3gpp2 \
  132. --enable-eap-dynamic \
  133. --enable-eap-radius \
  134. --enable-ext-auth \
  135. --enable-ipseckey \
  136. --enable-pkcs11 \
  137. --enable-farp \
  138. --enable-dhcp \
  139. --enable-ha \
  140. --enable-led \
  141. --enable-sqlite \
  142. --enable-tnc-ifmap \
  143. --enable-tnc-pdp \
  144. --enable-tnc-imc \
  145. --enable-tnc-imv \
  146. --enable-tnccs-20 \
  147. --enable-tnccs-11 \
  148. --enable-tnccs-dynamic \
  149. --enable-curl \
  150. --enable-cmd \
  151. --enable-acert \
  152. --enable-vici \
  153. --enable-swanctl \
  154. --enable-duplicheck \
  155. %if %{with tss}
  156. --enable-tss-trousers \
  157. --enable-aikgen \
  158. --enable-tpm \
  159. --enable-imc-test \
  160. --enable-imv-test \
  161. --enable-imc-scanner \
  162. --enable-imv-scanner \
  163. --enable-imc-attestation \
  164. --enable-imv-attestation \
  165. --enable-imv-os \
  166. --enable-imc-os \
  167. --enable-imc-swid \
  168. --enable-imv-swid \
  169. --enable-imc-swima \
  170. --enable-imv-swima \
  171. --enable-imc-hcd \
  172. --enable-imv-hcd \
  173. %endif
  174. %ifarch x86_64 %{ix86}
  175. --enable-aesni \
  176. %endif
  177. %if %{with systemd}
  178. --enable-systemd \
  179. %endif
  180. --enable-kernel-libipsec
  181. make %{?_smp_mflags}
  182. %install
  183. rm -rf %{buildroot}
  184. make install DESTDIR=%{buildroot}
  185. # prefix man pages
  186. for i in %{buildroot}%{_mandir}/*/*; do
  187. if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
  188. mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
  189. fi
  190. done
  191. find %{buildroot} -type f -name '*.la' -delete
  192. # delete unwanted library files - no consumers, so no -devel package
  193. rm %{buildroot}%{_libdir}/strongswan/*.so
  194. # fix config permissions
  195. chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  196. # Create ipsec.d directory tree.
  197. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
  198. for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
  199. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
  200. done
  201. %if %{with systemd}
  202. install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_tmpfilesdir}/strongswan.conf
  203. %else
  204. mkdir -p %{buildroot}%{_initdir}
  205. install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
  206. %endif
  207. %post
  208. %if %{with systemd}
  209. %systemd_post %{name}.service
  210. %else
  211. /sbin/chkconfig --add ipsec
  212. %endif
  213. %preun
  214. %if %{with systemd}
  215. %systemd_preun %{name}.service
  216. %else
  217. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  218. /sbin/service ipsec stop
  219. /sbin/chkconfig --del ipsec
  220. fi
  221. %endif
  222. %postun
  223. %if %{with systemd}
  224. %systemd_postun_with_restart %{name}.service
  225. %else
  226. if [ $1 -gt 0 ]; then
  227. /sbin/service ipsec condrestart
  228. fi
  229. %endif
  230. %files
  231. %doc README NEWS TODO ChangeLog
  232. %{!?_licensedir:%global license %%doc}
  233. %license COPYING
  234. %dir %attr(0700,root,root) %{_sysconfdir}/strongswan
  235. %config(noreplace) %{_sysconfdir}/strongswan/*
  236. %dir %{_libdir}/strongswan
  237. %dir %{_libdir}/strongswan/plugins
  238. %dir %{_libexecdir}/strongswan
  239. %{_sbindir}/charon-cmd
  240. %{_sbindir}/strongswan
  241. %{_sbindir}/swanctl
  242. %{_libdir}/strongswan/*.so.*
  243. %exclude %{_libdir}/strongswan/libipsec.so.*
  244. %{_libdir}/strongswan/plugins/*.so
  245. %exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  246. %{_libexecdir}/strongswan/*
  247. %if "%{?_dist_release}" != "vl6"
  248. %exclude %{_libexecdir}/strongswan/charon-nm
  249. %endif
  250. %{_mandir}/man?/*.gz
  251. %{_datadir}/strongswan/templates/config/
  252. %if %{with tss}
  253. %exclude %{_libdir}/strongswan/imcvs
  254. %exclude %{_libdir}/strongswan/libimcv.so.*
  255. %exclude %{_libdir}/strongswan/libtnccs.so.*
  256. %exclude %{_libdir}/strongswan/libradius.so.*
  257. %exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  258. %exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  259. %exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  260. %exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  261. %exclude %{_libexecdir}/strongswan/attest
  262. %exclude %{_libexecdir}/strongswan/pt-tls-client
  263. %{_datadir}/strongswan/templates/database/
  264. %exclude %dir %{_datadir}/strongswan/swidtag
  265. %endif
  266. %if %{with systemd}
  267. %{_sbindir}/charon-systemd
  268. %{_unitdir}/strongswan.service
  269. %{_unitdir}/strongswan-starter.service
  270. %{_tmpfilesdir}/strongswan.conf
  271. %else
  272. %{_initdir}/ipsec
  273. %endif
  274. %if %{with tss}
  275. %files tnc-imcvs
  276. %{_sbindir}/sw-collector
  277. %{_sbindir}/sec-updater
  278. %dir %{_libdir}/strongswan/imcvs
  279. %dir %{_libdir}/strongswan/plugins
  280. %{_libdir}/strongswan/libimcv.so.*
  281. %{_libdir}/strongswan/libtnccs.so.*
  282. %{_libdir}/strongswan/libradius.so.*
  283. %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  284. %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  285. %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  286. %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  287. %{_libexecdir}/strongswan/attest
  288. %{_libexecdir}/strongswan/pt-tls-client
  289. %dir %{_datadir}/strongswan/swidtag
  290. %{_datadir}/strongswan/swidtag/*.swidtag
  291. %endif
  292. %files libipsec
  293. %{_libdir}/strongswan/libipsec.so.*
  294. %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  295. %if "%{?_dist_release}" != "vl6"
  296. %files charon-nm
  297. %license COPYING
  298. %{_datadir}/dbus-1/system.d/nm-strongswan-service.conf
  299. %{_libexecdir}/strongswan/charon-nm
  300. %endif
  301. %changelog
  302. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.4-1
  303. - new upstream release.
  304. - imported Patch0 from rawhide.
  305. - fixed systemd stuff.
  306. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.2-1
  307. - new upstream release.
  308. * Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.1-1
  309. - new upstream release.
  310. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.2-1
  311. - new upstream release.
  312. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.1-1
  313. - new upstream release.
  314. - imported Patch3 from rawhide.
  315. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
  316. - initial build for Vine Linux.
  317. * Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
  318. - Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
  319. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
  320. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  321. * Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
  322. - Updated to 5.6.1 (RSA-PSS support)
  323. * Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
  324. - Rebuilt for libjson-c.so.3
  325. * Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
  326. - Fix the placement of charon-nm D-Bus policy
  327. * Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
  328. - Updated to 5.6.0
  329. - Fixup configure arguments, enabled a bunch of new features
  330. - Added new BuildRequires:
  331. - Fixup Obsolete/Conflicts, use license macro
  332. - Don't require autoconf/autotools for non-snapshots
  333. - Remove macro overuse, remove fedora/rhel checks and sysvinit support
  334. - Make listings/grouping of all plugins/libs to reduce file listing
  335. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
  336. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  337. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
  338. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  339. * Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
  340. - Updated to 5.5.3
  341. * Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
  342. - Updated to 5.5.2
  343. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
  344. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  345. * Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
  346. - Resolves: #1367796 - Enable the unity plugin
  347. * Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
  348. - New version 5.5.0
  349. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
  350. - Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
  351. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
  352. - New version 5.4.0
  353. * Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
  354. - New version 5.3.5
  355. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
  356. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  357. * Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
  358. - Enable IKEv2 GCM (requires gcrypt module as well)
  359. * Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
  360. - new version 5.3.3
  361. * Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
  362. - Resolves: #1264598 - strongswan: many configuration files are not protected
  363. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
  364. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  365. * Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
  366. - new version 5.3.2
  367. * Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
  368. - new version 5.3.1
  369. * Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
  370. - new version 5.3.0
  371. * Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
  372. - Fixes strongswan swanctl service issue rhbz#1193106
  373. * Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
  374. - new version 5.2.2
  375. * Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
  376. - Enabled ccm, and ctr plugins as it seems enabling just openssl does
  377. not work for using ccm and ctr algos.
  378. * Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
  379. - New strongswan developer release 5.2.2dr1
  380. * Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
  381. - 1167331: Enabled native systemd support.
  382. - Does not disable old systemd, starter, ipsec.conf support yet.
  383. * Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
  384. - New upstream release 5.2.1
  385. * Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
  386. - New upstream release candidate 5.2.1rc1
  387. * Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
  388. - new version 5.2.1dr1
  389. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
  390. - use upstream patch for json/json-c dependency
  391. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
  392. - Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
  393. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
  394. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  395. * Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
  396. - Resolves: #1081804 - enable Kernel IPSec support
  397. * Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
  398. - rebuilt
  399. * Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
  400. - fix json-c dependency
  401. * Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
  402. - New upstream release 5.2.0
  403. - The Attestation IMC/IMV pair supports the IMA-NG
  404. measurement format
  405. - Aikgen tool to generate an Attestation Identity Key bound
  406. to a TPM
  407. - Swanctl tool to provide a portable, complete IKE
  408. configuration and control interface for the command
  409. line using vici interface with libvici library
  410. - PT-EAP transport protocol (RFC 7171) for TNC
  411. - Enabled support for acert for checking X509 attribute certificate
  412. - Updated patches, removed selinux patch as upstream has fixed it
  413. in this release.
  414. - Updated spec file with minor cleanups
  415. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
  416. - improve prerelease macro
  417. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
  418. - Resolves: #1111895 - bump to 5.2.0dr6
  419. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
  420. - Related: #1087437 - remove or upstream all patches not specific to fedora/epel
  421. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
  422. - fix the pre-release version according to guidelines before it gets branched
  423. * Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
  424. - new version 5.2.0dr5
  425. - add json-c-devel to build deps
  426. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
  427. - merge two related patches
  428. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
  429. - clean up the patches a bit
  430. * Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
  431. - New upstream developer release 5.2.0dr4
  432. - Attestation IMV/IMC supports IMA-NG measurement format now
  433. - Aikgen tool to generate an Attestation Identity Key bound
  434. to a TPM
  435. - PT-EAP transport protocol (RFC 7171) for TNC
  436. - vici plugin provides IKE Configuration Interface for charon
  437. - Enabled support for acert for checking X509 attribute certificate
  438. - Updated patches
  439. - Updated spec file with minor cleanups
  440. * Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
  441. - new version 5.1.3
  442. * Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
  443. - new version 5.1.3rc1
  444. * Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
  445. - #1069928 - updated libexec patch.
  446. * Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
  447. - fixed el6 initscript
  448. - fixed pki directory location
  449. * Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
  450. - clean up the specfile a bit
  451. - replace the initscript patch with an individual initscript
  452. - patch to build for epel6
  453. * Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
  454. - #1071353 - bump to 5.1.2
  455. - #1071338 - strongswan is compiled without xauth-pam plugin
  456. - remove obsolete patches
  457. - sent all patches upstream
  458. - added comments to all patches
  459. - don't touch the config with sed
  460. * Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
  461. - Fixed full hardening for strongswan (full relro and PIE).
  462. The previous macros had a typo and did not work
  463. (see bz#1067119).
  464. - Fixed tnc package description to reflect the current state of
  465. the package.
  466. - Fixed pki binary and moved it to /usr/libexece/strongswan as
  467. others binaries are there too.
  468. * Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
  469. - #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
  470. * Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
  471. - Removed redundant patches and *.spec commands caused by branch merging
  472. * Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
  473. - rebuilt
  474. * Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
  475. - Resolves: 973315
  476. - Resolves: 1036844
  477. * Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
  478. - Support for PT-TLS (RFC 6876)
  479. - Support for SWID IMC/IMV
  480. - Support for command line IKE client charon-cmd
  481. - Changed location of pki to /usr/bin
  482. - Added swid tags files
  483. - Added man pages for pki and charon-cmd
  484. - Renamed pki to strongswan-pki to avoid conflict with
  485. pki-core/pki-tools package.
  486. - Update local patches
  487. - Fixes CVE-2013-6075
  488. - Fixes CVE-2013-6076
  489. - Fixed autoconf/automake issue as configure.ac got changed
  490. and it required running autoreconf during the build process.
  491. - added strongswan signature file to the sources.
  492. * Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
  493. - Fixed initialization crash of IMV and IMC particularly
  494. attestation imv/imc as libstrongswas was not getting
  495. initialized.
  496. * Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
  497. - Enabled fips support
  498. - Enabled TNC's ifmap support
  499. - Enabled TNC's pdp support
  500. - Fixed hardocded package name in this spec file
  501. * Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
  502. - rhbz#981429: New upstream release
  503. - Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
  504. - Fixes rhbz#991859 failed to build in rawhide
  505. - Updated local patches and removed which are not needed
  506. - Fixed errors around charon-nm
  507. - Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
  508. libstrongswan-sshkey.so
  509. - Added utility imv_policy_manager
  510. * Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
  511. - rename strongswan-NetworkManager to strongswan-charon-nm
  512. - fix enable_nm macro
  513. * Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
  514. - %%files tries to package some of the shared objects as directories (#984437)
  515. - fix broken systemd unit file (#984300)
  516. - fix rpmlint error: description-line-too-long
  517. - fix rpmlint error: macro-in-comment
  518. - fix rpmlint error: spelling-error Summary(en_US) fuctionality
  519. - depend on 'systemd' instead of 'systemd-units'
  520. - use new systemd scriptlet macros
  521. - NetworkManager subpackage should have a copy of the license (#984490)
  522. - enable hardened_build as this package meets the PIE criteria (#984429)
  523. - invocation of "ipsec _updown iptables" is broken as ipsec is renamed
  524. to strongswan in this package (#948306)
  525. - invocation of "ipsec scepclient" is broken as ipsec is renamed
  526. to strongswan in this package
  527. - add /etc/strongswan/ipsec.d and missing subdirectories
  528. - conditionalize building of strongswan-NetworkManager subpackage as the
  529. version of NetworkManager in EL6 is too old (#984497)
  530. * Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
  531. - Patch to fix a major crash issue when Freeradius loads
  532. attestatiom-imv and does not initialize libstrongswan which
  533. causes crash due to calls to PTS algorithms probing APIs.
  534. So this patch fixes the order of initialization. This issues
  535. does not occur with charon because libstrongswan gets
  536. initialized earlier.
  537. - Patch that allows to outputs errors when there are permission
  538. issues when accessing strongswan.conf.
  539. - Patch to make loading of modules configurable when libimcv
  540. is used in stand alone mode without charon with freeradius
  541. and wpa_supplicant.
  542. * Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
  543. - Enabled TNCCS 1.1 protocol
  544. - Fixed libxm2-devel build dependency
  545. - Patch to fix the issue with loading of plugins
  546. * Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
  547. - New upstream release
  548. - Fixes for CVE-2013-2944
  549. - Enabled support for OS IMV/IMC
  550. - Created and applied a patch to disable ECP in fedora, because
  551. Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
  552. it non-compliant to TCG's PTS standard, but there is no choice
  553. right now. see redhat bz # 319901.
  554. - Enabled Trousers support for TPM based operations.
  555. * Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
  556. - Rebuilt for a single specfile for rawhide/f19/f18/el6
  557. * Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
  558. - New upstream release
  559. - Enabled curl and eap-identity plugins
  560. - Enabled support for eap-radius plugin.
  561. * Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
  562. - Add gettext-devel to BuildRequires because of epel6
  563. - Remove unnecessary comments
  564. * Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
  565. - Enabled support for eap-radius plugin.
  566. * Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
  567. - Update to upstream release 5.0.2
  568. - Created sub package strongswan-tnc-imcvs that provides trusted network
  569. connect's IMC and IMV funtionality. Specifically it includes PTS
  570. based IMC/IMV for TPM based remote attestation and scanner and test
  571. IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
  572. by any third party TNC Client/Server implementation possessing a
  573. standard IF-IMC/IMV interface.
  574. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
  575. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  576. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
  577. - Update to release 5.0.1
  578. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
  579. - Add plugins to interoperate with Windows 7 and Android (#862472)
  580. (contributed by Haim Gelfenbeyn)
  581. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
  582. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  583. * Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
  584. - Fix configure substitutions in initscripts
  585. * Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
  586. - Update to current upstream release
  587. - Comment out all stuff that is only needed for git builds
  588. - Remove renaming patch from git
  589. - Improve init patch used for EPEL
  590. * Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
  591. - Build with openssl plugin enabled
  592. * Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
  593. - Add README.Fedora with link to 4.6 to 5.0 migration information
  594. * Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
  595. - Snapshot of upcoming major release
  596. - Move patches and renaming upstream
  597. http://wiki.strongswan.org/issues/194
  598. http://wiki.strongswan.org/issues/195
  599. - Notified upstream about manpage issues
  600. * Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
  601. - Make initscript patch more distro-neutral
  602. - Add links to bugreports for patches
  603. * Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
  604. - New upstream version (CVE-2012-2388)
  605. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
  606. - Add --enable-nm to configure
  607. - Add NetworkManager-devel to BuildRequires
  608. - Add NetworkManager-glib-devel to BuildRequires
  609. - Add strongswan-NetworkManager package
  610. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
  611. - New version of Strongswan
  612. - Support for RFC 3110 DNSKEY (see upstream changelog)
  613. - Fix corrupt scriptlets
  614. * Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
  615. - #808612 - strongswan binary renaming side-effect
  616. * Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
  617. - New upstream version
  618. - Changed from .tar.gz to .tar.bz2
  619. - Added libstrongswan-pkcs8.so
  620. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
  621. - Fix initscript's status function
  622. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
  623. - Expand tabs in config files for better readability
  624. - Add sysvinit script for epel6
  625. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
  626. - Fix program name in systemd unit file
  627. * Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
  628. - Improve fedora/epel conditionals
  629. * Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
  630. - Protect configuration directory from ordinary users
  631. - Add still missing directory /etc/strongswan
  632. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
  633. - Change directory structure to avoid clashes with Openswan
  634. - Prefixed all manpages with 'strongswan_'
  635. - Every file now includes 'strongswan' somewhere in its path
  636. - Removed conflict with Openswan
  637. - Finally fix permissions on strongswan.conf
  638. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
  639. - Change license tag from GPL to GPLv2+
  640. - Change permissions on /etc/strongswan.conf to 644
  641. - Rename ipsec.8 manpage to strongswan.8
  642. - Fix empty scriptlets for non-fedora builds
  643. - Add ldconfig scriptlet
  644. - Add missing directories and files
  645. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
  646. - Bump to version 4.6.1
  647. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
  648. - Add systemd scriptlets
  649. - Add conditions to also support EPEL6
  650. * Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
  651. - Experimental build for development