rest-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. %define package_version 0.7.12
  2. %define package_release 1%{?_dist_release}
  3. Name: rest
  4. Version: %{package_version}
  5. Release: %{package_release}
  6. Summary: RESTful web api query library
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.clutter-project.org/
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: glib2-devel
  13. BuildRequires: gobject-introspection-devel
  14. BuildRequires: libsoup-devel
  15. BuildRequires: openssl-devel
  16. BuildRequires: gtk-doc
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Takemikaduchi
  20. %description
  21. This library has been designed to make it easier to access web services that
  22. claim to be "RESTful". A reasonable definition of what this means can be found
  23. on Wikipedia [1]. However a reasonable description is that a RESTful service
  24. should have urls that represent remote objects which methods can then be
  25. called on.
  26. %package devel
  27. Summary: Development tools for rest
  28. Summary(ja): rest の開発環境
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: pkgconfig
  32. Requires: glib2-devel
  33. Requires: libsoup-devel
  34. Requires: libxml2-devel
  35. %description devel
  36. Header files and libraries for building a extension library for the
  37. rest.
  38. %package doc
  39. Summary: Documentation for rest
  40. Summary(ja): rest 用のドキュメント
  41. Group: Documentation
  42. Requires: %{name} = %{version}-%{release}
  43. BuildArch: noarch
  44. %description doc
  45. This package contains documentation for rest.
  46. %prep
  47. %setup -q
  48. %build
  49. %configure \
  50. --enable-gtk-doc \
  51. --disable-static \
  52. --enable-introspection=yes \
  53. --with-ca-certificates=%{_datadir}/ssl/certs
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make DESTDIR=$RPM_BUILD_ROOT install
  58. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %post -p /sbin/ldconfig
  62. %postun -p /sbin/ldconfig
  63. %files
  64. %defattr(-,root,root,-)
  65. %doc ChangeLog AUTHORS COPYING NEWS README
  66. %{_libdir}/*.so.*
  67. %{_libdir}/girepository-1.0/*.typelib
  68. %files devel
  69. %defattr(-, root, root)
  70. %{_includedir}/%{name}-0.7
  71. %{_libdir}/*.so
  72. %{_libdir}/pkgconfig/*.pc
  73. %{_datadir}/gir-1.0/*.gir
  74. %files doc
  75. %defattr(-, root, root)
  76. %{_datadir}/gtk-doc/html/%{name}-0.7
  77. %changelog
  78. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
  79. - new upstream release
  80. - add BuildRequires: openssl
  81. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
  82. - new upstream release
  83. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
  84. - initial build for Vine Linux