gyp-vl.spec 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. %define githash d6c5dd5
  2. Summary: Generate Your Projects
  3. Name: gyp
  4. Version: 0.1
  5. Release: 5.git%{githash}%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: iwaim
  10. License: BSD
  11. URL: https://gyp.gsrc.io
  12. # 1. git clone https://chromium.googlesource.com/external/gyp
  13. # 2. cd gyp
  14. # 3. version=$(grep version= setup.py|cut -d\' -f2)
  15. # 4. revision=$(git log --oneline|head -1|cut -d' ' -f1)
  16. # 5. cd ..
  17. # 6. tar -a --exclude-vcs -cf gyp-$version-git$revision.tar.xz gyp
  18. Source0: %{name}-%{version}-git%{githash}.tar.gz
  19. Patch0: gyp-rpmoptflags.patch
  20. Patch1: gyp-ninja-build.patch
  21. Patch2: gyp-python3.patch
  22. Patch3: gyp-python38.patch
  23. Patch4: gyp-fix-cmake.patch
  24. Patch5: gyp-python39.patch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  26. BuildArch: noarch
  27. BuildRequires: python3-devel
  28. BuildRequires: python3-rpm-macros
  29. BuildRequires: python3-setuptools
  30. BuildRequires: ninja
  31. Requires: python3
  32. Requires: python3-setuptools
  33. %description
  34. GYP is a tool to generates native Visual Studio, Xcode and SCons
  35. and/or make build files from a platform-independent input format.
  36. Its syntax is a universal cross-platform build representation
  37. that still allows sufficient per-platform flexibility to accommodate
  38. irreconcilable differences.
  39. %prep
  40. %setup -q -c -n %{name}
  41. %autopatch -p1
  42. for i in $(find pylib -name '*.py'); do
  43. sed -e '\,#![ \t]*/.*python,{d}' $i > $i.new && touch -r $i $i.new && mv $i.new $i
  44. done
  45. %build
  46. %py3_build
  47. %install
  48. %{__rm} -rf %{buildroot}
  49. %py3_install
  50. %check
  51. %{__python3} gyptest.py test/hello/gyptest-all.py
  52. %clean
  53. %{__rm} -rf %{buildroot}
  54. %files
  55. %defattr(-,root,root,-)
  56. %license LICENSE
  57. %doc AUTHORS
  58. %{_bindir}/gyp
  59. %{python3_sitelib}/*
  60. %changelog
  61. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1-5.d6c5dd5
  62. - updated to git HEAD.
  63. * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1-4.gite87d37d6
  64. - updated to git HEAD.
  65. - import Patch1-5 from rawhide.
  66. - switch to python3.
  67. * Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.46-1
  68. - update to svn r1569
  69. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1-2.svn827
  70. - rebuild with python-2.7.2
  71. * Fri Jun 4 2010 IWAI, Masaharu <iwai@alib.jp> 0.1-1.svn827
  72. - Initial build.