elfutils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730
  1. %define eu_version 0.152
  2. %define eu_release 2
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Name: elfutils
  5. Version: %{eu_version}
  6. Release: %{eu_release}%{?_dist_release}
  7. License: GPLv2 with exceptions
  8. Group: Development/Tools
  9. URL: https://fedorahosted.org/elfutils/
  10. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
  11. ##VINE##
  12. Patch10: elfutils-0.131-readelf_c.patch
  13. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  14. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. BuildRequires: bison >= 1.875
  17. BuildRequires: flex >= 2.5.4a
  18. BuildRequires: bzip2
  19. BuildRequires: bzip2-devel
  20. BuildRequires: zlib-devel
  21. BuildRequires: xz-devel
  22. BuildRequires: gettext
  23. BuildRequires: m4
  24. BuildRequires: gcc >= 3.4
  25. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  26. BuildRequires: glibc-headers >= 2.3.4-11
  27. %define _gnu %{nil}
  28. %define _program_prefix eu-
  29. %description
  30. Elfutils is a collection of utilities, including ld (a linker),
  31. nm (for listing symbols from object files), size (for listing the
  32. section sizes of an object or archive file), strip (for discarding
  33. symbols), readelf (to see the raw ELF file structures), and elflint
  34. (to check for well-formed ELF files).
  35. %package libs
  36. Summary: Libraries to handle compiled objects
  37. Group: System Environment/Libraries
  38. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  39. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  40. Conflicts: elfutils < %{version}-%{release}
  41. Conflicts: elfutils > %{version}-%{release}
  42. Conflicts: elfutils-devel < %{version}-%{release}
  43. Conflicts: elfutils-devel > %{version}-%{release}
  44. %description libs
  45. The elfutils-libs package contains libraries which implement DWARF, ELF,
  46. and machine-specific ELF handling. These libraries are used by the programs
  47. in the elfutils package. The elfutils-devel package enables building
  48. other programs using these libraries.
  49. %package devel
  50. Summary: Development libraries to handle compiled objects
  51. Group: Development/Libraries
  52. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  53. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  54. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  55. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  56. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  57. %description devel
  58. The elfutils-devel package contains the libraries to create
  59. applications for handling compiled objects. libebl provides some
  60. higher-level ELF access functionality. libdw provides access to
  61. the DWARF debugging information. libasm provides a programmable
  62. assembler interface.
  63. %package devel-static
  64. Summary: Static archives to handle compiled objects
  65. Group: Development/Libraries
  66. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  67. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  68. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  69. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  70. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  71. %description devel-static
  72. The elfutils-devel-static package contains the static archives
  73. with the code to handle compiled objects.
  74. %package libelf
  75. Summary: Library to read and write ELF files
  76. Group: System Environment/Libraries
  77. Provides: libelf = %{version}-%{release}
  78. Obsoletes: libelf <= 0.8.2-2
  79. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  80. Conflicts: elfutils < %{version}-%{release}
  81. Conflicts: elfutils > %{version}-%{release}
  82. Conflicts: elfutils-libs < %{version}-%{release}
  83. Conflicts: elfutils-libs > %{version}-%{release}
  84. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  85. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  86. %description libelf
  87. The elfutils-libelf package provides a DSO which allows reading and
  88. writing ELF files on a high level. Third party programs depend on
  89. this package to read internals of ELF files. The programs of the
  90. elfutils package use it also to generate new ELF files.
  91. %package libelf-devel
  92. Summary: Development support for libelf
  93. Group: Development/Libraries
  94. Provides: libelf-devel = %{version}-%{release}
  95. Obsoletes: libelf-devel <= 0.8.2-2
  96. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  97. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  98. Conflicts: libelf-devel < %{version}-%{release}
  99. %description libelf-devel
  100. The elfutils-libelf-devel package contains the libraries to create
  101. applications for handling compiled objects. libelf allows you to
  102. access the internals of the ELF object file format, so you can see the
  103. different sections of an ELF file.
  104. %package libelf-devel-static
  105. Summary: Static archive of libelf
  106. Group: Development/Libraries
  107. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  108. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  109. %description libelf-devel-static
  110. The elfutils-libelf-static package contains the static archive
  111. for libelf.
  112. %prep
  113. %setup -q
  114. %patch10 -p0 -b .readelf_c
  115. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  116. %build
  117. # Remove -Wall from default flags. The makefiles enable enough warnings
  118. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  119. # the makefiles disable some specific warnings for specific code.
  120. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  121. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  122. make -s %{?_smp_mflags}
  123. %install
  124. rm -rf ${RPM_BUILD_ROOT}
  125. make -s install DESTDIR=${RPM_BUILD_ROOT}
  126. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  127. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  128. %find_lang %{name}
  129. # XXX Nuke unpackaged files
  130. { cd ${RPM_BUILD_ROOT}
  131. rm -f .%{_bindir}/eu-ld
  132. }
  133. %check
  134. make -s check
  135. %clean
  136. rm -rf ${RPM_BUILD_ROOT}
  137. %post libs -p /sbin/ldconfig
  138. %postun libs -p /sbin/ldconfig
  139. %post libelf -p /sbin/ldconfig
  140. %postun libelf -p /sbin/ldconfig
  141. %files -f %{name}.lang
  142. %defattr(-,root,root)
  143. %doc README TODO
  144. %{_bindir}/eu-addr2line
  145. %{_bindir}/eu-ar
  146. %{_bindir}/eu-elfcmp
  147. %{_bindir}/eu-elflint
  148. %{_bindir}/eu-findtextrel
  149. %{_bindir}/eu-nm
  150. %{_bindir}/eu-objdump
  151. %{_bindir}/eu-ranlib
  152. %{_bindir}/eu-readelf
  153. %{_bindir}/eu-size
  154. %{_bindir}/eu-strings
  155. %{_bindir}/eu-strip
  156. #%{_bindir}/eu-ld
  157. %{_bindir}/eu-unstrip
  158. %{_bindir}/eu-make-debug-archive
  159. %files libs
  160. %defattr(-,root,root)
  161. %{_libdir}/libasm-%{version}.so
  162. %{_libdir}/libasm.so.*
  163. %{_libdir}/libdw-%{version}.so
  164. %{_libdir}/libdw.so.*
  165. %dir %{_libdir}/elfutils
  166. %{_libdir}/elfutils/lib*.so
  167. %files devel
  168. %defattr(-,root,root)
  169. %{_includedir}/dwarf.h
  170. %dir %{_includedir}/elfutils
  171. %{_includedir}/elfutils/elf-knowledge.h
  172. %{_includedir}/elfutils/libasm.h
  173. %{_includedir}/elfutils/libebl.h
  174. %{_includedir}/elfutils/libdw.h
  175. %{_includedir}/elfutils/libdwfl.h
  176. %{_includedir}/elfutils/version.h
  177. %{_libdir}/libebl.a
  178. %{_libdir}/libasm.so
  179. %{_libdir}/libdw.so
  180. %files devel-static
  181. %defattr(-,root,root)
  182. %{_libdir}/libasm.a
  183. %{_libdir}/libdw.a
  184. %files libelf
  185. %defattr(-,root,root)
  186. %{_libdir}/libelf-%{version}.so
  187. %{_libdir}/libelf.so.*
  188. %files libelf-devel
  189. %defattr(-,root,root)
  190. %{_includedir}/libelf.h
  191. %{_includedir}/gelf.h
  192. %{_includedir}/nlist.h
  193. %{_libdir}/libelf.so
  194. %files libelf-devel-static
  195. %defattr(-,root,root)
  196. %{_libdir}/libelf.a
  197. %changelog
  198. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  199. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  200. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  201. - update to 0.152
  202. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  203. - elfutils-libs: changed Group to System Environment/Libraries
  204. - elfutils-libelf: changed Group to System Environment/Libraries
  205. - elfutils-devel: changed Group to Development/Libraries
  206. - elfutils-devel-static: changed Group to Development/Libraries
  207. - elfutils-libelf-devel: changed Group to Development/Libraries
  208. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  209. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  210. - merged with Fedora 9 0.135-1
  211. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  212. - applied new versioning policy
  213. - added elfutils-0.131-readelf_c.patch
  214. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  215. - new upstream release
  216. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  217. - remove Obsoletes: libelf, libelf-devel from elfutils
  218. - add Obsoletes: libelf to elfutils-libelf
  219. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  220. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  221. - Update to 0.135
  222. - libdwfl: bug fixes
  223. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  224. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  225. - Update to 0.134
  226. - elflint: backend improvements for sparc, alpha (#204170)
  227. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  228. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  229. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  230. - Update to 0.133
  231. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  232. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  233. - libdwfl: bug fixes and optimization in relocation handling
  234. - elfcmp: bug fix for non-allocated section handling
  235. - ld: implement newer features of binutils linker.
  236. - Install eu-objdump and libasm, now has limited disassembler support.
  237. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  238. - Update to 0.132
  239. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  240. - eu-readelf: Fix handling of ET_REL files in archives.
  241. - libcpu: Implement x86 and x86-64 disassembler.
  242. - libasm: Add interface for disassembler.
  243. - all programs: add debugging of branch prediction.
  244. - libelf: new function elf_scnshndx.
  245. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  246. - Update to 0.131
  247. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  248. bug fixes for oddly-formatted DWARF
  249. - libdwfl: bug fixes in offline archive support, symbol table handling;
  250. apply partial relocations for dwfl_module_address_section on ET_REL
  251. - libebl: powerpc backend support for Altivec registers
  252. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  253. - Fix ET_REL support.
  254. - Fix odd indentation in eu-readelf -x output.
  255. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  256. - Update to 0.130
  257. - eu-readelf -p option can take an argument like -x for one section
  258. - eu-readelf --archive-index (or -c)
  259. - eu-readelf -n improved output for core dumps
  260. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  261. - eu-elflint: ditto
  262. - eu-elflint: stricter checks on debug sections
  263. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  264. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  265. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  266. - libebl: backend improvements (#324031)
  267. - libdwfl: build_id support, new functions for it
  268. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  269. - libdwfl offline archive support, new script eu-make-debug-archive
  270. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  271. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  272. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  273. - Update to 0.129
  274. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  275. - addr2line: new option --symbols (or -S)
  276. - libdw: dwarf_getscopes fixes (#230235)
  277. - libdwfl: dwfl_module_addrsym fixes (#249490)
  278. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  279. - Update to 0.128
  280. - new program: unstrip
  281. - elfcmp: new option --hash-inexact
  282. - Replace Conflicts: with Provides/Requires using -arch
  283. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  284. - Update to 0.127
  285. - libdw: new function dwarf_getsrcdirs
  286. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  287. dwfl_module_address_section
  288. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  289. - Update to 0.126
  290. - New program eu-ar.
  291. - libdw: fix missing dwarf_getelf (#227206)
  292. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  293. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  294. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  295. - Fix overeager warn_unused_result build failures.
  296. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  297. - Update to 0.125
  298. - elflint: Compare DT_GNU_HASH tests.
  299. - move archives into -static RPMs
  300. - libelf, elflint: better support for core file handling
  301. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  302. - Resolves: RHBZ #220817, RHBZ #213792
  303. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  304. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  305. - Update to 0.124
  306. - libebl: fix ia64 reloc support (#206981)
  307. - libebl: sparc backend support for return value location
  308. - libebl, libdwfl: backend register name support extended with more info
  309. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  310. - readelf, elflint: trivial bugs fixed
  311. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  312. - Update to 0.123
  313. - libebl: Backend build fixes, thanks to Stepan Kasal.
  314. - libebl: ia64 backend support for register names, return value location
  315. - libdwfl: Handle truncated linux kernel module section names.
  316. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  317. - elflint: Fix checks to permit --hash-style=gnu format.
  318. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  319. - Fix warnings in elflint compilation.
  320. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  321. - Update to 0.122
  322. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  323. - libebl: add function to test for relative relocation
  324. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  325. - elflint, readelf: add support for DT_GNU_HASH
  326. - libelf: add elf_gnu_hash
  327. - elflint, readelf: add support for 64-bit SysV-style hash tables
  328. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  329. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  330. - Update to 0.121
  331. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  332. - make all installed headers usable in C++ code (#193153).
  333. - eu-readelf: better output format.
  334. - eu-elflint: fix tests of dynamic section content.
  335. - libdw, libdwfl: handle files without aranges info.
  336. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  337. - rebuild to pick up -devel deps
  338. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  339. - Update to 0.120
  340. - License changed to GPL, with some exceptions for using
  341. the libelf, libebl, libdw, and libdwfl library interfaces.
  342. Red Hat elfutils is an included package of the Open Invention Network.
  343. - dwarf.h updated for DWARF 3.0 final specification.
  344. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  345. - libdwfl: New function dwfl_version; fixes for offline.
  346. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  347. - bump again for double-long bug on ppc(64)
  348. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  349. - rebuilt for new gcc4.1 snapshot and glibc changes
  350. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  351. - update to 0.119
  352. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  353. - rebuilt
  354. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  355. - update to 0.118
  356. - elflint: more tests.
  357. - libdwfl: New function dwfl_module_register_names.
  358. - libebl: New backend hook for register names.
  359. - Make sure -fexceptions is always in CFLAGS.
  360. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  361. - update to 0.117
  362. - libdwfl: New function dwfl_module_return_value_location (#166118)
  363. - libebl: Backend improvements for several CPUs
  364. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  365. - update to 0.116
  366. - libdw fixes, API changes and additions
  367. - libdwfl fixes (#169672)
  368. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  369. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  370. - Update requires/conflicts for better biarch update behavior.
  371. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  372. - update to 0.115
  373. - New program eu-strings.
  374. - libdw: New function dwarf_getscopes_die.
  375. - libelf: speed-ups of non-mmap reading.
  376. - Implement --enable-gcov option for configure.
  377. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  378. - update to 0.114
  379. - new program eu-ranlib
  380. - libdw: new calls for inlines
  381. - libdwfl: new calls for offline modules
  382. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  383. - update to 0.113
  384. - elflint: relax a bit. Allow version definitions for defined symbols
  385. against DSO versions also for symbols in nobits sections.
  386. Allow .rodata section to have STRINGS and MERGE flag set.
  387. - strip: add some more compatibility with binutils.
  388. - libdwfl: bug fixes.
  389. - Separate libdw et al into elfutils-libs subpackage.
  390. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  391. - update to 0.112
  392. - elfcmp: some more relaxation.
  393. - elflint: many more tests, especially regarding to symbol versioning.
  394. - libelf: Add elfXX_offscn and gelf_offscn.
  395. - libasm: asm_begin interface changes.
  396. - libebl: Add three new interfaces to directly access machine, class,
  397. and data encoding information.
  398. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  399. - update portability patch
  400. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  401. - update to 0.111
  402. - libdwfl library now merged into libdw
  403. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  404. - update to 0.110
  405. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  406. - update to 0.109
  407. - verify that libebl modules are from the same build
  408. - new eu-elflint checks on copy relocations
  409. - new program eu-elfcmp
  410. - new experimental libdwfl library
  411. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  412. - robustification of eu-strip and eu-readelf
  413. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  414. - more robustification
  415. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  416. - robustification
  417. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  418. - update to 0.108
  419. - merge strip fixes
  420. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  421. - update elf.h from glibc
  422. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  423. - fix strip -f byte-swapping bug
  424. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  425. - update to 0.107
  426. - readelf: improve DWARF output format
  427. - elflint: -d option to support checking separate debuginfo files
  428. - strip: fix ET_REL debuginfo files (#156341)
  429. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  430. - fix some bugs in new code, reenable make check
  431. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  432. - disable make check for most arches, for now
  433. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  434. - update to 0.106
  435. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  436. - update to 0.104
  437. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  438. - update to 0.103
  439. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  440. - update to 0.101.
  441. - use %%configure macro to get CFLAGS etc. right
  442. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  443. - upgrade to 0.99.
  444. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  445. - upgrade to 0.97.
  446. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  447. - upgrade to 0.96.
  448. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  449. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  450. warning
  451. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  452. - rebuilt
  453. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  454. - upgrade to 0.95.
  455. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  456. - rebuilt
  457. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  458. - rebuilt
  459. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  460. - upgrade to 0.94
  461. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  462. - upgrade to 0.93
  463. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  464. - full version
  465. - macroized spec file for GPL or OSL builds
  466. - include only libelf under GPL plus wrapper scripts
  467. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  468. - macroized spec file for GPL or OSL builds
  469. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  470. - split elfutils-devel into two packages.
  471. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  472. - include only libelf under GPL plus wrapper scripts
  473. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  474. - readelf, not readline, in %%description (#111214).
  475. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  476. - update to 0.89 (fix eu-strip)
  477. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  478. - update to 0.86 (fix eu-strip on s390x/alpha)
  479. - libebl is an archive now; remove references to DSO
  480. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  481. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  482. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  483. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  484. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  485. - upgrade to 0.82 (strip tests fixed on big-endian).
  486. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  487. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  488. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  489. - upgrade to 0.80 (debugedit changes for kernel in progress).
  490. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  491. - rebuilt
  492. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  493. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  494. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  495. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  496. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  497. - debuginfo rebuild
  498. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  499. - use the correct way of identifying the section via the sh_info link.
  500. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  501. - update to 0.75 (eu-strip -g fix)
  502. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  503. - update to 0.74 (fix for writing with some non-dirty sections)
  504. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  505. - another -0.73 update (with sparc fixes).
  506. - do "make check" in %%check, not %%install, section.
  507. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  508. - update to 0.73 (with s390 fixes).
  509. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  510. - rebuilt
  511. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  512. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  513. - fix other warnings
  514. - reenable checks on s390x
  515. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  516. - temporarily disable checks on s390x, until someone has
  517. time to look at it
  518. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  519. - update to 0.72
  520. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  521. - update to 0.71
  522. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  523. - update to 0.69.
  524. - add "make check" and segfault avoidance patch.
  525. - elfutils-libelf needs to run ldconfig.
  526. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  527. - update to 0.68.
  528. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  529. - update to 0.67.
  530. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  531. - update to 0.65.
  532. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  533. - update to 0.64.
  534. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  535. - split packages further into elfutils-libelf
  536. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  537. - update to 0.63.
  538. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  539. - Adjust for dropping libtool
  540. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  541. - update to 0.59
  542. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  543. - update to 0.56
  544. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  545. - update to 0.54
  546. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  547. - update to 0.53
  548. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  549. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  550. - get beehive to punch a rhpkg generated package.
  551. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  552. - build in 8.0.1.
  553. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  554. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  555. - Add libelf-devel to conflicts for elfutils-devel
  556. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  557. - Split into runtime and devel package
  558. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  559. - integrate into official sources
  560. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  561. - Swaddle.