expat-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.0.1
  4. %define release 6%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: MIT/X
  11. Group: Applications/Text
  12. URL: http://www.libexpat.org/
  13. Source: http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
  14. Patch100: expat-2.0.1_CVE-2009-3560.patch
  15. Patch110: expat-2.0.1_CVE-2009-3720.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Requires: lib%{name} = %{version}-%{release}
  18. BuildRequires: libtool
  19. %description
  20. This is Expat, a C library for parsing XML, written by James Clark.
  21. Expat is a stream-oriented XML parser. This means that you register
  22. handlers with the parser before starting the parse. These handlers
  23. are called when the parser discovers the associated structures in the
  24. document being parsed. A start tag is an example of the kind of
  25. structures for which you may register handlers.
  26. %package -n lib%{name}
  27. Summary: Runtime library of expat
  28. Summary(ja): Expat のための実行ライブラリ
  29. Group: System Environment/Libraries
  30. %description -n lib%{name}
  31. This package contains the runtime, shared library of expat, the C
  32. library for parsing XML.
  33. %description -n lib%{name} -l ja
  34. Expat を動作させるために必用となるライブラリです.
  35. %package devel
  36. Summary: Development environment for the expat XML parser
  37. Summary(ja): expat XML パーサ用開発環境
  38. Group: Development/Libraries
  39. Requires: lib%{name} = %{version}-%{release}
  40. %description devel
  41. Development environment for the expat XML parser
  42. %description devel -l ja
  43. expat XML パーサ用開発環境です.
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-lib%{name}
  46. Summary: Runtime library of expat
  47. Summary(ja): Expat のための実行ライブラリ
  48. Group: System Environment/Libraries
  49. Requires: lib%{name} = %{version}-%{release}
  50. %description -n compat32-lib%{name}
  51. This package contains the runtime, shared library of expat, the C
  52. library for parsing XML.
  53. %description -n compat32-lib%{name} -l ja
  54. Expat を動作させるために必用となるライブラリです.
  55. %package -n compat32-%{name}-devel
  56. Summary: Development environment for the expat XML parser
  57. Summary(ja): expat XML パーサ用開発環境
  58. Group: Development/Libraries
  59. Requires: %{name}-devel = %{version}-%{release}
  60. Requires: compat32-lib%{name} = %{version}-%{release}
  61. %description -n compat32-%{name}-devel
  62. Development environment for the expat XML parser
  63. %description -n compat32-%{name}-devel -l ja
  64. expat XML パーサ用開発環境です.
  65. %prep
  66. %setup -q
  67. %patch100 -p1 -b .CVE-2009-3560
  68. %patch110 -p1 -b .CVE-2009-3720
  69. %build
  70. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  71. %configure --enable-shared
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. rm -f examples/*.dsp
  76. chmod 644 README COPYING Changes doc/* examples/*
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %post -n lib%{name} -p /sbin/ldconfig
  82. %postun -n lib%{name} -p /sbin/ldconfig
  83. %post -n compat32-lib%{name} -p /sbin/ldconfig
  84. %postun -n compat32-lib%{name} -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root)
  87. %doc COPYING Changes README
  88. %{_bindir}/xmlwf
  89. %{_mandir}/man1/xmlwf.1*
  90. %files -n lib%{name}
  91. %defattr(-,root,root)
  92. %doc COPYING Changes README
  93. %{_libdir}/libexpat.so.*
  94. %files devel
  95. %defattr(-,root,root)
  96. %doc COPYING Changes README doc/* examples
  97. %{_includedir}/*
  98. %{_libdir}/libexpat.a
  99. %{_libdir}/libexpat.so
  100. ## to build compat32 for x86_64 architecture support
  101. %if %{build_compat32}
  102. %files -n compat32-lib%{name}
  103. %defattr(-,root,root)
  104. %{_libdir}/libexpat.so.*
  105. %files -n compat32-%{name}-devel
  106. %defattr(-,root,root)
  107. %{_libdir}/libexpat.a
  108. %{_libdir}/libexpat.so
  109. %endif
  110. %changelog
  111. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  112. - rebuilt with gcc-4.4.3-3 on ppc
  113. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  114. - rebuilt with new toolchains (for VineSeed)
  115. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  116. - add patch110 for fix CVE-2009-3720 (xml parser)
  117. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  118. - add Patch100 for fix CVE-2009-3560 (xml parser)
  119. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  120. - added Requires: tag to compat32-* sub-packages.
  121. - removed unnecessary %%configure CC='gcc -m32' option
  122. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  123. - applied new versioning policy and spec in utf-8
  124. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  125. - removed %%if !%%{build_compat32} case condition
  126. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  127. - new upstream release
  128. - drop Patch0
  129. - drop .la
  130. - chmod 644 the documentation
  131. - strip DSP files from examples
  132. - update description and drop description-ja
  133. - add -fPIC
  134. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  135. - rebuilt
  136. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  137. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  138. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  139. - added compat32* packages for x86_64 architecture support
  140. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  141. - add missing header file (expat_external.h) to %%files.
  142. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  143. - updated/revised Patch1 (%%install will fail without this patch)
  144. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  145. - new upstream release
  146. -- dropped patch1
  147. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  148. - updated to 1.95.7
  149. - changed URL and Group
  150. - fixed License to MIT/X (based on rpm package at sourceforge)
  151. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  152. - version up to 1.95.6
  153. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  154. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  155. - add manpage (xmlwf.1)
  156. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  157. - fixed license ( s/MPL or GPL/distributable/ )
  158. - use License tag
  159. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  160. - new sub-package libexpat.
  161. - added BuildPreReq: libtool
  162. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  163. - updated to 1.95.2 release
  164. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  165. - 1.95.1-3vl1
  166. - based on 1.95.1-3mdk from Mandrake 8.0
  167. - added Japanese summary and description
  168. - modified spec macros for Vine
  169. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  170. - real version is 1.95.1
  171. - reenable optimisations
  172. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  173. - release .
  174. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  175. - Don't try to use optimizations
  176. - Bzip2 sources
  177. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  178. - first version