gnome-power-manager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385
  1. %define dbus_version 1.4.0
  2. %define dbus_glib_version 0.88
  3. %define gnome_panel_version 2.32.0
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 2.32.0
  8. Release: 2%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source0: http://download.gnome.org/sources/gnome-power-manager/2.32/gnome-power-manager-%{version}.tar.bz2
  13. # ja.po from l10n
  14. Source101: gnome-power-manager.gnome-2-32.ja.po
  15. # for Vine Linux
  16. Patch10: gnome-power-manager-2.28.2-warningflags.patch
  17. Patch11: gnome-power-manager-2.28.2-math.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf >= 2.65
  20. BuildRequires: libgnomeui-devel
  21. BuildRequires: libglade2-devel
  22. BuildRequires: libwnck-devel
  23. BuildRequires: dbus-devel >= %{dbus_version}
  24. BuildRequires: libnotify-devel
  25. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  26. BuildRequires: scrollkeeper
  27. BuildRequires: gnome-doc-utils >= 0.3.2
  28. BuildRequires: desktop-file-utils
  29. BuildRequires: gettext
  30. BuildRequires: libtool
  31. BuildRequires: cairo-devel
  32. BuildRequires: libcanberra-devel >= 0.10
  33. BuildRequires: unique-devel >= 1.1.6
  34. ## BuildRequires: DeviceKit-power-devel >= 008
  35. BuildRequires: upower-devel >= 0.9.0
  36. BuildRequires: intltool
  37. BuildRequires: docbook-utils
  38. Requires: gtk2 >= 2.10.0
  39. Requires: gnome-mime-data
  40. Requires: gnome-icon-theme
  41. Requires: libnotify >= 0.4.3
  42. Requires: dbus-glib >= %{dbus_glib_version}
  43. Requires: dbus-x11 >= %{dbus_version}
  44. Requires: libcanberra-gtk2 >= 0.10
  45. Requires: unique >= 1.1.6
  46. Requires: upower >= 0.9.0
  47. Requires(post,postun): scrollkeeper
  48. Requires(post,pre,preun): GConf2
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. Packager: daisuke, Takemikaduchi
  52. %description
  53. GNOME Power Manager uses the information and facilities provided by HAL
  54. displaying icons and handling user callbacks in an interactive GNOME session.
  55. GNOME Power Preferences allows authorised users to set policy and
  56. change preferences.
  57. %package extra
  58. Summary: GNOME Power Manager extra utility programs
  59. Group: Applications/System
  60. Requires: %{name} = %{version}-%{release}
  61. %description extra
  62. Extra GNOME power management applications that are not normally needed.
  63. %prep
  64. %setup -q
  65. #%setup -q -n %{?name}-%{?version}-%{?alphatag}
  66. ## %patch10 -p1 -b .warnings
  67. ## %patch11 -p1 -b .math
  68. # copy ja.po
  69. cp -f %{SOURCE101} po/ja.po
  70. autoreconf -i
  71. %build
  72. %configure \
  73. --disable-scrollkeeper
  74. make
  75. # strip unneeded translations from .mo files
  76. # ideally intltool (ha!) would do that for us
  77. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  78. cd po
  79. grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  80. mv POTFILES.keep POTFILES.in
  81. intltool-update --pot
  82. for p in *.po; do
  83. msgmerge $p %{name}.pot > $p.out
  84. msgfmt -o `basename $p .po`.gmo $p.out
  85. done
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  89. make install DESTDIR=$RPM_BUILD_ROOT
  90. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  91. desktop-file-install --vendor gnome --delete-original \
  92. --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  93. $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  94. # save space by linking identical images in translated docs
  95. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  96. for f in $helpdir/C/figures/*.png; do
  97. b="$(basename $f)"
  98. for d in $helpdir/*; do
  99. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  100. g="$d/figures/$b"
  101. if [ -f "$g" ]; then
  102. if cmp -s $f $g; then
  103. rm "$g"; ln -s "../../C/figures/$b" "$g"
  104. fi
  105. fi
  106. fi
  107. done
  108. done
  109. %find_lang %name --with-gnome
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post
  113. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  114. gconftool-2 --makefile-install-rule \
  115. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
  116. scrollkeeper-update -q &> /dev/null || :
  117. touch --no-create %{_datadir}/icons/hicolor
  118. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  119. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  120. fi
  121. %pre
  122. if [ "$1" -gt 1 ]; then
  123. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  124. gconftool-2 --makefile-uninstall-rule \
  125. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  126. fi
  127. %preun
  128. if [ "$1" -eq 0 ]; then
  129. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  130. gconftool-2 --makefile-uninstall-rule \
  131. %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
  132. fi
  133. %postun
  134. scrollkeeper-update -q &> /dev/null || :
  135. touch --no-create %{_datadir}/icons/hicolor
  136. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  137. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  138. fi
  139. %files -f %{name}.lang
  140. %defattr(-,root,root)
  141. %doc AUTHORS COPYING README
  142. %{_bindir}/gnome-power-bugreport.sh
  143. %{_bindir}/gnome-power-manager
  144. %{_bindir}/gnome-power-preferences
  145. %{_sbindir}/gnome-power-backlight-helper
  146. %dir %{_datadir}/gnome-power-manager
  147. %{_datadir}/gnome-power-manager/acme.ui
  148. %{_datadir}/gnome-power-manager/gpm-prefs.ui
  149. %{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
  150. %{_mandir}/man1/gnome-power-manager.1.gz
  151. %{_mandir}/man1/gnome-power-preferences.1.gz
  152. %{_sysconfdir}/gconf/schemas/*.schemas
  153. %{_datadir}/dbus-1/services/gnome-power-manager.service
  154. #%{_datadir}/omf/gnome-power-manager
  155. %{_sysconfdir}/xdg/autostart/*.desktop
  156. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  157. %{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
  158. %{_datadir}/applications/gnome-power-preferences.desktop
  159. %{_libexecdir}/gnome-brightness-applet
  160. %{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
  161. %{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
  162. %{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
  163. %{_datadir}/polkit-1/actions/org.gnome.power.policy
  164. %files extra
  165. %defattr(-,root,root,-)
  166. %doc AUTHORS COPYING NEWS README
  167. %{_bindir}/gnome-power-statistics
  168. %{_mandir}/man1/gnome-power-statistics.1.gz
  169. %{_datadir}/gnome-power-manager/gpm-statistics.ui
  170. %{_datadir}/applications/gnome-power-statistics.desktop
  171. %{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
  172. %{_libexecdir}/gnome-inhibit-applet
  173. %{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
  174. %{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
  175. %{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
  176. %changelog
  177. * Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
  178. - add Source101(gnome-power-manager.gnome-2-32.ja.po)
  179. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  180. - new upstream release
  181. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  182. - fix %files
  183. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  184. - new upstream release
  185. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  186. - new upstream release
  187. - remove Patch1, Patch2, Patch3
  188. - change BuildRequires: DeviceKit-power-devel -> upower-devel
  189. - change Requires: DeviceKit-power -> upower
  190. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  191. - new upstream release
  192. - change BuildRequires: xmlto -> docbook-utils
  193. - remove BuildReuiqres: hal-devel
  194. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  195. - new upstream release
  196. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  197. - merge spec file from FC package
  198. - add Patch1, Patch2 and Patch3 from FC package
  199. - add Patch10 and Patch11 for Vine Linux
  200. - remove configure option --enable-policykit
  201. - add new package (extra)
  202. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  203. - new upstream release
  204. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  205. - new upstream release
  206. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  207. - new upstream release
  208. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  209. - new upstream release
  210. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  211. - new upstream release
  212. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  213. - rebuild with new environment/toolchain
  214. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  215. - new upstream release
  216. - drop Patch10 to enable suspend-to-ram.
  217. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  218. - new upstream release
  219. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  220. - new upstream release
  221. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  222. - new upstream release
  223. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  224. - new upstream release
  225. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  226. - new upstream release
  227. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  228. - new upstream release
  229. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  230. - new upstream release
  231. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  232. - new upstream release
  233. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  234. - add Patch10 to disable suspend-to-ram by default.
  235. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  236. - update ja.po from CVS head.
  237. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  238. - new upstream release
  239. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  240. - initial build for Vine Linux based on FC package
  241. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  242. - fix the fix in -2 and -3
  243. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  244. - fix the fix in -2
  245. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  246. - fix icon in bubbles (bug 184192).
  247. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  248. - Update to 2.13.93
  249. - ignore d-bus timeout errors
  250. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  251. - Add patch from Richard Hughes to potentially fix a
  252. crasher bug (bug 183127)
  253. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  254. - Buildrequires: gnome-doc-utils
  255. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  256. - Update to 2.13.92
  257. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  258. - Update to 2.13.91
  259. - Drop upstreamed patch
  260. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  261. - Update to 2.13.90
  262. - Require dbus-x11 (#176656)
  263. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  264. - remove Hibernate and Suspend from menus as part of
  265. panel/g-p-m integration effort
  266. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  267. - bump again for double-long bug on ppc(64)
  268. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  269. - pull cvs snapshot from HEAD and drop the patches caillon
  270. just added
  271. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  272. - Install into the autostart directory
  273. - Don't suspend on lid close while on AC power
  274. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  275. - rebuilt for new gcc4.1 snapshot and glibc changes
  276. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  277. - rebuild
  278. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  279. - packaging tweaks
  280. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  281. - Update to 2.13.5
  282. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  283. - Left clicking on the applet should bring up the menu
  284. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  285. - update to 0.3.4
  286. - disable updating scrollkeeper database in buildroot
  287. (move to %%post)
  288. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  289. - update to a cvs snap so that it works with hal cvs snap
  290. - make sure we use libnotify
  291. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  292. - rebuilt
  293. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  294. - rebuild for new dbus
  295. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  296. - Update to 0.3.1
  297. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  298. - Update to 0.3.0
  299. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  300. - update to 0.2.8
  301. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  302. - update to 0.2.6
  303. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  304. - update to 0.2.4
  305. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  306. - Initial import based on an SRPM from Richard Hughes