gstreamer-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472
  1. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  2. %define major 0.10
  3. %define _glib2_ver 2.20.0
  4. %define _libxml2_ver 2.6.15
  5. %define _gtk_doc_ver 1.3
  6. %define _check_ver 0.9.2
  7. %define _python_ver 2.1
  8. %define po_package %{name}-%{major}
  9. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  10. Name: gstreamer
  11. Summary: GStreamer streaming media framework runtime.
  12. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  13. Version: 0.10.32
  14. Release: 1%{?_dist_release}
  15. Group: System Environment/Libraries
  16. License: LGPL
  17. URL: http://gstreamer.freedesktop.org/
  18. Source: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: glib2-devel >= %{_glib2_ver}
  21. BuildRequires: libxml2-devel >= %{_libxml2_ver}
  22. BuildRequires: bison
  23. BuildRequires: gtk-doc >= %{_gtk_doc_ver}
  24. BuildRequires: flex
  25. BuildRequires: ghostscript
  26. BuildRequires: check >= %{_check_ver}
  27. BuildRequires: python >= %{_python_ver}, python-pyxml
  28. BuildRequires: gobject-introspection-devel
  29. Requires: glib2 >= %{_glib2_ver}
  30. Requires: libxml2 >= %{_libxml2_ver}
  31. Obsoletes: gstreamer-tools
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: inagaki
  35. %description
  36. GStreamer is a streaming-media framework, based on graphs of filters which
  37. operate on media data. Applications using this library can do anything
  38. from real-time sound processing to playing videos, and just about anything
  39. else media-related. Its plugin-based architecture means that new data
  40. types or processing capabilities can be added simply by installing new
  41. plugins.
  42. %package devel
  43. Summary: Libraries/header files for GStreamer streaming media framework.
  44. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: glib2-devel >= %{_glib2_ver}
  48. Requires: libxml2-devel >= %{_libxml2_ver}
  49. %description devel
  50. GStreamer is a streaming-media framework, based on graphs of filters which
  51. operate on media data. Applications using this library can do anything
  52. from real-time sound processing to playing videos, and just about anything
  53. else media-related. Its plugin-based architecture means that new data
  54. types or processing capabilities can be added simply by installing new
  55. plugins.
  56. This package contains the libraries and includes files necessary to develop
  57. applications and plugins for GStreamer.
  58. # compat32
  59. %package -n compat32-%{name}
  60. Summary: GStreamer streaming media framework runtime.
  61. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  62. Group: System Environment/Libraries
  63. %description -n compat32-%{name}
  64. GStreamer is a streaming-media framework, based on graphs of filters which
  65. operate on media data. Applications using this library can do anything
  66. from real-time sound processing to playing videos, and just about anything
  67. else media-related. Its plugin-based architecture means that new data
  68. types or processing capabilities can be added simply by installing new
  69. plugins.
  70. %package -n compat32-%{name}-devel
  71. Summary: Libraries/header files for GStreamer streaming media framework.
  72. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}-%{release}
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-glib2-devel >= %{_glib2_ver}
  77. Requires: compat32-libxml2-devel >= %{_libxml2_ver}
  78. %description -n compat32-%{name}-devel
  79. GStreamer is a streaming-media framework, based on graphs of filters which
  80. operate on media data. Applications using this library can do anything
  81. from real-time sound processing to playing videos, and just about anything
  82. else media-related. Its plugin-based architecture means that new data
  83. types or processing capabilities can be added simply by installing new
  84. plugins.
  85. This package contains the libraries and includes files necessary to develop
  86. applications and plugins for GStreamer.
  87. %prep
  88. %setup -q
  89. %build
  90. %configure \
  91. --with-package-name='Vine Linux gstreamer package' \
  92. --with-cachedir=%{_var}/cache/gstreamer-%{major} \
  93. --enable-introspection=yes \
  94. --disable-docbook --enable-gtk-doc \
  95. --disable-static --disable-examples \
  96. --disable-tests --disable-debug
  97. make %{?_smp_mflags}
  98. %install
  99. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  100. make install DESTDIR=$RPM_BUILD_ROOT
  101. mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  104. #rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
  105. %find_lang %{po_package}
  106. %clean
  107. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %files -f %{po_package}.lang
  113. %defattr(-, root, root)
  114. %doc AUTHORS ChangeLog COPYING README NEWS RELEASE
  115. %doc TODO ABOUT-NLS
  116. %{_bindir}/*
  117. %dir %{_libdir}/gstreamer-%{major}
  118. %{_libdir}/gstreamer-%{major}/*.so*
  119. %{_libdir}/*.so.*
  120. %{_libdir}/girepository-1.0/*.typelib
  121. %dir %{_libexecdir}/gstreamer-%{major}
  122. %{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
  123. %{_mandir}/man1/*
  124. %dir %{_var}/cache/gstreamer-%{major}
  125. %files devel
  126. %defattr(-, root, root)
  127. %dir %{_includedir}/%{name}-%{major}
  128. %{_includedir}/%{name}-%{major}/*
  129. #{_libdir}/*.a
  130. %{_libdir}/*.so
  131. %{_libdir}/pkgconfig/gstreamer*.pc
  132. %{_datadir}/aclocal/*.m4
  133. %{_datadir}/gtk-doc/html/gstreamer-%{major}
  134. %{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
  135. %{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
  136. %{_datadir}/gir-1.0/*.gir
  137. # compat32
  138. %if %{build_compat32}
  139. %files -n compat32-%{name}
  140. %defattr(-, root, root)
  141. %dir %{_libdir}/gstreamer-%{major}
  142. %{_libdir}/gstreamer-%{major}/*.so*
  143. %{_libdir}/*.so.*
  144. %files -n compat32-%{name}-devel
  145. %defattr(-, root, root)
  146. #{_libdir}/*.a
  147. %{_libdir}/*.so
  148. %{_libdir}/pkgconfig/gstreamer*.pc
  149. %endif
  150. %changelog
  151. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
  152. - new upstream release
  153. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
  154. - new upstream release
  155. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
  156. - new upstream release
  157. - add BuildRequires: gobject-introspection-devel
  158. - add configure option (--enable-introspection=yes)
  159. - fix %files
  160. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
  161. - build with rpm-4.8.1-1 for pkg-config file
  162. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
  163. - new upstream release
  164. * Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
  165. - new upstream release
  166. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
  167. - new upstream release
  168. - used make install instead of %%makeinstall
  169. * Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
  170. - new upstream release
  171. - built with new toolchain
  172. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
  173. - new upstream release
  174. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
  175. - new upstream release
  176. * Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
  177. - added compat32 package for x86_64 arch support
  178. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
  179. - new upstream release
  180. - removed static librairies from devel package
  181. - added Packager tag
  182. * Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
  183. - new upstream release
  184. - changed Group to System Environment/Libraries
  185. * Wed Oct 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
  186. - new upstream release
  187. - spec in UTF-8
  188. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
  189. - new upstream release
  190. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
  191. - new upstream release
  192. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
  193. - new upstream release
  194. * Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
  195. - new upstream release
  196. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
  197. - new upstream release
  198. * Sat Jun 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
  199. - new upstream release
  200. * Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
  201. - new upstream release
  202. - add Vendor/Distribution tag
  203. - add '-with-package-name' option to %%configure
  204. - use more macros
  205. * Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
  206. - new upstream release
  207. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
  208. - new upstream release
  209. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
  210. - new upstream release
  211. * Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
  212. - new upstream release
  213. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
  214. - new upstream release
  215. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
  216. - new upstream release
  217. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
  218. - new upstream release
  219. * Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
  220. - new upstream release
  221. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
  222. - new upstream release
  223. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
  224. - new upstream release
  225. - change major to 0.10
  226. - update URLs
  227. - update versions: glibc >= 2.8, gtk-doc >= 1.3
  228. - add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
  229. - remove from BuildRequires: popt, zlib-devel
  230. - remove obsolete options from %%configure
  231. - add --enable-gtk-doc to %%configure
  232. - add gtk-doc/html/gstreamer-* to gstreamer-devel package
  233. - add RELEASE to %%doc
  234. - remove REQUIREMENTS DOCBUILDING from %%doc
  235. - not exec gst-register-%%{major} at %%post
  236. * Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
  237. - new upstream release
  238. * Thu May 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
  239. - new upstream release
  240. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
  241. - new upstream release
  242. - removed dependancy related to documentaion build
  243. * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
  244. - new upstream release
  245. * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
  246. - new upstream release
  247. * Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
  248. - update alpha-noWerror patch (Patch10)
  249. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
  250. - new upstream release
  251. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  252. - new upstream release
  253. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
  254. - new upstream release
  255. * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
  256. - build without -Werror on alpha (Patch10)
  257. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  258. - new upstream release
  259. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
  260. - merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
  261. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  262. - fix broken %files entries..
  263. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  264. - new upstream release
  265. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
  266. - build for Vine Linux
  267. * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
  268. - Add patch1 to fix C++ plugins on ia64
  269. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  270. - %post -p was wrong
  271. * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
  272. - explicitly add %{_libdir}/libgstreamer-{major}.so
  273. - explicitly add %{_libdir}/libgstcontrol-{major}.so
  274. * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
  275. - bump release
  276. * Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
  277. - move .so files out of -devel
  278. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  279. - new version 0.5.0
  280. - require docbook-style-xsl
  281. - add gstreamer-tools package too
  282. - New patch to use the right docbook prefix.
  283. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  284. - downgrade to a release candidate. Should work better on other arches
  285. - build without Werror
  286. * Mon Dec 9 2002 Jonathan Blandford <jrb@redhat.com>
  287. - update to new version. Remove ExcludeArch
  288. * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
  289. - excludearch some arches
  290. * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
  291. - import into CVS and build "officially"
  292. - use smp_mflags
  293. - temporarily disable docs build, doesn't seem to work
  294. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  295. - 0.4.2
  296. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  297. - 0.4.1
  298. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  299. - minor cleanups
  300. * Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
  301. - moved header location
  302. * Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
  303. - added popt
  304. - removed .la
  305. * Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
  306. - added release of gstreamer to req of gstreamer-devel
  307. - changed location of API docs to be in gtk-doc like other gtk-doc stuff
  308. - reordered SPEC file
  309. * Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
  310. - moved html docs to gtk-doc standard directory
  311. * Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
  312. - move version defines of glib2 and libxml2 to configure.ac
  313. - add BuildRequires for these two libs
  314. * Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
  315. - put html docs in canonical place, avoiding %doc erasure
  316. - added devhelp support, current install of it is hackish
  317. * Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
  318. - Added documentation to build
  319. * Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
  320. - added libgstbasicscheduler
  321. - renamed libgst to libgstreamer
  322. * Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
  323. - Added configdir parameter as it seems the configdir gets weird otherwise
  324. * Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
  325. - split off gstreamer-editor from core
  326. - removed gstreamer-gnome-apps
  327. * Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
  328. - Cleaned up the spec file for the gstreamer core/plug-ins split
  329. - Improve spec file
  330. * Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
  331. - Split of more plugins from the core and put them into their own modules
  332. - Includes colorspace, xfree and wav
  333. - Improved package Require lines
  334. - Added mp3encode (lame based) to the SPEC
  335. * Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
  336. - Thomas merged mpeg plugins into one
  337. * Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
  338. - More minor cleanups including some fixed descriptions from Andrew Mitchell
  339. * Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
  340. - Added logging to the make statement
  341. * Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
  342. - Updated in preparation for 0.3.0 release
  343. * Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
  344. - Updated for 0.2.1 release
  345. - Split out the GUI packages into their own RPM
  346. - added new plugins (FLAC, festival, quicktime etc.)
  347. * Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
  348. - Visualisation plugins bundled out togheter
  349. - Moved files sections up close to their respective descriptions
  350. * Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
  351. - Split the package into separate RPMS,
  352. putting most plugins out by themselves.
  353. * Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
  354. - Updated with change suggestions from Dennis Bjorklund
  355. * Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
  356. - updated to build -devel package as well
  357. * Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
  358. - first draft of spec file