123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429 |
- Summary: Backends for the gio framework in GLib
- Summary(ja): GLib の GIO フレームワークのバックエンド
- Name: gvfs
- Version: 1.6.6
- Release: 1%{?_dist_release}
- License: LGPLv2+
- Group: System Environment/Libraries
- URL: http://www.gtk.org
- Source: http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.6/%{name}-%{version}.tar.bz2
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: pkgconfig
- BuildRequires: glib2-devel >= 2.24.0
- BuildRequires: dbus-glib-devel
- BuildRequires: /usr/bin/ssh
- BuildRequires: libcdio-devel >= 0.78.2
- BuildRequires: libsoup-devel >= 2.30.0
- BuildRequires: avahi-glib-devel >= 0.6
- BuildRequires: libgnome-keyring-devel
- BuildRequires: intltool
- BuildRequires: gettext
- BuildRequires: perl-XML-Parser
- BuildRequires: GConf2-devel
- BuildRequires: libgudev1-devel
- BuildRequires: gnome-disk-utility-devel >= 2.30
- Requires(post): desktop-file-utils
- Requires(postun): desktop-file-utils
- # The patch touches Makefile.am files:
- BuildRequires: automake autoconf
- BuildRequires: libtool
- Patch1: gvfs-0.99.2-archive-integration.patch
- %description
- The gvfs package provides backend implementations for the gio
- framework in GLib. It includes ftp, sftp, cifs.
- %package devel
- Summary: Development files for gvfs
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- The gvfs-devel package contains headers and other files that are
- required to develop applications using gvfs.
- %package fuse
- Summary: FUSE support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- BuildRequires: fuse-devel
- Requires: fuse
- %description fuse
- This package provides support for applications not using gio
- to access the gvfs filesystems.
- %package smb
- Summary: Windows fileshare support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- BuildRequires: libsmbclient-devel
- %description smb
- This package provides support for reading and writing files on windows
- shares (SMB) to applications using gvfs.
- %package archive
- Summary: Archiving support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- BuildRequires: libarchive-devel
- %description archive
- This package provides support for accessing files inside Zip and Tar archives,
- as well as ISO images, to applications using gvfs.
- %package obexftp
- Summary: ObexFTP support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- BuildRequires: bluez-libs-devel >= 4.15
- BuildRequires: expat-devel
- %description obexftp
- This package provides support for reading files on Bluetooth mobile phones
- and devices through ObexFTP to applications using gvfs.
- %package gphoto2
- Summary: gphoto2 support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- BuildRequires: libgphoto2-devel
- BuildRequires: libusb-devel
- BuildRequires: libexif-devel
- %description gphoto2
- This package provides support for reading and writing files on
- PTP based cameras (Picture Transfer Protocol) and MTP based
- media players (Media Transfer Protocol) to applications using gvfs.
- %package afc
- Summary: AFC support for gvfs
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: usbmuxd
- BuildRequires: libimobiledevice-devel >= 0.9.7
- %description afc
- This package provides support for reading files on mobile devices
- including phones and music players to applications using gvfs.
- %prep
- %setup -q
- %patch1 -p0 -b .archive-integration
- %build
- # Needed for gvfs-0.2.1-archive-integration.patch
- libtoolize --force || :
- aclocal || :
- autoheader || :
- automake || :
- autoconf || :
- %configure --disable-hal --enable-gdu
- make # %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm $RPM_BUILD_ROOT%{_libdir}/*.la
- rm $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.la
- %find_lang gvfs
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- # Reload .mount files:
- killall -USR1 gvfsd >&/dev/null || :
- # Update desktop files mime mappings:
- update-desktop-database &> /dev/null ||:
- update-gio-modules "$host" &> /dev/null || :
- %postun
- /sbin/ldconfig
- # Update desktop files mime mappings:
- update-desktop-database &> /dev/null ||:
- update-gio-modules "$host" &> /dev/null || :
- # Reload .mount files when single subpackage is installed:
- %post smb
- killall -USR1 gvfsd >&/dev/null || :
- %post archive
- killall -USR1 gvfsd >&/dev/null || :
- %post obexftp
- killall -USR1 gvfsd >&/dev/null || :
- %post gphoto2
- killall -USR1 gvfsd >&/dev/null || :
- %post afc
- killall -USR1 gvfsd >&/dev/null || :
- %files -f gvfs.lang
- %defattr(-, root, root, -)
- %doc AUTHORS COPYING NEWS README
- %dir %{_datadir}/gvfs
- %dir %{_datadir}/gvfs/mounts
- %{_sysconfdir}/profile.d/gvfs-bash-completion.sh
- %{_datadir}/gvfs/mounts/sftp.mount
- %{_datadir}/gvfs/mounts/trash.mount
- %{_datadir}/gvfs/mounts/cdda.mount
- %{_datadir}/gvfs/mounts/computer.mount
- %{_datadir}/gvfs/mounts/dav.mount
- %{_datadir}/gvfs/mounts/dav+sd.mount
- %{_datadir}/gvfs/mounts/http.mount
- %{_datadir}/gvfs/mounts/localtest.mount
- %{_datadir}/gvfs/mounts/burn.mount
- %{_datadir}/gvfs/mounts/dns-sd.mount
- %{_datadir}/gvfs/mounts/network.mount
- %{_datadir}/gvfs/mounts/ftp.mount
- %{_datadir}/dbus-1/services/org.gtk.Private.GduVolumeMonitor.service
- %{_datadir}/dbus-1/services/gvfs-daemon.service
- %{_datadir}/dbus-1/services/gvfs-metadata.service
- %{_datadir}/gvfs/remote-volume-monitors/gdu.monitor
- %{_libdir}/libgvfscommon.so.*
- %{_libdir}/libgvfscommon-dnssd.so.*
- %{_libdir}/gio/modules/libgioremote-volume-monitor.so
- %{_libdir}/gio/modules/libgvfsdbus.so
- %{_libdir}/gio/modules/libgiogconf.so
- %{_libexecdir}/gvfsd
- %{_libexecdir}/gvfsd-ftp
- %{_libexecdir}/gvfsd-sftp
- %{_libexecdir}/gvfsd-trash
- %{_libexecdir}/gvfsd-cdda
- %{_libexecdir}/gvfsd-computer
- %{_libexecdir}/gvfsd-dav
- %{_libexecdir}/gvfsd-http
- %{_libexecdir}/gvfsd-localtest
- %{_libexecdir}/gvfsd-burn
- %{_libexecdir}/gvfsd-dnssd
- %{_libexecdir}/gvfsd-network
- %{_libexecdir}/gvfsd-metadata
- %{_libexecdir}/gvfs-gdu-volume-monitor
- %{_bindir}/gvfs-cat
- %{_bindir}/gvfs-copy
- %{_bindir}/gvfs-info
- %{_bindir}/gvfs-less
- %{_bindir}/gvfs-ls
- %{_bindir}/gvfs-mkdir
- %{_bindir}/gvfs-monitor-dir
- %{_bindir}/gvfs-monitor-file
- %{_bindir}/gvfs-mount
- %{_bindir}/gvfs-move
- %{_bindir}/gvfs-open
- %{_bindir}/gvfs-rename
- %{_bindir}/gvfs-rm
- %{_bindir}/gvfs-save
- %{_bindir}/gvfs-set-attribute
- %{_bindir}/gvfs-trash
- %{_bindir}/gvfs-tree
- %files devel
- %defattr(-, root, root, -)
- %dir %{_includedir}/gvfs-client
- %dir %{_includedir}/gvfs-client/gvfs
- %{_includedir}/gvfs-client/gvfs/gvfsurimapper.h
- %{_includedir}/gvfs-client/gvfs/gvfsuriutils.h
- %{_libdir}/libgvfscommon.so
- %{_libdir}/libgvfscommon-dnssd.so
- %files fuse
- %defattr(-, root, root, -)
- %{_libexecdir}/gvfs-fuse-daemon
- %files smb
- %defattr(-, root, root, -)
- %{_libexecdir}/gvfsd-smb
- %{_libexecdir}/gvfsd-smb-browse
- %{_datadir}/gvfs/mounts/smb-browse.mount
- %{_datadir}/gvfs/mounts/smb.mount
- %files archive
- %defattr(-, root, root, -)
- %dir %{_datadir}/applications/mount-archive.desktop
- %{_libexecdir}/gvfsd-archive
- %{_datadir}/gvfs/mounts/archive.mount
- %files obexftp
- %defattr(-, root, root, -)
- %{_libexecdir}/gvfsd-obexftp
- %{_datadir}/gvfs/mounts/obexftp.mount
- %files gphoto2
- %defattr(-, root, root, -)
- %{_libexecdir}/gvfsd-gphoto2
- %{_datadir}/gvfs/mounts/gphoto2.mount
- %{_libexecdir}/gvfs-gphoto2-volume-monitor
- %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
- %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
- %files afc
- %defattr(-, root, root, -)
- %{_libexecdir}/gvfsd-afc
- %{_datadir}/gvfs/mounts/afc.mount
- %{_libexecdir}/gvfs-afc-volume-monitor
- %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
- %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
- %changelog
- * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
- - new upstream release
- - drop Patch2
- * Sun Oct 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
- - add Patch2 (gvfs-1.6.4-sftp-timeout.patch)
- * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
- - new upstream release
- * Sun Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
- - new upstream release
- * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
- - new upstream release
- * Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-3
- - rebuilt with libcdio-0.82
- * Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.1-2
- - add configure option --enable-gdu
- - add BR: gnome-disk-utility-devel
- - add afc subpackage for new AFC backend,
- providing access to Apple's iPhone, and iPod Touch devices
- * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
- - new upstream release
- * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
- - new upstream release
- - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
- - change BuildRequires: hal-devel -> ibgudev1-devel
- - add configure option (--disable-hal)
- * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
- - new upstream release
- * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-1
- - new upstream release
- * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-2
- - new upstream release
- * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
- - new upstream release
- * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-2
- - new upstream release
- * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
- - new upstream release
- - BR: bluez-libs-devel >= 4.15
- * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.1-2
- - rebuild with bluez-libs-devel-4.15
- * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
- - new upstream release
- * Mon Sep 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
- - new upstream release
- * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.6-1
- - new upstream release
- - split out backends to sub packages
- * Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
- - new upstream release
- * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.3-1vl5
- - new upstream release
- * Wed Apr 2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.2-1vl5
- - Initial build for Vine Linux
- * Fri Mar 28 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.2-1
- - Update to 0.2.2
- * Tue Mar 25 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-4
- - Moved fuse stuff to a dedicated package
- * Thu Mar 20 2008 Alexander Larsson <alexl@redhat.com> - 0.2.1-3
- - Add patch with simple archive backend UI integration
- * Tue Mar 19 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-2
- - Added libarchive dependency for archive backend
- - Require new libsmbclient in order to get smb backend working again
- * Tue Mar 18 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.2.1-1
- - Update to 0.2.1 (archive backend temporarily disabled)
- * Mon Mar 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.2.0.1-2
- - Silence %%post
- * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.2.0.1-1
- - Update to 0.2.0.1
- * Thu Mar 6 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.11-2
- - Add patch that fixes a deadlock when foreign volume is removed
- * Tue Mar 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.11-1
- - Update to 0.1.11
- * Tue Mar 04 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.1.10-1
- - Update to 0.1.10
- * Mon Feb 25 2008 Alexander Larsson <alexl@redhat.com> - 0.1.8-1
- - Update to 0.1.8
- * Thu Feb 14 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-3
- - Add patch that fixes a smb bug that can cause short reads when copying files
- * Tue Feb 12 2008 Alexander Larsson <alexl@redhat.com> - 0.1.7-2
- - Fix double free in hal volume monitor
- - Ensure gconf module is built by adding build dep
- * Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.7-1
- - Update to 0.1.7
- * Tue Jan 29 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.6-1
- - Update to 0.1.6
- * Mon Jan 28 2008 Matthias Clasen <mclasen@redhat.com> - 0.1.5-1
- - Update to 0.1.5
- - Reenable http/dav
- * Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-2
- - Remove the http/dav stuff for now, as we don't have the latest libsoup
- * Mon Jan 21 2008 Alexander Larsson <alexl@redhat.com> - 0.1.4-1
- - Update to 0.1.4
- - Send USR1 in post to reload config
- * Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> 0.1.2-1
- - Update to 0.1.2
- * Tue Jan 8 2008 Matthias Clasen <mclasen@redhat.com> 0.1.1-1
- - Update to 0.1.1
- * Thu Dec 20 2007 Matthias Clasen <mclasen@redhat.com> 0.1.0-1
- - Initial packaging
|