kBuild-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. %define origver 0.1.5-p2
  2. Summary: A cross-platform build environment
  3. Summary(ja): クロスプラットフォームビルド環境
  4. Name: kBuild
  5. Version: 0.1.5p2
  6. Release: 1%{?_dist_release}
  7. Group: Development/Tools
  8. License: BSD and GPLv2+
  9. # most tools are from NetBSD, some are from FreeBSD,
  10. # and make and sed are from GNU
  11. URL: http://svn.netlabs.org/kbuild
  12. Source0: ftp://ftp.netlabs.org/pub/kbuild/%{name}-%{origver}-src.tar.gz
  13. Patch0: kBuild-0.1.3-escape.patch
  14. Patch1: kBuild-0.1.5-dprintf.patch
  15. Patch2: kBuild-0.1.5-pthread.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: byacc libacl-devel flex
  18. BuildRequires: autoconf automake gettext-devel cvs
  19. %description
  20. This is a GNU make fork with a set of scripts to simplify
  21. complex tasks and portable versions of various UNIX tools to
  22. ensure cross-platform portability.
  23. It is used mainly to build VirtualBox OSE packages for RPM Fusion
  24. repository.
  25. %prep
  26. %setup -q -n %{name}-%{origver}
  27. %patch0 -p1 -b .escape
  28. %patch1 -p1 -b .dprintf
  29. %patch2 -p1 -b .pthreads
  30. # Remove prebuilt stuff
  31. rm -rf kBuild/bin/*
  32. %build
  33. %define bootstrap_mflags %{_smp_mflags} \\\
  34. CFLAGS="%{optflags}" \\\
  35. KBUILD_VERBOSE=2
  36. %define mflags %{bootstrap_mflags} \\\
  37. NIX_INSTALL_DIR=%{_prefix} \\\
  38. BUILD_TYPE=release \\\
  39. MY_INST_MODE=0644 \\\
  40. MY_INST_BIN_MODE=0755
  41. # The bootstrap would probably not be needed if we depended on ourselves,
  42. # yet it is not guarranteed that new versions are compilable with older
  43. # kmk versions, so with this we are on a safer side
  44. kBuild/env.sh --full make -f bootstrap.gmk %{bootstrap_mflags}
  45. kBuild/env.sh kmk %{mflags} rebuild
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. export KBUILD_VERBOSE=2
  49. kBuild/env.sh kmk %{mflags} PATH_INS=$RPM_BUILD_ROOT install
  50. # These are included later in files section
  51. rm -r $RPM_BUILD_ROOT%{_docdir}
  52. %clean
  53. rm -rf $RPM_BUILD_ROOT
  54. %files
  55. %defattr(-,root,root,-)
  56. %{_bindir}/*
  57. %{_datadir}/*
  58. %doc COPYING ChangeLog
  59. %doc kBuild/doc/COPYING-FDL-1.3 kBuild/doc/QuickReference*
  60. %changelog
  61. * Sun Apr 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5p2-1
  62. - update to 0.1.5-p2
  63. - add patch2 to fix build
  64. * Fri May 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-1
  65. - initial build for Vine Linux
  66. * Mon Apr 13 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-4
  67. - Fix typoes (Robert P. J. Day, #495393)
  68. - Comment out the colliding dprintf
  69. * Sun Mar 1 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-3
  70. - Fix up BRs
  71. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.5-2
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  73. * Sat Jan 24 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-1
  74. - Update to new upstream release
  75. * Tue Dec 30 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.5-0.1.20081106svn
  76. - Update to build VirtualBox OSE 2.1.0
  77. * Fri Sep 19 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.4-1
  78. - New upstream release
  79. * Thu Aug 28 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-2
  80. - Add gettext-devel to BRs for autopoint
  81. * Sun Aug 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.1.3-1
  82. - New upstream version
  83. - Install into FHS hierarchy
  84. - Honour optflags
  85. - No need to be arch specific
  86. * Tue Oct 30 2007 Till Maas <opensource till name> - 0.1.0-0.3.20070627svn
  87. - add support for x86_64
  88. - add BR: autoconf, automake
  89. * Wed Jun 27 2007 Till Maas <opensource till name> - 0.1.0-0.2.20070627svn
  90. - Update to a new version
  91. - just copy the bin files to %%{_libexecdir}, kmk install does not work
  92. * Sun Feb 18 2007 Till Maas <opensource till name> - 0.1.0-0.1.20070218svn
  93. - Initial spec for fedora extras