konq-plugins-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. # The 4.6.1 tarball is missing all documentation, keep the old one for now.
  2. %global docversion 4.4.0
  3. Name: konq-plugins
  4. Summary: Additional plugins that interact with konqueror
  5. Version: 4.6.1
  6. Release: 2%{?_dist_release}
  7. Group: Applications/Internet
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://extragear.kde.org
  10. Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/konq-plugins-%{version}.tar.bz2
  11. Source1: ftp://ftp.kde.org/pub/kde/stable/%{docversion}/src/extragear/konq-plugins-%{docversion}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. ## upstream patches
  14. BuildRequires: cmake
  15. BuildRequires: gettext
  16. BuildRequires: kdebase4-devel >= %{version}
  17. BuildRequires: libtidy-devel
  18. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
  19. Requires: kdebase4 >= %{version}
  20. %description
  21. Some additional plugins that interact with konqueror
  22. * adblock: AdBlock plugin
  23. * akregator: Add feeds directly to akregator (kdepim is needed)
  24. * autorefresh: Refresh websites after a specifig period
  25. * babelfish: Translate a website with babelfish
  26. * crashes: Crash monitor
  27. * dirfilter: Filter the current directory in many ways
  28. * domtreeviewer: Displays the document object model in a box
  29. * fsview: Graphical Disk Usage for inode/directory
  30. * imagerotation: service menu to image operations
  31. * khtmlsettingsplugin: Enable/disable some HTML settings
  32. * kimggalleryplugin: Creates an HTML page with thumbnails of
  33. all the images in the current directory.
  34. * mediarealfolder: service menu to open a medium mountpoints
  35. * minitools: Implement bookmarklets into konqueror
  36. * rellinks: Allows access to relations defined in the header of a document
  37. * searchbar: Search Bar
  38. * sidebar: a small embedded mediaplayer, for songs/video preview
  39. * smbmounter: provides two menus items to smbmount/umount samba shares
  40. * uachanger: Change the user agent for websites
  41. * validators: Website validators
  42. * webarchiver: Web Archiver
  43. %prep
  44. %setup -q -a 1
  45. # use documentation from the old tarball
  46. mv -f %{name}-%{docversion}/doc* .
  47. tail -n 2 %{name}-%{docversion}/CMakeLists.txt >>CMakeLists.txt
  48. rm -rf %{name}-%{docversion}
  49. %build
  50. mkdir -p %{_target_platform}
  51. pushd %{_target_platform}
  52. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  53. %cmake \
  54. -DCMAKE_BUILD_TYPE=release \
  55. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  56. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  57. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  58. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  59. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  60. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  61. ..
  62. popd
  63. make %{?_smp_mflags} -C %{_target_platform}
  64. %install
  65. rm -rf %{buildroot}
  66. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  67. # don't install kwebkitpart stuff on RHEL
  68. #rm -rf %{buildroot}%{_kde4_appsdir}/kwebkitpart/
  69. #find_lang %{name}
  70. #--with-kde
  71. %clean
  72. rm -rf %{buildroot}
  73. %post
  74. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  75. touch --no-create %{_datadir}/icons/oxygen &> /dev/null || :
  76. %postun
  77. if [ $1 -eq 0 ] ; then
  78. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  79. touch --no-create %{_datadir}/icons/oxygen &> /dev/null
  80. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  81. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  82. fi
  83. %posttrans
  84. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  85. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null || :
  86. #-f %{name}.lang
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc COPYING COPYING.DOC COPYING.LIB README
  90. %{_bindir}/fsview
  91. %{_datadir}/config/translaterc
  92. # co-owned with kdepim, since there's no shared dep
  93. %{_datadir}/kde4/apps/akregator/
  94. %{_datadir}/kde4/apps/dolphinpart/kpartplugins/*
  95. %{_datadir}/kde4/apps/domtreeviewer/
  96. %{_datadir}/kde4/apps/fsview/
  97. %{_datadir}/kde4/apps/khtml/kpartplugins/*
  98. %{_datadir}/kde4/apps/konqueror/icons/*
  99. %{_datadir}/kde4/apps/konqueror/kpartplugins/*
  100. %{_datadir}/kde4/apps/konqueror/opensearch/*
  101. %{_datadir}/kde4/apps/kwebkitpart/kpartplugins/*
  102. %{_datadir}/config.kcfg/validators.kcfg
  103. %{_datadir}/kde4/services/*.desktop
  104. %{_datadir}/kde4/services/ServiceMenus/*.desktop
  105. %{_datadir}/icons/hicolor/*/*/*
  106. %{_datadir}/icons/oxygen/*/*/*
  107. %{_libdir}/kde4/*.so
  108. %{_docdir}/HTML/*/konq-plugins
  109. %changelog
  110. * Mon Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.1-2
  111. - initial build for Vine Linux
  112. * Sat Mar 05 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.1-1
  113. - update to 4.6.1, fixes file conflict with kde-l10n
  114. - drop upstreamed patches
  115. - use documentation from 4.4.0 because it's missing in 4.6.1
  116. - drop old commented-out translation-finding code
  117. - drop no longer needed BR webkitpart-devel, code uses abstract interfaces now
  118. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-7
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  120. * Tue Oct 26 2010 Alexey Kurov <nucleo@fedoraproject.org> - 4.4.0-6
  121. - Fix the window.close regression in adblock (kde#253921)
  122. * Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-5
  123. - Embeddable Image Viewer permanently messes up status bar (kde#234624)
  124. * Tue Sep 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-4
  125. - ftbfs qt47 issues (#599830)
  126. * Tue Feb 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-3
  127. - Requires: kdebase4 (it's not multilib'd, no need for arch'd dep)
  128. * Sat Feb 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.4.0-2
  129. - backport upstream patch to fix BabelFish plugin WebKitPart support (#564552)
  130. * Fri Feb 12 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-1
  131. - konq-plugins-4.4.0 for real
  132. * Thu Feb 11 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.4.0-0.1.20100211
  133. - home-brew konq-plugins-4.4.0 (20100211 create_tarball.rb snapshot)
  134. * Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-5
  135. - BR libtidy-devel (Fedora only)
  136. * Thu Dec 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-4
  137. - fix build with KDE 4.3.80's version of webkitkde (upstream patch)
  138. * Wed Nov 25 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.3-3
  139. - rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
  140. * Mon Nov 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-2
  141. - BR: webkitpart-devel >= 0.0.2
  142. * Sat Nov 07 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-1
  143. - 4.3.3
  144. * Mon Oct 26 2009 Than Ngo <than@redhat.com> - 4.3.1-3
  145. - rhel cleanup
  146. * Sun Sep 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-2
  147. - BR: webkitpart-devel
  148. - use %%find_lang --all-names --with-kde
  149. - Requires: kdebase4%%{_?isa} >= %%version
  150. * Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 4.3.1-1
  151. - 4.3.1
  152. - use scriplet for HTML docdirs
  153. * Tue Aug 11 2009 Sebastian Vahl <fedora@deadbabylon.de> 4.3.0-1
  154. * KDE 4.3.0
  155. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.3-2
  156. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  157. * Fri May 08 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.3-1
  158. - 4.2.3
  159. * Tue Apr 7 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
  160. - KDE 4.2.2
  161. * Wed Mar 25 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-4
  162. - fixup handbook install
  163. - optimize scriptlets
  164. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-3
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  166. * Wed Feb 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-2
  167. - update %%description
  168. - Requires: kdebase4 >= 4.2
  169. * Fri Jan 23 2009 Than Ngo <than@redhat.com> - 4.2.0-1
  170. - 4.2.0
  171. * Mon Jan 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.3-4
  172. - make install/fast
  173. - jpegorient is not installed (#478736, kdebug#178612)
  174. * Sun Dec 14 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.3-3
  175. - rebuild for Python 2.6 (contains Python bytecode despite no dependencies)
  176. * Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-2
  177. - include adblock language files
  178. * Tue Nov 11 2008 Sebastian Vahl <fedora@deadbabylon.de> 4.1.3-1
  179. - 4.1.3
  180. * Sat Oct 04 2008 Than Ngo <than@redhat.com> 4.1.2-1
  181. - 4.1.2
  182. * Fri Aug 29 2008 Than Ngo <than@redhat.com> 4.1.1-1
  183. - 4.1.1
  184. * Thu Aug 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.1.0-2
  185. - fix data files from akregator plugin not getting installed
  186. * Wed Aug 06 2008 Rex Dieter <rdieter@fedoraproject.org> - 4.1.0-1
  187. - 4.1.0
  188. - drop searchbar-crash patch (no longer needed with Konqueror 4.1)
  189. * Sun May 04 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.3.20080409svn
  190. - fix searchbar plugin crash (#445144)
  191. * Wed Apr 16 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.0.3-0.2.20080409svn
  192. - rebuild because of corrupt PPC RPM causing signing failure (#442761)
  193. * Wed Apr 09 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.3-0.1.20080409svn
  194. - new svn checkout
  195. - some minor spec cleanups
  196. - License: GPLv2+ and LGPLv2+
  197. - drop icons patch
  198. * Tue Apr 01 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.2.20080303svn
  199. - rebuild for NDEBUG and _kde4_libexecdir
  200. - enhance %%description a bit
  201. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.2-0.1.20080303svn
  202. - new svn checkout (for KDE 4.0.2)
  203. - update cmakelists patch
  204. - remove icons patch (not needed anymore)
  205. - add "svn" to release
  206. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.2.20080214svn
  207. - added konq-plugins-4.0.1-icons.patch
  208. - add .po files to tarball
  209. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.1-0.1.20080213svn
  210. - initial version