libfli-vl.spec 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. %define majorver 1
  2. Name: libfli
  3. Version: 1.7
  4. Release: 8%{?_dist_release}
  5. Summary: Library for FLI CCD Camera & Filter Wheels
  6. Group: System Environment/Libraries
  7. # Code and LICENSE.LIB have different versions of the BSD license
  8. # https://sourceforge.net/tracker2/?func=detail&aid=2568511&group_id=90275&atid=593019
  9. License: BSD
  10. URL: http://indi.sourceforge.net/index.php
  11. Source0: http://downloads.sourceforge.net/indi/%{name}%{majorver}_%{version}.tar.gz
  12. Patch0: libfli-suffix.patch
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake
  15. %description
  16. Finger Lakes Instrument library is used by applications to control FLI
  17. line of CCDs and Filter wheels
  18. %package devel
  19. Summary: Libraries, includes, etc. used to develop an application with %{name}
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}-%{release}
  22. %description devel
  23. These are the header files needed to develop a %{name} application
  24. %prep
  25. %setup -q -n %{name}%{majorver}-%{version}
  26. %patch0 -p1
  27. %build
  28. mkdir -p %{_target_platform}
  29. pushd %{_target_platform}
  30. CFLAGS="${CFLAGS:-%optflags}" \
  31. CXXFLAGS="${CXXFLAGS:-%optflags}" \
  32. FFLAGS="${FFLAGS:-%optflags}" \
  33. %cmake \
  34. -DCMAKE_BUILD_TYPE=release \
  35. -DDATA_INSTALL_DIR:PATH=%{_datadir} \
  36. ..
  37. popd
  38. make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
  39. %install
  40. rm -fr %{buildroot}
  41. make install DESTDIR=%{buildroot} -C %{_target_platform}
  42. %clean
  43. rm -fr %{buildroot}
  44. %post -p /sbin/ldconfig
  45. %postun -p /sbin/ldconfig
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc LICENSE.BSD
  49. %{_libdir}/*.so.*
  50. %files devel
  51. %defattr(-,root,root,-)
  52. %{_includedir}/*
  53. %{_libdir}/*.so
  54. %changelog
  55. * Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7-8
  56. - use %%cmake macro
  57. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-7
  58. - Initial build for Vine Linux
  59. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-6
  60. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  61. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-5
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  63. * Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 1.7-4
  64. - Adding disttag
  65. * Thu Feb 05 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 1.7-3
  66. - Description lines wrapped around
  67. - Consistent macros
  68. - Redownloaded source from upstream
  69. * Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 1.7-2
  70. - Added patch to use LIB_SUFFIX
  71. * Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 1.7-1
  72. - First specfile version