ffmpeg-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323
  1. #TODO: Build with openjpeg
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. ## available for v0.6 or lower
  5. %define with_libfaad 1
  6. %define with_faac 1
  7. %define with_vaapi 1
  8. %define with_libvpx 1
  9. Summary: Digital VCR and streaming server
  10. Name: ffmpeg
  11. Version: 0.6.1
  12. Release: 2%{?svndate:.%svndate}%{?_dist_release}
  13. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  14. Source1: %{name}-snapshot.sh
  15. # pre-built man files
  16. Source90: ffmpeg.1.gz
  17. Source91: ffplay.1.gz
  18. Source92: ffserver.1.gz
  19. Source93: ffprobe.1.gz
  20. License: GPLv2+
  21. Group: Applications/Multimedia
  22. URL: http://ffmpeg.org/
  23. BuildRequires: bzip2-devel
  24. ##BuildRequires: dirac-devel
  25. BuildRequires: gsm-devel
  26. BuildRequires: imlib2-devel
  27. BuildRequires: libdc1394-devel
  28. BuildRequires: libraw1394-devel
  29. BuildRequires: librtmp-devel >= 2.3
  30. BuildRequires: libtheora-devel
  31. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  32. BuildRequires: libvdpau-devel
  33. BuildRequires: libvorbis-devel
  34. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  35. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
  36. ##BuildRequires: openjpeg-devel
  37. ##BuildRequires: schroedinger-devel
  38. BuildRequires: SDL-devel
  39. BuildRequires: speex-devel
  40. ##BuildRequires: texi2html
  41. BuildRequires: zlib-devel
  42. BuildRequires: libogg-devel
  43. %ifarch %{ix86} x86_64
  44. BuildRequires: yasm
  45. %endif
  46. # *-devel packages provided by other self-build-* should only be listed
  47. # in self-build-%{name}.spec as PreReq.
  48. #BuildRequires: a52dec-devel
  49. #BuildRequires: faac-devel
  50. #BuildRequires: lame-devel
  51. #BuildRequires: libdca-devel
  52. #BuildRequires: faad2-devel
  53. #BuildRequires: x264-devel >= 0.0.0-15.20110322
  54. #BuildRequires: xvidcore-devel
  55. Requires: %{name}-libs = %{version}-%{release}
  56. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  57. %description
  58. FFMpeg is a complete and free Internet live audio and video
  59. broadcasting solution for Linux/Unix. It also includes a digital
  60. VCR. It can encode in real time in many formats including MPEG1 audio
  61. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  62. %package libs
  63. Summary: Libraries for %{name}
  64. Group: System Environment/Libraries
  65. %description libs
  66. FFMpeg is a complete and free Internet live audio and video
  67. broadcasting solution for Linux/Unix. It also includes a digital
  68. VCR. It can encode in real time in many formats including MPEG1 audio
  69. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  70. This package contains the libraries for %{name}.
  71. %package devel
  72. Summary: Development package for %{name}
  73. Group: Development/Libraries
  74. Requires: %{name}-libs = %{version}-%{release}
  75. Requires: pkgconfig
  76. %description devel
  77. FFMpeg is a complete and free Internet live audio and video
  78. broadcasting solution for Linux/Unix. It also includes a digital
  79. VCR. It can encode in real time in many formats including MPEG1 audio
  80. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  81. This package contains development files for %{name}.
  82. %prep
  83. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  84. #% setup -q
  85. #%patch0 -p1 -b .textrel
  86. %build
  87. %ifarch ppc
  88. # compile with -mlongcall on ppc/ppc64 (rf804)
  89. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  90. %endif
  91. ./configure \
  92. --prefix=%{_prefix} \
  93. --incdir=%{_includedir}/%{name} \
  94. --shlibdir=%{_libdir} \
  95. --libdir=%{_libdir} \
  96. --mandir=%{_mandir} \
  97. --arch=%{_target_cpu} \
  98. %ifarch %{ix86}
  99. --cpu=%{_target_cpu} \
  100. %endif
  101. %ifarch ppc
  102. --cpu=g3 \
  103. --enable-pic \
  104. %endif
  105. --enable-runtime-cpudetect \
  106. --extra-cflags="$RPM_OPT_FLAGS" \
  107. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
  108. --enable-bzlib \
  109. --enable-zlib \
  110. --enable-libdc1394 \
  111. %{?_with_libdirac:--enable-libdirac} \
  112. %{?with_faac:--enable-libfaac --enable-nonfree} \
  113. %{?with_libfaad:--enable-libfaad} \
  114. --enable-libgsm \
  115. --enable-libmp3lame \
  116. %{?_with_openjpeg:--enable-libopenjpeg} \
  117. --enable-librtmp \
  118. --enable-libspeex \
  119. --enable-libtheora \
  120. --enable-libvorbis \
  121. %{?with_libvpx:--enable-libvpx} \
  122. --enable-libx264 \
  123. --enable-libxvid \
  124. \
  125. --enable-x11grab \
  126. --enable-avfilter \
  127. --enable-postproc \
  128. --enable-pthreads \
  129. --disable-static \
  130. --enable-shared \
  131. --enable-gpl \
  132. --disable-doc \
  133. --disable-debug \
  134. --disable-stripping \
  135. ;
  136. %{__make} %{?_smp_mflags}
  137. #% {__make}
  138. #%{__make} documentation
  139. %install
  140. %__make install DESTDIR=$RPM_BUILD_ROOT
  141. # ## install tool/qt-faststart
  142. # %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  143. ## install man
  144. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  145. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
  146. $RPM_BUILD_ROOT%{_mandir}/man1/
  147. %clean
  148. %{__rm} -rf $RPM_BUILD_ROOT
  149. %post libs -p /sbin/ldconfig
  150. %postun libs -p /sbin/ldconfig
  151. %files
  152. %defattr(-,root,root,-)
  153. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  154. %{_bindir}/ffmpeg
  155. %{_bindir}/ffplay
  156. %{_bindir}/ffprobe
  157. %{_bindir}/ffserver
  158. #%{_bindir}/qt-faststart
  159. %{_mandir}/man1/ffmpeg.1*
  160. %{_mandir}/man1/ffplay.1*
  161. %{_mandir}/man1/ffprobe.1*
  162. %{_mandir}/man1/ffserver.1*
  163. %{_datadir}/ffmpeg
  164. %files libs
  165. %defattr(-,root,root,-)
  166. %{_libdir}/lib*.so.*
  167. %files devel
  168. %defattr(-,root,root,-)
  169. %doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
  170. %{_includedir}/ffmpeg
  171. %{_libdir}/pkgconfig/lib*.pc
  172. %{_libdir}/lib*.so
  173. %changelog
  174. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  175. - required latest x264 build
  176. - added BuildRequires: librtmp-devel >= 2.3
  177. - build PIC objects on PPC
  178. #- add qt-faststart tool
  179. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  180. - new upstream release
  181. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  182. - change release to sync with self-build-ffmpeg-vl.spec
  183. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  184. - added BuildRequires: libvpx-devel >= 0.9.1
  185. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  186. - new upstream release
  187. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  188. - bumped version to pre-0.6
  189. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  190. - updated source snapshot 20100410
  191. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  192. - change release to sync with self-build-ffmpeg-vl.spec
  193. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  194. - change release to sync with self-build-ffmpeg-vl.spec
  195. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  196. - updated source snapshot 20100401
  197. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  198. - updated source snapshot 20100326
  199. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  200. - change release to sync with self-build-ffmpeg
  201. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  202. - updated source snapshot 20100216
  203. - rebuild with recent x264-devel
  204. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  205. - added BuildRequires: libvdpau-devel
  206. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  207. - change release to sync with self-build-ffmpeg
  208. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  209. - change release to sync with self-build-ffmpeg
  210. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  211. - applied ffmpeg-0.5-disable-texi2html.patch
  212. - dropped BuildRequires: texi2html
  213. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  214. - change release to sync with self-build-ffmpeg
  215. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  216. - corrected release number
  217. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  218. - new upstream release
  219. - added BuildRequires:
  220. - speex-devel
  221. - bzip2-devel
  222. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  223. - 20090227 snapshot
  224. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  225. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  226. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  227. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  228. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  229. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  230. - 20090202 snapshot
  231. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  232. - 20090110 snapshot
  233. - dropped some patches
  234. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  235. - source updated (r15488)
  236. - fixed License: GPLv2+
  237. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  238. - added BuildRequires: yasm (only %%ix86)
  239. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  240. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  241. - spec in utf8
  242. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  243. - change release to sync with self-build-ffmpeg
  244. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  245. - drop "Patch100: ffmpeg-vine.patch".
  246. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  247. - build with new versioning policy
  248. - change to use svn export from svn checkout on post install
  249. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  250. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  251. - [self-build-ffmpeg.spec]
  252. For all pre-required package that is provied by self-build,
  253. changed to its self-build package
  254. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  255. - initial build for Vine Linux 4.2
  256. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  257. ### end of file