perl-PPI-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-PPI
  4. Version: 1.215
  5. Release: 1%{?_dist_release}
  6. Summary: Parse, Analyze and Manipulate Perl
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/PPI/
  10. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
  11. Patch0: PPI-1.215-UTF8.patch
  12. BuildArch: noarch
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(List::Util) >= 1.20
  15. BuildRequires: perl(Storable) >= 2.17
  16. BuildRequires: perl(Clone) >= 0.30
  17. BuildRequires: perl(Digest::MD5) >= 2.35
  18. BuildRequires: perl(File::Remove) >= 1.42
  19. BuildRequires: perl(IO::String) >= 1.07
  20. BuildRequires: perl(List::MoreUtils) >= 0.16
  21. BuildRequires: perl(Params::Util) >= 1.00
  22. BuildRequires: perl(Task::Weaken)
  23. BuildRequires: perl(Test::More) >= 0.86
  24. BuildRequires: perl(Test::NoWarnings) >= 0.084
  25. BuildRequires: perl(Test::Object) >= 0.07
  26. BuildRequires: perl(Test::SubCalls) >= 1.07
  27. BuildRequires: perl(Class::Inspector) >= 1.25
  28. # Circular dependencies in release tests, so don't do them when bootstrapping:
  29. # Perl::MinimumVersion -> PPI
  30. %if 0%{!?perl_bootstrap:1}
  31. BuildRequires: perl(File::Find::Rule) >= 0.32
  32. BuildRequires: perl(File::Find::Rule::Perl) >= 1.09
  33. BuildRequires: perl(Perl::MinimumVersion) >= 1.20
  34. BuildRequires: perl(Test::ClassAPI) >= 1.03
  35. BuildRequires: perl(Test::CPAN::Meta)
  36. BuildRequires: perl(Test::MinimumVersion) >= 0.101080
  37. BuildRequires: perl(Test::Pod) >= 1.00
  38. %endif
  39. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. Packager: shaolin
  43. %description
  44. Parse, analyze and manipulate Perl (without perl).
  45. %prep
  46. %setup -q -n PPI-%{version}
  47. # Re-code docs as UTF-8
  48. %patch0 -p1
  49. # Filter out redundant unversioned provides
  50. %if %{_dist_release} > "vl6"
  51. %global __provides_exclude ^perl\\(PPI::.+\\)$
  52. %else
  53. cat << \EOF > %{name}-prov
  54. #!/bin/sh
  55. %{__perl_provides} $* |\
  56. sed -e '/^perl(PPI::.\+)$/d'
  57. EOF
  58. %global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
  59. chmod +x %{__perl_provides}
  60. %endif
  61. %build
  62. perl Makefile.PL INSTALLDIRS=vendor
  63. make %{?_smp_mflags}
  64. %install
  65. make pure_install DESTDIR=%{buildroot}
  66. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  67. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  68. %{_fixperms} %{buildroot}
  69. %check
  70. make test
  71. %if 0%{!?perl_bootstrap:1}
  72. make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
  73. %endif
  74. %files
  75. %doc Changes LICENSE README inline2test.conf inline2test.tpl
  76. %{perl_vendorlib}/PPI/
  77. %{perl_vendorlib}/PPI.pm
  78. %{_mandir}/man3/PPI*.3pm*
  79. %changelog
  80. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
  81. - initial build for Vine Linux
  82. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  84. * Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
  85. - always run test suite but don't run release tests when bootstrapping
  86. - nobody else likes macros for commands
  87. - clean up for modern rpm:
  88. - drop explicit buildroot tag
  89. - drop buildroot cleaning
  90. - drop %%defattr
  91. - use native provides filtering
  92. - use a patch rather than scripting iconv to fix character encoding
  93. - upstream file permissions no longer need fixing
  94. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
  95. - rebuild with Perl 5.14.1
  96. - use perl_bootstrap macro
  97. * Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
  98. - update to 1.215 (general fix release):
  99. - index_locations on an empty document no longer warns
  100. - Corrected a bug in line-spanning attribute support
  101. - Regression test for line-spanning attribute support
  102. - return { foo => 1 } should parse curlys as hash constructor, not block
  103. (CPAN RT#61305)
  104. - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
  105. - Updated copyright year to 2011
  106. - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
  107. - Backed out glob fix
  108. - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
  109. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
  110. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  111. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
  112. - rebuild to fix problems with vendorarch/lib (#661697)
  113. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
  114. - update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
  115. - Updated to Module::Install 1.00
  116. - Updated module dependencies in xt author tests
  117. - Fixed extremely broken PPI::Token::Pod::merge and added test case
  118. - bump perl(Perl::MinimumVersion) requirement to 1.25
  119. - bump perl(Test::CPAN::Meta) requirement to 0.17
  120. - bump perl(Test::Pod) requirement to 1.44
  121. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
  122. - update to 1.212 (experimental/development support and bugfixes)
  123. - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
  124. - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
  125. - Upgraded to Module::Install 0.93
  126. - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
  127. - Added an extra test case to validate we handle byte order marks properly
  128. - Moved author tests from t to xt
  129. - Fixed CPAN RT#26082: scalar { %%x } is misparsed
  130. - Fixed CPAN RT#26591: VMS patch for PPI 1.118
  131. - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
  132. - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
  133. - run release tests as well as regular test suite
  134. - BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
  135. perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
  136. for release tests
  137. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
  138. - update to 1.210 (packaging fixes)
  139. - use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
  140. * Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
  141. - update to 1.209 (small optimisation release, no functional changes)
  142. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
  143. - update to 1.208
  144. - don't assign '' to $^W, it generates a warning on Gentoo
  145. - added missing PPI::Token::Regexp fix to Changes file
  146. - updating Copyright to the new year
  147. - fixed #50309: literal() wrong result on "qw (a b c)"
  148. - PPI::Dumper no longer causes Elements to flush location data
  149. - PPI::Dumper no longer disables location information for non-Documents
  150. - +{ package => 1 } doesn't create a PPI::Statement::Package
  151. - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
  152. - use %%{_fixperms} macro instead of our own chmod incantation
  153. * Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
  154. - BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
  155. - enable AUTOMATED_TESTING
  156. - use DESTDIR rather than PERL_INSTALL_ROOT
  157. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
  158. - Mass rebuild with perl-5.12.0
  159. * Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
  160. - fix filtering, provide versioned provides
  161. * Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
  162. - make rpmlint happy
  163. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
  164. - rebuild against perl 5.10.1
  165. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
  166. - new upstream version
  167. - update build requires
  168. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  170. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
  171. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  172. * Tue Sep 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
  173. - update to 1.203
  174. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
  175. - Rebuild for perl 5.10 (again)
  176. * Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
  177. - rebuild for new perl
  178. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
  179. - bump to 1.201
  180. * Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
  181. - Update to 1.118.
  182. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
  183. - Update to 1.117.
  184. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
  185. - Removed the perl(IO::Scalar) build requirement.
  186. * Sun Jun 4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
  187. - Update to 1.115.
  188. * Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
  189. - Update to 1.113.
  190. * Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
  191. - Update to 1.112.
  192. * Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
  193. - First build.