kdegames3-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518
  1. %define make_cvs 1
  2. # These games are already in KDE 4.
  3. %define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines klickety kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
  4. Name: kdegames3
  5. Summary: KDE Games not ported to KDE 4
  6. Summary(ja): KDE 4 に移植されていない KDE ゲーム集
  7. Version: 3.5.10
  8. Release: 2%{?_dist_release}
  9. License: GPLv2
  10. Group: Applications/Games
  11. URL: http://www.kde.org/
  12. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
  13. Patch0: kdegames-3.5.10-trademarks.patch
  14. # fix build with make_cvs enabled and autoconf >= 2.64
  15. Patch1: arts-acinclude.patch
  16. # fix FTBFS with the new stricter ld in F13 (#565113)
  17. Patch2: kdegames-3.5.10-ftbfs.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: kdelibs3-devel >= %{version}
  20. BuildRequires: zlib-devel libpng-devel libjpeg-devel
  21. %if %{make_cvs}
  22. BuildRequires: automake libtool
  23. %endif
  24. Requires: kdelibs3 >= %{version}
  25. Requires: hicolor-icon-theme
  26. %description
  27. Games and gaming libraries for KDE which have not been ported to KDE 4 yet.
  28. Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
  29. kenolaba, kfouleggs, kpoker, ksirtet, ksmiletris, ksnake.
  30. %package devel
  31. Summary: Development files for kdegames3
  32. Summary(ja): kdegames3 の開発用ファイル
  33. Group: Development/Libraries
  34. License: LGPLv2
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: kdelibs3-devel >= %{version}
  37. %description devel
  38. Development files for the KDE gaming libraries.
  39. Install kdegames-devel if you wish to develop or compile games for the
  40. KDE desktop.
  41. %prep
  42. %setup -q -n kdegames-%{version}
  43. %patch0 -p1
  44. %patch1 -p1 -b .autoconf
  45. %patch2 -p1 -b .ftbfs
  46. export DO_NOT_COMPILE="%{donotcompilelist}"
  47. %if %{make_cvs}
  48. # hack/fix for newer automake
  49. sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
  50. make -f admin/Makefile.common cvs
  51. %endif
  52. %build
  53. unset QTDIR || : ; . /etc/profile.d/qt.sh
  54. export DO_NOT_COMPILE="%{donotcompilelist}"
  55. %configure \
  56. --with-qt-libraries=$QTDIR/lib \
  57. --enable-new-ldflags \
  58. --disable-dependency-tracking \
  59. --disable-rpath \
  60. --enable-final \
  61. --disable-debug \
  62. --disable-warnings \
  63. --includedir=%{_includedir}/kde \
  64. --disable-setgid
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. export DO_NOT_COMPILE="%{donotcompilelist}"
  69. make DESTDIR=$RPM_BUILD_ROOT install
  70. # locales
  71. %find_lang %{name} || touch %{name}.lang
  72. HTML_DIR=$(kde-config --expandvars --install html)
  73. if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
  74. for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
  75. if [ -d $lang_dir ]; then
  76. # remove documentation for games we don't ship
  77. pushd $lang_dir
  78. for i in *; do
  79. case "%{donotcompilelist}" in
  80. *$i*)
  81. # $i is listed in %{donotcompilelist}, zap
  82. [ -d $i ] && rm -rf $i
  83. ;;
  84. esac
  85. done
  86. rm -rf kdegames-apidocs
  87. popd
  88. lang=$(basename $lang_dir)
  89. echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
  90. # replace absolute symlinks with relative ones
  91. pushd $lang_dir
  92. for i in *; do
  93. [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
  94. done
  95. popd
  96. fi
  97. done
  98. fi
  99. # rpmdocs
  100. for dir in atlantik k* ; do
  101. case "%{donotcompilelist}" in
  102. *$dir*)
  103. # $dir is listed in %{donotcompilelist}, skip
  104. ;;
  105. *)
  106. for file in AUTHORS ChangeLog README TODO ; do
  107. test -s "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
  108. done
  109. ;;
  110. esac
  111. done
  112. # remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
  113. rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %post
  117. /sbin/ldconfig
  118. for f in crystalsvg hicolor ; do
  119. touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
  120. gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
  121. done
  122. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  123. %postun
  124. /sbin/ldconfig
  125. for f in crystalsvg hicolor ; do
  126. touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
  127. gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
  128. done
  129. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  130. %files
  131. %defattr(-,root,root)
  132. %doc %{_datadir}/doc/HTML/en/*
  133. %{_bindir}/*
  134. %{_libdir}/lib*.so.*
  135. %{_libdir}/lib*.la
  136. %{_libdir}/kde3/*
  137. %{_datadir}/applications/kde/*.desktop
  138. %{_datadir}/apps/*
  139. %{_datadir}/config.kcfg/*
  140. %{_datadir}/icons/crystalsvg/*/*/*
  141. %{_datadir}/icons/hicolor/*/*/*
  142. %{_datadir}/services/*
  143. %files devel
  144. %defattr(-,root,root)
  145. %{_includedir}/kde/*
  146. %{_libdir}/lib*.so
  147. %changelog
  148. * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
  149. - dropt klickety
  150. * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
  151. - updated to 3.5.10 based on FC
  152. - built with new toolchain
  153. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
  154. - renamed kdegames3
  155. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  156. - applied new versioning policy, spec in UTF-8
  157. * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  158. - rebuild for VineSeed
  159. * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  160. - new upstream release
  161. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  162. - rebuild for VineSeed
  163. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  164. - new upstream release
  165. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  166. - new upstream release
  167. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  168. - added --with-qt-libraries and --enable-libsuffix option
  169. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  170. - rebuild for VineSeed
  171. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  172. - new upstream release
  173. * Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
  174. - changed Group to Applications/Games
  175. - added Japanese summary
  176. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  177. - rebuild for VineSeed
  178. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  179. - new upstream release
  180. * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  181. - rebuild for VineSeed
  182. * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  183. - new upstream release
  184. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  185. - rebuild for VineSeed
  186. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  187. - new upstream release
  188. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  189. - rebuild for VineSeed
  190. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  191. - new upstream release
  192. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  193. - rebuild for VineSeed
  194. * Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  195. - new upstream release
  196. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  197. - new upstream release
  198. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  199. - new upstream release
  200. * Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  201. - new upstream release
  202. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  203. - rebuild for VineSeed
  204. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  205. - new upstream release
  206. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  207. - build for VineSeed
  208. - add --disable-rpath to configure option
  209. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  210. - new upstream release
  211. - use %%{?_smp_mflags} for make option
  212. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  213. - rebuild for VineSeed
  214. * Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  215. - new upstream release
  216. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  217. - new upstream release (3.4.0-rc1)
  218. - update %%files
  219. * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  220. - rebuild for VineSeed
  221. * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  222. - source upgrade
  223. - build for Vine Linux 3.1
  224. * Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  225. - source upgrade
  226. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  227. - rebuild with qt32
  228. * Sun Jun 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  229. - source upgrade
  230. - remove lines about vine26
  231. - add URL: http://www.kde.org/
  232. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  233. - source upgrade
  234. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  235. - move *.so to main package
  236. * Tue Mar 9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  237. - source upgrade
  238. * Thu Feb 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  239. - source upgrade
  240. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  241. - rebuild for VineSeedPlus
  242. * Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  243. - source upgrade
  244. - build for VinePlus/2.6
  245. - (VinePlus/2.6) BuildPrereq: autoconf258
  246. * Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  247. - build for VineSeed with new toolchain and qt-3.2.3
  248. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  249. - rebuild with qt-3.2.1-0.26vl3
  250. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  251. - rebuild with qt-3.2.1-0vl3
  252. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  253. - source upgrade
  254. - build with gcc-3.2.3
  255. * Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  256. - source upgrade
  257. - change spec to build with gcc295
  258. - change make option for SMP and add script
  259. * Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  260. - change spec to build with g++-2.95.3
  261. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  262. - source upgrade
  263. - built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
  264. * Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  265. - source upgrade
  266. - change spec to build both VineSeed and Vine2.5/2.6
  267. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
  268. - source upgrade to 3.1-stable
  269. * Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
  270. - source upgrade to 3.1rc7
  271. - stop using objprelink2, it does not work with gcc3
  272. - change spec to make monolithic package only
  273. - move %{_libdir}/*.la and %{_libdir}/*.so to devel package
  274. - add %{_libdir}/kde3/*
  275. - cleanup spec
  276. * Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
  277. - source upgrade
  278. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  279. - objprelink2 support only ix86 (add %ifarch %{ix86} ... )
  280. - add Prereq: ldconfig
  281. - add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
  282. - add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
  283. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  284. - source upgrade
  285. - BuildPrereq: autoconf253 objprelink2
  286. * Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  287. - source upgrade
  288. * Fri Jul 5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  289. - source upgrade
  290. * Fri Jun 7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
  291. - source update to 3.0.1
  292. * Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
  293. - source update to 3.0
  294. - add configure option `--with-xinerama --enable-final'
  295. - add kbounce
  296. * Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
  297. - merged with rawhide 3.0.0-0.cvs20020306.1
  298. - source update to cvs-20020329
  299. - add BuildPrereq: autoconf252 automake15
  300. - There is Vine's previous changes, hacked for Vine
  301. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
  302. - update to 2.2.2
  303. -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
  304. - Delete Epoch
  305. - Change BuildRequires and Requires
  306. - objprelink (i386 only)
  307. - Build for VineSeed
  308. * Wed Mar 6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
  309. - Fix packaging glitch in monolithic version
  310. * Tue Mar 5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
  311. - Make splits a buildtime option (off by default) on request
  312. * Mon Jan 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
  313. - Update to work with latest kdelibs changes
  314. * Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
  315. - Update
  316. - Add missing %{_bindir}/kbattleship
  317. * Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
  318. - Update
  319. - Split into several packages (one package per game)
  320. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  321. - Update
  322. - Work around ia64 breakages
  323. - Add build requirements (#48977)
  324. * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  325. - Fix problem when changing the card type (Bug #28824)
  326. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  327. - 2.1-respin
  328. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  329. - 2.1
  330. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  331. - don't use make -j CPU, it's broken
  332. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  333. - Run ldconfig in %%post and %%postun to make libkdegames happy
  334. - Replace absolute symlinks with relative symlinks (#24787)
  335. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  336. - Update
  337. - includedir=/usr/include/kde,
  338. now that libkdegames installs kcarddeck.h
  339. * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  340. - Get rid of the gcc bug workaround, it's no longer needed
  341. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  342. - Update
  343. - Don't exclude ia64
  344. * Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  345. - Update to HEAD
  346. * Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  347. - Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
  348. * Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  349. - 2.0 final
  350. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  351. - 2.0
  352. * Mon Oct 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  353. - new CVS
  354. - work around g++ bugs (in kjumpingcube)
  355. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  356. - 1.93
  357. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  358. - new version
  359. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  360. - fix docdir
  361. - rebuild 16 July snapshot
  362. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  363. - SMPify
  364. - don't hardcode QTDIR
  365. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  366. - use gcc 2.96
  367. - new snapshot
  368. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  369. - new snapshot
  370. - ExcludeArch ia64 for now
  371. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  372. - new snapshot
  373. - move it to /usr, where it belongs
  374. * Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  375. - 2.0 snapshot
  376. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  377. - mark doc files as such
  378. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  379. - 1.1.2 release.
  380. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  381. - snapshot, includes kde 1.1.1 + fixes
  382. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  383. - last snapshot before release
  384. - ripped out asteroids and sirtet
  385. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  386. - latest stable snapshot
  387. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  388. - Injected new description and group.
  389. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  390. - upgraded to KDE 1.1 final.
  391. * Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
  392. - rebuilt for new libstdc++ etc.
  393. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  394. - re-merged updates from Duncan Haldane, change /opt/kde --> /usr