compiz-vl.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define mate_plugins annotate glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.8
  16. Release: 7%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post): desktop-file-utils
  23. BuildRequires: mesa-libGLU-devel
  24. BuildRequires: libdrm-devel
  25. BuildRequires: libwnck-devel
  26. BuildRequires: libX11-devel
  27. BuildRequires: libXcomposite-devel
  28. BuildRequires: libXdamage-devel
  29. BuildRequires: libXext-devel
  30. BuildRequires: libXfixes-devel
  31. BuildRequires: libXmu-devel
  32. BuildRequires: libXrandr-devel
  33. BuildRequires: libXrender-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libSM-devel
  36. BuildRequires: dbus-devel
  37. BuildRequires: dbus-glib-devel
  38. BuildRequires: fuse-devel
  39. BuildRequires: gnome-desktop-devel >= 2.30.0
  40. BuildRequires: libglade2-devel
  41. BuildRequires: librsvg2-devel
  42. BuildRequires: libxslt-devel
  43. BuildRequires: marco-devel
  44. BuildRequires: mate-control-center-devel
  45. BuildRequires: desktop-file-utils
  46. BuildRequires: intltool >= 0.35
  47. BuildRequires: gettext
  48. %if %{with kde}
  49. BuildRequires: kdebase-workspace-devel
  50. BUildRequires: dbus-qt-devel
  51. %endif
  52. Conflicts: control-center < 2.32.1-2
  53. # Make sure that former beryl users still have bling
  54. Obsoletes: beryl-core
  55. Obsoletes: %{name}-gnome < 0.8.8-7
  56. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  57. Source1: desktop-effects-%{dialogversion}.tar.bz2
  58. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  59. # Sources from fedora
  60. #Source11: compiz-gtk
  61. #Source12: compiz-gtk.desktop
  62. #Source13: compiz-gnome.desktop
  63. #Source14: compiz-gnome.session
  64. # Patches from fedora
  65. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  66. Patch103: composite-cube-logo.patch
  67. Patch111: gconf-core-plugin-loopfix.patch
  68. # Make sure configuration plugins never get unloaded
  69. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  70. # Patches from ubuntu
  71. Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
  72. Patch1150: 015_optional-fbo.patch
  73. Patch1160: 016_call_glxwaitx_before_drawing.patch
  74. Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
  75. Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
  76. Patch1490: 049-damage-report-non-empty.patch
  77. Patch1600: 060_move_checks_to_compiz.patch
  78. # Patches from upstream
  79. Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
  80. Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
  81. # Vine default options
  82. Patch3000: compiz-0.8.6-vine-default.patch
  83. Patch3001: compiz-mate.patch
  84. Vendor: Project Vine
  85. Distribution: Vine Linux
  86. %description
  87. Compiz is one of the first OpenGL-accelerated compositing window
  88. managers for the X Window System. The integration allows it to perform
  89. compositing effects in window management, such as a minimization
  90. effect and a cube workspace. Compiz is an OpenGL compositing manager
  91. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  92. binding redirected top-level windows to texture objects.
  93. %package devel
  94. Summary: Development packages for compiz
  95. Summary(ja): compiz の開発パッケージ
  96. Group: Development/Libraries
  97. Requires: compiz = %{version}-%{release}
  98. Requires: pkgconfig
  99. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  100. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  101. Requires: libxslt-devel startup-notification-devel
  102. %description devel
  103. The compiz-devel package includes the header files,
  104. and developer docs for the compiz package.
  105. Install compiz-devel if you want to develop plugins for the compiz
  106. windows and compositing manager.
  107. %package mate
  108. Summary: Compiz mate integration bits
  109. Summary(ja): Compiz mate integration bits
  110. Group: User Interface/Desktops
  111. Requires: mate-session-manager
  112. Requires: marco
  113. Requires: libwnck
  114. Requires: glx-utils
  115. Requires: %{name} = %{version}
  116. %description mate
  117. The compiz-mate package contains gtk-window-decorator,
  118. and other mate integration related stuff.
  119. %if %{with kde}
  120. %package kde
  121. Summary: Compiz kde integration bits
  122. Summary(ja): Compiz kde integration bits
  123. Group: User Interface/Desktops
  124. Requires: %{name} = %{version}
  125. Requires: compiz-manager
  126. Obsoletes: beryl-kde
  127. %description kde
  128. The compiz-kde package contains kde-window-decorator,
  129. and other kde integration related stuff.
  130. %endif
  131. %prep
  132. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  133. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  134. %setup -q
  135. pushd ../desktop-effects-%{dialogversion}
  136. %patch102 -p1 -b .wall-plugin
  137. popd
  138. %patch103 -p1 -b .composite-cube-logo
  139. %patch111 -p1 -b .gconf-core-loop
  140. ## %patch123 -p1 -b .initial-plugins
  141. # ubuntu patch
  142. %patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  143. %patch1150 -p1 -b .disable-fbo
  144. %patch1160 -p1 -b .call_glxwaitx_before_drawing
  145. %patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
  146. %patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
  147. %patch1490 -p1 -b .damage-report-non-empty
  148. %patch1600 -p1 -b .move-check-to-compiz
  149. # upstream patch
  150. #%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
  151. #%patch2010 -p1 -b .fix-pixmap-size-calculation
  152. # vine patch
  153. %patch3000 -p1 -b .vine-default
  154. %patch3001 -p1 -b .mate
  155. %build
  156. rm -rf $RPM_BUILD_ROOT
  157. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  158. export CPPFLAGS
  159. #needed to find kde4 libs
  160. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  161. #export LDFLAGS
  162. #libtoolize
  163. autoreconf -if
  164. %configure \
  165. %{?with_kde: --enable-kde4 } \
  166. %{!?with_kde: --disable-kde4 } \
  167. --disable-kde \
  168. --disable-gconf \
  169. --enable-dbus \
  170. --enable-librsvg \
  171. --enable-gtk \
  172. --enable-marco \
  173. --enable-mate \
  174. --with-default-plugins=%{plugins} \
  175. --enable-gnome-keybindings
  176. make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  177. # desktop-effects
  178. cd ../desktop-effects-%{dialogversion}
  179. %configure
  180. %install
  181. rm -rf $RPM_BUILD_ROOT
  182. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
  183. echo INSTALLING DESKTOP EFFECTS
  184. pushd ../desktop-effects-%{dialogversion}
  185. make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
  186. #desktop-file-install --vendor vine --delete-original \
  187. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  188. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  189. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  190. popd
  191. %if %{with kde}
  192. # kde-desktop-effects
  193. echo INSTALLING KDE DESKTOP EFFECTS
  194. pushd ../kde-desktop-effects-%{kde_dialogversion}
  195. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  196. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  197. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  198. iconlist="16 24 32 36 48 96"
  199. for i in $iconlist; do
  200. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  201. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  202. done
  203. desktop-file-install --vendor="" \
  204. --dir=%{buildroot}%{_datadir}/applications/kde \
  205. kde-desktop-effects.desktop
  206. popd
  207. %endif
  208. %if !%{with kde}
  209. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  210. %endif
  211. #install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
  212. #desktop-file-install --vendor="" \
  213. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  214. # %{SOURCE12}
  215. # set up an X session
  216. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
  217. #install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
  218. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  219. #install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
  220. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  221. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  222. %find_lang compiz
  223. %find_lang desktop-effects
  224. cat compiz.lang > core-files.txt
  225. cat desktop-effects.lang > mate-files.txt
  226. for f in %{core_plugins}; do
  227. echo %{_libdir}/compiz/lib$f.so
  228. echo %{_datadir}/compiz/$f.xml
  229. done >> core-files.txt
  230. for f in %{mate_plugins}; do
  231. echo %{_libdir}/compiz/lib$f.so
  232. echo %{_datadir}/compiz/$f.xml
  233. done >> mate-files.txt
  234. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/compiz.desktop
  235. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/gconf.xml
  236. %post -p /sbin/ldconfig
  237. %postun -p /sbin/ldconfig
  238. %post mate
  239. update-desktop-database -q %{_datadir}/applications
  240. touch --no-create %{_datadir}/icons/hicolor
  241. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  242. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  243. fi
  244. %postun mate
  245. update-desktop-database -q %{_datadir}/applications
  246. touch --no-create %{_datadir}/icons/hicolor
  247. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  248. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  249. fi
  250. %if %{with kde}
  251. %post kde
  252. update-desktop-database -q %{_datadir}/applications/kde
  253. touch --no-create %{_datadir}/icons/hicolor
  254. %postun kde
  255. touch --no-create %{_datadir}/icons/hicolor
  256. %endif
  257. %clean
  258. rm -rf $RPM_BUILD_ROOT
  259. %files -f core-files.txt
  260. %defattr(-, root, root)
  261. %doc AUTHORS ChangeLog COPYING* README TODO
  262. %{_bindir}/compiz
  263. %{_libdir}/libdecoration.so.*
  264. %dir %{_libdir}/compiz
  265. %dir %{_datadir}/compiz
  266. %{_datadir}/compiz/*.png
  267. %{_datadir}/compiz/core.xml
  268. %files mate -f mate-files.txt
  269. %defattr(-, root, root)
  270. %{_bindir}/gtk-window-decorator
  271. %{_bindir}/desktop-effects
  272. %{_libdir}/window-manager-settings/libcompiz.so
  273. %{_datadir}/compiz/desktop-effects.glade
  274. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  275. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  276. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  277. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  278. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  279. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  280. %{_datadir}/mate/wm-properties/compiz-wm.desktop
  281. %{_datadir}/mate-control-center/keybindings/50-compiz-desktop-key.xml
  282. %{_datadir}/mate-control-center/keybindings/50-compiz-key.xml
  283. %if %{with kde}
  284. %files kde
  285. %defattr(-, root, root)
  286. %{_bindir}/kde4-window-decorator
  287. %{_docdir}/compiz-kde-%{version}
  288. %{_bindir}/kde-desktop-effects.sh
  289. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  290. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  291. %{_datadir}/compiz/kconfig.xml
  292. %endif
  293. %files devel
  294. %defattr(-, root, root)
  295. %{_libdir}/pkgconfig/compiz.pc
  296. %{_libdir}/pkgconfig/libdecoration.pc
  297. %{_libdir}/pkgconfig/compiz-cube.pc
  298. %{_libdir}/pkgconfig/compiz-scale.pc
  299. %{_includedir}/compiz
  300. %{_libdir}/libdecoration.so
  301. %changelog
  302. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-7
  303. - add Patch3001 (compiz-mate.patch)
  304. - add BuildRequires: marco-devel, mate-control-center-devel
  305. - remove BuildRequires: GConf2-devel, control-center-devel, metacity-devel
  306. - create %%{name}-mate subpackage
  307. - remove %%{name}-gnome subpackage
  308. * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-6
  309. - rebuild with VineSeed environment
  310. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-5
  311. - rebuild with VineSeed environment
  312. * Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-4
  313. - remove follow files
  314. Source11 (compiz-gtk)
  315. Source12 (compiz-gtk.desktop)
  316. Source13 (compiz-gnome.desktop)
  317. Source14 (compiz-gnome.session)
  318. * Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
  319. - remove SandyBridge chipset from blacklist
  320. - add BR: dbus-glib-devel
  321. * Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
  322. - add Source files from Fedora
  323. Source11 (compiz-gtk)
  324. Source12 (compiz-gtk.desktop)
  325. Source13 (compiz-gnome.desktop)
  326. Source14 (compiz-gnome.session)
  327. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
  328. - new upstream release
  329. - add BuildRequires: libxslt-devel, libglade2-devel
  330. - drop Patch2000,2010
  331. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
  332. - add Patch3000
  333. - disable Sync to vblank
  334. - increase drop-shadow radius
  335. - set default decorator to gtk-window-decorator
  336. - change default daces in cube plugin
  337. - use "smart" placement mode
  338. * Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
  339. - drop compiz-gtk
  340. - add Conflicts: control-center < 2.32.1-2
  341. * Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
  342. - rebuild with mesa-7.10.1
  343. - add cherry picked ubuntu patch
  344. - Patch1150: add --no-fbo option
  345. - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
  346. - Patch1160: call glxwaitx before drawing
  347. - Patch1170: always unredirect screensaver on nvidia
  348. - Patch1490: damage report non empty
  349. - Patch1600: move check to compiz
  350. - add upstream patch
  351. - Patch2000: replace gdk_draw_drawable with cairo equivalents
  352. - Patch2010: fix pixmap size calculation
  353. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  354. - rebuild with rpm-4.8.1 for pkg-config file
  355. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  356. - new upstream release (build on GNOME-2.30)
  357. - drop Patch123, Patch300
  358. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  359. - rebuild with mesa-7.6
  360. - add Patch300 to build with gconf-2.28
  361. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  362. - disable glib plugin in compiz-gtk
  363. - use direct rendering on virtualbox video adaptor.
  364. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  365. - add Requires: glx-utils to compiz-gnome
  366. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  367. - new upstream release
  368. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  369. - re-enable metacity decoration on gtk-window-decorator
  370. - BR: metacity-devel instead of metacity
  371. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  372. - fix pre/post scripts for speeding up gconf schema installation
  373. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  374. - add ccp compiz option to compiz-gtk
  375. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  376. - remove desktop-effect.desktop
  377. - we use gnome-appearance-properties integrated version.
  378. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  379. - add Patch121,122 from upstream fix.
  380. - add Patch123: make sure configuration plugins never get unloaded
  381. - add Patch124: memleak fix from upstream
  382. - add Patch125: make the terminal keybind work
  383. - add Patch120,126,127 for kde42
  384. - add Patch128: gwd fix from upstream
  385. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  386. - rebuild with gnome-desktop-2.26.0
  387. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  388. - add compiz-gtk scripts and desktop file from fedora
  389. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  390. - new upstream release
  391. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  392. - rebuild with gnome-desktop-2.24.0
  393. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  394. - new upstream release
  395. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  396. - new upstream release
  397. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  398. - initial build for Vine Linux
  399. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  400. - Fix gconf plugin loop RH #438794, patch based on
  401. older one from Guillaume Seguin
  402. - Add core to default plugin list
  403. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  404. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  405. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  406. - Update to 0.7.2
  407. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  408. - Autorebuild for GCC 4.3
  409. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  410. - Update to desktop-effects version 0.7.17 which include more
  411. translations and move desktop-effects translations to compiz-gnome.
  412. - Fix spelling in beryl-core obsoletes.
  413. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  414. - Update buildrequires (kwd uses the kde3 api)
  415. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  416. - Fix a typo in description of the main package.
  417. - All descriptions should end with a dot (unlike the summary line)
  418. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  419. - Include kde-desktop-effects in kde subpackage
  420. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  421. - Obsolete berly-core
  422. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  423. - 0.6.2
  424. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  425. - Disable scale corner initiate and install a GNOME key config entry.
  426. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  427. - 0.6.0 final
  428. - always-restack-windows-on-map
  429. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  430. - Make compiz behave with gnome-terminal (#304051)
  431. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  432. - Also install gwd.schemas (#319621)
  433. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  434. - Update to more recent 0.6 branch snapshot (fixes #253575).
  435. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  436. - compiz-gnome: install core schema so it actually works
  437. - remove unnecessary gconf stuff from %%install
  438. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  439. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  440. will pull it in (thans to Adel Gadllah).
  441. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  442. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  443. up dialog.
  444. - Fix broken gconf install and uninstall rules.
  445. - Pick up shadowman logo for RHEL builds (#232398).
  446. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  447. - Add more-sm-junk.patch so we set SM restart style to
  448. SmRestartIfRunning on exit (#247163, #245971).
  449. - Add Requires to compiz-devel (#253407).
  450. - Update to desktop-effects 0.7.6, which terminates decorator when
  451. switching to metacity or on compiz failure (#215247, #215032).
  452. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  453. - Split into gnome and kde subpackages
  454. - Minor cleanups
  455. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  456. - Reorder plugin list to avoid 'place' getting removed on startup.
  457. - Add run-command-key.patch to put the run command key in the GNOME
  458. keyboard shortcut dialog (#213576).
  459. - Drop a bunch of obsolete patches.
  460. - Bump mesa-libGL and X server requires to fix TFP bugs for
  461. power-of-two textures (#251935).
  462. - Rebase fedora-logo and composite-cube-logo patch.
  463. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  464. - Build with desktop-effects so we don't pick up metacity work spaces.
  465. Fixes #250568.
  466. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  467. - Build git snapshot from fedora branch at
  468. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  469. branch.
  470. - Fixes #237486.
  471. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  472. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  473. 'glib' on the command line too.
  474. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  475. - Move xml meta data files to main package.
  476. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  477. - Update to 0.5.2.
  478. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  479. with LIBGL_ALWAYS_INDIRECT set.
  480. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  481. - Update to 0.5.0
  482. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  483. - Update to 0.4.0
  484. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  485. - Rebuild against new libwnck
  486. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  487. - Don't install INSTALL
  488. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  489. - Update metacity build requires to metacity-devel.
  490. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  491. - Fix typo in ./configure option.
  492. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  493. - Add place and clone plugins to default plugin list.
  494. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  495. - Update URL (#208214).
  496. - Require at least metacity 2.18 (#232831).
  497. - Add close-session.patch to deregister from SM when replaced (#229113).
  498. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  499. - Explicitly disable KDE parts (#234128).
  500. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  501. - Fix some directory ownership issues (#233825)
  502. - Small spec cleanups
  503. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  504. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  505. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  506. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  507. - Update to 0.3.6, update patches.
  508. - Drop autotool build requires.
  509. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  510. - Add libdecoration.so
  511. - Update to desktop-effects-0.7.0, which spawns the right decorator
  512. and plays nicely with unknown plugins.
  513. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  514. - Update the fedora logo patch (#217224)
  515. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  516. - Update to 0.3.4
  517. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  518. - Use cow by default, bug 208044
  519. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  520. - Update to 0.3.2
  521. - Drop upstreamed patches
  522. - Work with new metacity theme api
  523. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  524. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  525. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  526. - Add buildrequires on intltool
  527. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  528. - Build
  529. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  530. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  531. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  532. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  533. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  534. - Change default plugin list to not include the plane plugin. (Bug 208448).
  535. - Change default keybinding for shrink to be Pause (Bug 206187).
  536. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  537. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  538. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  539. - Add restart.patch to make compiz ask the session manager to restart it
  540. if it crashes (bug 200280).
  541. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  542. - Change plane.patch to not do cyclical window movement in dimensions
  543. where the desktop has size 1 (bug 207263).
  544. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  545. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  546. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  547. - Change .plane patch to
  548. (a) not set the background color to pink in the plane plugin.
  549. (b) allow workspaces with horizontal sizes less then 4.
  550. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  551. - Change plane patch to correctly initialize the screen size to the
  552. defaults (bug 206088).
  553. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  554. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  555. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  556. directories before attempting to install to them).
  557. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  558. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  559. that the new version has icons.
  560. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  561. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  562. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  563. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  564. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  565. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  566. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  567. - Add patch to fix thumbnail sorting (bug 201605)
  568. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  569. - Add patch to fix double clicking (bug 201783).
  570. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  571. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  572. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  573. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  574. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  575. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  576. corresponding visuals.
  577. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  578. - Make number of vertical size configurable
  579. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  580. - Fix vertical viewport support in the plane patch.
  581. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  582. - Upgrade to 0.6.61 of the dialog
  583. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  584. - Add libtool to BuildRequires
  585. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  586. - Add automake and autoconf to BuildRequires
  587. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  588. - Add a patch to put viewports on a plane.
  589. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  590. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  591. server evicts offscreen pixmaps automatically on
  592. GLX_EXT_texture_from_pixmap usage.
  593. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  594. - Add cow.patch to make compiz use the composite overlay window.
  595. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  596. - Rebase to desktop-effects 0.6.41
  597. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  598. - Rebase to desktop-effects 0.6.19 and drop
  599. desktop-effects-0.6.1-delete-session.patch
  600. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  601. - Add patch from upstream to also use sync protocol for override
  602. redirect windows (sync-override-redirect-windows.patch).
  603. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  604. - Rebase to latest upstream changes which has the rest of the bindings
  605. rewrite. Add resize-move-keybindings.patch to make move and resize
  606. bindings work like metacity.
  607. - Add back scale plugin.
  608. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  609. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  610. - unlink session file on changing wms (bug 201473)
  611. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  612. - Add Requires: gnome-session 2.15.4-3
  613. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  614. - New version of dialog box. Macro the version number.
  615. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  616. - Add 'desktop effects' dialog box.
  617. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  618. - Add libwnck requires.
  619. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  620. - Bump and build for fc5 AIGLX repo.
  621. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  622. - Fix gconf hooks.
  623. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  624. - Require system-logos instead.
  625. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  626. - Bump version to work around tagging weirdness.
  627. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  628. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  629. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  630. - Add workaround for AIGLX throttling problem.
  631. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  632. - Drop scale plugin from snapshot.
  633. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  634. - Don't build on s390
  635. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  636. - Do some changes forced upon us by package review
  637. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  638. - Use sane numbering scheme.
  639. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  640. - Drop the fullscreen hardcode patch and require X server that has
  641. GLX_MESA_copy_sub_buffer.
  642. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  643. - Unbreak --replace.
  644. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  645. - Add Requires, fix start-compiz.sh.
  646. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  647. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  648. Assches spec file (#192432).