eigen3-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. # The (empty) main package is arch, to have the package built and tests run
  2. # on all arches, but the actual result package is the noarch -devel subpackge.
  3. # Debuginfo packages are disabled to prevent rpmbuild from generating an empty
  4. # debuginfo package for the empty main package.
  5. %global debug_package %{nil}
  6. %global commit 10219c95fe65
  7. Name: eigen3
  8. Version: 3.2.4
  9. Release: 2%{?_dist_release}
  10. Summary: A lightweight C++ template library for vector and matrix math
  11. Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
  12. Group: Development/Libraries
  13. License: MPLv2.0 and LGPLv2+ and BSD
  14. URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
  15. # Source file is at: http://bitbucket.org/eigen/eigen/get/3.1.3.tar.bz2
  16. # Renamed source file so it's not just a version number
  17. Source0: eigen-%{version}.tar.bz2
  18. # Fix build with recent suitesparse versions
  19. Patch0: eigen-3.2.3_suitesparse.patch
  20. # Vine Patch
  21. Patch700: eigen-3.2.4_BVHsegfault.patch
  22. #BuildRequires: atlas-devel
  23. BuildRequires: fftw3-devel
  24. BuildRequires: glew-devel
  25. BuildRequires: gmp-devel
  26. BuildRequires: gsl-devel
  27. BuildRequires: mpfr-devel
  28. #BuildRequires: sparsehash-devel
  29. BuildRequires: suitesparse-devel
  30. BuildRequires: gcc-gfortran
  31. #BuildRequires: SuperLU-devel
  32. BuildRequires: qt4-devel
  33. BuildRequires: cmake
  34. BuildRequires: doxygen
  35. BuildRequires: graphviz
  36. BuildRequires: texlive-collection-latex
  37. #BuildRequires: tex(latex)
  38. %description
  39. %{summary}.
  40. %package devel
  41. Summary: A lightweight C++ template library for vector and matrix math
  42. Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
  43. Group: Development/Libraries
  44. BuildArch: noarch
  45. # -devel subpkg only atm, compat with other distros
  46. Provides: %{name} = %{version}-%{release}
  47. # not *strictly* a -static pkg, but the results are the same
  48. Provides: %{name}-static = %{version}-%{release}
  49. %description devel
  50. %{summary}.
  51. %package doc
  52. Summary: Developer documentation for Eigen
  53. Summary(ja): Eigen の開発用ドキュメント
  54. Group: Documentation
  55. BuildArch: noarch
  56. Requires: %{name}-devel = %{version}-%{release}
  57. %description doc
  58. Developer documentation for Eigen.
  59. %prep
  60. %setup -q -n eigen-eigen-%{commit}
  61. %patch0 -p1
  62. %patch700 -p1
  63. %build
  64. mkdir %{_target_platform}
  65. pushd %{_target_platform}
  66. #cmake .. -DBLAS_LIBRARIES="cblas" -DSUPERLU_INCLUDES=%{_includedir}/SuperLU
  67. %cmake .. -DBLAS_LIBRARIES="cblas"
  68. popd
  69. make -C %{_target_platform} %{?_smp_mflags}
  70. make doc -C %{_target_platform} %{?_smp_mflags}
  71. rm -f %{_target_platform}/doc/html/installdox
  72. rm -f %{_target_platform}/doc/html/unsupported/installdox
  73. %install
  74. rm -rf %{buildroot}
  75. %make_install -C %{_target_platform}
  76. %check
  77. # Run tests but make failures non-fatal. Note that upstream doesn't expect the
  78. # tests to pass consistently since they're seeded randomly.
  79. make -C %{_target_platform} %{?_smp_mflags} buildtests
  80. make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
  81. %clean
  82. rm -rf %{buildroot}
  83. %files devel
  84. %doc COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
  85. %{_includedir}/eigen3
  86. %{_datadir}/pkgconfig/*
  87. %files doc
  88. %doc %{_target_platform}/doc/html
  89. %changelog
  90. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.2.4-2
  91. - Initial build for Vine Linux
  92. * Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
  93. - Update to release 3.2.4
  94. * Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
  95. - Backport upstream Rotation2D fix
  96. * Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
  97. - Update to release 3.2.3
  98. - Drop upstreamed eigen3-ppc64.patch
  99. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  101. * Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
  102. - Update to release 3.2.2
  103. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  105. * Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
  106. - Add ppc64 support
  107. * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
  108. - Make doc package noarch
  109. * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
  110. - Split off doc to a separate package
  111. * Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
  112. - Udpate to release 3.2.1
  113. * Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
  114. - Build and run tests
  115. - Drop -DBLAS_LIBRARIES_DIR, not used
  116. - Add some BR to enable tests of corresponding backends
  117. - spec cleanup
  118. * Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
  119. - Update to release 3.2
  120. * Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
  121. - Add upstream patch to fix malloc/free bugs (rhbz#978971)
  122. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
  123. - Update to release 3.1.3
  124. - Add patch for unused typedefs warning with gcc4.8
  125. * Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
  126. - Update to release 3.1.2
  127. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  129. * Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
  130. - Update to release 3.0.6 (fixes GCC 4.7 warnings)
  131. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  133. * Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
  134. - Update to release 3.0.5
  135. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  137. * Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
  138. - Update to release 3.0.4
  139. * Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
  140. - Update to release 3.0.3
  141. * Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
  142. - Patched sources to fix build failure
  143. - Removed fixes made upstream
  144. - Added project name to source tarball filename
  145. * Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
  146. - Update to release 3.0.0
  147. * Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
  148. - Change blas-devel buildrequirement to atlas-devel
  149. - Don't make the built-in experimental blas library
  150. * Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
  151. - Initial package