cmake-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. # Set to bcond_with or use --without gui to disable qt4 gui build
  2. %bcond_without gui
  3. Name: cmake
  4. Summary: Cross-platform make system
  5. Summary(ja): クロスプラットフォームな Make システム
  6. Version: 2.8.2
  7. Release: 3%{?_dist_release}
  8. Group: Development/Tools
  9. License: BSD
  10. URL: http://www.cmake.org/
  11. Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
  12. Source1: macros.cmake
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: ncurses-devel
  15. %if %{with gui}
  16. BuildRequires: qt4-devel, desktop-file-utils
  17. %define qt_gui --qt-gui
  18. %endif
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. CMake is used to control the software compilation process using simple
  23. platform and compiler independent configuration files. CMake generates
  24. native makefiles and workspaces that can be used in the compiler
  25. environment of your choice. CMake is quite sophisticated: it is possible
  26. to support complex environments requiring system configuration, pre-processor
  27. generation, code generation, and template instantiation.
  28. %package gui
  29. Summary: Qt GUI for %{name}
  30. Group: Development/Tools
  31. Requires: %{name} = %{version}-%{release}
  32. Requires(post): desktop-file-utils, shared-mime-info
  33. Requires(postun): desktop-file-utils, shared-mime-info
  34. %description gui
  35. The %{name}-gui package contains the Qt based GUI for CMake.
  36. %prep
  37. %setup -q
  38. # Fixup permissions
  39. find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  40. %build
  41. ./bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
  42. --mandir=/share/man --with-system-libs %{?qt_gui}
  43. make VERBOSE=1 %{?_smp_mflags}
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make install DESTDIR=$RPM_BUILD_ROOT
  47. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  48. rm -rf $RPM_BUILD_ROOT/usr/doc
  49. # RPM macros
  50. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  51. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  52. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  53. %if %{with gui}
  54. # Desktop file
  55. desktop-file-install --delete-original \
  56. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  57. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  58. %endif
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %if %{with gui}
  62. %post gui
  63. update-desktop-database &> /dev/null || :
  64. update-mime-database %{_datadir}/mime &> /dev/null || :
  65. %postun gui
  66. update-desktop-database &> /dev/null || :
  67. update-mime-database %{_datadir}/mime &> /dev/null || :
  68. %endif
  69. %files
  70. %defattr(-,root,root)
  71. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  72. %doc Docs/*
  73. %doc Example/
  74. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  75. %{_bindir}/ccmake
  76. %{_bindir}/cmake
  77. %{_bindir}/cpack
  78. %{_bindir}/ctest
  79. %{_datadir}/%{name}/
  80. %{_mandir}/man1/*
  81. %if %{with gui}
  82. %files gui
  83. %defattr(-,root,root,-)
  84. %{_bindir}/cmake-gui
  85. %{_datadir}/applications/CMake.desktop
  86. %{_datadir}/mime/packages/cmakecache.xml
  87. %{_datadir}/pixmaps/CMakeSetup32.png
  88. %endif
  89. %changelog
  90. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  91. - add BuildRequires: ncurses-devel
  92. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  93. - generate gui package
  94. - renamed module directory
  95. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  96. - new upstream release
  97. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  98. - rebuilt with new toolchain
  99. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  100. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  101. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  102. - new upstream release
  103. - added Vendor/Distribution tag
  104. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  105. - new upstream release
  106. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  107. - new upstream release
  108. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  109. - new upstream release
  110. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  111. - new upstream release
  112. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  113. - new upstream release
  114. - drop Patch100
  115. - use bootstrap script instead of configure
  116. - delete caches from %%doc
  117. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  118. - rebuilt with new toolchain
  119. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  120. - new upstream release
  121. - delete duped docs
  122. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  123. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  124. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  125. - source version up
  126. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  127. - initial build for Vine Linux