123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239 |
- # build_client:
- # If you want to build both client and server change value to 1
- # If you want to only build the server change value to 0
- %define build_client 1
- Name: spice
- Version: 0.12.0
- Release: 1%{?_dist_release}
- Summary: Implements the SPICE protocol
- Group: User Interface/Desktops
- License: LGPLv2+
- URL: http://www.spice-space.org/
- Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
- Source1: spice-xpi-client-spicec
- BuildRequires: pkgconfig
- BuildRequires: spice-protocol >= 0.10.1
- BuildRequires: zlib-devel
- BuildRequires: celt051-devel
- BuildRequires: pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
- %if %{build_client}
- BuildRequires: libXinerama-devel libXrandr-devel cegui06-devel
- %endif
- BuildRequires: libcacard-devel cyrus-sasl-devel
- BuildRequires: pyparsing
- BuildRequires: autoconf automake libtool
- %description
- The Simple Protocol for Independent Computing Environments (SPICE) is
- a remote display system built for virtual environments which allows
- you to view a computing 'desktop' environment not only on the machine
- where it is running, but from anywhere on the Internet and from a wide
- variety of machine architectures.
- %if %{build_client}
- %package client
- Summary: Implements the client side of the SPICE protocol
- Group: User Interface/Desktops
- %description client
- The Simple Protocol for Independent Computing Environments (SPICE) is
- a remote display system built for virtual environments which allows
- you to view a computing 'desktop' environment not only on the machine
- where it is running, but from anywhere on the Internet and from a wide
- variety of machine architectures.
- This package contains the SPICE client application.
- %endif
- %package server
- Summary: Implements the server side of the SPICE protocol
- Group: System Environment/Libraries
- %description server
- The Simple Protocol for Independent Computing Environments (SPICE) is
- a remote display system built for virtual environments which allows
- you to view a computing 'desktop' environment not only on the machine
- where it is running, but from anywhere on the Internet and from a wide
- variety of machine architectures.
- This package contains the run-time libraries for any application that wishes
- to be a SPICE server.
- %package server-devel
- Summary: Header files, libraries and development documentation for spice-server
- Group: Development/Libraries
- Requires: %{name}-server = %{version}-%{release}
- Requires: pkgconfig
- %description server-devel
- This package contains the header files, static libraries and development
- documentation for spice-server. If you like to develop programs
- using spice-server, you will need to install spice-server-devel.
- %prep
- %setup -q
- %build
- %if %{build_client}
- %define configure_client --enable-client --enable-gui
- %else
- %define configure_client --disable-client
- %endif
- autoreconf -fi
- %configure --enable-smartcard %{configure_client}
- make WARN_CFLAGS='' %{?_smp_mflags}
- %install
- make DESTDIR=%{buildroot} install
- rm -f %{buildroot}%{_libdir}/libspice-server.a
- rm -f %{buildroot}%{_libdir}/libspice-server.la
- mkdir -p %{buildroot}%{_libexecdir}
- %if %{build_client}
- touch %{buildroot}%{_libexecdir}/spice-xpi-client
- install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
- %endif
- %post server -p /sbin/ldconfig
- %postun server -p /sbin/ldconfig
- %if %{build_client}
- %files client
- %defattr(-,root,root,-)
- %doc COPYING README NEWS
- %{_bindir}/spicec
- %ghost %{_libexecdir}/spice-xpi-client
- %{_libexecdir}/spice-xpi-client-spicec
- %endif
- %files server
- %defattr(-,root,root,-)
- %doc COPYING README NEWS
- %{_libdir}/libspice-server.so.*
- %files server-devel
- %defattr(-,root,root,-)
- %{_includedir}/spice-server
- %{_libdir}/libspice-server.so
- %{_libdir}/pkgconfig/spice-server.pc
- %changelog
- * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
- - initial build for Vine Linux
- * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Mon May 14 2012 Alon Levy <alevy@redhat.com>
- - Fix mjpeg memory leak and bad behavior.
- - Add usbredir to list of channels for security purposes. (#819484)
- * Sun May 13 2012 Alon Levy <alevy@redhat.com>
- - Add double free fix. (#808936)
- %changelog
- * Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
- - Add 32 bit fixes from git master. (#815717)
- * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
- - Rebuilt for c++ ABI breakage
- * Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
- - New upstream release 0.10.1
- * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
- - New upstream release 0.10.0
- - support spice-server.i686
- * Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
- - Provides spice-xpi-client alternative in spice-client
- * Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
- - New upstream release 0.9.1
- * Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
- - New upstream release 0.9.0
- * Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
- - New upstream release 0.8.1
- * Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
- - Fix being unable to send ctrl+alt+key when release mouse is bound to
- ctrl+alt (which can happen when used from RHEV-M)
- * Tue Mar 1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
- - New upstream release 0.8.0
- * Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
- - New upstream release 0.7.3
- * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
- - New upstream release 0.7.2
- * Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
- - New upstream release 0.7.1
- - Drop all patches (all upstreamed)
- - Enable smartcard (CAC) support
- * Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
- - Fix the info layer not showing when used through the XPI
- - Do not let the connection gui flash by when a hostname has been specified
- on the cmdline
- - Fix spice client locking up when dealing with XIM input (#654265)
- - Fix modifier keys getting stuck (#655048)
- - Fix spice client crashing when dealing with XIM ibus input (#655836)
- - Fix spice client only showing a white screen in full screen mode
- * Sat Nov 6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
- - Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
- fixes spicec from aborting when run in a non writable dir (#650253)
- * Fri Nov 5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
- - Various bugfixes from upstream git:
- - Make spicec work together with the Firefox XPI for RHEV-M
- - Make sure the spicec window gets properly raised when first shown
- * Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
- - Update to 0.6.3
- - Enable GUI
- * Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
- - Update to 0.6.1.
- * Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
- - Update to 0.6.0 (stable release)
- * Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
- - Update to 0.5.3
- * Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
- - Quote %% in changelog to avoid macro expansion.
- * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
- - %%configure handles CFLAGS automatically, no need to fiddle
- with %%{optflags} manually.
- * Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
- - Fix license: LGPL.
- - Cleanup specfile, drop bits not needed any more with
- recent rpm versions (F13+).
- - Use optflags as-is.
- -
- * Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
- - initial package.
|