elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define eu_version 0.170
  3. %define eu_release 1
  4. %global nocheck true
  5. Summary: A collection of utilities and DSOs to handle compiled objects
  6. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  7. Name: elfutils
  8. Version: %{eu_version}
  9. Release: %{eu_release}%{?_dist_release}
  10. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  11. Group: Development/Tools
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: flex >= 2.5.4a
  19. BuildRequires: bzip2
  20. BuildRequires: bzip2-devel
  21. BuildRequires: zlib-devel
  22. BuildRequires: xz-devel
  23. BuildRequires: gettext
  24. BuildRequires: m4
  25. BuildRequires: gcc >= 3.4
  26. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  27. BuildRequires: glibc-headers >= 2.3.4-11
  28. %define _gnu %{nil}
  29. %define _program_prefix eu-
  30. %description
  31. Elfutils is a collection of utilities, including ld (a linker),
  32. nm (for listing symbols from object files), size (for listing the
  33. section sizes of an object or archive file), strip (for discarding
  34. symbols), readelf (to see the raw ELF file structures), and elflint
  35. (to check for well-formed ELF files).
  36. %package libs
  37. Summary: Libraries to handle compiled objects
  38. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  39. License: GPLv2+ or LGPLv3+
  40. Group: System Environment/Libraries
  41. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  42. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  43. Conflicts: elfutils < %{version}-%{release}
  44. Conflicts: elfutils > %{version}-%{release}
  45. Conflicts: elfutils-devel < %{version}-%{release}
  46. Conflicts: elfutils-devel > %{version}-%{release}
  47. %description libs
  48. The elfutils-libs package contains libraries which implement DWARF, ELF,
  49. and machine-specific ELF handling. These libraries are used by the programs
  50. in the elfutils package. The elfutils-devel package enables building
  51. other programs using these libraries.
  52. %package devel
  53. Summary: Development libraries to handle compiled objects
  54. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  55. License: GPLv2+ or LGPLv3+
  56. Group: Development/Libraries
  57. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  58. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  59. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  60. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  61. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  62. %description devel
  63. The elfutils-devel package contains the libraries to create
  64. applications for handling compiled objects. libebl provides some
  65. higher-level ELF access functionality. libdw provides access to
  66. the DWARF debugging information. libasm provides a programmable
  67. assembler interface.
  68. %package devel-static
  69. Summary: Static archives to handle compiled objects
  70. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  71. License: GPLv2+ or LGPLv3+
  72. Group: Development/Libraries
  73. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  74. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  75. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  76. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  77. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  78. %description devel-static
  79. The elfutils-devel-static package contains the static archives
  80. with the code to handle compiled objects.
  81. %package libelf
  82. Summary: Library to read and write ELF files
  83. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  84. License: GPLv2+ or LGPLv3+
  85. Group: System Environment/Libraries
  86. Provides: libelf = %{version}-%{release}
  87. Obsoletes: libelf <= 0.8.2-2
  88. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  89. Conflicts: elfutils < %{version}-%{release}
  90. Conflicts: elfutils > %{version}-%{release}
  91. Conflicts: elfutils-libs < %{version}-%{release}
  92. Conflicts: elfutils-libs > %{version}-%{release}
  93. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  94. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  95. %description libelf
  96. The elfutils-libelf package provides a DSO which allows reading and
  97. writing ELF files on a high level. Third party programs depend on
  98. this package to read internals of ELF files. The programs of the
  99. elfutils package use it also to generate new ELF files.
  100. %package libelf-devel
  101. Summary: Development support for libelf
  102. Summary(ja): libelf の開発用ライブラリ
  103. License: GPLv2+ or LGPLv3+
  104. Group: Development/Libraries
  105. Provides: libelf-devel = %{version}-%{release}
  106. Obsoletes: libelf-devel <= 0.8.2-2
  107. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  108. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  109. Conflicts: libelf-devel < %{version}-%{release}
  110. %description libelf-devel
  111. The elfutils-libelf-devel package contains the libraries to create
  112. applications for handling compiled objects. libelf allows you to
  113. access the internals of the ELF object file format, so you can see the
  114. different sections of an ELF file.
  115. %package libelf-devel-static
  116. Summary: Static archive of libelf
  117. Summary(ja): libelf の静的ライブラリ
  118. License: GPLv2+ or LGPLv3+
  119. Group: Development/Libraries
  120. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  121. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  122. %description libelf-devel-static
  123. The elfutils-libelf-static package contains the static archive
  124. for libelf.
  125. # compat32
  126. %package -n compat32-%{name}-libelf
  127. Summary: Library to read and write ELF files
  128. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  129. License: GPLv2+ or LGPLv3+
  130. Group: System Environment/Libraries
  131. Provides: compat32-libelf = %{version}-%{release}
  132. %description -n compat32-%{name}-libelf
  133. The elfutils-libelf package provides a DSO which allows reading and
  134. writing ELF files on a high level. Third party programs depend on
  135. this package to read internals of ELF files. The programs of the
  136. elfutils package use it also to generate new ELF files.
  137. %prep
  138. %setup -q
  139. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  140. %build
  141. # Remove -Wall from default flags. The makefiles enable enough warnings
  142. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  143. # the makefiles disable some specific warnings for specific code.
  144. # But add -Wformat explicitly for use with -Werror=format-security which
  145. # doesn't work without -Wformat (enabled by -Wall).
  146. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  147. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  148. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  149. make -s %{?_smp_mflags}
  150. %install
  151. rm -rf ${RPM_BUILD_ROOT}
  152. make -s install DESTDIR=${RPM_BUILD_ROOT}
  153. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  154. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  155. %find_lang %{name}
  156. # XXX Nuke unpackaged files
  157. { cd ${RPM_BUILD_ROOT}
  158. rm -f .%{_bindir}/eu-ld
  159. }
  160. %check
  161. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  162. %clean
  163. rm -rf ${RPM_BUILD_ROOT}
  164. %post libs -p /sbin/ldconfig
  165. %postun libs -p /sbin/ldconfig
  166. %post libelf -p /sbin/ldconfig
  167. %postun libelf -p /sbin/ldconfig
  168. %post -n compat32-%{name}-libelf -p /sbin/ldconfig
  169. %postun -n compat32-%{name}-libelf -p /sbin/ldconfig
  170. %files -f %{name}.lang
  171. %defattr(-,root,root)
  172. %doc README TODO
  173. %{_bindir}/eu-addr2line
  174. %{_bindir}/eu-ar
  175. %{_bindir}/eu-elfcmp
  176. %{_bindir}/eu-elflint
  177. %{_bindir}/eu-findtextrel
  178. %{_bindir}/eu-nm
  179. %{_bindir}/eu-objdump
  180. %{_bindir}/eu-ranlib
  181. %{_bindir}/eu-readelf
  182. %{_bindir}/eu-size
  183. %{_bindir}/eu-stack
  184. %{_bindir}/eu-strings
  185. %{_bindir}/eu-strip
  186. #%{_bindir}/eu-ld
  187. %{_bindir}/eu-unstrip
  188. %{_bindir}/eu-make-debug-archive
  189. %{_bindir}/eu-elfcompress
  190. %files libs
  191. %defattr(-,root,root)
  192. %{_libdir}/libasm-%{version}.so
  193. %{_libdir}/libasm.so.*
  194. %{_libdir}/libdw-%{version}.so
  195. %{_libdir}/libdw.so.*
  196. %dir %{_libdir}/elfutils
  197. %{_libdir}/elfutils/lib*.so
  198. %files devel
  199. %defattr(-,root,root)
  200. %{_includedir}/dwarf.h
  201. %dir %{_includedir}/elfutils
  202. %{_includedir}/elfutils/elf-knowledge.h
  203. %{_includedir}/elfutils/known-dwarf.h
  204. %{_includedir}/elfutils/libasm.h
  205. %{_includedir}/elfutils/libebl.h
  206. %{_includedir}/elfutils/libdw.h
  207. %{_includedir}/elfutils/libdwelf.h
  208. %{_includedir}/elfutils/libdwfl.h
  209. %{_includedir}/elfutils/version.h
  210. %{_libdir}/libebl.a
  211. %{_libdir}/libasm.so
  212. %{_libdir}/libdw.so
  213. %{_libdir}/pkgconfig/libdw.pc
  214. %files devel-static
  215. %defattr(-,root,root)
  216. %{_libdir}/libasm.a
  217. %{_libdir}/libdw.a
  218. %files libelf
  219. %defattr(-,root,root)
  220. %{_libdir}/libelf-%{version}.so
  221. %{_libdir}/libelf.so.*
  222. %files libelf-devel
  223. %defattr(-,root,root)
  224. %{_includedir}/libelf.h
  225. %{_includedir}/gelf.h
  226. %{_includedir}/nlist.h
  227. %{_libdir}/libelf.so
  228. %{_libdir}/pkgconfig/libelf.pc
  229. %files libelf-devel-static
  230. %defattr(-,root,root)
  231. %{_libdir}/libelf.a
  232. %if %{build_compat32}
  233. %files -n compat32-%{name}-libelf
  234. %defattr(-,root,root)
  235. %{_libdir}/libelf-%{version}.so
  236. %{_libdir}/libelf.so.*
  237. %endif
  238. %changelog
  239. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  240. - updated to 0.170.
  241. - dropped all patches.
  242. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  243. - rebuild with gcc-5.4.0
  244. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  245. - create compat32-elfutils-libelf subpackage
  246. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  247. - update to 0.161
  248. - added Japanese summary
  249. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  250. - update to 0.157
  251. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  252. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  253. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  254. - update to 0.152
  255. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  256. - elfutils-libs: changed Group to System Environment/Libraries
  257. - elfutils-libelf: changed Group to System Environment/Libraries
  258. - elfutils-devel: changed Group to Development/Libraries
  259. - elfutils-devel-static: changed Group to Development/Libraries
  260. - elfutils-libelf-devel: changed Group to Development/Libraries
  261. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  262. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  263. - merged with Fedora 9 0.135-1
  264. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  265. - applied new versioning policy
  266. - added elfutils-0.131-readelf_c.patch
  267. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  268. - new upstream release
  269. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  270. - remove Obsoletes: libelf, libelf-devel from elfutils
  271. - add Obsoletes: libelf to elfutils-libelf
  272. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  273. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  274. - Update to 0.135
  275. - libdwfl: bug fixes
  276. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  277. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  278. - Update to 0.134
  279. - elflint: backend improvements for sparc, alpha (#204170)
  280. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  281. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  282. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  283. - Update to 0.133
  284. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  285. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  286. - libdwfl: bug fixes and optimization in relocation handling
  287. - elfcmp: bug fix for non-allocated section handling
  288. - ld: implement newer features of binutils linker.
  289. - Install eu-objdump and libasm, now has limited disassembler support.
  290. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  291. - Update to 0.132
  292. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  293. - eu-readelf: Fix handling of ET_REL files in archives.
  294. - libcpu: Implement x86 and x86-64 disassembler.
  295. - libasm: Add interface for disassembler.
  296. - all programs: add debugging of branch prediction.
  297. - libelf: new function elf_scnshndx.
  298. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  299. - Update to 0.131
  300. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  301. bug fixes for oddly-formatted DWARF
  302. - libdwfl: bug fixes in offline archive support, symbol table handling;
  303. apply partial relocations for dwfl_module_address_section on ET_REL
  304. - libebl: powerpc backend support for Altivec registers
  305. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  306. - Fix ET_REL support.
  307. - Fix odd indentation in eu-readelf -x output.
  308. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  309. - Update to 0.130
  310. - eu-readelf -p option can take an argument like -x for one section
  311. - eu-readelf --archive-index (or -c)
  312. - eu-readelf -n improved output for core dumps
  313. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  314. - eu-elflint: ditto
  315. - eu-elflint: stricter checks on debug sections
  316. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  317. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  318. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  319. - libebl: backend improvements (#324031)
  320. - libdwfl: build_id support, new functions for it
  321. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  322. - libdwfl offline archive support, new script eu-make-debug-archive
  323. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  324. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  325. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  326. - Update to 0.129
  327. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  328. - addr2line: new option --symbols (or -S)
  329. - libdw: dwarf_getscopes fixes (#230235)
  330. - libdwfl: dwfl_module_addrsym fixes (#249490)
  331. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  332. - Update to 0.128
  333. - new program: unstrip
  334. - elfcmp: new option --hash-inexact
  335. - Replace Conflicts: with Provides/Requires using -arch
  336. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  337. - Update to 0.127
  338. - libdw: new function dwarf_getsrcdirs
  339. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  340. dwfl_module_address_section
  341. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  342. - Update to 0.126
  343. - New program eu-ar.
  344. - libdw: fix missing dwarf_getelf (#227206)
  345. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  346. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  347. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  348. - Fix overeager warn_unused_result build failures.
  349. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  350. - Update to 0.125
  351. - elflint: Compare DT_GNU_HASH tests.
  352. - move archives into -static RPMs
  353. - libelf, elflint: better support for core file handling
  354. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  355. - Resolves: RHBZ #220817, RHBZ #213792
  356. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  357. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  358. - Update to 0.124
  359. - libebl: fix ia64 reloc support (#206981)
  360. - libebl: sparc backend support for return value location
  361. - libebl, libdwfl: backend register name support extended with more info
  362. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  363. - readelf, elflint: trivial bugs fixed
  364. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  365. - Update to 0.123
  366. - libebl: Backend build fixes, thanks to Stepan Kasal.
  367. - libebl: ia64 backend support for register names, return value location
  368. - libdwfl: Handle truncated linux kernel module section names.
  369. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  370. - elflint: Fix checks to permit --hash-style=gnu format.
  371. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  372. - Fix warnings in elflint compilation.
  373. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  374. - Update to 0.122
  375. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  376. - libebl: add function to test for relative relocation
  377. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  378. - elflint, readelf: add support for DT_GNU_HASH
  379. - libelf: add elf_gnu_hash
  380. - elflint, readelf: add support for 64-bit SysV-style hash tables
  381. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  382. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  383. - Update to 0.121
  384. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  385. - make all installed headers usable in C++ code (#193153).
  386. - eu-readelf: better output format.
  387. - eu-elflint: fix tests of dynamic section content.
  388. - libdw, libdwfl: handle files without aranges info.
  389. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  390. - rebuild to pick up -devel deps
  391. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  392. - Update to 0.120
  393. - License changed to GPL, with some exceptions for using
  394. the libelf, libebl, libdw, and libdwfl library interfaces.
  395. Red Hat elfutils is an included package of the Open Invention Network.
  396. - dwarf.h updated for DWARF 3.0 final specification.
  397. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  398. - libdwfl: New function dwfl_version; fixes for offline.
  399. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  400. - bump again for double-long bug on ppc(64)
  401. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  402. - rebuilt for new gcc4.1 snapshot and glibc changes
  403. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  404. - update to 0.119
  405. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  406. - rebuilt
  407. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  408. - update to 0.118
  409. - elflint: more tests.
  410. - libdwfl: New function dwfl_module_register_names.
  411. - libebl: New backend hook for register names.
  412. - Make sure -fexceptions is always in CFLAGS.
  413. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  414. - update to 0.117
  415. - libdwfl: New function dwfl_module_return_value_location (#166118)
  416. - libebl: Backend improvements for several CPUs
  417. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  418. - update to 0.116
  419. - libdw fixes, API changes and additions
  420. - libdwfl fixes (#169672)
  421. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  422. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  423. - Update requires/conflicts for better biarch update behavior.
  424. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  425. - update to 0.115
  426. - New program eu-strings.
  427. - libdw: New function dwarf_getscopes_die.
  428. - libelf: speed-ups of non-mmap reading.
  429. - Implement --enable-gcov option for configure.
  430. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  431. - update to 0.114
  432. - new program eu-ranlib
  433. - libdw: new calls for inlines
  434. - libdwfl: new calls for offline modules
  435. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  436. - update to 0.113
  437. - elflint: relax a bit. Allow version definitions for defined symbols
  438. against DSO versions also for symbols in nobits sections.
  439. Allow .rodata section to have STRINGS and MERGE flag set.
  440. - strip: add some more compatibility with binutils.
  441. - libdwfl: bug fixes.
  442. - Separate libdw et al into elfutils-libs subpackage.
  443. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  444. - update to 0.112
  445. - elfcmp: some more relaxation.
  446. - elflint: many more tests, especially regarding to symbol versioning.
  447. - libelf: Add elfXX_offscn and gelf_offscn.
  448. - libasm: asm_begin interface changes.
  449. - libebl: Add three new interfaces to directly access machine, class,
  450. and data encoding information.
  451. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  452. - update portability patch
  453. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  454. - update to 0.111
  455. - libdwfl library now merged into libdw
  456. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  457. - update to 0.110
  458. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  459. - update to 0.109
  460. - verify that libebl modules are from the same build
  461. - new eu-elflint checks on copy relocations
  462. - new program eu-elfcmp
  463. - new experimental libdwfl library
  464. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  465. - robustification of eu-strip and eu-readelf
  466. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  467. - more robustification
  468. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  469. - robustification
  470. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  471. - update to 0.108
  472. - merge strip fixes
  473. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  474. - update elf.h from glibc
  475. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  476. - fix strip -f byte-swapping bug
  477. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  478. - update to 0.107
  479. - readelf: improve DWARF output format
  480. - elflint: -d option to support checking separate debuginfo files
  481. - strip: fix ET_REL debuginfo files (#156341)
  482. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  483. - fix some bugs in new code, reenable make check
  484. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  485. - disable make check for most arches, for now
  486. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  487. - update to 0.106
  488. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  489. - update to 0.104
  490. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  491. - update to 0.103
  492. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  493. - update to 0.101.
  494. - use %%configure macro to get CFLAGS etc. right
  495. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  496. - upgrade to 0.99.
  497. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  498. - upgrade to 0.97.
  499. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  500. - upgrade to 0.96.
  501. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  502. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  503. warning
  504. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  505. - rebuilt
  506. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  507. - upgrade to 0.95.
  508. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  509. - rebuilt
  510. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  511. - rebuilt
  512. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  513. - upgrade to 0.94
  514. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  515. - upgrade to 0.93
  516. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  517. - full version
  518. - macroized spec file for GPL or OSL builds
  519. - include only libelf under GPL plus wrapper scripts
  520. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  521. - macroized spec file for GPL or OSL builds
  522. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  523. - split elfutils-devel into two packages.
  524. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  525. - include only libelf under GPL plus wrapper scripts
  526. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  527. - readelf, not readline, in %%description (#111214).
  528. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  529. - update to 0.89 (fix eu-strip)
  530. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  531. - update to 0.86 (fix eu-strip on s390x/alpha)
  532. - libebl is an archive now; remove references to DSO
  533. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  534. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  535. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  536. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  537. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  538. - upgrade to 0.82 (strip tests fixed on big-endian).
  539. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  540. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  541. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  542. - upgrade to 0.80 (debugedit changes for kernel in progress).
  543. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  544. - rebuilt
  545. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  546. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  547. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  548. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  549. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  550. - debuginfo rebuild
  551. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  552. - use the correct way of identifying the section via the sh_info link.
  553. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  554. - update to 0.75 (eu-strip -g fix)
  555. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  556. - update to 0.74 (fix for writing with some non-dirty sections)
  557. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  558. - another -0.73 update (with sparc fixes).
  559. - do "make check" in %%check, not %%install, section.
  560. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  561. - update to 0.73 (with s390 fixes).
  562. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  563. - rebuilt
  564. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  565. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  566. - fix other warnings
  567. - reenable checks on s390x
  568. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  569. - temporarily disable checks on s390x, until someone has
  570. time to look at it
  571. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  572. - update to 0.72
  573. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  574. - update to 0.71
  575. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  576. - update to 0.69.
  577. - add "make check" and segfault avoidance patch.
  578. - elfutils-libelf needs to run ldconfig.
  579. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  580. - update to 0.68.
  581. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  582. - update to 0.67.
  583. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  584. - update to 0.65.
  585. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  586. - update to 0.64.
  587. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  588. - split packages further into elfutils-libelf
  589. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  590. - update to 0.63.
  591. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  592. - Adjust for dropping libtool
  593. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  594. - update to 0.59
  595. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  596. - update to 0.56
  597. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  598. - update to 0.54
  599. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  600. - update to 0.53
  601. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  602. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  603. - get beehive to punch a rhpkg generated package.
  604. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  605. - build in 8.0.1.
  606. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  607. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  608. - Add libelf-devel to conflicts for elfutils-devel
  609. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  610. - Split into runtime and devel package
  611. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  612. - integrate into official sources
  613. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  614. - Swaddle.