1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495 |
- Summary: Simplistic interface to pkg-config
- Name: perl-ExtUtils-PkgConfig
- Version: 1.12
- Release: 1%{?_dist_release}
- Group: Development/Libraries
- License: LGPLv2+
- URL: http://search.cpan.org/dist/ExtUtils-PkgConfig/
- Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/ExtUtils-PkgConfig-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: pkgconfig
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(Test::More)
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- Requires: pkgconfig
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- The pkg-config program retrieves information about installed libraries,
- usually for the purposes of compiling against and linking to them.
- ExtUtils::PkgConfig is a very simplistic interface to this utility,
- intended for use in the Makefile.PL of perl extensions which bind
- libraries that pkg-config knows. It is really just boilerplate code
- that you would've written yourself.
- %prep
- %setup -q -n ExtUtils-PkgConfig-%{version}
- %build
- %{__perl} Makefile.PL INSTALLDIRS=vendor
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
- find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
- find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
- chmod -R u+w $RPM_BUILD_ROOT/*
- %check
- make test
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %doc Changes README
- %{perl_vendorlib}/ExtUtils/
- %{_mandir}/man3/*.3pm*
- %changelog
- * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.12-1
- - new upstream release
- - add Vendor and Distribution tags
- * Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.08-1
- - new upstream release
- - build on perl-5.10
- * Wed Aug 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.07-5vl1
- - Initial build for Vine
- * Sat Sep 9 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-5
- - Rebuild for FC6.
- * Fri Feb 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-4
- - Rebuild for FC5 (perl 5.8.8).
- * Thu Dec 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.07-3
- - Dist tag.
- * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.07-2
- - rebuilt
- * Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.07-1
- - Update to 1.07.
- * Sun Oct 3 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-0.fdr.1
- - Update to 1.06.
- * Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
- - First build.
|