mplayer-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. #% global with_ffmpeg 1
  5. %global ffmpegver 0.11.5
  6. #% global svndate 20120525
  7. %define codecdir %{_libdir}/codecs
  8. %global ttfontdir %{_datadir}/fonts
  9. %global ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  10. TrueType-sazanami-gothic/sazanami-gothic
  11. Summary: The Movie Player
  12. Summary(ja): 動画プレイヤー
  13. Name: mplayer
  14. Version: 1.1.1
  15. Release: 3%{?svndate:.%svndate}%{?_dist_release}
  16. Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
  17. #Source0: mplayer-export-%{svndate}.tar.xz
  18. Source1: http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
  19. Source10: mplayer-snapshot-vine.sh
  20. Source11: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.10.tar.bz2
  21. Source12: http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
  22. Source13: http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
  23. Source14: http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
  24. # set defaults for Vine Linux
  25. #Patch2: %{name}-config.patch
  26. #Patch2: %{name}-config-20120525-vine.patch
  27. Patch2: %{name}-1.1.1-config-vine.patch
  28. # use roff include statements instead of symlinks
  29. Patch8: %{name}-1.1.1-manlinks.patch
  30. # erase any trace of libdvdcss
  31. Patch14: %{name}-1.1.1-nodvdcss.patch
  32. # use system FFmpeg libraries
  33. Patch18: %{name}-1.1.1-ffmpeg.patch
  34. ## Vine
  35. %if 0%{!?_without_amr:1}
  36. License: GPLv3+
  37. %else
  38. License: GPLv2+
  39. %endif
  40. Group: Applications/Multimedia
  41. URL: http://www.mplayerhq.hu/
  42. BuildRequires: SDL-devel
  43. BuildRequires: aalib-devel
  44. BuildRequires: alsa-lib-devel
  45. BuildRequires: cdparanoia-devel
  46. BuildRequires: desktop-file-utils
  47. ##!!BuildRequires: em8300-devel
  48. BuildRequires: libdvdnav-devel
  49. BuildRequires: enca-devel
  50. BuildRequires: fontconfig-devel
  51. BuildRequires: freetype2-devel >= 2.0.9
  52. BuildRequires: fribidi-devel
  53. BuildRequires: giflib-devel
  54. BuildRequires: gtk2-devel
  55. BuildRequires: mesa-libGL-devel
  56. BuildRequires: libXinerama-devel
  57. BuildRequires: libXScrnSaver-devel
  58. BuildRequires: libXv-devel
  59. BuildRequires: libXvMC-devel
  60. BuildRequires: libXxf86dga-devel
  61. BuildRequires: libXxf86vm-devel
  62. BuildRequires: libass-devel
  63. BuildRequires: libpng-devel
  64. BuildRequires: libjpeg-devel
  65. BuildRequires: libdvdread
  66. BuildRequires: libmpcdec-devel >= 1.2.1
  67. BuildRequires: librtmp-devel >= 2.3
  68. BuildRequires: speex-devel >= 1.1
  69. %{?with_vaapi:BuildRequires:libva-devel}
  70. BuildRequires: libvdpau-devel
  71. BuildRequires: libvorbis-devel
  72. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  73. BuildRequires: lzo-devel >= 2
  74. BuildRequires: pulseaudio-lib-devel
  75. BuildRequires: speex-devel >= 1.1
  76. BuildRequires: twolame-devel
  77. BuildRequires: xorg-x11-devel
  78. BuildRequires: yasm
  79. BuildRequires: zlib-devel
  80. # *-devel packages provided by other self-build-* should only be listed
  81. # in self-build-%{name}.spec as PreReq.
  82. ##Requires: self-build-mplayer-codecs
  83. ##BuildRequires: self-build-libdvdcss
  84. ##BuildRequires: self-build-lame
  85. ##BuildRequires: self-build-libdca
  86. ##BuildRequires: self-build-x264 >= 0.129
  87. ##BuildRequires: self-build-xvidcore >= 0.9.2
  88. ##BuildRequires: self-build-faad2 >= 2.6.1
  89. ##BuildRequires: self-build-libmpeg2
  90. Requires: TrueType-vlgothic
  91. Requires: mesa-libGL
  92. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  93. Obsoletes: mplayer < %{version}-%{release}
  94. %description
  95. MPlayer can play most standard video formats out of the box and almost
  96. all others with the help of external codecs.
  97. MPlayer currently works best from the command line, but visual feedback
  98. for many functions is available from its onscreen status display (OSD),
  99. which is also used for displaying subtitles.
  100. MPlayer also has a GUI with skin support and several unofficial alternative
  101. graphical frontends are available.
  102. MEncoder is a command line video encoder for advanced users that can
  103. be built from the MPlayer source tree. Unofficial graphical frontends
  104. exist but arenot included.
  105. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  106. support for some newer codecs are not yet inpmlemented.
  107. You should install mplayer-codecs package if you want to play videos
  108. using those new codecs.
  109. %description -l ja
  110. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  111. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  112. で再生できます。
  113. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  114. 多くの操作は字幕と同様に、
  115. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  116. MPlayer には スキンを変更できる GUI も用意されていますし、
  117. また複数の非公式なフロントエンドも利用できます。
  118. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  119. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  120. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  121. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  122. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  123. をインストールする必要があります。
  124. %prep
  125. #% setup -q -n mplayer-export-%{svndate}
  126. %setup -q -n MPlayer-%{version}
  127. %__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
  128. %patch2 -p1 -b .vine
  129. %patch8 -p1 -b .manlinks
  130. %patch14 -p1 -b .nodvdcss
  131. %{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
  132. %build
  133. ./configure \
  134. --prefix=%{_prefix} \
  135. --bindir=%{_bindir} \
  136. --datadir=%{_datadir}/mplayer \
  137. --mandir=%{_mandir} \
  138. --confdir=%{_sysconfdir}/mplayer \
  139. --libdir=%{_libdir} \
  140. --codecsdir=%{codecdir} \
  141. \
  142. --extra-cflags="$RPM_OPT_FLAGS" \
  143. --language=ja,en \
  144. --enable-joystick \
  145. --enable-gui --enable-menu \
  146. --enable-radio --enable-radio-capture \
  147. --enable-runtime-cpudetection \
  148. --enable-unrarexec \
  149. \
  150. --disable-dvdread-internal \
  151. --disable-libdvdcss-internal \
  152. --disable-nemesi \
  153. \
  154. %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
  155. %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
  156. %{!?with_faac:--disable-faac} \
  157. --disable-libmpeg2-internal \
  158. --disable-libopenjpeg \
  159. \
  160. --disable-bitmap-font \
  161. --disable-dga1 --disable-dga2 \
  162. --disable-directfb \
  163. --disable-svga \
  164. --disable-termcap \
  165. --enable-xvmc \
  166. --with-xvmclib=XvMCW \
  167. \
  168. --disable-arts --disable-esd --disable-jack --disable-openal \
  169. --disable-live \
  170. ;
  171. %{__make} V=1 %{?_smp_mflags}
  172. %install
  173. %{__rm} -rf ${RPM_BUILD_ROOT}
  174. %{__make} install INSTALLSTRIP= \
  175. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  176. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  177. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  178. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  179. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  180. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  181. ;
  182. ## install some default config files
  183. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  184. %{__install} -pm 644 etc/example.conf \
  185. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  186. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  187. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  188. # # Icons
  189. # for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
  190. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
  191. # install -pm 644 etc/mplayer$iconsize.png \
  192. # $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
  193. # done
  194. # install skins and set the default skin
  195. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  196. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  197. for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
  198. %__tar xf ${x} || exit 1
  199. done
  200. %__ln_s Blue default || exit 1
  201. popd
  202. # make sybolic link to ttf font for subtitle
  203. for i in %{ttfontlist}; do
  204. if [ -e %{ttfontdir}/$i.ttf ];then
  205. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  206. break;
  207. fi;
  208. done
  209. ## install TOOLS
  210. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  211. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  212. done
  213. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  214. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  215. done
  216. for file in vobshift.py ; do
  217. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  218. done
  219. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  220. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  221. %clean
  222. %{__rm} -rf ${RPM_BUILD_ROOT}
  223. %post
  224. touch --no-create %{_datadir}/icons/hicolor
  225. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  226. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  227. fi
  228. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  229. %postun
  230. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  231. touch --no-create %{_datadir}/icons/hicolor
  232. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  233. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  234. fi || :
  235. %files
  236. %defattr(-,root,root)
  237. #%doc AUTHORS Changelog Copyright LICENSE README
  238. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  239. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  240. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  241. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  242. %{_bindir}/mplayer
  243. %{_bindir}/gmplayer
  244. %{_bindir}/mencoder
  245. %{_datadir}/mplayer/skins/default
  246. %{_datadir}/mplayer/skins/Blue
  247. %{_datadir}/mplayer/skins/Blue-small
  248. %{_datadir}/mplayer/skins/OSX-Mod
  249. %{_datadir}/mplayer/skins/standard
  250. %{_datadir}/mplayer/subfont.ttf
  251. %{_datadir}/applications/mplayer.desktop
  252. %{_datadir}/icons/hicolor/*/apps/mplayer.png
  253. %{_mandir}/man1/mplayer.1*
  254. %{_mandir}/man1/mencoder.1*
  255. ## TOOLS
  256. %{_bindir}/aconvert
  257. %{_bindir}/calcbpp
  258. %{_bindir}/countquant
  259. %{_bindir}/divx2svcd
  260. %{_bindir}/dvd2divxscript
  261. %{_bindir}/mencvcd
  262. %{_bindir}/midentify
  263. %{_bindir}/mpconsole
  264. %{_bindir}/qepdvcd
  265. %{_bindir}/subsearch
  266. %{_bindir}/vobshift
  267. %{_datadir}/mplayer/*.fp
  268. %changelog
  269. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
  270. - rebuilt with ffmpeg-0.11.5
  271. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  272. - remove some obsolete comments
  273. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  274. - updated to 1.1.1
  275. - build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
  276. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
  277. - rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
  278. * Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
  279. - updated to 1.1
  280. - built with ffmpeg-0.11.1
  281. - added some skins
  282. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  283. - updated snapshot 20120525 with ffmpeg 0.11
  284. * Tue Jan 3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
  285. - updated snapshot 20120102
  286. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
  287. - updated snapshot 20111217 (with ffmpeg 0.9)
  288. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  289. - s/self-build-libdvdnav/libdvdnav/
  290. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  291. - updated %%SOURCE1
  292. - update to 1.8
  293. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  294. - dropped BuildRequires: esound-devel
  295. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  296. - new upstream release
  297. - ready for Vine Linux 6
  298. - revived support for Vine Linux 5
  299. - added BuildRequires:
  300. - libass-devel
  301. - librtmp-devel >= 2.3
  302. - speex-devel >= 1.1
  303. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  304. - added BuildRequires:
  305. - aalib-devel
  306. - enca-devel
  307. - lzo-devel
  308. - speex-devel
  309. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  310. - updated fixed %{name}-config.patch
  311. - applied %{name}-config-20100709-vine.patch
  312. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  313. - change release to sync with self-build-mplayer
  314. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  315. - updated source snapshot 20100709
  316. - renamed %%Source10 to mplayer-snapshot-vine.sh
  317. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  318. - added BuildRequires: libvpx-devel >= 0.9.1
  319. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  320. - updated source snapshot 20100621
  321. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  322. - updated source snapshot 20100615
  323. - added BuildRequires: libXinerama-devel
  324. - dropped vl4 support
  325. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  326. - updated source snapshot 20100410
  327. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  328. - updated source snapshot 20100401
  329. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  330. - updated source snapshot 20100326
  331. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  332. - updated source snapshot 20100317
  333. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  334. - updated source snapshot 20100216
  335. - moved scripts from TOOLS
  336. - added --disable-libopenjpeg in configure options
  337. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  338. - updated source snapshot 20100201
  339. - dropped obsolete patches
  340. - added BuildRequires:
  341. - libvdpau-devel
  342. - libXScrnSaver-devel
  343. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  344. - update mplayer-config-20091215-vine.patch
  345. - update mplayer-20091215-x86_32-compile.patch
  346. - added --enable-runtime-cpudetection in configure options
  347. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  348. - source snapshot 20091031
  349. - updated mplayer-20091031-x86_32-compile.patch
  350. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  351. - source snapshot 20091003
  352. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  353. - change release to sync with self-build-mplayer
  354. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  355. - source snapshot 20090905
  356. - added settings for vl6
  357. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  358. - source snapshot 20090821
  359. - replaced BR: libungif-devel with BR: giflib-devel
  360. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  361. - source snapshot 20090722
  362. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  363. - source snapshot 20090702
  364. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  365. - source snapshot 20090611
  366. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  367. - added Requires: TrueType-vlgothic
  368. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  369. - source snapshot 20090522
  370. - build with x264 >= 0.0.0-9.20090522
  371. - updated mplayer-20090522-nodvdcss.patch
  372. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  373. - change release to sync with self-build-mplayer
  374. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  375. - source snapshot 20090502
  376. - updated mplayer-20090503-x86_32-compile.patch
  377. - updated mplayer-20090502-nodvdcss.patch
  378. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  379. - applied mplayer-config-vine.patch
  380. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  381. - source snapshot 20090327
  382. - updated mplayer-20090327-x86_32-compile.patch
  383. - updated mplayer-20090325-nodvdcss.patch
  384. - dropped gmplayer-about-vine.patch
  385. - install some default config files
  386. - added configure options:
  387. - --disable-termcap
  388. - --enable-xvmc
  389. - --with-xvmclib=XvMCW
  390. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  391. - fixed %%files for *.conf
  392. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  393. - source snapshot 20090305
  394. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  395. - source snapshot 20090227
  396. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  397. - source snapshot 20090216
  398. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  399. - source snapshot 20090206
  400. - dropped mplayer-man-zh_CN.patch
  401. - updated mplayer-20090206-nodvdcss.patch
  402. - changed to PreReq: self-build-faad2 from faad2-devel
  403. - added PreReq: self-build-libmad
  404. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  405. - source snapshot 20090131
  406. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  407. - change release to sync with self-build-mplayer
  408. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  409. - source snapshot
  410. - update mplayer-20090122-nodvdcss.patch
  411. - added BuildRequires:
  412. - faad2-devel
  413. - libmpcdec-devel
  414. - twolame-devel
  415. - yasm
  416. - faac-devel (as PreReq in self-build-%{name})
  417. - lame-devel (as PreReq in self-build-%{name})
  418. - libdca-devel (as PreReq in self-build-%{name})
  419. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  420. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  421. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  422. - source snapshot
  423. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  424. --disable-faad-internal in configure options
  425. - dropped gmplayer-add-flv-extension.patch
  426. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  427. - source snapshot
  428. - fixed License
  429. - added some patches from RPM Fusion
  430. - updated gmplayer-about-vine.patch for 20081001 snapshot
  431. - added BuildRequires: libdvdread
  432. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  433. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  434. in configure options
  435. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  436. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  437. - fixed License
  438. - added some devel packages to support OpenGL
  439. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  440. - spec in utf8
  441. - fix sybolic link of subfont for vl5
  442. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  443. - add "Patch105: CVE-2008-1558.patch".
  444. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  445. - build with new versioning policy.
  446. - fix Source[01] URLs.
  447. - add "Patch200: gmplayer-about-vine.patch".
  448. - add "Patch201: gmplayer-add-flv-extension.patch".
  449. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  450. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  451. CVE-2008-0629, CVE-2008-0630)
  452. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  453. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  454. - change source download URL. <BTS:VineLinux:603>
  455. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  456. - fix CONFDIR for make install. <BTS:wishes:33>
  457. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  458. - initial build for Vine Linux