self-build-x265-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. %global commit 5e604833c5aa
  2. %global pkgname x265
  3. %global name self-build-%{pkgname}
  4. %global version 1.4
  5. %global release 1%{?_dist_release}
  6. %global sourceurl0 https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source100: x265-pc-path.patch
  14. Source101: x265-test-shared.patch
  15. Source102: x265-pic.patch
  16. License: GPLv2+ and BSD
  17. Group: Restricted Software
  18. Obsoletes: x265 < %{version}, x265-devel < %{version}
  19. Obsoletes: self-build-x265 < %{version}-%{release}
  20. Requires(post): self-build-setup >= 0.9.9
  21. # (build)requies of target package.
  22. Requires(post): cmake
  23. Requires(post): yasm
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. The primary objective of x265 is to become the best H.265/HEVC encoder
  29. available anywhere, offering the highest compression efficiency and the
  30. highest performance on a wide variety of hardware platforms.
  31. If you install this package, it automaticaly downloads source
  32. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  33. And the created rpm packages are automatically installed
  34. if installation is executed by apt-get command or synaptic
  35. package manager.
  36. [Note]
  37. This package requires many other packages to compile
  38. targetsoftware. So it consume more disk space than usual.
  39. Also installation takes logner time because of compilation.
  40. (This will take a few minutes to quarter or half of an hour,
  41. depends on building environment)
  42. [About self-build package]
  43. For some kind of software, distributing of binary package
  44. may viorate the patent or law. Therefore we chose self-build
  45. packge, create binary package on your machine, for such kind
  46. of softwares instead of distributing binary package.
  47. Please obey the national law when you use the created binary
  48. packages. And if you want to use the softwares using patented
  49. thechnology, it may be required to get a permission, make an
  50. agreement or purchas a license. Please consider it with your
  51. purpose or way of use and take appropriate action.
  52. %description -l ja
  53. x265はH.265/HEVCをエンコードするためのライブラリです。
  54. このパッケージをインストールすると、自動的にソースコードを
  55. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  56. パッケージを作成します。
  57. また apt-get コマンドや synaptic パッケージマネージャから実行
  58. した場合は、作成された rpm パッケージのインストールも自動的に
  59. 行います。
  60. [注意]
  61. コンパイルに必要な多くの関連パッケージを要求するので通常より
  62. ディスクの領域を多く消費します。
  63. またインストール時にコンパイルを行うため、通常より時間がかか
  64. る場合があります。(環境にもよりますが数分から数十分程度)
  65. [self-build パッケージについて]
  66. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  67. 違反する可能性があるものがあります。その為、このような問題が
  68. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  69. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  70. ジという方法を採っています。
  71. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  72. アのライセンス、および利用する国の各種法令に従ってください。
  73. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  74. センスの購入などが必要となる場合がありますので、利用する目的
  75. や形態に応じて各自で判断し適切な対応を取ってください。
  76. %prep
  77. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  78. %install
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. %{__install} -m 644 %{SOURCE100} %{SOURCE101} %{SOURCE102} \
  83. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  84. %clean
  85. %{__rm} -rf ${RPM_BUILD_ROOT}
  86. %posttrans
  87. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 24000
  88. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  89. %{pkgname}-devel-%{version}-%{release}
  90. %files
  91. %defattr(-,root,root)
  92. %{_datadir}/%{name}
  93. %changelog
  94. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
  95. - new upstream release
  96. - initial build based on RPM Fusion rawhide