x265-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. %global commit 5e604833c5aa
  2. Summary: H.265/HEVC encoder library
  3. Name: x265
  4. Version: 1.4
  5. Release: 1%{?_dist_release}
  6. URL: http://x265.org/
  7. Source0: https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
  8. # fix pkgconfig file installation path
  9. Patch0: x265-pc-path.patch
  10. # link test binaries with shared library
  11. Patch1: x265-test-shared.patch
  12. # build with -fPIC on arm and i686, too
  13. Patch2: x265-pic.patch
  14. # source/Lib/TLibCommon - BSD
  15. # source/Lib/TLibEncoder - BSD
  16. # everything else - GPLv2+
  17. License: GPLv2+ and BSD
  18. BuildRequires: cmake
  19. BuildRequires: yasm
  20. %description
  21. The primary objective of x265 is to become the best H.265/HEVC encoder
  22. available anywhere, offering the highest compression efficiency and the
  23. highest performance on a wide variety of hardware platforms.
  24. This package contains the command line encoder and the shared library.
  25. %package devel
  26. Summary: H.265/HEVC encoder library development files
  27. Requires: %{name}%{?_isa} = %{version}-%{release}
  28. %description devel
  29. The primary objective of x265 is to become the best H.265/HEVC encoder
  30. available anywhere, offering the highest compression efficiency and the
  31. highest performance on a wide variety of hardware platforms.
  32. This package contains the shared library development files.
  33. %prep
  34. %setup -q -n multicoreware-%{name}-%{commit}
  35. %patch0 -p1 -b .p
  36. # tests are crashing on x86 if linked against shared libx265
  37. %ifnarch i686
  38. %patch1 -p1 -b .ts
  39. %endif
  40. %patch2 -p1 -b .pic
  41. # f=doc/uncrustify/drag-uncrustify.bat
  42. # tr -d '\r' < ${f} > ${f}.unix && \
  43. # touch -r ${f} ${f}.unix && \
  44. # %__mv ${f}.unix ${f} || exit 1
  45. %build
  46. %cmake -G "Unix Makefiles" \
  47. -DCMAKE_SKIP_RPATH:BOOL=YES \
  48. -DENABLE_TESTS:BOOL=ON \
  49. source
  50. %__make %{?_smp_mflags}
  51. %install
  52. %__make DESTDIR=%{buildroot} install
  53. %__rm %{buildroot}%{_libdir}/libx265.a || exit 1
  54. # %__install -Dpm644 COPYING %{buildroot}%{_pkgdocdir}/COPYING
  55. %check
  56. LD_LIBRARY_PATH=$(pwd) test/PoolTest
  57. LD_LIBRARY_PATH=$(pwd) test/TestBench
  58. exit 0
  59. %post -p /sbin/ldconfig
  60. %postun -p /sbin/ldconfig
  61. %files
  62. %{_bindir}/x265
  63. # %dir %{_pkgdocdir}
  64. # %{_pkgdocdir}/COPYING
  65. %doc COPYING
  66. %{_libdir}/libx265.so.35
  67. %files devel
  68. %doc doc/*
  69. %{_includedir}/x265.h
  70. %{_includedir}/x265_config.h
  71. %{_libdir}/libx265.so
  72. %{_libdir}/pkgconfig/x265.pc
  73. %changelog
  74. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
  75. - new upstream release
  76. - initial build based on RPM Fusion rawhide
  77. * Sun Aug 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-5
  78. - don't include contributor agreement in doc
  79. - make sure /usr/share/doc/x265 is owned
  80. - add a comment noting which files are BSD-licenced
  81. * Fri Aug 08 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-4
  82. - don't create bogus soname (patch by Xavier)
  83. * Thu Jul 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-3
  84. - fix tr call to remove DOS EOL
  85. - build the library with -fPIC on arm and i686, too
  86. * Sun Jul 13 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-2
  87. - use version in source URL
  88. - update License tag
  89. - fix EOL in drag-uncrustify.bat
  90. - don't link test binaries with shared binary on x86 (segfault)
  91. * Thu Jul 10 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-1
  92. - initial build
  93. - fix pkgconfig file install location
  94. - link test binaries with shared library