libsoup-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: Soup, an HTTP library implementation
  4. Summary(ja): Soup - HTTP ライブラリ実装
  5. Name: libsoup
  6. Version: 2.74.0
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: LGPL
  12. %global shortver %(echo %{version} | cut -d . -f 1,2)
  13. URL: ftp://ftp.gnome.org/pub/gnome/sources/libsoup/
  14. Source: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: glib2-devel >= 2.26.0
  17. BuildRequires: gnutls-devel, libxml2-devel, pkgconfig
  18. BuildRequires: libproxy-devel >= 0.2.3
  19. BuildRequires: libgnome-keyring-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: gobject-introspection-devel
  22. BuildRequires: vala
  23. BuildRequires: python3
  24. BuildRequires: meson
  25. BuildRequires: brotli-devel
  26. BuildRequires: libpsl-devel
  27. #BuildRequires: mod_ssl-apache2
  28. BuildRequires: curl
  29. BuildRequires: glib-networking
  30. Requires: glib-networking
  31. %description
  32. Libsoup is an HTTP library implementation in C. It was originally part
  33. of a SOAP (Simple Object Access Protocol) implementation called Soup, but
  34. the SOAP and non-SOAP parts have now been split into separate packages.
  35. libsoup uses the Glib main loop and is designed to work well with GTK
  36. applications. This enables GNOME applications to access HTTP servers
  37. on the network in a completely asynchronous fashion, very similar to
  38. the Gtk+ programming model (a synchronous operation mode is also
  39. supported for those who want it).
  40. %package devel
  41. Summary: Header files for the Soup library
  42. Summary(ja): Soup ライブラリのヘッダファイル
  43. Group: programming
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: glib2-devel >= 2.26.0
  46. Requires: gnutls-devel, libxml2-devel, libgpg-error-devel
  47. %description devel
  48. Libsoup is an HTTP library implementation in C. This package allows
  49. you to develop applications that use the libsoup library.
  50. %package vala
  51. Summary: Vala bindings for %{name}
  52. Summary(ja): %{name} の Vala バインディング
  53. Group: programming
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: vala
  56. %description vala
  57. Vala bindings for %{name}.
  58. # compat32
  59. %package -n compat32-%{name}
  60. Summary: Soup, an HTTP library implementation
  61. Summary(ja): Soup - HTTP ライブラリ実装
  62. Group: system,legacy
  63. %description -n compat32-%{name}
  64. Libsoup is an HTTP library implementation in C. It was originally part
  65. of a SOAP (Simple Object Access Protocol) implementation called Soup, but
  66. the SOAP and non-SOAP parts have now been split into separate packages.
  67. libsoup uses the Glib main loop and is designed to work well with GTK
  68. applications. This enables GNOME applications to access HTTP servers
  69. on the network in a completely asynchronous fashion, very similar to
  70. the Gtk+ programming model (a synchronous operation mode is also
  71. supported for those who want it).
  72. %debug_package
  73. %prep
  74. %setup -q
  75. %build
  76. %meson \
  77. -Dgssapi=disabled \
  78. -Dntlm=disabled \
  79. -Dsysprof=disabled
  80. %meson_build
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. %meson_install
  84. %find_lang %{name}
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files -f %{name}.lang
  88. %defattr(-, root, root)
  89. %license COPYING
  90. %doc README NEWS AUTHORS
  91. %{_libdir}/lib*.so.*
  92. %{_libdir}/girepository-1.0
  93. %files devel
  94. %defattr(-, root, root)
  95. %{_includedir}/libsoup-2.4
  96. %{_includedir}/libsoup-gnome-2.4
  97. %{_libdir}/*.so
  98. %{_libdir}/pkgconfig/*.pc
  99. #%{_datadir}/gtk-doc/html/libsoup-2.4
  100. %{_datadir}/gir-1.0
  101. %files vala
  102. %defattr(-, root, root)
  103. %{_datadir}/vala/vapi/libsoup-2.4.vapi
  104. %{_datadir}/vala/vapi/libsoup-2.4.deps
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %defattr(-, root, root)
  108. %{_libdir}/lib*.so.*
  109. %endif
  110. %changelog
  111. * Fri Aug 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.74.0-1
  112. - new upstream release.
  113. * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.72.0-1
  114. - new upstream release.
  115. - dropped scriptlets.
  116. * Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.70.0-1
  117. - new upstream release.
  118. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.61.1-1
  119. - new upstream release.
  120. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.54.1-1
  121. - new upstream release
  122. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-2
  123. - create compat32-libsoup subpackage
  124. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-1
  125. - new upstream release
  126. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.1-1
  127. - new upstream release
  128. - add BuildRequires: vala-devel, vala-tools
  129. - create %%{name}-vala subpackage
  130. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.50.0-1
  131. - new upstream release
  132. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
  133. - new upstream release
  134. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.0-1
  135. - new upstream release
  136. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.0-1
  137. - new upstream release
  138. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.2-1
  139. - new upstream release
  140. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  141. - new upstream release
  142. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  143. - new upstream release
  144. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  145. - new upstream release
  146. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
  147. - new upstream release
  148. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
  149. - new upstream release
  150. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  151. - new upstream release
  152. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  153. - new upstream release
  154. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  155. - new upstream release
  156. * Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  157. - new upstream release
  158. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
  159. - new upstream release
  160. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.92-1
  161. - new upstream release
  162. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.90-1
  163. - new upstream release
  164. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.5-1
  165. - new upstream release
  166. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.4-1
  167. - new upstream release
  168. - add BuildRequires: glib-networking
  169. - add Requires: glib-networking
  170. - change BuildRequires: mod_ssl-apache2 instead of apache2
  171. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  172. - new upstream release
  173. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  174. - new upstream release
  175. - add BuildRequires: apache2, curl
  176. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  177. - new upstream release
  178. - add configure option (--enable-introspection=yes)
  179. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.2-2
  180. - build with rpm-4.8.1-1 for pkg-config file
  181. * Mon Jun 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  182. - new upstream release
  183. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  184. - new upstream release
  185. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  186. - new upstream release
  187. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  188. * Sat Jan 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  189. - new upstream release
  190. - added BR: gnome-keyring-devel, GConf2-devel, sqlite3-devel
  191. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  192. - new upstream release
  193. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  194. - new upstream release
  195. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  196. - new upstream release
  197. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  198. - new upstream release
  199. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  200. - new upstream release
  201. - add BR: libproxy-devel >= 0.2.3
  202. * Sat Mar 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  203. - new upstream release
  204. * Sat Jan 17 2009 Toshiharu kudoh <toshi.kd2@gmail.com> 2.24.2.1-2
  205. - rebuild with gnutls-2.6.3
  206. * Fri Jan 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2.1-1
  207. - new upstream release
  208. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
  209. - new upstream release
  210. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  211. - new upstream release
  212. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  213. - new upstream release
  214. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.91-1
  215. - new upstream release
  216. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
  217. - new upstream release
  218. * Thu Mar 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl5
  219. - new upstream release
  220. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.104-0vl1
  221. - new upstream release
  222. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.100-0vl1
  223. - new upstream release
  224. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.99-0vl1
  225. - new upstream release
  226. (includes security fix CVE-2006-5876 <BTS:462>)
  227. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.96-0vl2
  228. - rebuild with gnutls-1.4.1
  229. * Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.96-0vl1
  230. - new upstream release
  231. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.93-0vl1
  232. - new upstream release
  233. * Wed Nov 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-0vl1
  234. - new upstream release
  235. * Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6.1-0vl1
  236. - new upstream release
  237. - added BuildRequires: gnutls-devel instead of openssl-devel
  238. * Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  239. - new upstream release
  240. * Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.28-0vl1
  241. - new upstream release
  242. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.26-0vl1
  243. - new upstream release
  244. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.23-0vl1
  245. - new upstream release
  246. * Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.22-0vl1
  247. - new upstream release
  248. * Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.20-1vl1
  249. - build for Vine Linux
  250. * Tue May 6 2003 Jeremy Katz <katzj@redhat.com> 1.99.20-1
  251. - 1.99.20
  252. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-3
  253. - include ssl proxy so that ssl urls work properly (#90165, #90166)
  254. * Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-2
  255. - forward port patch to use a union initializer to fix build on x86_64
  256. * Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-1
  257. - rename package to libsoup
  258. - update to 1.99.17
  259. - don't obsolete soup for now, it's parallel installable
  260. * Sun Apr 6 2003 Jeremy Katz <katzj@redhat.com> 0.7.11-1
  261. - update to 0.7.11
  262. * Wed Apr 2 2003 Matt Wilson <msw@redhat.com> 0.7.10-5
  263. - added soup-0.7.10-64bit.patch to fix 64 bit platforms (#86347)
  264. * Sat Feb 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  265. - only runtime libs in normal rpm
  266. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  267. - rebuilt
  268. * Tue Jan 21 2003 Jeremy Katz <katzj@redhat.com>
  269. - update url (#82347)
  270. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-2
  271. - use pkgconfig's openssl configuration information, if it exists
  272. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.7.10-1
  273. - update to 0.7.10
  274. * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-4
  275. - fix fpic patch
  276. - soup-devel should require soup
  277. * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-3
  278. - better lib64 patch
  279. - fix building of libwsdl-build to use libtool so that it gets built
  280. with -fPIC as needed
  281. * Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-2
  282. - change popt handling in configure slightly so that it will work on
  283. multilib arches
  284. * Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-1
  285. - update to 0.7.9, pulling the tarball out of Ximian packages
  286. * Wed Oct 23 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-3
  287. - fix to not try to include non-existent doc files and remove all
  288. unwanted files from the build
  289. - include api docs
  290. - don't build the apache module
  291. * Wed Sep 25 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-2
  292. - various specfile tweaks to include in Red Hat Linux
  293. - include all the files
  294. * Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
  295. - Inital RPM config.