tzdata-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374
  1. %bcond_with java18
  2. Summary: Timezone data
  3. Summary(ja): タイムゾーンのデータ
  4. Name: tzdata
  5. Version: 2016d
  6. %define tzdata_version 2016d
  7. %define tzcode_version 2016d
  8. Release: 1%{?_dist_release}
  9. License: Public Domain
  10. Group: System Environment/Base
  11. URL: https://www.iana.org/time-zones
  12. # These are official upstream.
  13. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  14. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  15. Source2: javazic.tar.gz
  16. Source3: javazic-1.8-37392f2f5d59.tar.xz
  17. Patch100: javazic-fixup.patch
  18. Patch101: rebase-01.patch
  19. Patch102: rebase-02.patch
  20. Patch103: 7090844.patch
  21. Patch104: 7133138.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. BuildRequires: gawk, glibc, perl
  25. BuildRequires: java-devel
  26. BuildRequires: glibc-common >= 2.5.90-7
  27. Conflicts: glibc-common <= 2.3.2-63
  28. %description
  29. This package contains data files with rules for various timezones around
  30. the world.
  31. %description -l ja
  32. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  33. %package java
  34. Summary: Timezone data for Java
  35. Group: System Environment/Base
  36. %description java
  37. This package contains timezone information for use by Java runtimes.
  38. %prep
  39. %setup -q -c -a 1
  40. mkdir javazic
  41. tar zxf %{SOURCE2} -C javazic
  42. pushd javazic
  43. %patch100
  44. %patch101
  45. %patch102
  46. %patch103
  47. %patch104
  48. # Hack alert! sun.tools may be defined and installed in the
  49. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  50. # for creating the zoneinfo files, rebase all the packages
  51. # from "sun." to "rht.". Unfortunately, gcj does not support
  52. # any of the -Xclasspath options, so we must go this route
  53. # to ensure the greatest compatibility.
  54. mv sun rht
  55. find . -type f -name '*.java' -print0 \
  56. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  57. -e 's:sun\.util\.:rht.util.:g'
  58. popd
  59. tar xf %{SOURCE3}
  60. echo "%{name}%{tzdata_version}" >> VERSION
  61. %build
  62. FILES="africa antarctica asia australasia europe northamerica southamerica
  63. pacificnew etcetera backward"
  64. mkdir zoneinfo/{,posix,right}
  65. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  66. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  67. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  68. grep -v tz-art.htm tz-link.htm > tz-link.html
  69. # Java 6/7 tzdata
  70. pushd javazic
  71. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  72. popd
  73. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  74. -d javazi \
  75. $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  76. %if %{with java18}
  77. # Java 8 tzdata
  78. pushd javazic-1.8
  79. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  80. popd
  81. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  82. -srcdir . -dstfile tzdb.dat \
  83. -verbose \
  84. $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  85. %endif
  86. %install
  87. rm -fr $RPM_BUILD_ROOT
  88. install -d $RPM_BUILD_ROOT%{_datadir}
  89. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  90. install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  91. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  92. %if %{with java18}
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  94. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  95. %endif
  96. %clean
  97. rm -fr $RPM_BUILD_ROOT
  98. %files
  99. %defattr(-,root,root)
  100. %{_datadir}/zoneinfo
  101. %doc README
  102. %doc Theory
  103. %doc tz-link.html
  104. %files java
  105. %defattr(-,root,root)
  106. %{_datadir}/javazi
  107. %if %{with java18}
  108. %{_datadir}/javazi-1.8
  109. %endif
  110. %changelog
  111. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  112. - updated to 2016d.
  113. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  114. - updated to 2015f.
  115. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  116. - updated to 2015e.
  117. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  118. - update to tzdata-2012c, tzcode-2012b
  119. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  120. - rebuilt with rpm-4.8.1-3
  121. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  122. - update to tzdata-2010l, tzcode-2010l
  123. - added java subpackage
  124. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  125. - update to tzdata-2009d, tzcode-2009d
  126. - spec in utf-8
  127. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  128. - update to tzdata-2008b, tzcode-2008a
  129. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  130. - initial build for VineSeed
  131. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  132. - Upstream 2007d
  133. - Mongolia has abolished DST.
  134. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  135. than 01:00 standard time.
  136. - Cuba observed DST starting Sunday.
  137. - Resolute, Nunavut switched from Central to Eastern time last
  138. November.
  139. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  140. - Upstream 2007c
  141. - Pulaski County, Indiana, switched back to eastern time.
  142. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  143. - Upstream 2007b
  144. - Changes to the commentary in "leapseconds".
  145. - Upstream 2007a
  146. - Updates to Bahamas, they will be in sync with 2007 US DST change
  147. - New zone Australia/Eucla
  148. - Africa/Asmera renamed to Africa/Asmara, link created
  149. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  150. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  151. - Upstream 2006p
  152. - Covers changes from 2006m-2 and 2006m-3
  153. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  154. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  155. - Patch for Western Australia DST trial
  156. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  157. - Proposed upstream patch (#210058)
  158. - Jordan will switch to winter time on October 27, not September 29
  159. - Brazil's DST this year is the first Sunday in November to the last
  160. Sunday in February. (Thanks to Frederico A. C. Neves.)
  161. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  162. - Commentary and past timestamps changes
  163. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  164. - Upstream 2006m:
  165. - Adjustments for Egypt, Palestine, Uruguay
  166. - Better description of `until' field in zic (8) manpage
  167. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  168. - Upstream 2006k, 2006l:
  169. - Adjustments for Egypt, Palestine, Cuba, Honduras
  170. - Documentation changes
  171. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  172. - Upstream 2006j
  173. - Honduras stopped observing DST on Monday at 00:00
  174. - America/Bermuda will follow the US's lead next year
  175. - America/Moncton will use US-style rules next year
  176. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  177. year
  178. - New zone: America/Atikokan instead of America/Coral_Harbour
  179. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  180. - Historical changes
  181. - Commentary updates
  182. - Upstream 2006i
  183. - localtime.c fixes
  184. - Upstream 2006h
  185. - zic leapsecond fix
  186. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  187. - rebuild
  188. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  189. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  190. - Nicaragua updates
  191. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  192. - Upstream 2006f
  193. - America/Guatemala observes DST between Apr/30 and Oct/1
  194. - Historical changes for Nicaragua
  195. - Update of America/Indiana/Vincennes in zone table
  196. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  197. - Upstream 2006d
  198. - Haiti observes DST
  199. - Sri Lanka change actually took effect Apr/15
  200. - All Canada is now scheduled for 2007 US DST rules
  201. - Some historical fixes
  202. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  203. - Upstream 2006c
  204. - Time-related changes:
  205. - dozens of historical and commentary changes
  206. - Iran stopped observing DST
  207. - Sri Lanka switches from UTC+6 to UTC+5:30
  208. - America/Thule and America/Edmonton will adopt new US rules,
  209. starting 2007
  210. - Tunisia is adopting regular DST
  211. - Code:
  212. - asctime.c: Chages in format strings to silent gcc warnings
  213. - removing K&R notation from function signatures
  214. - few fixes across the code
  215. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  216. - Patch for Sri Lanka time zone change (#184514)
  217. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  218. - Upstream 2006b:
  219. - using tz64code version, as 32 is legacy according to tzdata ML
  220. - new manual pages for ctime, strftime, tzset
  221. - some source code reorganizations
  222. - no timezone/dst rule updates
  223. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  224. - Small changes in tst-timezone.c
  225. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  226. - Upstream 2006a:
  227. - private.h(scheck): changing char* to char const*
  228. - Rule changes for Palestine, zone changes for Indiana/US, both
  229. changes for Canada.
  230. - Many related doc changes.
  231. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  232. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  233. - 2005r-3
  234. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  235. so that it won't clash across updates.
  236. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  237. - 2005r
  238. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  239. northamerica to guard against old files with obsolete information
  240. being left in the time zone binary directory.
  241. - Changes for countries that are supposed to join 2007 US DST
  242. change. This includes most of Canada, however entries already in
  243. the database (Alberta, British Columbia, Newfoundland, Northwest
  244. Territories, and Yukon) were left alone for the time being.
  245. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  246. is checked for emptiness.
  247. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  248. - 2005q
  249. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  250. - SystemV timezone changes
  251. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  252. - 2005n
  253. - changes for Kyrgyzstan and Uruguay
  254. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  255. make check), update tst-timezone.c from glibc CVS (#172102)
  256. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  257. - 2005m
  258. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  259. Australia, Kazakhstan
  260. - historical timezone data changes for Japan, Poland, Northern Ireland and
  261. Mali
  262. - timezone name change for East Timor
  263. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  264. - 2005k
  265. - leap seconds update
  266. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  267. - 2005i
  268. - updates for Iran, Haiti and Nicaragua
  269. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  270. - 2005h
  271. - fixes for Kazakhstan
  272. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  273. - 2005g
  274. - fixes for Uruguay
  275. - include README and Theory from tzcode tarball in %{_docdir};
  276. Theory includes a good summary of how the timezone data files
  277. are supposed to be named
  278. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  279. - 2005f
  280. - more updates for Israel, updates for Azerbaijan
  281. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  282. - 2005c
  283. - updates for Israel and Paraguay
  284. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  285. - 2004g (#141107)
  286. - updates for Cuba
  287. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  288. - 2004e (#135194)
  289. - updates for Brazil, Uruguay and Argentina
  290. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  291. - 2004b
  292. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  293. - 2003d
  294. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  295. - 2003c
  296. - updates for Brazil (#104840)
  297. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  298. - rebuilt
  299. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  300. - initial package