lsb-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787
  1. # Define this to link to which library version eg. /lib64/ld-lsb-x86-64.so.3
  2. %define lsbsover 3
  3. %ifarch %{ix86}
  4. %define ldso ld-linux.so.2
  5. %define lsbldso ld-lsb.so
  6. %endif
  7. %ifarch ia64
  8. %define ldso ld-linux-ia64.so.2
  9. %define lsbldso ld-lsb-ia64.so
  10. %endif
  11. %ifarch ppc
  12. %define ldso ld.so.1
  13. %define lsbldso ld-lsb-ppc32.so
  14. %endif
  15. %ifarch ppc64
  16. %define ldso ld64.so.1
  17. %define lsbldso ld-lsb-ppc64.so
  18. %endif
  19. %ifarch s390
  20. %define ldso ld.so.1
  21. %define lsbldso ld-lsb-s390.so
  22. %endif
  23. %ifarch s390x
  24. %define ldso ld64.so.1
  25. %define lsbldso ld-lsb-s390x.so
  26. %endif
  27. %ifarch x86_64
  28. %define ldso ld-linux-x86-64.so.2
  29. %define lsbldso ld-lsb-x86-64.so
  30. %endif
  31. %ifarch ia64 ppc64 s390x x86_64
  32. %define qual ()(64bit)
  33. %else
  34. %define qual %{nil}
  35. %endif
  36. %define upstreamlsbrelver 2.0
  37. %define lsbrelver 3.0
  38. %define srcrelease 1
  39. Summary: LSB support for Vine Linux
  40. Summary(ja): Vine Linux の LSB サポート
  41. Name: lsb
  42. Version: 3.2
  43. Release: 1%{?_dist_release}
  44. URL: http://www.linuxfoundation.org/
  45. Source0: %{name}-vine-%{version}.tar.bz2
  46. License: GPLv2
  47. Group: System Environment/Base
  48. BuildRoot: %{_tmppath}/%{name}-root
  49. # dependency for primary LSB application for v1.3
  50. Provides: lsb = %{version}
  51. # dependency for primary LSB application for v2.0 and v3.0
  52. %ifarch %{ix86}
  53. %define archname ia32
  54. %endif
  55. %ifarch ia64
  56. %define archname ia64
  57. %endif
  58. %ifarch ppc
  59. %define archname ppc32
  60. %endif
  61. %ifarch ppc64
  62. %define archname ppc64
  63. %endif
  64. %ifarch s390
  65. %define archname s390
  66. %endif
  67. %ifarch s390x
  68. %define archname s390x
  69. %endif
  70. %ifarch x86_64
  71. %define archname amd64
  72. %endif
  73. Provides: lsb-core-%{archname} = %{version}
  74. Provides: lsb-graphics-%{archname} = %{version}
  75. Provides: lsb-core-noarch = %{version}
  76. Provides: lsb-graphics-noarch = %{version}
  77. ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x
  78. %ifarch %{ix86}
  79. # archLSB IA32 Base Libraries
  80. Requires: libatk-1.0.so.0
  81. Requires: libc.so.6
  82. Requires: libcrypt.so.1
  83. Requires: libdl.so.2
  84. Requires: libgcc_s.so.1
  85. Requires: libgdk-x11-2.0.so.0
  86. Requires: libgdk_pixbuf-2.0.so.0
  87. Requires: libgdk_pixbuf_xlib-2.0.so.0
  88. Requires: libglib-2.0.so.0
  89. Requires: libgmodule-2.0.so.0
  90. Requires: libgobject-2.0.so.0
  91. Requires: libgthread-2.0.so.0
  92. Requires: libgtk-x11-2.0.so.0
  93. Requires: libm.so.6
  94. Requires: libncurses.so.5
  95. Requires: libpango-1.0.so.0
  96. Requires: libpangoft2-1.0.so.0
  97. Requires: libpangoxft-1.0.so.0
  98. Requires: libpthread.so.0
  99. Requires: libqt-mt.so.3
  100. Requires: libQtCore.so.4
  101. Requires: libQtGui.so.4
  102. Requires: libQtNetwork.so.4
  103. Requires: libQtOpenGL.so.4
  104. Requires: libQtSql.so.4
  105. Requires: libQtSvg.so.4
  106. Requires: libQtXml.so.4
  107. Requires: libstdc++.so.6
  108. Requires: libutil.so.1
  109. Requires: libz.so.1
  110. %endif
  111. %ifarch ia64
  112. # archLSB IA64 Base Libraries
  113. Requires: libatk-1.0.so.0()(64bit)
  114. Requires: libc.so.6.1()(64bit)
  115. Requires: libcrypt.so.1()(64bit)
  116. Requires: libdl.so.2()(64bit)
  117. Requires: libgcc_s.so.1()(64bit)
  118. Requires: libgdk-x11-2.0.so.0()(64bit)
  119. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  120. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  121. Requires: libglib-2.0.so.0()(64bit)
  122. Requires: libgmodule-2.0.so.0()(64bit)
  123. Requires: libgobject-2.0.so.0()(64bit)
  124. Requires: libgthread-2.0.so.0()(64bit)
  125. Requires: libgtk-x11-2.0.so.0()(64bit)
  126. Requires: libm.so.6.1()(64bit)
  127. Requires: libncurses.so.5()(64bit)
  128. Requires: libpango-1.0.so.0()(64bit)
  129. Requires: libpangoft2-1.0.so.0()(64bit)
  130. Requires: libpangoxft-1.0.so.0()(64bit)
  131. Requires: libpthread.so.0()(64bit)
  132. Requires: libqt-mt.so.3()(64bit)
  133. Requires: libQtCore.so.4()(64bit)
  134. Requires: libQtGui.so.4()(64bit)
  135. Requires: libQtNetwork.so.4()(64bit)
  136. Requires: libQtOpenGL.so.4()(64bit)
  137. Requires: libQtSql.so.4()(64bit)
  138. Requires: libQtSvg.so.4()(64bit)
  139. Requires: libQtXml.so.4()(64bit)
  140. Requires: libstdc++.so.6()(64bit)
  141. Requires: libutil.so.1()(64bit)
  142. Requires: libz.so.1()(64bit)
  143. %endif
  144. %ifarch ppc
  145. # archLSB PPC32 Base Libraries
  146. Requires: libatk-1.0.so.0
  147. Requires: libc.so.6
  148. Requires: libcrypt.so.1
  149. Requires: libdl.so.2
  150. Requires: libgcc_s.so.1
  151. Requires: libgdk-x11-2.0.so.0
  152. Requires: libgdk_pixbuf-2.0.so.0
  153. Requires: libgdk_pixbuf_xlib-2.0.so.0
  154. Requires: libglib-2.0.so.0
  155. Requires: libgmodule-2.0.so.0
  156. Requires: libgobject-2.0.so.0
  157. Requires: libgthread-2.0.so.0
  158. Requires: libgtk-x11-2.0.so.0
  159. Requires: libm.so.6
  160. Requires: libncurses.so.5
  161. Requires: libpango-1.0.so.0
  162. Requires: libpangoft2-1.0.so.0
  163. Requires: libpangoxft-1.0.so.0
  164. Requires: libpthread.so.0
  165. Requires: libqt-mt.so.3
  166. Requires: libQtCore.so.4
  167. Requires: libQtGui.so.4
  168. Requires: libQtNetwork.so.4
  169. Requires: libQtOpenGL.so.4
  170. Requires: libQtSql.so.4
  171. Requires: libQtSvg.so.4
  172. Requires: libQtXml.so.4
  173. Requires: libstdc++.so.6
  174. Requires: libutil.so.1
  175. Requires: libz.so.1
  176. %endif
  177. %ifarch ppc64
  178. # archLSB PPC64 Base Libraries
  179. Requires: libatk-1.0.so.0()(64bit)
  180. Requires: libc.so.6()(64bit)
  181. Requires: libcrypt.so.1()(64bit)
  182. Requires: libdl.so.2()(64bit)
  183. Requires: libgcc_s.so.1()(64bit)
  184. Requires: libgdk-x11-2.0.so.0()(64bit)
  185. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  186. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  187. Requires: libglib-2.0.so.0()(64bit)
  188. Requires: libgmodule-2.0.so.0()(64bit)
  189. Requires: libgobject-2.0.so.0()(64bit)
  190. Requires: libgthread-2.0.so.0()(64bit)
  191. Requires: libgtk-x11-2.0.so.0()(64bit)
  192. Requires: libm.so.6()(64bit)
  193. Requires: libncurses.so.5()(64bit)
  194. Requires: libpango-1.0.so.0()(64bit)
  195. Requires: libpangoft2-1.0.so.0()(64bit)
  196. Requires: libpangoxft-1.0.so.0()(64bit)
  197. Requires: libpthread.so.0()(64bit)
  198. Requires: libqt-mt.so.3()(64bit)
  199. Requires: libQtCore.so.4()(64bit)
  200. Requires: libQtGui.so.4()(64bit)
  201. Requires: libQtNetwork.so.4()(64bit)
  202. Requires: libQtOpenGL.so.4()(64bit)
  203. Requires: libQtSql.so.4()(64bit)
  204. Requires: libQtSvg.so.4()(64bit)
  205. Requires: libQtXml.so.4()(64bit)
  206. Requires: libstdc++.so.6()(64bit)
  207. Requires: libutil.so.1()(64bit)
  208. Requires: libz.so.1()(64bit)
  209. %endif
  210. %ifarch s390
  211. # archLSB S390 Base Libraries
  212. Requires: libatk-1.0.so.0
  213. Requires: libc.so.6
  214. Requires: libcrypt.so.1
  215. Requires: libdl.so.2
  216. Requires: libgcc_s.so.1
  217. Requires: libgdk-x11-2.0.so.0
  218. Requires: libgdk_pixbuf-2.0.so.0
  219. Requires: libgdk_pixbuf_xlib-2.0.so.0
  220. Requires: libglib-2.0.so.0
  221. Requires: libgmodule-2.0.so.0
  222. Requires: libgobject-2.0.so.0
  223. Requires: libgthread-2.0.so.0
  224. Requires: libgtk-x11-2.0.so.0
  225. Requires: libm.so.6
  226. Requires: libncurses.so.5
  227. Requires: libpango-1.0.so.0
  228. Requires: libpangoft2-1.0.so.0
  229. Requires: libpangoxft-1.0.so.0
  230. Requires: libpthread.so.0
  231. Requires: libqt-mt.so.3
  232. Requires: libQtCore.so.4
  233. Requires: libQtGui.so.4
  234. Requires: libQtNetwork.so.4
  235. Requires: libQtOpenGL.so.4
  236. Requires: libQtSql.so.4
  237. Requires: libQtSvg.so.4
  238. Requires: libQtXml.so.4
  239. Requires: libstdc++.so.6
  240. Requires: libutil.so.1
  241. Requires: libz.so.1
  242. %endif
  243. %ifarch s390x
  244. # archLSB S390X Base Libraries
  245. Requires: libatk-1.0.so.0()(64bit)
  246. Requires: libc.so.6()(64bit)
  247. Requires: libcrypt.so.1()(64bit)
  248. Requires: libdl.so.2()(64bit)
  249. Requires: libgcc_s.so.1()(64bit)
  250. Requires: libgdk-x11-2.0.so.0()(64bit)
  251. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  252. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  253. Requires: libglib-2.0.so.0()(64bit)
  254. Requires: libgmodule-2.0.so.0()(64bit)
  255. Requires: libgobject-2.0.so.0()(64bit)
  256. Requires: libgthread-2.0.so.0()(64bit)
  257. Requires: libgtk-x11-2.0.so.0()(64bit)
  258. Requires: libm.so.6()(64bit)
  259. Requires: libncurses.so.5()(64bit)
  260. Requires: libpango-1.0.so.0()(64bit)
  261. Requires: libpangoft2-1.0.so.0()(64bit)
  262. Requires: libpangoxft-1.0.so.0()(64bit)
  263. Requires: libpthread.so.0()(64bit)
  264. Requires: libqt-mt.so.3()(64bit)
  265. Requires: libQtCore.so.4()(64bit)
  266. Requires: libQtGui.so.4()(64bit)
  267. Requires: libQtNetwork.so.4()(64bit)
  268. Requires: libQtOpenGL.so.4()(64bit)
  269. Requires: libQtSql.so.4()(64bit)
  270. Requires: libQtSvg.so.4()(64bit)
  271. Requires: libQtXml.so.4()(64bit)
  272. Requires: libstdc++.so.6()(64bit)
  273. Requires: libutil.so.1()(64bit)
  274. Requires: libz.so.1()(64bit)
  275. %endif
  276. %ifarch x86_64
  277. # archLSB AMD64 Base Libraries
  278. Requires: libatk-1.0.so.0()(64bit)
  279. Requires: libc.so.6()(64bit)
  280. Requires: libcrypt.so.1()(64bit)
  281. Requires: libdl.so.2()(64bit)
  282. Requires: libgcc_s.so.1()(64bit)
  283. Requires: libgdk-x11-2.0.so.0()(64bit)
  284. Requires: libgdk_pixbuf-2.0.so.0()(64bit)
  285. Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
  286. Requires: libglib-2.0.so.0()(64bit)
  287. Requires: libgmodule-2.0.so.0()(64bit)
  288. Requires: libgobject-2.0.so.0()(64bit)
  289. Requires: libgthread-2.0.so.0()(64bit)
  290. Requires: libgtk-x11-2.0.so.0()(64bit)
  291. Requires: libm.so.6()(64bit)
  292. Requires: libncurses.so.5()(64bit)
  293. Requires: libpango-1.0.so.0()(64bit)
  294. Requires: libpangoft2-1.0.so.0()(64bit)
  295. Requires: libpangoxft-1.0.so.0()(64bit)
  296. Requires: libpthread.so.0()(64bit)
  297. Requires: libqt-mt.so.3()(64bit)
  298. Requires: libQtCore.so.4()(64bit)
  299. Requires: libQtGui.so.4()(64bit)
  300. Requires: libQtNetwork.so.4()(64bit)
  301. Requires: libQtOpenGL.so.4()(64bit)
  302. Requires: libQtSql.so.4()(64bit)
  303. Requires: libQtSvg.so.4()(64bit)
  304. Requires: libQtXml.so.4()(64bit)
  305. Requires: libstdc++.so.6()(64bit)
  306. Requires: libutil.so.1()(64bit)
  307. Requires: libz.so.1()(64bit)
  308. %endif
  309. # gLSB Base/Utility/Stdc++/Graphics Libraries
  310. Requires: libasound.so.2%{qual}
  311. Requires: libatk-1.0.so.0%{qual}
  312. Requires: libcrypt.so.1%{qual}
  313. Requires: libcups.so.2%{qual}
  314. Requires: libcupsimage.so.2%{qual}
  315. Requires: libdl.so.2%{qual}
  316. Requires: libfontconfig.so.1%{qual}
  317. Requires: libfreetype.so.6%{qual}
  318. Requires: libgcc_s.so.1%{qual}
  319. Requires: libgdk-x11-2.0.so.0%{qual}
  320. Requires: libgdk_pixbuf-2.0.so.0%{qual}
  321. Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
  322. Requires: libGL.so.1%{qual}
  323. Requires: libglib-2.0.so.0%{qual}
  324. Requires: libgmodule-2.0.so.0%{qual}
  325. Requires: libgobject-2.0.so.0%{qual}
  326. Requires: libgthread-2.0.so.0%{qual}
  327. Requires: libgtk-x11-2.0.so.0%{qual}
  328. Requires: libICE.so.6%{qual}
  329. Requires: libjpeg.so.62%{qual}
  330. Requires: libncurses.so.5%{qual}
  331. Requires: libpam.so.0%{qual}
  332. Requires: libpango-1.0.so.0%{qual}
  333. Requires: libpangoft2-1.0.so.0%{qual}
  334. Requires: libpangoxft-1.0.so.0%{qual}
  335. Requires: libpng12.so.0%{qual}
  336. Requires: libpthread.so.0%{qual}
  337. Requires: libqt-mt.so.3%{qual}
  338. Requires: libQtCore.so.4%{qual}
  339. Requires: libQtGui.so.4%{qual}
  340. Requires: libQtNetwork.so.4%{qual}
  341. Requires: libQtOpenGL.so.4%{qual}
  342. Requires: libQtSql.so.4%{qual}
  343. Requires: libQtSvg.so.4%{qual}
  344. Requires: libQtXml.so.4%{qual}
  345. Requires: librt.so.1%{qual}
  346. Requires: libSM.so.6%{qual}
  347. Requires: libstdc++.so.6%{qual}
  348. Requires: libutil.so.1%{qual}
  349. Requires: libX11.so.6%{qual}
  350. Requires: libXext.so.6%{qual}
  351. Requires: libXft.so.2%{qual}
  352. Requires: libXi.so.6%{qual}
  353. Requires: libxml2.so.2%{qual}
  354. Requires: libXrender.so.1%{qual}
  355. Requires: libXt.so.6%{qual}
  356. Requires: libz.so.1%{qual}
  357. # gLSB Command and Utilities
  358. Requires: /bin/awk
  359. Requires: /bin/basename
  360. Requires: /bin/cat
  361. Requires: /bin/chgrp
  362. Requires: /bin/chmod
  363. Requires: /bin/chown
  364. Requires: /bin/cp
  365. Requires: /bin/cpio
  366. Requires: /bin/cut
  367. Requires: /bin/date
  368. Requires: /bin/dd
  369. Requires: /bin/df
  370. Requires: /bin/dmesg
  371. Requires: /bin/echo
  372. Requires: /bin/ed
  373. Requires: /bin/egrep
  374. Requires: /bin/env
  375. Requires: /bin/false
  376. Requires: /bin/fgrep
  377. Requires: /bin/gettext
  378. Requires: /bin/grep
  379. Requires: /bin/gunzip
  380. Requires: /bin/gzip
  381. Requires: /bin/hostname
  382. Requires: /bin/kill
  383. Requires: /bin/ln
  384. Requires: /bin/ls
  385. Requires: mailx
  386. Requires: /bin/mkdir
  387. Requires: /bin/mknod
  388. Requires: /bin/mktemp
  389. Requires: /bin/more
  390. Requires: /bin/mount
  391. Requires: /bin/mv
  392. Requires: /bin/nice
  393. Requires: /bin/ps
  394. Requires: /bin/pwd
  395. Requires: /bin/rm
  396. Requires: /bin/rmdir
  397. Requires: /bin/sed
  398. Requires: /bin/sh
  399. Requires: /bin/sleep
  400. Requires: /bin/sort
  401. Requires: /bin/stty
  402. Requires: /bin/su
  403. Requires: /bin/sync
  404. Requires: /bin/tar
  405. Requires: /bin/touch
  406. Requires: /bin/true
  407. Requires: /bin/umount
  408. Requires: /bin/uname
  409. Requires: /bin/zcat
  410. Requires: /sbin/fuser
  411. Requires: /sbin/pidof
  412. Requires: /sbin/shutdown
  413. Requires: /usr/bin/[
  414. Requires: /usr/bin/ar
  415. Requires: /usr/bin/at
  416. Requires: /usr/bin/batch
  417. Requires: /usr/bin/bc
  418. Requires: /usr/bin/chfn
  419. Requires: /usr/bin/chsh
  420. Requires: /usr/bin/cksum
  421. Requires: /usr/bin/cmp
  422. Requires: /usr/bin/col
  423. Requires: /usr/bin/comm
  424. Requires: /usr/bin/crontab
  425. Requires: /usr/bin/csplit
  426. Requires: /usr/bin/diff
  427. Requires: /usr/bin/dirname
  428. Requires: /usr/bin/du
  429. Requires: /usr/bin/expand
  430. Requires: /usr/bin/expr
  431. Requires: /usr/bin/fc-cache
  432. Requires: /usr/bin/fc-list
  433. Requires: /usr/bin/fc-match
  434. Requires: /usr/bin/file
  435. Requires: /usr/bin/find
  436. Requires: /usr/bin/fold
  437. Requires: /usr/bin/foomatic-rip
  438. Requires: /usr/bin/gencat
  439. Requires: /usr/bin/getconf
  440. Requires: /usr/bin/groups
  441. Requires: /usr/bin/gs
  442. Requires: /usr/bin/head
  443. Requires: /usr/bin/iconv
  444. Requires: /usr/bin/id
  445. Requires: /usr/bin/install
  446. Requires: /usr/bin/ipcrm
  447. Requires: /usr/bin/ipcs
  448. Requires: /usr/bin/join
  449. Requires: /usr/bin/killall
  450. Requires: /usr/bin/locale
  451. Requires: /usr/bin/localedef
  452. Requires: /usr/bin/logger
  453. Requires: /usr/bin/logname
  454. Requires: /usr/bin/lp
  455. Requires: /usr/bin/lpr
  456. Requires: /usr/bin/m4
  457. Requires: /usr/bin/make
  458. Requires: /usr/bin/man
  459. Requires: /usr/bin/md5sum
  460. Requires: /usr/bin/mkfifo
  461. Requires: /usr/bin/msgfmt
  462. Requires: /usr/bin/newgrp
  463. Requires: /usr/bin/nl
  464. Requires: /usr/bin/nohup
  465. Requires: /usr/bin/od
  466. Requires: /usr/bin/passwd
  467. Requires: /usr/bin/paste
  468. Requires: /usr/bin/patch
  469. Requires: /usr/bin/pathchk
  470. Requires: /usr/bin/pax
  471. Requires: /usr/bin/perl
  472. Requires: /usr/bin/pr
  473. Requires: /usr/bin/printf
  474. Requires: /usr/bin/python
  475. Requires: /usr/bin/renice
  476. Requires: /usr/bin/split
  477. Requires: /usr/bin/strip
  478. Requires: /usr/bin/tail
  479. Requires: /usr/bin/tee
  480. Requires: /usr/bin/test
  481. Requires: /usr/bin/time
  482. Requires: /usr/bin/tr
  483. Requires: /usr/bin/tsort
  484. Requires: /usr/bin/tty
  485. Requires: /usr/bin/unexpand
  486. Requires: /usr/bin/uniq
  487. Requires: /usr/bin/wc
  488. Requires: /usr/bin/xargs
  489. Requires: /usr/sbin/groupadd
  490. Requires: /usr/sbin/groupdel
  491. Requires: /usr/sbin/groupmod
  492. Requires: /usr/sbin/sendmail
  493. Requires: /usr/sbin/useradd
  494. Requires: /usr/sbin/userdel
  495. Requires: /usr/sbin/usermod
  496. %description
  497. The Linux Standard Base (LSB) is an attempt to develop a set of
  498. standards that will increase compatibility among Linux distributions.
  499. The lsb package provides utilities needed for LSB Compliant
  500. Applications. It also contains requirements that will ensure that all
  501. components required by the LSB that are provided by Red Hat Linux are
  502. installed on the system.
  503. %prep
  504. %setup -q -n %{name}-vine-%{version}
  505. %build
  506. cd lsb-release-%{upstreamlsbrelver}
  507. make
  508. %install
  509. rm -rf $RPM_BUILD_ROOT
  510. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  511. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
  512. $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
  513. $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
  514. make DESTDIR=$RPM_BUILD_ROOT install
  515. cd lsb-release-%{upstreamlsbrelver}
  516. make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
  517. cd ..
  518. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
  519. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
  520. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
  521. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
  522. # and claim LSB 3.1 is supported as well
  523. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
  524. touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
  525. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
  526. touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
  527. for LSBVER in %{lsbsover}; do
  528. ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
  529. done
  530. mkdir -p $RPM_BUILD_ROOT/bin
  531. # LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
  532. # According to the lsb-core documentation provided by
  533. # http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
  534. # it's OK to put non binary in /usr/lib.
  535. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
  536. ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
  537. ln -snf mail $RPM_BUILD_ROOT/bin/mailx
  538. gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
  539. -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
  540. install -m 700 lsb_vine_trigger.%{_target_cpu} \
  541. $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  542. cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
  543. %clean
  544. rm -rf $RPM_BUILD_ROOT
  545. %triggerpostun -- glibc
  546. if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
  547. /usr/sbin/lsb_vine_trigger.%{_target_cpu}
  548. fi
  549. %ifnarch %{ix86}
  550. /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
  551. %else
  552. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  553. for LSBVER in %{lsbsover}; do
  554. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  555. done
  556. else
  557. for LSBVER in %{lsbsover}; do
  558. /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  559. done
  560. fi
  561. %endif
  562. %ifarch %{ix86}
  563. %post
  564. # make this softlink again for /emul
  565. if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
  566. for LSBVER in %{lsbsover}; do
  567. /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
  568. done
  569. fi
  570. %endif
  571. %files
  572. #/usr/X11R6/lib/X11/fonts
  573. #/usr/X11R6/lib/X11/rgb.txt
  574. %defattr(-,root,root)
  575. %{_sysconfdir}/lsb-vine
  576. %dir %{_sysconfdir}/lsb-release.d
  577. # These files are needed because they shows which LSB we're supporting now,
  578. # for example, if core-3.1-noarch exists, it means we are supporting LSB3.1 now
  579. %{_sysconfdir}/lsb-release.d/*
  580. %{_mandir}/*/*
  581. %{_bindir}/*
  582. /bin/lsb_vine_init
  583. /usr/lib/lsb
  584. /%{_lib}/*so*
  585. /lib/lsb*
  586. %{_sbindir}/lsb_vine_trigger.%{_target_cpu}
  587. /bin/mailx
  588. %changelog
  589. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
  590. - initial build for Vine Linux
  591. * Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
  592. - Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
  593. * Wed Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
  594. - Port forward to LSB 3.2
  595. - Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
  596. - Since F10 put mailx under /usr/bin, change the corresponding requires
  597. * Thu Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
  598. - Remove 2 requires which provided by redhat-lsb
  599. - Add comments explaining why hard-coded path is kept
  600. - Resolve some hard-coded path problems
  601. - Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
  602. - Replace %{_libdir}/lsb with /usr/lib/lsb
  603. - Replace /%{_lib}/* with /%{_lib}/*so*
  604. - Replace /lib/lsb with /lib/lsb*
  605. * Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
  606. - remove symlink for mailx (Bug #457241)
  607. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
  608. - Autorebuild for GCC 4.3
  609. * Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
  610. - fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
  611. * Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
  612. - fix build issue in minimal build root (Bug #265241)
  613. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
  614. - Rebuild for selinux ppc32 issue.
  615. * Fri Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
  616. - update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
  617. * Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
  618. - Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
  619. - forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
  620. * Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
  621. - fixed Bug 232918 for new glibc version
  622. * Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
  623. - fixed Bug 226363
  624. * Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
  625. - replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
  626. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
  627. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  628. * Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
  629. - Fix upgrade issue; Bug 202548
  630. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
  631. - rebuild
  632. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
  633. - for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
  634. * Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
  635. - generate spec file on RHEL5-Alpha system
  636. - fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
  637. * Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
  638. - Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
  639. rather than sniffing through sgml
  640. - remove redundent script and bump up tarball version
  641. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
  642. - bump again for double-long bug on ppc(64)
  643. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
  644. - rebuilt for new gcc4.1 snapshot and glibc changes
  645. * Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
  646. - Migrated back to rawhide
  647. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
  648. - Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
  649. * Wed Aug 3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
  650. - Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
  651. depends on /etc/lsb-release.d/ (Advised by LSB committee)
  652. - Removed /etc/lsb-release (Advised by LSB committee)
  653. * Mon Aug 1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
  654. - Made the /etc/lsb-release useful (RH#154605)
  655. - Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
  656. - Fixed AMD64 base libraries requirement parsing (RH#154605)
  657. * Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
  658. - Fixed redhat-lsb's mkredhat-lsb on fetching lib and
  659. cmd requirements
  660. * Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
  661. - Rebuilt
  662. * Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
  663. - Disabled support for LSB 1.3 and 2.0
  664. * Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
  665. - Upgraded to lsb-release 2.0
  666. * Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
  667. - Moved to LSB 3.0
  668. * Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
  669. - Fixed ix86 package with ia32 emul support
  670. * Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
  671. - Sync what we have changed on the branches
  672. Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
  673. - added post section to recreate the softlink in emul mode (bug 140739)
  674. Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
  675. Tiny correction of bug in new triggers
  676. * Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
  677. - Add support provide on lsb-core-* for each arch
  678. * Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
  679. - Add to support multiple LSB test suite version
  680. - Add %%endif in trigger postun
  681. * Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
  682. - Fixed invalid sln call for trigger in postun on ia64 (#137647)
  683. * Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
  684. - Bump release and rebuilt for RHEL4.
  685. * Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
  686. - fix lsb ld.so name for ia64 (#100613)
  687. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  688. - use /usr/lib/lsb for install_initd, remove_initd
  689. * Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
  690. - add ia64 x86_64 ppc ppc64 s390 s390x
  691. * Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
  692. - 1.3
  693. * Wed Sep 4 2002 Matt Wilson <msw@redhat.com>
  694. - 1.2.0
  695. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  696. - automated rebuild
  697. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  698. - automated rebuild
  699. * Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
  700. - addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
  701. forced downgrade case.
  702. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
  703. - add initscripts support
  704. * Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
  705. - Initial build.